Subject: [MMUSIC] [Technical Errata Reported] RFC5245 (3107)

From: RFC Errata System <[email-masked]>
Date: Sun, 5 Feb 2012 21:15:55 -0800 (PST)

The following errata report has been submitted for RFC5245,
"Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer Protocols".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5245&eid=3107

--------------------------------------
Type: Technical
Reported by: N V S Kaushik <[email-masked]>

Section: Appendix B.6

Original Text
-------------
However, the check from agent R has not yet generated a response, and agent R receives the updated offer (message 7) before getting the response (message 9).  

Corrected Text
--------------
However, the check from agent R has not yet received a response, and agent R receives the updated offer (message 7) before getting the response (message 9).  

Notes
-----
Here Agent R(ideally Agent B as per the figure 11) has generated the request, so it must receive the response. The original text may give a meaning that Agent R has to generate a response.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5245 (draft-ietf-mmusic-ice-19)
--------------------------------------
Title               : Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer Protocols
Publication Date    : April 2010
Author(s)           : J. Rosenberg
Category            : PROPOSED STANDARD
Source              : Multiparty Multimedia Session Control
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: "Kevin P. Fleming" <[email-masked]>
Date: Mon, 13 Feb 2012 17:28:25 -0600

On 02/05/2012 11:15 PM, RFC Errata System wrote:
> Reported by: N V S Kaushik<[email-masked]>
>
> Section: Appendix B.6
>
> Original Text
> -------------

This section needs quite a bit of fixing, actually. The agent 
designators don't match the Figure at all (agent L in the text is Agent 
A in the figure, and agent R in the text is agent B in the figure).

However, this errata is correct: in the figure, agent A *has* generated 
a response, but it was lost, and so agent B has not received it. It 
would possibly be clearer to word this as:

However, the response generated by agent A (message 6) was not received 
by agent B, and agent B receives the updated offer (message 7) before 
receiving the response (message 9).

-- 
Kevin P. Fleming
Digium, Inc. | Director of Software Technologies
Jabber: [email-masked] | SIP: [email-masked] | Skype: kpfleming
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
Check us out at www.digium.com & www.asterisk.org