Subject: Re: [MMUSIC] Suggestion to moving ahead with BUNDLE

From: Stefan Hakansson LK <[email-masked]>
Date: Wed, 8 Feb 2012 12:03:27 +0100

Being involved in the rtcweb/webrtc work, I would like this proposal to 
move forward (as it solves an important problem in that context).

Stefan

On 02/08/2012 12:00 PM, Stefan Håkansson LK wrote:
> Hi,
>
> At the Taipei IETF I presented the BUNDLE draft, written by myself
> and Harald, which extends the SDP grouping framework in order to
> allow the usage of identical port values in multiple m- lines in an
> SDP offer/answer.
>
>
>
> http://tools.ietf.org/id/draft-holmberg-mmusic-sdp-multiplex-negotiation-00.txt
>
>  It can be used when negotiating the usage of multiplexing of
> multiple media streams. Such mechanism is very likely going to be
> needed e.g. in the work being done in RTCWEB.
>
> When presented, some people indicated that they may want to look at
> other alternatives.
>
> However, as no alternative solutions have been brought forward since
> then, my question is whether people now would be interested in
> moving ahead with the BUNDLE mechanism, and adopt the above draft as
> a starting point?
>
> Best regards,
>
> Christer

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Wed, 8 Feb 2012 11:58:52 +0000

+1

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Stefan Hakansson LK
>Sent: Wednesday, February 08, 2012 4:33 PM
>To: [email-masked]
>Subject: Re: [MMUSIC] Suggestion to moving ahead with BUNDLE
>
>> At the Taipei IETF I presented the BUNDLE draft, written by myself and
>> Harald, which extends the SDP grouping framework in order to allow the
>> usage of identical port values in multiple m- lines in an SDP
>> offer/answer.
>>
>>
>>
>>  It can be used when negotiating the usage of multiplexing of multiple
>> media streams. Such mechanism is very likely going to be needed e.g.
>> in the work being done in RTCWEB.
>>
>> then, my question is whether people now would be interested in moving
>> ahead with the BUNDLE mechanism, and adopt the above draft as a
>> starting point?
>>
>> Best regards,
>>
>> Christer
>
>_______________________________________________
>mmusic mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Severa, Michael J (Mike)" <[email-masked]>
Date: Thu, 9 Feb 2012 11:57:04 -0600

Just out of curiosity, how does this relate/compare to RFC5888? Was there much thought put into usage within RTSP environments? 

Thanks,

MIke

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stefan Hakansson LK
Sent: Wednesday, February 08, 2012 3:03 AM
To: [email-masked]
Subject: Re: [MMUSIC] Suggestion to moving ahead with BUNDLE

Being involved in the rtcweb/webrtc work, I would like this proposal to move forward (as it solves an important problem in that context).

Stefan

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 09 Feb 2012 15:53:50 -0500

On 2/9/12 12:57 PM, Severa, Michael J (Mike) wrote:
> Just out of curiosity, how does this relate/compare to RFC5888?

 From 5888:

8.5.3. Same IP Address and Port Number

    If media streams using several different codecs have to be sent to
    the same IP address and port, the traditional SDP syntax of listing
    several codecs in the same "m" line MUST be used.  FID MUST NOT be
    used to group "m" lines with the same IP address/port.

	Thanks,
	Paul

> Was there much thought put into usage within RTSP environments?
>
> Thanks,
>
> MIke
>

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 09 Feb 2012 14:57:01 -0800

> Just out of curiosity, how does this relate/compare to RFC5888?
It is a direct application of the mechanism that RFC 5888 provides.
Note: It is completely independent of the FID specification in RFC 5888.
>   Was there much thought put into usage within RTSP environments?
None at all as far as I know; the requirement that led to this being 
written came from a pure RTP environment.