Subject: Re: [MMUSIC] Suggestion to moving ahead with BUNDLE

From: Cullen Jennings <[email-masked]>
Date: Tue, 7 Feb 2012 06:15:54 -0700

I think this draft is very good and solves an important problem. We have been discussing this a long time, there is lots of consensus that this is basically the right way to go, I really hope the WG adopts it soon. 

Cullen

On Jan 31, 2012, at 9:30 AM, Christer Holmberg wrote:

> 
> FYI,
> 
> Christer
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
> Sent: 31. tammikuuta 2012 15:09
> To: [email-masked]
> Subject: [MMUSIC] Suggestion to moving ahead with BUNDLE
> 
> Hi,
> 
> At the Taipei IETF I presented the BUNDLE draft, written by myself and Harald, which extends the SDP grouping framework in order to allow the usage of identical port values in multiple m- lines in an SDP offer/answer.
> 
> 
> 
> http://tools.ietf.org/id/draft-holmberg-mmusic-sdp-multiplex-negotiation-00.txt
> 
> It can be used when negotiating the usage of multiplexing of multiple media streams. Such mechanism is very likely going to be needed e.g. in the work being done in RTCWEB.
> 
> When presented, some people indicated that they may want to look at other alternatives.
> 
> However, as no alternative solutions have been brought forward since then, my question is whether people now would be interested in moving ahead with the BUNDLE mechanism, and adopt the above draft as a starting point?
> 
> Best regards,
> 
> Christer
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: Justin Uberti <[email-masked]>
Date: Tue, 7 Feb 2012 18:39:31 -0800

I agree this is an important problem to solve, and I like the clean
approach proposed in this document.

We have implemented an initial version of this functionality without much
difficulty and would like to see this proposal move forward.

--justin

> > At the Taipei IETF I presented the BUNDLE draft, written by myself and
> Harald, which extends the SDP grouping framework in order to allow the
> usage of identical port values in multiple m- lines in an SDP offer/answer.
> >
> >
> >
> >
> > It can be used when negotiating the usage of multiplexing of multiple
> media streams. Such mechanism is very likely going to be needed e.g. in the
> work being done in RTCWEB.
> >
> > However, as no alternative solutions have been brought forward since
> then, my question is whether people now would be interested in moving ahead
> with the BUNDLE mechanism, and adopt the above draft as a starting point?
> >
> > Best regards,
> >
> > Christer