Subject: [MMUSIC] ICE and draft-ietf-mmusic-sctp-sdp

From: Cullen Jennings <[email-masked]>
Date: Mon, 19 Mar 2012 08:00:48 -0600

I like draft-ietf-mmusic-sctp-sdp but I'd like to see it have more stuff in it. Specifically I would like it to 

1) clearly define how to do the SDP for use of SCTP over DTLS over UPD with ICE. This is the use case we need to solve 

2) make sure it works with bundle 

3) SCTP has sub addresses (SCTP Channels), I think these need to be negotiated as well in some cases so I would like to see an optional way of negotiating and signaling the channels including correlation with some sort of application defined label 

Cullen

---

From: Salvatore Loreto <[email-masked]>
Date: Tue, 20 Mar 2012 09:56:44 +0100

Hi Cullen,

>  1) clearly define how to do the SDP for use of SCTP over DTLS over UPD with ICE. This is the use case we need to solve
right,
in Quebec we decided not to specify the ICE usage for *plain* SCTP in
this draft...
but for sure we have to define the usage of SCTP over DTLS with ICE in
the draft

>  2) make sure it works with bundle
+1

>  3) SCTP has sub addresses (SCTP Channels), I think these need to be negotiated as well in some cases so I would like to see an optional way of negotiating and signaling the channels including corr…

yep,  we can define a way to signal/negotiate the number of channels we
want initially in the association vs having this number configured;
and eventually even go further e.g. negotiate the addition of channels,
and perhaps some sort of correlation of a channel
with an application defined label

Salvatore

-- 
Salvatore Loreto, PhD
www.sloreto.com