Subject: [MMUSIC] WGLC of draft-ietf-mmusic-rfc2326bis-29.txt

From: "Miguel A. Garcia" <[email-masked]>
Date: Wed, 18 Apr 2012 15:02:06 +0200

This is to start a 4-week Working Group Last Call for

      draft-ietf-mmusic-rfc2326bis-29.txt

The WGLC ends on May 16th, 2012. Notice that this is a special 4-week 
WGLC due to the length of the document.

We would especially like reviewers to focus on the changes since the last 
WGLC, which was for version -23.

Please reply to this e-mail that includes the authors and the mailing list.

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 19 Apr 2012 11:10:17 +0200

> Please reply to this e-mail that includes the authors and the mailing list.

Hi,

As an author I can post the link of the Diff between 23 and now:

https://tools.ietf.org/rfcdiff?url1=draft-ietf-mmusic-rfc2326bis-23&difftype=--html&submit=Go!&url2=draft-ietf-mmusic-rfc2326bis-29

This is quite a substantiall amount of changes. Unfortunately the
section reordering makes it difficult to spot changes in some sub-sections.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Yuepeiyu (Roy)" <[email-masked]>
Date: Wed, 25 Apr 2012 02:24:48 +0000

Hi,

I have read the latest draft and think it is good enough for publication.

BR, Roy

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Magnus Westerlund
发送时间: 2012年4月19日 17:10
收件人: [email-masked]
主题: Re: [MMUSIC] WGLC of draft-ietf-mmusic-rfc2326bis-29.txt

Hi,

Cheers

Magnus Westerlund

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 26 Apr 2012 17:56:14 +0200

Hi,

I have to add a WG last call comment on my own document. This comes from
a discussion on the AVTCORE ECN for RTP document with Pete Resnick
regarding ABNF extension definitions and the qdtext definition of UTF-8.

Fist of all it doesn't provide any escaping of strings including " and
secondly its definition of UTF-8 and additional characters are in error.

>     quoted-string   =  ( DQ *qdtext DQ )
>     qdtext          =  %x20-21 / %x23-7E / %x80-FF / UTF8-NONASCII
>                        ; any UTF-8 TEXT except<">
>     DQ              =  %x22  ; US-ASCII double-quote mark (34)
>     UTF8-NONASCII    =  %xC0-DF 1UTF8-CONT
>                      /  %xE0-EF 2UTF8-CONT
>                      /  %xF0-F7 3UTF8-CONT
>                      /  %xF8-FB 4UTF8-CONT
>                      /  %xFC-FD 5UTF8-CONT
>     UTF8-CONT        =  %x80-BF
>
First of all, I don't think you should be including %x80-FF not in the
context of UTF-8. As you said, if you want binary content (or random
octets), you can always BASE64 the thing. This should be for strings,
and that means either US-ASCII or UTF-8 and nothing else.

I think you should incorporate definitions from 5234 (DQUOTE) and 3629
(UTF8-1, UTF8-2, UTF8-3, and UTF8-4) and simply make this:

quoted-string = ( DQUOTE *qdtext DQUOTE )
qdtext = %x20-21 / %x23-7E / UTF8-NONASCII
UTF8-NONASCII = UTF8-1 / UTF8-2 / UTF8-3 / UTF8-4

If you want to add the quoted-pair escaping mechanism, the simplest
would be:

quoted-string = ( DQUOTE *qdtext DQUOTE )
qdtext = %x20-21 / %x23-5B / %x5D-7E / quoted-pair / UTF8-NONASCII
    ; No DQUOTE and no "\"
quoted-pair = "\\" / ( "\" DQUOTE )
UTF8-NONASCII = UTF8-1 / UTF8-2 / UTF8-3 / UTF8-4

Cheers

Magnus Westerlund