Subject: [MMUSIC] I-D Action: draft-ietf-mmusic-sctp-sdp-03.txt

From: [email-masked]
Date: Mon, 21 Jan 2013 05:53:24 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

	Title           : Stream Control Transmission Protocol (SCTP)-Based Media Transport in the Session Description Protocol (SDP)
	Author(s)       : Salvatore Loreto
                          Gonzalo Camarillo
	Filename        : draft-ietf-mmusic-sctp-sdp-03.txt
	Pages           : 14
	Date            : 2013-01-21

Abstract:
   SCTP (Stream Control Transmission Protocol) is a transport protocol
   used to establish associations between two endpoints.  This document
   describes how to express media transport over SCTP in SDP (Session
   Description Protocol).  This document defines the 'SCTP', 'SCTP/DTLS'
   and 'DTLS/SCTP' protocol identifiers for SDP.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mmusic-sctp-sdp

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-mmusic-sctp-sdp-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-sctp-sdp-03

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Horvath, Ernst" <[email-masked]>
Date: Wed, 23 Jan 2013 13:13:59 +0000

I am sorry to say that the treatment of attributes in this I-D is a bit of a mess. 

- In 4.3 the attributes are introduced with a colon-notation, e.g. "a=stream:", but the ABNF definitions in 5.2 through 5.7 use a notation "a=stream=" etc. The colon-notation is the more common one for SDP attributes.

- Looking at the examples, I suspect that 'sctpmap' is the only real attribute and the rest is meant to be parameters of an attribute 'webrtc-DataChannel', which appears in examples but is not defined in section 5. If this is correct then 'webrtc-DataChannel' needs to be added as a new attribute in section 5, and what is now in 5.2 - 5.7 should become sub-sections of this attribute definition and be renamed as "parameters".

- Section 11 says "This document defines two SDP session and media-level attributes", but lists only one (sctpmap). Was the missing one meant to be 'webrtc-DataChannel'?

Note: An SDP attribute 'label' is already defined (RFC 4574) and listed in the IANA registry. This would cause a name clash if 5.3 is really intended as attribute and not as parameter definition.

Thanks,
Ernst Horvath