Subject: [MMUSIC] SDP Miscellaneous capabilities: port numbers

From: <[email-masked]>
Date: Fri, 25 Jan 2013 08:17:31 +0000

Dear WG,

An issue came up during review of http://tools.ietf.org/html/draft-ietf-mmusic-sdp-miscellaneous-caps-03 . Figures 6 to 8 present an example SDP which uses the "a=ccap" connection address capability to present two alternative SDP configurations, one for IP based media, and the other for PSTN based media.

The issue is that these two alternative configurations use a different port number. However, there is currently no way to indicate alternative port numbers using the SDP capability negotiation mechanism.

For PSTN based media, the port number does not carry any meaningful information, and http://tools.ietf.org/html/draft-ietf-mmusic-sdp-cs-15 proposes to use a fixed port number (9, the discard port) which is to be ignored at reception. So, in this particular example we can add a note that since the alternative offered media uses a PSTN bearer, the port should be hardcoded to "9" by the implementer. However, for other types of media this does not work, nor is the example usable in the case where PSTN media is included in the "m=" line, and the address for alternative RTP based media using the "a=ccap" attribute.

In order to fix the issue, probably something like "port capability attribute" should be defined. This has been discussed in the past, but it has its own challenges (because of overlap with ICE, among other things).

The authors' proposal consist of adding a paragraph in the example description where we indicate that this particular example works because the CS description uses a well-known port number, but in general, the example is not applicable if the negotiated capabilities require a change in the port number.

Regards,
Simo & Miguel

---

From: Andrew Allen <[email-masked]>
Date: Fri, 25 Jan 2013 11:25:20 +0000

I am fine with the proposal.

Andrew

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, January 25, 2013 3:18 AM
To: [email-masked]
Subject: [MMUSIC] SDP Miscellaneous capabilities: port numbers

Dear WG,

Regards,
Simo & Miguel

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.