Subject: Re: [MMUSIC] The rtp-duplication related drafts - Initial comments on draft-ietf-mmusic-delayed-duplication

From: Christer Holmberg <[email-masked]>
Date: Tue, 8 Jan 2013 12:56:15 +0000

Hi Ali,

Some initial comments on draft-ietf-mmusic-delayed-duplication:

Q1:	I assume the attribute indicates the SENDING delay, or? I think it needs to be more explicit.

Q2:	There are no SDP Offer/Answer considerations. Does the Offer have impact on the Answer? What is the expected behavior if the Answerer does not support the mechanism? Etc.

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ali C. Begen (abegen)
Sent: 4. tammikuuta 2013 0:31
To: [email-masked]
Subject: [MMUSIC] The rtp-duplication related drafts

Hi everyone,

The following two drafts have been adopted by MMUSIC a while ago and the main draft discussing the RTP duplication issues is being finalized in AVTEXT (this was also adopted as a WG item a while ago). It is simply waiting for the WG to make a decision on the srcname proposal.

http://datatracker.ietf.org/doc/draft-ietf-mmusic-delayed-duplication/
http://datatracker.ietf.org/doc/draft-ietf-mmusic-duplication-grouping/

These two mmusic drafts are essentially completed and they are needed to be done for the avtext draft. I hope they will be WGLC'ed some time soon. In the mean time, I would like to get any comments, feedback that you might have.

Thanks.
-acbegen

PS Here is the AVTEXT draft.
http://datatracker.ietf.org/doc/draft-ietf-avtext-rtp-duplication/ 
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Tue, 8 Jan 2013 16:46:57 +0000

Hi Christer,

> Q1:	I assume the attribute indicates the SENDING delay, or? I think it needs to be more explicit.
Yes, the dup delay refers to the delay applied during sending. The delay between the dup packets might be different on the receiving side. Is this what you asked?

> Q2:	There are no SDP Offer/Answer considerations. Does the Offer have impact on the Answer? What is the expected behavior if the Answerer does not support the mechanism? Etc.

This attribute is used with the grouping defined in the other draft. And O/A stuff applies to that grouping semantics, which the draft explains. Maybe, I should put a note regarding this in this draft?

Cheers,
-acbegen