Subject: [MMUSIC] The rtp-duplication related drafts

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Thu, 3 Jan 2013 22:31:11 +0000

Hi everyone,

The following two drafts have been adopted by MMUSIC a while ago and the main draft discussing the RTP duplication issues is being finalized in AVTEXT (this was also adopted as a WG item a while ago). It is simply waiting for the WG to make a decision on the srcname proposal.

http://datatracker.ietf.org/doc/draft-ietf-mmusic-delayed-duplication/
http://datatracker.ietf.org/doc/draft-ietf-mmusic-duplication-grouping/

These two mmusic drafts are essentially completed and they are needed to be done for the avtext draft. I hope they will be WGLC'ed some time soon. In the mean time, I would like to get any comments, feedback that you might have.

Thanks.
-acbegen

PS Here is the AVTEXT draft.
http://datatracker.ietf.org/doc/draft-ietf-avtext-rtp-duplication/

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 03 Jan 2013 21:29:17 -0500

Ali,

> http://datatracker.ietf.org/doc/draft-ietf-mmusic-duplication-grouping/

I have a question about these:

Each example shows only one group. But couldn't there be multiple 
duplication groups?

If so, the current proposal has no mechanism for specifying separate 
duplication-delay for each group.

	Thanks,
	Paul

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Fri, 4 Jan 2013 02:47:18 +0000

Thanks for the review.

On Jan 3, 2013, at 9:29 PM, Paul Kyzivat <[email-masked]> wrote:

> Each example shows only one group. But couldn't there be multiple duplication groups?
> 
There could be.

> If so, the current proposal has no mechanism for specifying separate duplication-delay for each group.
> 

a=duplication-delay:X could be specified in each media session. For example:

	a=rtpmap:100 MP2T/90000
        a=ssrc:1000 cname:[email-masked]
        a=ssrc:1010 cname:[email-masked]
        a=ssrc-group:DUP 1000 1010
        a=duplication-delay:100
        a=mid:Group1
	a=rtpmap:101 MP2T/90000
        a=ssrc:2000 cname:[email-masked]
        a=ssrc:2010 cname:[email-masked]
        a=ssrc-group:DUP 2000 2010
        a=duplication-delay:150
        a=mid:Group2

(The SSRC need not be different as SSRC only need to be unique within each media session)

For the non-ssrc grouping, your comment holds. It does not support specifying different delay values for different groups. Do you think we should support distinct delay values for different groups (which probably means duplication-delay attribute has to be media-level only)?

-acbegen

> 	Thanks,
> 	Paul
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 03 Jan 2013 22:41:31 -0500

>          a=ssrc-group:DUP 2000 2010

This makes the attributes very order dependent. If this is intended, 
then I think you need more words to say that. Currently it says:

    If used as a media-level
    attribute, it MUST be used with the 'ssrc-group' attribute and "DUP"
    grouping semantics...

What does "used with" mean? I assumed it simply meant that both 
attributes had to be present in the media section. But what you are 
saying now says that there is some very specific ordering required. E.g. 
that the a=duplicaation-delay must follow the a=ssrc-group:DUP to which 
it applies, and precede any other a=ssrc-group:DUP. This is possible, 
but ugly to specify.

> For the non-ssrc grouping, your comment holds. It does not support specifying different delay values for different groups. Do you think we should support distinct delay values for different groups…

I don't know. Nothing seems appealing.

	Thanks,
	Paul

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Fri, 4 Jan 2013 04:20:11 +0000

On Jan 3, 2013, at 10:41 PM, Paul Kyzivat <[email-masked]> wrote:

> This makes the attributes very order dependent. If this is intended, then I think you need more words to say that. Currently it says:
> 
>   If used as a media-level

My mistake, did not copy/paste the whole thing.

	m=video 30000 RTP/AVP 100
        c=IN IP4 233.252.0.1/127
        a=source-filter:incl IN IP4 233.252.0.1 198.51.100.1
        a=rtpmap:100 MP2T/90000
        a=ssrc:1000 cname:[email-masked]
        a=ssrc:1010 cname:[email-masked]
        a=ssrc-group:DUP 1000 1010
        a=duplication-delay:100
        a=mid:Group1
	m=video 40000 RTP/AVP 101
        c=IN IP4 233.252.0.2/127
        a=source-filter:incl IN IP4 233.252.0.2 198.51.100.1
        a=rtpmap:101 MP2T/90000
        a=ssrc:2000 cname:[email-masked]
        a=ssrc:2010 cname:[email-masked]
        a=ssrc-group:DUP 2000 2010
        a=duplication-delay:150
        a=mid:Group2

so there is one duplication-delay attribute in each media session (specified by a m= line). It does not matter whether it is before or after the ssrc-group line. It is OK as long as it is somewhere before the next m line.

> 
> What does "used with" mean? I assumed it simply meant that both attributes had to be present in the media section. But what you are saying now says that there is some very specific ordering required. E.g. that the a=duplicaation-delay must follow the a=ssrc-group:DUP to which it applies, and precede any other a=ssrc-group:DUP. This is possible, but ugly to specify.

I hope it is clear now?

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 07 Jan 2013 15:06:40 -0500

> so there is one duplication-delay attribute in each media session (specified by a m= line). It does not matter whether it is before or after the ssrc-group line. It is OK as long as it is somewhere…

But then, duplication-delay applies to a=ssrc-group:DUP groups within 
that media section. You could have two groups of ssrcs in there. So the 
problem is the same as the problem across different m-lines. E.g.

	m=video 30000 RTP/AVP 100
         c=IN IP4 233.252.0.1/127
         a=source-filter:incl IN IP4 233.252.0.1 198.51.100.1
         a=rtpmap:100 MP2T/90000
         a=ssrc:1000 cname:[email-masked]
         a=ssrc:1010 cname:[email-masked]
         a=ssrc:1020 cname:[email-masked]
         a=ssrc:1030 cname:[email-masked]
         a=ssrc-group:DUP 1000 1010
         a=duplication-delay:100
         a=ssrc-group:DUP 1020 1030
         a=duplication-delay:200
	m=video 40000 RTP/AVP 101
         c=IN IP4 233.252.0.2/127
         a=source-filter:incl IN IP4 233.252.0.2 198.51.100.1
         a=rtpmap:101 MP2T/90000
         a=ssrc:2000 cname:[email-masked]
         a=ssrc:2010 cname:[email-masked]
         a=ssrc-group:DUP 2000 2010
         a=ssrc:2020 cname:[email-masked]
         a=ssrc:2030 cname:[email-masked]
         a=ssrc-group:DUP 2020 2030
         a=duplication-delay:250

 From what you say, the two duplication-delay attributes in one media 
section would make no sense.

>>> For the non-ssrc grouping, your comment holds. It does not support specifying different delay values for different groups. Do you think we should support distinct delay values for different group…

Well, for the non-ssrc grouping you could put the group name in the 
a=duplication-delay attribute value.

And for the ssrc-grouping case you could put one of the grouped ssrcs in 
the a=duplication-delay attr value.

	Thanks,
	Paul