Subject: [MMUSIC] Cullen Notes from ports call today.

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 21 Feb 2013 19:30:40 +0000

My random notes more for myself than anyone else …

Christer explained new draft is combination between old and new. If you don't each side support bundle, use diff port number in offer, after that you use same with 

Question about 3pcc use cases. Not clear exactly what cases because some of the B2BUA cases, it's not an issues.  Dale  point at music on hold MOH case, draft-worrley-service-example. To me this looks like a B2BUA that is offering SDP that it does not understand. If an INVITE with replaces was used instead of re-INVITE in same dialog seems like this would work fine. 

Some people thought that every offer/answer re was in depended of previous one. People gave example where is just not this way. For example, ICE can not restarted on updated offer, m line can be offer. 

Richard pointed out this is lesser of evils, suggestion is initial offer differs ports, answer if it does not want to bundle, use diff ports. If answer wants to do multiplexing, then 5 tuple used is first valid non zero m-line is used for the entire bundle. All others are disabled by port=0 or connection address is unspecified. Still have bundle group to group these all together. For subsequent offer answers, does the offer have candidates for all m-lines or just one valid line. Revised idea, the port used by offerer, is first valid m line in offer, the port used in answer, is first valid port in answer. May not be the same m-line. Middle boxes would need to know about this to have any hope of working. Problem that the answer can't disable some m-line's in subsequent o/a. 

Open issue is does a subsequent offer in a dialog has different or same ports. 

how to have m-line that are only used if you do bundle?

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 22 Feb 2013 11:51:12 +0000

>how to have m-line that are only used if you do bundle?

There is a solution alternative for that, called MMT :)

Regards,

Christer