Subject: Re: [MMUSIC] Signaling trickle support

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Fri, 22 Feb 2013 03:09:28 +0000

On Nov 13, 2012, at 2:03 AM, Harald Alvestrand <[email-masked]> wrote:

>> Because of the min. 20 ms Ta timer constraints, which apply cross-media stream ? Can somebody refresh my mind as to why that is (e.g. are residential NATs at this point generally not capable of creating NAT bindings faster than at 20 ms intervals) ?
> I have been told that in BEHAVE testing, NATs were found that would behave incoherently at short binding creation intervals, but none were found that couldn't handle one new binding every 20 ms, so this was set at the minimum interval for potentially binding-creation actions.
> 
>            Harald

Some of the testing was getting the programs working for the results in http://tools.ietf.org/html/draft-jennings-midcom-stun-results-02 but other stuff done at Cornel and I think MIT came up with similar results.

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Fri, 22 Feb 2013 03:11:10 +0000

On Nov 13, 2012, at 10:57 AM, Flemming Andreasen <[email-masked]> wrote:

> I've been told (second hand) that Google Maps routinely opens 50 TCP connections at a time, but don't have any details as to the speed with which they are opened. Anybody have any further insights or similar examples (that seem to work in practice) ?

Google maps is a bad example as it regularly has this fail in many locations - when it fails, there are whole strips of the map that do not load. So it is pretty much an example of something that is on the fairly aggressive level.