Subject: [MMUSIC] SDP Directorate: Review of draft-ietf-xrblock-rtcp-xr-decodability-07

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Sun, 24 Feb 2013 21:54:54 +0000

I am the assigned SDP directorate reviewer for this draft. For background
on the SDP directorate, please see the FAQ at
http://www.ietf.org/iesg/directorate/sdp.html

Please wait for direction from your document shepherd or AD before posting
a new version of the draft.

Summary:
--------
- The RTCP XR extension syntax looks fine
- There is one (small) technical issue
- There are quite a few editorial issues

Technical Issues:
-----------------
1) I am puzzled why you named the new block as "non-psi-ts-decodability".
It does not follow what you have in the title. I also did not get the
"non" part.

Editorial Issues:
-----------------
1) I don't have the ISO document handy but I think the container is called
MPEG2 Transport Stream not MPEG Transport Stream. Please double check.

2) The abstract mentions the use of broadcast of transport streams in IPTV
systems. IPTV uses only unicast and multicast. Cable and satellite systems
use the broadcast of transport streams.

3) Document's short name is "RTCP XR Non PSI Decodability". Why?

4) The title has "metric" but the abstract has "metrics." Please be
consistent.

5) Section 1.1. "application-dependant" -> "application-dependent"

6) Use either "decodability" or "de-codability".

7) Section 1.4. AFAIK, there is no such thing called "MPEG4 TS content."
The content could be encoded with MPEG4 but the transport stream is still
MPEG2 Transport Stream. So, you could say "MPEG4 over MPEG2-TS over RTP."

8) The text seems to be using both "MPEG TS PSI Independent decodability
statistics metrics" and "MPEG-TS PSI Independent Decodability Metrics". I
think you need the former.

9) There are several typos (mostly due to copy/paste errors). Please fix
them. Acknowledgements section also has misspellings and typos.

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 25 Feb 2013 08:28:22 +0000

Dear Ali,

Thank you for the review. Please see inline.

Best Regards!
Rachel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ali C. Begen (abegen)
Sent: Monday, February 25, 2013 5:55 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [MMUSIC] SDP Directorate: Review of draft-ietf-xrblock-rtcp-xr-decodability-07

Summary:
--------

Technical Issues:
-----------------

[Rachel]: To get consistent with the title we used, how about we propose to change the block name in SDP as "ts-psi-indep-decodability"?

Editorial Issues:
-----------------

[Rachel]: Okay. Thanks.

[Rachel]: Okay. Will fix this.

[Rachel]: Will be changed to "RTCP XR PSI Independent Decodability".

[Rachel]:Okay.

[Rachel]:Okay.

[Rachel]:Okay.

[Rachel]:Right.

[Rachel]:Okay.

[Rachel]: Will do.

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 25 Feb 2013 09:48:59 +0000

-----Original Message-----
From: "Huangyihong   (Rachel)" <[email-masked]>
Date: Monday, February 25, 2013 3:28 AM
To: "Ali C. Begen" <[email-masked]>,
"[email-masked]"
<[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: RE: [MMUSIC] SDP Directorate: Review of
draft-ietf-xrblock-rtcp-xr-decodability-07

>[Rachel]: To get consistent with the title we used, how about we propose
>to change the block name in SDP as "ts-psi-indep-decodability"?

I see that you already submitted a revision. Your current title says:

RTP Control Protocol (RTCP) Extended Report (XR) Block for MPEG2 Program
      Specific Information (PSI) Independent Transport Stream (TS)
                Decodability Statistics Metric reporting

This still does not make sense to me. "Transport Stream" should be before
"Program Specific Information". My other comment on the title was it
should be "Š Metrics Reporting" not "Metric reporting".

-acbegen

---

From: Qin Wu <[email-masked]>
Date: Mon, 25 Feb 2013 18:41:10 +0800

Fixed.
The diff is:
http://www.ietf.org/rfcdiff?url2=draft-ietf-xrblock-rtcp-xr-decodability-09

Regards!
-Qin
----- Original Message ----- 
From: "Ali C. Begen (abegen)" <[email-masked]>
To: "Huangyihong (Rachel)" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Monday, February 25, 2013 5:48 PM
Subject: Re: [xrblock] [MMUSIC] SDP Directorate: Review of draft-ietf-xrblock-rtcp-xr-decodability-07

-----Original Message-----
From: "Huangyihong   (Rachel)" <[email-masked]>
Date: Monday, February 25, 2013 3:28 AM
To: "Ali C. Begen" <[email-masked]>,

-acbegen

_______________________________________________
xrblock mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/xrblock