Subject: [MMUSIC] The 171-attribute spreadsheet

From: Harald Alvestrand <[email-masked]>
Date: Wed, 06 Feb 2013 05:28:30 +0100

Just in case anyone else lost the link, the spreadsheet with all defined 
SDP attributes that an m-line can have is here:

https://docs.google.com/spreadsheet/ccc?key=0Av-aF69sk5C6dDhPblpRV2pkbXVGNV9lUFI3cHlIRFE#gid=0

Everyone with the link should be able to edit.

             Harald

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 6 Feb 2013 22:51:57 +0100

This is still missing any criteria for deciding whether something is in or out. I assume importance to RTCWEB has only two values from what I can see (1 = important, 0 = not important). I believe I could make a use case for all of these being supported, I'm sure all of them can be found in SDP when interworking - the question is whether any of these cases are useful to applications or not, and whether an otherwise successful communication would fail if an attribute was not understood, and therefore dropped.

I can solve the problem of g.3gpp.cat and g.3gpp.crs for you. These are misregistrations and are in fact values of the content attribute (which is missing from your list because it has only just been inserted as a correction, and probably is important to RTCWEB). It is in the process of being sorted but requires some changes to the registration data in the references specification to make things clear.

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Harald Alvestrand
Sent: 06 February 2013 04:29
To: mmusic; [email-masked]
Subject: [rtcweb] The 171-attribute spreadsheet

Just in case anyone else lost the link, the spreadsheet with all defined SDP attributes that an m-line can have is here:

            Harald

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 07 Feb 2013 04:16:17 +0100

On 02/06/2013 10:51 PM, DRAGE, Keith (Keith) wrote:
>
> This is still missing any criteria for deciding whether something is 
> in or out. I assume importance to RTCWEB has only two values from what 
> I can see (1 = important, 0 = not important). I believe I could make a 
> use case for all of these being supported, I'm sure all of them can be 
> found in SDP when interworking -- the question is whether any of these 
> cases are useful to applications or not, and whether an otherwise 
> successful communication would fail if an attribute was not 
> understood, and therefore dropped.
>
I don't think "in" or "out" is what we're looking for.
It's either Transport, Flow or Media - which gives us a basis for seeing 
how bigthe problem is:

- under BUNDLE, there must be new rules for Transport ("pick first", 
"sum values", or "other processing")
- under "two M-lines" and MMT, theFlow attributes need to be redefined 
to be per-SSRC, or we have to decide to ignore them
- I think the Media ones are OK with either proposal, unless some usage 
of them depends on there being only one flow in an M-line, in which case 
they're really Flow, even though they're marking Media

I put in only 1 and 0 for RTCWEB because I started in on the easy cases- 
if you feel a more graded scale is useful, please suggest values!

> I can solve the problem of g.3gpp.cat and g.3gpp.crs for you. These 
> are misregistrations and are in fact values of the content attribute 
> (which is missing from your list because it has only just been 
> inserted as a correction, and probably is important to RTCWEB). It is 
> in the process of being sorted but requires some changes to the 
> registration data in the references specification to make things clear.
>
values of a=content? That's good to know about. Hope you can put notes 
on those in the "notes" columns!

> Keith
>
> ------------------------------------------------------------------------
>
> *From:[email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Harald Alvestrand
> *Sent:* 06 February 2013 04:29
> *To:* mmusic; [email-masked]
> *Subject:* [rtcweb] The 171-attribute spreadsheet
>
> Just in case anyone else lost the link, the spreadsheet with all 
> defined SDP attributes that an m-line can have is here:
>