Subject: [MMUSIC] How does an answerer reject the first m line in a BUNDLE?

From: "Ejzak, Richard P (Richard)" <[email-masked]>
Date: Mon, 25 Feb 2013 15:52:00 +0000

Hi Christer,
In rereading your latest BUNDLE draft I was confused about what the answerer does when it needs to reject the first m line in a bundle group.  The following text in your draft implies to me that the answerer is not allowed to reject the first m line:

"Until the SDP Answerer receives the new SDP Offer, which contains an

   identical port number value for each "m=" line associated with a

   "BUNDLE" group, it MUST use the port, and related information (ICE

   candidates, SDES keys etc) associated with the first "m=" line in the

   "BUNDLE" group."

What does this text mean if the answerer rejects the first line?  Doesn't this mean that the answerer must wait for the "new" SDP offer with identical ports for each group member before it knows the 5-tuple to use for the bundle, thus delaying call setup?  What does it mean to use SDES keys for a rejected m line (since these keys should only apply to this m line).

It may not be common to reject the first line but I think we have to allow for it.

BR, Richard

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 25 Feb 2013 20:36:05 +0000

Hi,

>“Until the SDP Answerer receives the new SDP Offer, which contains an

>   "BUNDLE" group.”
>
>What does this text mean if the answerer rejects the first line?  Doesn’t this mean that the answerer must wait for the “new” SDP offer with identical ports for each group member before it knows the
>5-tuple to use for the bundle, thus delaying call setup?  What does it mean to use SDES keys for a rejected m line (since these keys should only apply to this m line).

If the answerer rejects the first m- line, I guess it has to wait for the second offer.

Note that Charles suggested that the answerer shall always wait for the second offer anyway, so that's something that needs to be discussed.

>It may not be common to reject the first line but I think we have to allow for it.

Absolutely.

Regards,

Christer

---

From: [email-masked] (Dale R. Worley)
Date: Mon, 25 Feb 2013 17:44:42 -0500 (EST)

> From: "Ejzak, Richard P (Richard)" <[email-masked]>
> 
> In rereading your latest BUNDLE draft I was confused about what the
> answerer does when it needs to reject the first m line in a bundle
> group.  The following text in your draft implies to me that the
> answerer is not allowed to reject the first m line:

My opinion is that handling the "reject the first m= line" problem is
sufficiently messy that it is one of the major reasons why we should
have a separate bundle media description.  A separate bundle media
description allows the constituent media descriptions to be accepted
or rejected independently without complicated logic to relocate the
bundle transport flow information between media descriptions.

Dale