Subject: [MMUSIC] BUNDLE: Allowed to change local bundle port in SDP Answer?

From: Christer Holmberg <[email-masked]>
Date: Wed, 29 May 2013 09:35:35 +0000

Hi,

When the answerer receives the first bundle offer, it will assign a local bundle port. Nothing strange there.

Paul raised a question whether, when an updated offer is received, the answerer is allowed to change the local bundle port in the associated answer.

Personally, I can't think of a reason why it should not be allowed - no matter whether the offer contains different bundle ports or not - it would be according to normal O/A procedures.

If NOT allowed, if the answerer wants to change its local bundle port, it would have to send a new offer by itself (the details of such offer is discussed in another tread).

Comments?

Regards,

Christer

---

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 29 May 2013 10:05:38 +0000

Cannot see why the answerer should be prevented from changing the port and even the connection address and candidates etc. in any new answer any such restriction would seem to be a major diversion from existing offer/answer procedures and I cannot see why we would want to consider it.

We need to maintain the existing offer/answer procedures as much as possible.

Andy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 29 May 2013 10:36
To: [email-masked]
Subject: [MMUSIC] BUNDLE: Allowed to change local bundle port in SDP Answer?

Hi,

Comments?

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 29 May 2013 10:10:15 +0000

Hi,

> Cannot see why the answerer should be prevented from changing the port and even the connection address and 
> candidates etc. in any new answer any such restriction would seem to be a major diversion from existing offer/answer 
> procedures and I cannot see why we would want to consider it.
>

Agree.

Regards,

Christer

Hi,

Comments?

Regards,

Christer