Subject: [MMUSIC] BUNDLE DECISSION: SDP Answer Restrictions

From: Christer Holmberg <[email-masked]>
Date: Fri, 24 May 2013 12:32:37 +0000

Hi,

At the interim meeting yesterday, we agreed on some restrictions regarding creating SDP answers containing bundle group(s).

Note that the restrictions 1-3 are simply alignments with RFC 5888, and are listed simply for clarification purpose. Restrictions 4 is BUNDLE specific. Restriction 5 is also alignment with RFC 5888, as m- lines with port zero are not allowed within groups, but we will need some clarification text saying that a new offer will have to be sent in order to remove a stream (either from a bundle group, or completely from the session).

(Note that the text below is not necessarily the wording that will go into the draft)

In an SDP answer:

1)      a BUNDLE group MUST NOT be created, unless it was included in the associated offer

2)      an m- line MUST NOT be added to a BUNDLE group, unless it was included in a BUNDLE group in the associated offer

3)      an m- line MUST NOT be added to another BUNDLE group than the group in which was included in the associated offer

4)      an m- line MUST NOT be removed from a BUNDLE group if, in the associated offer, an identical port number was indicated for all m- lines in a BUNDLE group

5)      an m- line MUST NOT be rejected if, in the associated offer, an identical port number was indicated for all m- lines in a BUNDLE group

Note that there is also a discussion regarding bundle offers, e.g. when restrictions when adding new m- lines to a bundle. Based on the outcome of that, there may be some additional answer restrictions, e.g. regarding the change of bundle transport parameters. But, let's deal with that in the offer thread.

So, if anyone OBJECTS to the restrictions above, please indicate so.

Regards,

Christer

---

From: Kevin Dempsey <[email-masked]>
Date: Fri, 24 May 2013 15:39:54 +0100

Can someone please explain why a m-line can be rejected when the port
numbers are different, but not if all the port numbers are the same?

On 24 May 2013 13:32, Christer Holmberg <[email-masked]>wrote:

>  Hi,****
>
> ** **
>
> At the interim meeting yesterday, we agreed on some restrictions regarding
> creating SDP answers containing bundle group(s).****
>
> ** **
>
> Note that the restrictions 1-3 are simply alignments with RFC 5888, and
> are listed simply for clarification purpose. Restrictions 4 is BUNDLE
> specific. Restriction 5 is also alignment with RFC 5888, as m- lines with
> port zero are not allowed within groups, but we will need some
> clarification text saying that a new offer will have to be sent in order to
> remove a stream (either from a bundle group, or completely from the
> session).****
>
> ** **
>
> (Note that the text below is not necessarily the wording that will go into
> the draft)****
>
> ** **
>
> In an SDP answer:****
>
> **1)      **a BUNDLE group MUST NOT be created, unless it was included in
> the associated offer****
>
> **2)      **an m- line MUST NOT be added to a BUNDLE group, unless it was
> included in a BUNDLE group in the associated offer****
>
> **3)      **an m- line MUST NOT be added to another BUNDLE group than the
> group in which was included in the associated offer****
>
> **4)      **an m- line MUST NOT be removed from a BUNDLE group if, in the
> associated offer, an identical port number was indicated for all m- lines
> in a BUNDLE group****
>
> **5)      **an m- line MUST NOT be rejected if, in the associated offer,
> an identical port number was indicated for all m- lines in a BUNDLE group*
> ***
>
> ** **
>
> ** **
>
> Note that there is also a discussion regarding bundle offers, e.g. when
> restrictions when adding new m- lines to a bundle. Based on the outcome of
> that, there may be some additional answer restrictions, e.g. regarding the
> change of bundle transport parameters. But, let’s deal with that in the
> offer thread.****
>
> ** **
>
> So, if anyone OBJECTS to the restrictions above, please indicate so.****
>
> ** **
>
> Regards,****
>
> ** **
>
> Christer****
>
> ** **
>
> ** **
>
> ** **
>
> ** **
>
> ** **
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 24 May 2013 10:41:00 -0400

I object to (5) below (see inline).
Otherwise these seem ok to me.

	Thanks,
	Paul

On 5/24/13 8:32 AM, Christer Holmberg wrote:
> Hi,
>
> At the interim meeting yesterday, we agreed on some restrictions
> regarding creating SDP answers containing bundle group(s).
>
> specific. Restriction 5 is also alignment with RFC 5888, as m- lines
> with port zero are not allowed within groups, but we will need some
> clarification text saying that a new offer will have to be sent in order
> to remove a stream (either from a bundle group, or completely from the
> session).
>
> 1)a BUNDLE group MUST NOT be created, unless it was included in the
> associated offer
>
> 2)an m- line MUST NOT be added to a BUNDLE group, unless it was included
> in a BUNDLE group in the associated offer
>
> 3)an m- line MUST NOT be added to another BUNDLE group than the group in
> which was included in the associated offer
>
> 4)an m- line MUST NOT be removed from a BUNDLE group if, in the
> associated offer, an identical port number was indicated for all m-
> lines in a BUNDLE group
>
> 5)an m- line MUST NOT be rejected if, in the associated offer, an
> identical port number was indicated for all m- lines in a BUNDLE group

Where did (5) come from? And what is the justification for it?
I can see no good reason to impose this restriction.

> restrictions when adding new m- lines to a bundle. Based on the outcome
> of that, there may be some additional answer restrictions, e.g.
> regarding the change of bundle transport parameters. But, let’s deal
> with that in the offer thread.
>

---

From: Suhas Nandakumar <[email-masked]>
Date: Fri, 24 May 2013 14:47:21 -0700

Hi Christer

  Please find my comments in line.

On Fri, May 24, 2013 at 5:32 AM, Christer Holmberg <
[email-masked]> wrote:

> **
  [Suhas]  .. RFC5888 doesn't clarify what does removing means. Hence, I
would be happy to see 4)
                  If a m-line is removed ( not rejected) in the Answer,
then the m-line should include a unique port that doesn't collide with port
associated with any BUNDLE groups.

5)      **an m- line MUST NOT be rejected if, in the associated offer, an
> identical port number was indicated for all m- lines in a BUNDLE group****
>
> **
>
 [Suhas]. I agree with Paul here. Rejecting a m-line MUST be allowed by the
answerer by setting port to zero and removing mid from the BUNDLE group
attribute line. This is special case where BUNDLE should be satisfied if
            a) Either all the port are identical
            b) Ports in the BUNDLE group can be zero (if rejected).

>  **
> offer thread.

 [Suhas] Agreed.

---

From: Suhas Nandakumar <[email-masked]>
Date: Fri, 24 May 2013 14:48:52 -0700

Forgot to clarify the port zero below to say "pending on RFC5888 update"

On Fri, May 24, 2013 at 2:47 PM, Suhas Nandakumar <[email-masked]>wrote:

>> regarding creating SDP answers containing bundle group(s).****
>>
>> ** **
>>
>> (Note that the text below is not necessarily the wording that will go
>> into the draft)****
>>
>> ** **
>>
>> In an SDP answer:****
>>
>> **1)      **a BUNDLE group MUST NOT be created, unless it was included
>> in the associated offer****
>>
>> **2)      **an m- line MUST NOT be added to a BUNDLE group, unless it
>> was included in a BUNDLE group in the associated offer****
>>
>> **3)      **an m- line MUST NOT be added to another BUNDLE group than
>> the group in which was included in the associated offer****
>>
>> **4)      **an m- line MUST NOT be removed from a BUNDLE group if, in
>> the associated offer, an identical port number was indicated for all m-
>> lines in a BUNDLE group****
>>
>> **
>>
>  [Suhas]. I agree with Paul here. Rejecting a m-line MUST be allowed by
> the answerer by setting port to zero and removing mid from the BUNDLE group

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 27 May 2013 10:53:43 +0000

Hi,

>> Note that the restrictions 1-3 are simply alignments with RFC 5888, 
>> and are listed simply for clarification purpose. Restrictions 4 is 
>> BUNDLE specific. Restriction 5 is also alignment with RFC 5888, as m- 
>> lines with port zero are not allowed within groups, but we will need 
>> some clarification text saying that a new offer will have to be sent 
>> in order to remove a stream (either from a bundle group, or completely 
>> from the session).
>>
>> into the draft)
>> 2)an m- line MUST NOT be added to a BUNDLE group, unless it was 
>> included in a BUNDLE group in the associated offer
>>
>> 3)an m- line MUST NOT be added to another BUNDLE group than the group 
>> in which was included in the associated offer
>>

I was checking my notes, but could not find anything justifying it. Maybe I mixed it up with the offer restrictions we were discussing...

> Note that there is also a discussion regarding bundle offers, e.g. 
> when restrictions when adding new m- lines to a bundle. Based on the 
> outcome of that, there may be some additional answer restrictions, e.g.
> regarding the change of bundle transport parameters. But, let's deal 

Yes.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 27 May 2013 10:57:10 +0000

Hi,

>  [Suhas]  .. RFC5888 doesn't clarify what does removing means. Hence, I would be happy to see 4) 
>                  If a m-line is removed ( not rejected) in the Answer, then the m-line should include a unique port that doesn't collide with port associated with any BUNDLE groups.

Yes.

Regards,

Christer

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Mon, 27 May 2013 13:30:55 +0000

4 and 5 are very confusing and do not match the notes I had from the call. I'm pretty sure I disagree with both of them. 

>From a requirement point of view, I think it is very important that the answer be able to reject any m-line by setting it's port to zero.

On May 24, 2013, at 6:32 AM, Christer Holmberg <[email-masked]> wrote:

> Note that there is also a discussion regarding bundle offers, e.g. when restrictions when adding new m- lines to a bundle. Based on the outcome of that, there may be some additional answer restrictions, e.g. regarding the change of bundle transport parameters. But, let’s deal with that in the offer thread.
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 27 May 2013 14:28:22 +0000

Hi,

> From a requirement point of view, I think it is very important that the answer be able to reject any m-line by setting it's port to zero.

Forget about 5 (at least for now) - I probably mixed some things up.

My take from the meeting is that there was an agreement on 4.

But, if you disagree with 4, which port do you think the offerer shall use for receiving media? It cannot use the "bundle port", as the answerer removed the m- line from the bundle group.

Regards,

Christer

---

From: Martin Thomson <[email-masked]>
Date: Tue, 28 May 2013 09:10:22 -0700

> 4)      an m- line MUST NOT be removed from a BUNDLE group if, in the associated offer, an identical port number was indicated for all m- lines in a BUNDLE group

Use words like unbundled instead perhaps.  And it's not MUST NOT, it's
simply "cannot".

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 28 May 2013 16:51:47 +0000

Hi,
 
> Use words like unbundled instead perhaps.  And it's not MUST NOT, it's simply "cannot".

My intention was to add a NOTE, with some "cannot" text.

Regards,

Christer