Subject: [MMUSIC] Reply to Liaison statement to IETF concerning 3D video

From: Ari Keränen <[email-masked]>
Date: Thu, 16 May 2013 22:58:14 +0300

Here is what we are planning to send as a response to the 3GPP liaison 
request regarding 3D video work at MMUSIC (for details, see 
https://datatracker.ietf.org/liaison/1239/).

Regards,
Ari & Flemming (MMUSIC co-chairs)

---

Title:    Reply to Liaison statement to IETF concerning 3D video formats 
signalling in SDP

Source: IETF MMUSIC WG
To:     TSG-SA WG4

The MMUSIC Working Groups thanks SA4 for their information request 
around work related to SDP signaling of 3D video formats. At the present 
time, the MMUSIC WG does not have any active work in this area.

For your information, the MMUSIC WG did previously (in 2012) consider 
work in this area based on the following 3 documents:

http://datatracker.ietf.org/doc/draft-capelastegui-mmusic-3dv-sdp/
http://datatracker.ietf.org/doc/draft-greevenbosch-mmusic-sdp-parallax/
http://datatracker.ietf.org/doc/draft-greevenbosch-mmusic-sdp-3d-format/

The drafts were presented in a couple of meetings and discussed on the 
MMUSIC mailing list, however there was not significant interest nor 
technical agreement in the WG for adoption of these items at the time. 
It was also believed that additional 3D video expertise and alignment 
with MPEG would be needed to adequately cover this area. In lieu of the 
above, the work was not adopted.

The MMUSIC WG would welcome further input from SA WG4 on this matter.

Next IETF meetings:
- IETF 87 July 28 - August 2, 2013, Berlin, Germany
- IETF 88 November 3-8, 2013, Vancouver, BC, Canada

Regards,
Flemming Andreasen and Ari Keränen
MMUSIC WG co-chairs

---

From: Stephan Wenger <[email-masked]>
Date: Thu, 16 May 2013 20:06:09 +0000

Let me suggest that coordination would be helpful not only with MPEG but
also with ITU-T Q6/16 (VCEG).   Most relevant work towards 3D is now done
in JCT-3V, which is a joint team composed of MPEG-Video and VCEG.
Stephan

On 5.16.2013 12:58 , "Ari Keränen" <[email-masked]> wrote:

>_______________________________________________
>mmusic mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mmusic

---

From: Mary Barnes <[email-masked]>
Date: Thu, 16 May 2013 15:21:21 -0500

I'm just curious if it was intentional to leave out the fact that two
of the documents were agreed as WG documents (and submitted as such)
in November 2011:
http://www.ietf.org/proceedings/82/minutes/mmusic.htm

but were dropped after the IPR declaration appeared in Feb 2012:
 http://www.ietf.org/proceedings/83/minutes/minutes-83-mmusic.htm

Then, they came back as individual again and there was not enough
interest to pick them up again:
http://www.ietf.org/proceedings/84/minutes/minutes-84-mmusic

I'm not debating the conclusion at all, but it seems to me that
leaving out the fact that there were at one time agreed as WG
documents and later dropped due to IPR/lack of interest is a relevant
fact.

Mary.

On Thu, May 16, 2013 at 2:58 PM, Ari Keränen <[email-masked]> wrote:
> The MMUSIC Working Groups thanks SA4 for their information request around
> work related to SDP signaling of 3D video formats. At the present time, the
> MMUSIC WG does not have any active work in this area.
>
> For your information, the MMUSIC WG did previously (in 2012) consider work
> in this area based on the following 3 documents:
>
> technical agreement in the WG for adoption of these items at the time. It
> was also believed that additional 3D video expertise and alignment with MPEG
> would be needed to adequately cover this area. In lieu of the above, the
> work was not adopted.
>

---

From: Flemming Andreasen <[email-masked]>
Date: Fri, 17 May 2013 14:01:51 -0400

> documents and later dropped due to IPR/lack of interest is a relevant
I wouldn't say the drafts were dropped due to IPR (but understand that 
different people may have different opinions on this), however the lack 
of an IPR disclosure prior to the documents' original adoption as WG 
items resulted in them going back to individual drafts. IPR disclosures 
were then made in accordance with IETF requirements, and following that, 
we had a renewed discussion in the WG around interest in the work as 
well as relevant expertise in the WG. As part of that, we noted the lack 
of coordination with and requirements from external bodies with respect 
to 3D video. There were also different opinions on the technical 
approach. In the end, as you note, there was not sufficient interest or 
concensus in the WG for adopting the work (as noted below).

If you think it's important to convey the IPR issue and the history 
around that, we can certainly do so. Personally, I don't think it 
changes anything and wouldn't want to suggest any presupposition as to 
what the WG might want to do if MPEG were to express a need for this 
work, but I'm open either way.

Thanks

-- Flemming

> .

---

From: Mary Barnes <[email-masked]>
Date: Mon, 20 May 2013 09:39:52 -0500

Whether or not you explicitly mention the IPR, I think it should be
mentioned that the document was adopted as a WG document but latter
dropped due to some of the reasons you note. It it not a common
occurrence for a document to be agreed as a WG document and then
shortly thereafter have that decision revert. So, I think it's worth a
mention.

Thanks,
Mary.

On Fri, May 17, 2013 at 1:01 PM, Flemming Andreasen <[email-masked]> wrote:
> different people may have different opinions on this), however the lack of
> an IPR disclosure prior to the documents' original adoption as WG items
> resulted in them going back to individual drafts. IPR disclosures were then
> made in accordance with IETF requirements, and following that, we had a
> renewed discussion in the WG around interest in the work as well as relevant
> expertise in the WG. As part of that, we noted the lack of coordination with
> and requirements from external bodies with respect to 3D video. There were
> also different opinions on the technical approach. In the end, as you note,
> there was not sufficient interest or concensus in the WG for adopting the
> work (as noted below).
>
> If you think it's important to convey the IPR issue and the history around
> that, we can certainly do so. Personally, I don't think it changes anything
> and wouldn't want to suggest any presupposition as to what the WG might want
> to do if MPEG were to express a need for this work, but I'm open either way.
>
> Thanks
>
> -- Flemming
>
>> Mary.
>>
>>> work

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Tue, 21 May 2013 14:19:18 +0000

It seems the subtext here is that WG4 is saying they have a need for this and asking if we are doing anything. We might want to send back that we would welcome drafts and input in this and people that would want this should come and help us get this done. What I don't want to see happen is some SDO outside mmusic try and define the SDP for this. We should directly tell them that if people want this, bring a proposal to MMUSIC and people with the domain expertise would be very welcome in MMUSIC to work with people with the SDP expertise to help meet the needs of WG4. 

On May 16, 2013, at 1:58 PM, Ari Keränen <[email-masked]> wrote:

> Here is what we are planning to send as a response to the 3GPP liaison request regarding 3D video work at MMUSIC (for details, see https://datatracker.ietf.org/liaison/1239/).
> 
> 
> Regards,
> Title:    Reply to Liaison statement to IETF concerning 3D video formats signalling in SDP
> 
> Source: IETF MMUSIC WG
> To:     TSG-SA WG4
> 
> The MMUSIC Working Groups thanks SA4 for their information request around work related to SDP signaling of 3D video formats. At the present time, the MMUSIC WG does not have any active work in this area.
> 
> For your information, the MMUSIC WG did previously (in 2012) consider work in this area based on the following 3 documents:
> 
> The drafts were presented in a couple of meetings and discussed on the MMUSIC mailing list, however there was not significant interest nor technical agreement in the WG for adoption of these items at the time. It was also believed that additional 3D video expertise and alignment with MPEG would be needed to adequately cover this area. In lieu of the above, the work was not adopted.
>

---

From: Bert Greevenbosch <[email-masked]>
Date: Wed, 22 May 2013 05:57:49 +0000

Although I agree that the reversion of the draft to individual status was justified at the time, I fail to see how it is relevant to 3GPP. It seems an internal IETF process issue to me.

I agree with Flemming's draft response about the reasons for ceasing the work on this.

Best regards,
Bert

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mary Barnes
Sent: 2013年5月20日 22:40
To: Flemming Andreasen
Cc: Ari Keränen; mmusic
Subject: Re: [MMUSIC] Reply to Liaison statement to IETF concerning 3D video

Thanks,
Mary.

---

From: Ari Keränen <[email-masked]>
Date: Thu, 23 May 2013 01:06:20 +0300

Hi Stephan,

Thanks for your feedback! We'll take this into consideration for the reply.

Cheers,
Ari

---

From: Ari Keränen <[email-masked]>
Date: Thu, 23 May 2013 01:06:39 +0300

Hi Cullen,

Thanks for your feedback. We already mention in the reply draft that we 
welcome more input on the matter but having also domain experts could be 
helpful. We'll take also this into consideration for the reply.

Cheers,
Ari

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 23 May 2013 13:19:00 +0000

I talked to more people about this after I sent my email and the more I talked to people, the more I thought your original proposal was just fine. 

On May 22, 2013, at 4:06 PM, Ari Keränen <[email-masked]> wrote:

> Hi Cullen,
> 
> Thanks for your feedback. We already mention in the reply draft that we welcome more input on the matter but having also domain experts could be helpful. We'll take also this into consideration for the reply.
> 
> 
> Cheers,
> Ari