Subject: [MMUSIC] BUNDLE: SDP Offer Types

From: Christer Holmberg <[email-masked]>
Date: Fri, 31 May 2013 10:30:54 +0000

Hi,

As we know, BUNDLE currently uses two main "types" of SDP Offers: one where each m- line in the BUNDLE group has a different port number value, and one where each m- line has the same port value.

Often we refer to these as "the first offer" resp. "the second offer".

Now, this works fine when we talk about the session establishment, but as we know a session can contain multiple additional offers, and with BUNDLE those can be of either type.

So, my question is whether we should come up with some better wording.

I'll throw the ball out with suggesting the following ones:

-          Bundle restart offer (different port value, currently referred to as "first offer")

The reason I use "restart" wording is because this is used, no matter whether in the beginning of the session or mid-session, to (re-)negotiate the usage of BUNDLE, and the bundle address information selection.

-          Bundle sync offer (identical port value, currently referred to as "second offer")

The reason I used "sync" wording is because this is used to ensure that intermediaries have correct address information for each m- line.

Keep in mind that we may even need to split the sync offer into more sub types, when we get into the details of adding new m- lines etc, but I'd like to agree a base to start from :)

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 31 May 2013 10:14:49 -0400

On 5/31/13 6:30 AM, Christer Holmberg wrote:
> Hi,
>
> As we know, BUNDLE currently uses two main ”types” of SDP Offers: one
> where each m- line in the BUNDLE group has a different port number
> value, and one where each m- line has the same port value.
>
> Often we refer to these as “the first offer” resp. “the second offer”.
>
> Now, this works fine when we talk about the session establishment, but
> as we know a session can contain multiple additional offers, and with
> BUNDLE those can be of either type.
>

Yes, I agree we need something better.

> I’ll throw the ball out with suggesting the following ones:
>
> -*Bundle restart offer* (different port value, currently referred to as
> “first offer”)
>
> The reason I use “restart” wording is because this is used, no matter
> whether in the beginning of the session or mid-session, to
> (re-)negotiate the usage of BUNDLE, and the bundle address information
> selection.
>
> -*Bundle sync offer* (identical port value, currently referred to as
> “second offer”)
>
> The reason I used “sync” wording is because this is used to ensure that
> intermediaries have correct address information for each m- line.
>
> Keep in mind that we may even need to split the sync offer into more sub
> types, when we get into the details of adding new m- lines etc, but I’d
> like to agree a base to start from :)

Above seems like a good start, but I'm still grappling with some things 
and don't know how to talk about concisely:

I understand that the next offer after a Bundle Restart Offer will 
typically be a Bundle Sync Offer. But if there is another offer after a 
Bundle Sync Offer, and it doesn't change anything about the bundle, then 
is it still a Bundle Sync Offer?

Also, I don't believe the above are mutually exclusive. If I send an 
offer to add a new m-line to a bundle, and I give it distinct address 
info so that the answerer may take it out of the bundle if needed, then 
is that a Bundle Restart Offer or a Bundle Sync Offer? It seems to be a 
bit of each. And of course there may be multiple bundles described by 
the SDP, and these terms apply independently to each.

Maybe we need a couple more terms for:

- offer that adds a new m-line to bundle using the existing bundle
   address info.

- offer that adds a new m-line to an existing bundle using unique
   address info.

And even if we do that we still need to explain that they only describe 
typical cases, not all cases. Or else we need to find a way to use terms 
that apply more narrowly than to a complete offer or answer.

	Thanks,
	Paul