Subject: [MMUSIC] BUNDLE: SDP O/A Open Issue: Allowed for Offerer to assign same address to multiple m- lines before Answerer has indicated BUNDLE support in SDP Answer?

From: Christer Holmberg <[email-masked]>
Date: Mon, 17 Jun 2013 07:20:16 +0000

Hi,

In BUNDLE-04, there are a couple of open issues associated with assigning the same address to multiple m= lines in a BUNDLE group.

The main technical issue is whether it should be allowed to do it *before* the Answerer has, in the SDP Answer, indicated support of BUNDLE.

I.e. should it be allowed to, in the *initial* SDP Offer, assign the same address to multiple m= lines in a BUNDLE group?

Paul has indicated that it should be allowed, if the Offerer e.g. "knows" that the environment where it is operating in supports BUNDLE.

Now, as that is very similar to my original BUNDLE proposal, I would like to hear what others (especially Cullen) thinks about it.

Regards,

Christer

---

From: Martin Thomson <[email-masked]>
Date: Mon, 17 Jun 2013 09:26:49 -0700

On 17 June 2013 00:20, Christer Holmberg <[email-masked]> wrote:
> whether it should be allowed to do it *before* the Answerer has, in the SDP
> Answer, indicated support of BUNDLE.

I have no problem with allowing this, though I think that it requires
a reasonable amount of text to ensure that the risks are known.