Subject: [MMUSIC] DECISION: Offerer assigning address:port to multiple m- lines before Answerer has selected that address:port as BUNDLE address?

From: Christer Holmberg <[email-masked]>
Date: Wed, 26 Jun 2013 07:33:31 +0000

Hi,

BUNDLE currently specifies that an Offerer is not allowed to assign an address:port to multiple m- lines before that address:port has been selected as BUNDLE address by the Answerer.

Paul indicated that such rule is ineffective, as it always requires two O/A transactions (one for the negotiation, and another one for the sync) in order to negotiate/re-negotiate a BUNDLE address.

Instead, Paul suggested that an Offerer should be allowed to assign a new address:port to multiple m- lines before the Answerer has selected that address:port as a BUNDLE address.

Paul also suggested that an Offerer should be allowed to do this before the Answerer has sent an SDP Answer, indicating support of BUNDLE.

Q5: Within a SIP session, once both endpoints have indicated support of BUNDLE, do we allow an Offerer to assign an address:port to multiple m- lines, before the Answerer has selected that address:port as a BUNDLE address?

Q6: If Q5, do we allow an Offerer to assign an address:port to multiple m- lines before the Answerer has, within the SIP session, indicated that it supports BUNDLE? A typical example would be assigning an address:port to multiple m- lines already in the initial SDP Offer for a SIP session.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 26 Jun 2013 09:45:14 -0400

Q5: yes

Q6: yes. I don't expect this to be used all the time. But there will be 
cases when the offerer has enough understanding of the context in which 
it is used that doing so is worthwhile in order to save effort in 
session setup. Doing so comes with the obligation to cope with the 
consequences if the assumptions are wrong and the answerer doesn't 
support bundle.

This is also a matter of acknowledging the real world. If we ban this, 
it is reasonable to expect that those that want it will do so anyway.

	Thanks,
	Paul

On 6/26/13 3:33 AM, Christer Holmberg wrote:
> Hi,
>
> BUNDLE currently specifies that an Offerer is not allowed to assign an
> address:port to multiple m- lines before that address:port has been
> selected as BUNDLE address by the Answerer.
>
> Paul indicated that such rule is ineffective, as it always requires two
> O/A transactions (one for the negotiation, and another one for the sync)
> in order to negotiate/re-negotiate a BUNDLE address.
>
> Instead, Paul suggested that an Offerer should be allowed to assign a
> new address:port to multiple m- lines before the Answerer has selected
> that address:port as a BUNDLE address.
>
> Paul also suggested that an Offerer should be allowed to do this before
> the Answerer has sent an SDP Answer, indicating support of BUNDLE.
>
> *Q5*: Within a SIP session, once both endpoints have indicated support
> of BUNDLE, do we allow an Offerer to assign an address:port to multiple
> m- lines, before the Answerer has selected that address:port as a BUNDLE
> address?
>
> *Q6*: If Q5, do we allow an Offerer to assign an address:port to
> multiple m- lines before the Answerer has, within the SIP session,
> indicated that it supports BUNDLE? A typical example would be assigning
> an address:port to multiple m- lines already in the initial SDP Offer
> for a SIP session.
>
> Regards,
>
> Christer
>
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>