Subject: [MMUSIC] SDP Directorate: Review of draft-ietf-xrblock-rtcp-xr-loss-conceal-05

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 3 Jun 2013 10:58:58 +0000

I am the assigned SDP directorate reviewer for this draft. For background on the SDP directorate, please see the FAQ at
http://www.ietf.org/iesg/directorate/sdp.html

Please wait for direction from your document shepherd or AD before posting a new version of the draft.

Summary:
- The RTCP XR extension syntax seems to have an issue, see below
- There are a few editorial issues

Issues:
1) Section 1.4: Can I use these metrics for the audio component of A/V applications? If yes, then section 1.4 sounds overly restrictive.

2) Capitalization of the block/metric names is inconsistent.

3) Section 5.1, first parag.: The document defines two blocks not one.

4) Section 5.1:

Why are using 

   xr-format =/ xr-conceal-block
   xr-format =/ xr-conc-sec-block

instead of

   xr-format =/ xr-conceal-block / xr-conc-sec-block

5) Section 6.1: Where do "NCS" and "NLC" come from? Why not choose more appropriate acronyms? Also use the correct registry name: "RTP Control Protocol Extended Reports (RTCP XR) Block Type Registry"

6) Section 6.2: Please use the correct registry name: "RTP Control Protocol Extended Reports (RTCP XR) Session Description Protocol (SDP) Parameters Registry".

---

From: Qin Wu <[email-masked]>
Date: Mon, 3 Jun 2013 12:24:50 +0000

Hi, Ali:
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ali C. Begen (abegen)
Sent: Monday, June 03, 2013 6:59 PM
To: [email-masked]
Cc: xrblock-chairs; mmusic
Subject: [MMUSIC] SDP Directorate: Review of draft-ietf-xrblock-rtcp-xr-loss-conceal-05

Summary:

Issues:

[Qin]: Right, I propose the following change:
OLD TEXT:
"
These metrics are only applicable to audio applications of RTP.
"
NEW TEXT:
"
These metrics are applicable to both audio applications of RTP and the audio component of A/V applications.
"

[Qin]: Okay, will fix this.

[Qin]: Okay, will fix this.

4) Section 5.1:

Why are using 

instead of

[Qin]: Agree to use the latter, thank for your proposed change.

5) Section 6.1: Where do "NCS" and "NLC" come from? Why not choose more appropriate acronyms? 

[Qin]: Okay.
Also use the correct registry name: "RTP Control Protocol Extended Reports (RTCP XR) Block Type Registry"
[Qin]: Okay.

[Qin]: Okay.
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic