Subject: Re: [MMUSIC] BUNDLE DISCUSION Q8 (NEW): SDP 'bundle-only' attribute

From: Christer Holmberg <[email-masked]>
Date: Mon, 2 Sep 2013 10:16:42 +0000

Hi,

Updated text, based on Martin's comment.

Note that the text says that the Answerer, in the Answer, assigns its BUNDLE address also to the 'bundle-only' m- lines (again, that MAY be impacted on the port-zero discussions). 

Regards,

Christer

-----------------------------

X.  SDP 'bundle-only' attribute

X.1.  General

This section defines a new SDP media-level attribute, 'bundle-only'. The attribute
is used, in an SDP Offer, to indicate that an "m=" line, to which the attribute
has been assigned, is only to be accepted by the Answerer if the Answerer keeps 
the "m=" line within the BUNDLE group to which the "m=" line is associated in the 
SDP Offer.

X.2.  SDP Offer/Answer Procedures

X.2.1.  SDP Offer Procedures

When an Offerer sends an SDP Offer, which contains a BUNDLE group, it can assign the
SDP 'bundle-only' attribute to an "m=" line associated with the BUNDLE group,
in order to request that the Answerer only accepts the "m=" line if is kept within 
the BUNDLE group to which the "m=" line is associated in the SDP Offer.

An Offerer MUST NOT assign the SDP 'bundle-only' attribute to an "m=" line that is not
associated with a BUNDLE group.

If an Offerer receives an SDP Answer where an "m=" line, to which it assigned an
'bundle-only' attribute in the associated Offer, has been removed from a BUNDLE group, but
has not been rejected ([ref-to-section- 6.5.2.]), the Offerer MUST send a new Offer, in which
it assigns a zero port value to the "m=" line.

X.2.2.  SDP Answerer Procedures

According to the procedures in Section 6.5.2.1, when the Answerer receives an SDP Offer, it
selects a local BUNDLE address, and in the SDP Answer assigns it to each "m=" line associated
with a BUNDLE group. This also applies to "m=" lines which contained an SDP 'bundle-only' attribute
in the SDP Offer, and are not removed from the BUNDLE group by the Answerer.

The Answerer MAY choose to remove an "m=" line out of a BUNDLE group ([ref-to-section- 6.5.2.]). If an SDP 
'bundle-only' attribute has been assigned to such "m=" line, the Answerer MUST reject the "m=" line, according 
to the procedures in Section 6.5.3.

An Answerer MUST NOT insert an SDP 'bundle-only' attribute in an SDP Answer.

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 02 Sep 2013 16:16:50 -0400

Christer,

I thought the *point* of bundle-only was to avoid the need to assign 
unique ports in the offer. But this text doesn't address that.

	Thanks,
	Paul

On 8/30/13 9:48 AM, Christer Holmberg wrote:
> Hi,
>
> I started to draft some text for the definition of the SDP 'bundle-only'
> attribute (my assumption is that it will be defined in draft-bundle).
>
> Note that, at this point, I don’t suggest any normative text regarding
> the usage of port zero in the SDP Offer, as we are still discussing that
> (the outcome of that discussion may affect at least the last paragraph
> in section x.2.1.).
>
> Also note that I don’t say anything about in which “scope/context”
> (webrtc etc) the usage of the attribute is allowed.
>
> So, leaving the usage of port zero, and the scope question, aside for
> the moment, please take a look and indicate whether you have any issues
> (at this point, I ask you to focus on the technical stuff – and stuff
> which is unclear) with the text :)
>
> Regards,
>
> Christer
>
> --------------------------
>
> When an Answerer receives an SDP Offer ([ref-to-section- 6.5.]), the
> Answerer MAY choose
>
> to remove an "m=" line out of a BUNDLE group ([ref-to-section- 6.5.2.]).
> If an SDP
>
> 'bundle-only' attribute has been assigned to such "m=" line, the
> Answerer MUST reject
>
> the "m=" line, according to the procedures in Section 6.5.3.
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 02 Sep 2013 16:18:25 -0400

On 8/30/13 2:24 PM, Christer Holmberg wrote:
> Hi,
>
>> This presumes there is such a thing as "bundle-only" m-lines.
>>
>> I don't believe we've determined consensus or not on your previous proposal to get rid of them, which was a long thread starting here I think:
>> https://www.ietf.org/mail-archive/web/mmusic/current/msg12114.html

I was in favor of that proposal. But my impression was that we were not 
going to get consensus for it.

	Thanks,
	Paul

> My issue has not been with the 'bundle-attribute', but with the usage of port zero, and that e-mail was a suggestion on how to get rid of that.
>
> However, when re-reading that e-mail, if we would go ahead with my suggestion it might also remove the need for the attribute...
>
> Regards,
>
> Christer
>
>
>
> On Aug 30, 2013, at 9:48 AM, Christer Holmberg <[email-masked]> wrote:
>
>>
>> Hi,
>>
>> I started to draft some text for the definition of the SDP 'bundle-only' attribute (my assumption is that it will be defined in draft-bundle).
>>
>> Note that, at this point, I don't suggest any normative text regarding the usage of port zero in the SDP Offer, as we are still discussing that (the outcome of that discussion may affect at least the last paragraph in section x.2.1.).
>>
>> Also note that I don't say anything about in which "scope/context" (webrtc etc) the usage of the attribute is allowed.
>>
>> So, leaving the usage of port zero, and the scope question, aside for the moment, please take a look and indicate whether you have any issues (at this point, I ask you to focus on the technical stuff - and stuff which is unclear) with the text :)
>>
>> Regards,
>>
>> Christer
>>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Sep 2013 06:27:21 +0000

Hi,

We haven't got much feedback, so it is difficult to know what consensus we would get/would not get :)

Regards,

Christer

Sent from Windows using TouchDown (www.nitrodesk.com)

-----Original Message-----
From: Paul Kyzivat [[email-masked]]
To: [email-masked] [[email-masked]]
Subject: Re: [MMUSIC] BUNDLE DISCUSION Q8 (NEW): SDP &apos;bundle-only&apos; attribute

        Thanks,
        Paul

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Sep 2013 11:14:02 +0000

Hi Paul,

As we yet have no consensus regarding how to implement the avoid-the-need-to-assign-unique-ports part (Are we going to use port zero? Are we going to add the bundle-only m- lines in the 2nd Offer? Are we going to do something else?), I've left that out on purpose.

The OTHER reason for bundle-only, which the text does cover, is the ability to request that an m- line should be rejected unless it is accepted as part of the BUNDLE group.

So, we for sure will need more text, but I am trying to reach text agreements on the parts where we don't seem to have any open issues :)

Regards,

Christer

-----Alkuperäinen viesti-----
Lähettäjä: [email-masked] [mailto:[email-masked]] Puolesta Paul Kyzivat
Lähetetty: 2. syyskuuta 2013 23:17
Vastaanottaja: [email-masked]
Aihe: Re: [MMUSIC] BUNDLE DISCUSION Q8 (NEW): SDP 'bundle-only' attribute

Christer,

I thought the *point* of bundle-only was to avoid the need to assign unique ports in the offer. But this text doesn't address that.

	Thanks,
	Paul

On 8/30/13 9:48 AM, Christer Holmberg wrote:
> Note that, at this point, I don't suggest any normative text regarding 
> the usage of port zero in the SDP Offer, as we are still discussing 
> that (the outcome of that discussion may affect at least the last 
> paragraph in section x.2.1.).
>
> Also note that I don't say anything about in which "scope/context"
> the moment, please take a look and indicate whether you have any 
> issues (at this point, I ask you to focus on the technical stuff - and 
> stuff which is unclear) with the text :)
>
> Regards,
>
> Christer
>