Subject: Re: [MMUSIC] DECISION (BERLIN-Q1/Q2/Q7): Usage of specific PT value for single codec configuration

From: Christer Holmberg <[email-masked]>
Date: Tue, 10 Sep 2013 09:56:22 +0000

Hi,

Below is the "official" (from the minutes) outcome of questions Q1,Q2 and Q7 in Berlin.

Questions:

Q1: "Can we agree that, within a BUNDLE group (including all m- lines associated with the group), any given PT value can only be used for a single codec configuration?"
Q2: "If Q1, do we agree that we need EXPLICIT text somewhere*, as there are opinions that simply referencing RFC 3550 might not be clear enough?"
Q7: "Within a BUNDLE group, do we allow the usage of the same PT value in multiple RTP m- lines, for the SAME codec configuration?"

Outcome:

Q1: Yes
Q2: Yes, Lennox will send suggested text to clarify the term "codec configuration".
Q7: Yes.

So, again, we need definition text for "codec configuration". Jonathan promised to submit something, but anyone is of course welcome to do that.

The other alternative is to not say anything about PT value usages within the scope of BUNDLE, but that is not what the meeting wanted.

Regards,

Christer

From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 23. elokuuta 2013 13:53
To: mmusic
Subject: [MMUSIC] DECISION (BERLIN-Q1/Q2/Q7): Usage of specific PT value for single codec configuration

Hi,

One of the open issues related to BUNDLE presented in Berlin (Q1, Q2 and Q7 in my slides) was regarding the usage of any given PT value.

My take of the outcome was that:

-          We agreed that any given PT value can only be used for a single codec configuration (Q1)

-          We agreed that we need some definition text for "codec configuration" (Q2)

-          We agreed that, within a BUNDLE group, any given PT value can be used in multiple m- lines, as long as it is used for a single codec configuration (Q7).

Jonathan Lennox promised to suggest some definition text for "codec configuration", so let's wait for that until we go into those discussions.

But, if you have any issues with the agreements in general, please bring them up :)

Regards,

Christer

---

From: Jonathan Lennox <[email-masked]>
Date: Tue, 10 Sep 2013 15:18:28 -0400

My strawman proposal at the mic in Berlin was that a codec configuration is defined by the top-level media type of the m= line and the content of a given PT value's rtpmap and fmtp lines.  I.e., the full media type, with all its parameters.

The questions I would have to this straw man are:

* Is this excessive?  E.g., should items like H.264's sprop- parameters be allowed to differ across m= line blocks?

* Is this sufficient?  Should other items (sometimes) indexed by PT (e.g., the imageattr, rtcp-fb, or extmap attributes) need to be the same across m-lines as well?

My suggestion would be that this work should be folded into the work being done in draft-nandakumar-mmusic-sdp-mux-attributes (which really should be integrated with BUNDLE).  Currently (I believe) the mux-attributes draft assumes that PTs are unique across m-lines, so this work is going to imply changes to the analysis of a number of attributes in that draft, regardless.  Probably a new category will need to be defined for attributes which have to be consistent per payload type.

On Sep 10, 2013, at 5:56 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Below is the “official” (from the minutes) outcome of questions Q1,Q2 and Q7 in Berlin.

Questions:

Q1: “Can we agree that, within a BUNDLE group (including all m- lines associated with the group), any given PT value can only be used for a single codec configuration?”
Q2: “If Q1, do we agree that we need EXPLICIT text somewhere*, as there are opinions that simply referencing RFC 3550 might not be clear enough?”
Q7: “Within a BUNDLE group, do we allow the usage of the same PT value in multiple RTP m- lines, for the SAME codec configuration?”

Outcome:

Q1: Yes
Q2: Yes, Lennox will send suggested text to clarify the term “codec configuration”.
Q7: Yes.

So, again, we need definition text for “codec configuration”. Jonathan promised to submit something, but anyone is of course welcome to do that.

Regards,

Christer

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Christer Holmberg
Sent: 23. elokuuta 2013 13:53
To: mmusic
Subject: [MMUSIC] DECISION (BERLIN-Q1/Q2/Q7): Usage of specific PT value for single codec configuration

Hi,

-          We agreed that any given PT value can only be used for a single codec configuration (Q1)
-          We agreed that we need some definition text for “codec configuration” (Q2)
-          We agreed that, within a BUNDLE group, any given PT value can be used in multiple m- lines, as long as it is used for a single codec configuration (Q7).

Jonathan Lennox promised to suggest some definition text for “codec configuration”, so let’s wait for that until we go into those discussions.

Regards,

Christer

--
Jonathan Lennox
[email-masked]<mailto:[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 11 Sep 2013 07:12:06 +0000

Hi,

It would be so easy if we could define the PT mappings on the SDP session level, and then simply refer to them within the m- lines :)

Regards,

Christer

From: Jonathan Lennox [mailto:[email-masked]]
Sent: 10. syyskuuta 2013 22:18
To: Christer Holmberg
Cc: mmusic
Subject: Re: [MMUSIC] DECISION (BERLIN-Q1/Q2/Q7): Usage of specific PT value for single codec configuration

Hi,

Questions:

Outcome:

Q1: Yes

Regards,

Christer

Hi,

Regards,

Christer