Subject: [MMUSIC] POF/PAN: Need for more m- lines in the PAN than in the associated POF

From: Christer Holmberg <[email-masked]>
Date: Mon, 21 Oct 2013 10:04:20 +0000

Hi,

The following issue is related to the case where a media description in a POF implicitly affect other media descriptions (not present in the POF), but this e-mail looks at a similar case from a PAN perspective.

Section 5.3 says:

        If the preceding steps have been performed for each media section
        without resulting in a rejection, then the agent forms a partial
        answer consisting of a single o= line, and all of the media sections
        that were generated as part of the preceding steps. Note that this
        processing will always yield the same number of media sections in a
        partial answer as were present in the partial offer.

The text says that the PAN will contain the same number of media sections as the associated POF. But, what if the POF also caused other media sections to change? Those media sections cannot be added to the PAN.

(If the offerer "knows" which media sections will be modified by the answerer in the PAN, it can of course included those in the POF - even if they are not modified in the POF)

The answerer can of course send the PAN, followed by an Offer/POF which modifies the other affected media sections that didn't "fit" into the PAN. But, that may not always be very feasible, especially if some properties in those media sections are removed or changed.

So, I think we would need some text saying that a POF might have to be rejected, if it will affect media sections that cannot be put into associated PAN.

Again, whether situations like this will occur in real-life of course depends on what people will use POFs/PANs for, so some input (re-pinging Justin) would be useful.

Regards,

Christer

---

From: Adam Roach <[email-masked]>
Date: Mon, 21 Oct 2013 08:58:04 -0500

On 10/21/13 05:04, Christer Holmberg wrote:
>
> Hi,
>
> The following issue is related to the case where a media description 
> in a POF implicitly affect other media descriptions (not present in 
> the POF), but this e-mail looks at a similar case from a PAN perspective.
>
> Section 5.3 says:
>
> The text says that the PAN will contain the same number of media 
> sections as the associated POF. But, what if the POF also caused other 
> media sections to change?
>

Can you give a concrete example of how this might happen?

/a

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 21 Oct 2013 14:19:28 +0000

Hi,

One example is a video encoding engine, that can handle a certain number of macro blocks per second. Assuming my existing m- lines are using 70%, and the new m- line would require 40% more, I may have to adjust some properties of the existing m- lines.

One can of course ask whether I should do that in the Answer to begin with, or send a separate Offer. I guess it depends on how time-critical the change is, how user experience would be affected, etc.

But, I think it would be good to mention in the draft, that such scenario can occur, and how it can be dealt with (it may be obvious to us, but not the everyone else out there).

And, as we discussed earlier, with BUNDLE the change of one m- line may implicitly change other m- lines. But, that needs to be studied a little more.

Regards,

Christer

From: Adam Roach [mailto:[email-masked]]
Sent: 21. lokakuuta 2013 16:58
To: Christer Holmberg; [email-masked]
Subject: Re: [MMUSIC] POF/PAN: Need for more m- lines in the PAN than in the associated POF

Section 5.3 says:

The text says that the PAN will contain the same number of media sections as the associated POF. But, what if the POF also caused other media sections to change?

/a