Subject: [MMUSIC] General SDP usage question

From: "Klatsky, Carl" <[email-masked]>
Date: Thu, 31 Oct 2013 21:03:41 +0000

HI MMUSICers,

I have a general SDP usage question that could not confirm from the RFCs.

Party A sends an Offer with codecs 9,0
Party B does not support codec 9, so Party B Answer is just 0
Party A sends ACK to setup the call with codec 0

Later, Party A performs a flash hook to place Party B on-hold, and Party A sends an Offer again with codecs 9,0
Party B sends a 488 Not Acceptable Here error

Question: When Party A performs the flash hook, should it have only included codec 0 since it has previous knowledge that Party B only supports codec 0?  Or is what Party A sent acceptable within the definition of this protocol?

Thanks & Regards,

Carl Klatsky

---

From: Adam Roach <[email-masked]>
Date: Thu, 31 Oct 2013 16:10:09 -0500

On 10/31/13 16:03, Klatsky, Carl wrote:
> Later, Party A performs a flash hook to place Party B on-hold, and 
> Party A sends an Offer again with codecs 9,0
>
> Question: When Party A performs the flash hook, should it have only 
> included codec 0 since it has previous knowledge that Party B only 
> supports codec 0?  Or is what Party A sent acceptable within the 
> definition of this protocol?
>
>

Yeah, party B is at fault here. It should be able to perform the same 
negotiations on a reinvite as it does on an initial invite.

/a