Subject: [MMUSIC] BUNDLE/SDP : ISSUE#3: Should BUNDLE deal with DECLARATIVE SDP ?

From: Suhas Nandakumar <[email-masked]>
Date: Wed, 30 Oct 2013 21:52:43 -0700

Hello All

  Magnus raised an important question while analyzing  RFC6064 SDP
attributes related to RTSP SDP attributes for 3GPP.  Since these attributes
are declaratively used, SHOULD BUNDLE be dealing with specifying the
behavior in Non Offer/Answer Scenarios ?

If the answer is NO, we can assign category to be NOT IMPACTED for these
attributes,

If the answer is YES, i think there needs to be more discussions on
handling this scenario.

Please let me know your thoughts.

Cheers
Suhas

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 31 Oct 2013 05:54:17 +0000

Hi,

In general, without commenting on this specific attribute, the scope of BUNDLE is Offer/Answer, and personally I would not want to expand that - at least not in "version 1".

Regards,

Christer

Sent from my Sony Ericsson Xperia arc S

Suhas Nandakumar <[email-masked]> wrote:

Hello All

  Magnus raised an important question while analyzing  RFC6064 SDP attributes related to RTSP SDP attributes for 3GPP.  Since these attributes are declaratively used, SHOULD BUNDLE be dealing with specifying the behavior in Non Offer/Answer Scenarios ?

If the answer is NO, we can assign category to be NOT IMPACTED for these attributes,

If the answer is YES, i think there needs to be more discussions on handling this scenario.

Cheers
Suhas

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 31 Oct 2013 08:49:35 +0100

Could you expand "declaratively" for me here? If it means "stated, not
negotiated", this is the same as for many attrs in the draft already. If it
means "never used in offer/answer", I agree with Christer.

---

From: Suhas Nandakumar <[email-masked]>
Date: Thu, 31 Oct 2013 12:56:13 -0700

Good point Harald. Thinking of it , I feel this question applies to all the
declarative usages of SDP attributes in the context of BUNDLE.

>From Christer's and your point, I feel the BUNDLE specification should
state it explicitly that only O/A procedures are supported for this
version. That way, we handle all the attributes that has declarative
semantics along with O/A or otherwise.

please let me know your thoughts.

Thanks
Suhas

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 31 Oct 2013 20:12:08 +0000

Hi,

I think the BUNDLE spec does say that it is a way to use O/A in order to negotiate multiplexing.

But, if people don't think it's not clear enough, we can for sure add more text :)

Regards,

Christer

________________________________
From: Suhas Nandakumar [[email-masked]]
Sent: Thursday, 31 October 2013 9:56 PM
To: Harald Alvestrand
Cc: Cullen Jennings; Christer Holmberg; mmusic WG
Subject: Re: BUNDLE/SDP : ISSUE#3: Should BUNDLE deal with DECLARATIVE SDP ?

Good point Harald. Thinking of it , I feel this question applies to all the declarative usages of SDP attributes in the context of BUNDLE.

>From Christer's and your point, I feel the BUNDLE specification should state it explicitly that only O/A procedures are supported for this version. That way, we handle all the attributes that has declarative semantics along with O/A or otherwise.

Thanks
Suhas

On Thu, Oct 31, 2013 at 12:49 AM, Harald Alvestrand <[email-masked]<mailto:[email-masked]>> wrote:

Could you expand "declaratively" for me here? If it means "stated, not negotiated", this is the same as for many attrs in the draft already. If it means "never used in offer/answer", I agree with Christer.

31. okt. 2013 05:52 skrev "Suhas Nandakumar" <[email-masked]<mailto:[email-masked]>> følgende:

Hello All

Cheers
Suhas

---

From: Suhas Nandakumar <[email-masked]>
Date: Thu, 31 Oct 2013 13:26:52 -0700

Hi Christer

   My bad, the very introduction is clear about it .

 This specification defines a new SDP Grouping Framework extension,

   "BUNDLE", that can be used with the Session Description Protocol
   (SDP) Offer/Answer mechanism to negotiate the usage of bundled media,
   which refers to the usage of a single 5-tuple for media associated
   with multiple SDP media descriptions ("m=" lines).

Above statement should suffice I believe. I should probably add a
requirement in the Mux Draft saying that the analysis applies only to
Offer/Answer usage of SDP.

If everyone is fine with add an explicit statement in the Mux draft, I
think we can close this issue

Cheers
Suhas

On Thu, Oct 31, 2013 at 1:12 PM, Christer Holmberg <
[email-masked]> wrote:

> ------------------------------
> *From:* Suhas Nandakumar [[email-masked]]
> *Sent:* Thursday, 31 October 2013 9:56 PM
> *To:* Harald Alvestrand
> *Cc:* Cullen Jennings; Christer Holmberg; mmusic WG
> *Subject:* Re: BUNDLE/SDP : ISSUE#3: Should BUNDLE deal with DECLARATIVE
> SDP ?
>
>   Good point Harald. Thinking of it , I feel this question applies to all
> the declarative usages of SDP attributes in the context of BUNDLE.
>
> On Thu, Oct 31, 2013 at 12:49 AM, Harald Alvestrand <[email-masked]>wrote:
>