Subject: [MMUSIC] UDPTL-DTLS: Open Issue regarding usage of the SDP connection attribute

From: Christer Holmberg <[email-masked]>
Date: Tue, 19 Nov 2013 10:40:34 +0000

Hi,

One of the open issues (indicated in an Editor's Note) in the UDPTL-DTLS draft is regarding the usage of the SDP connection attribute:

"Editor's note: FFS if connection attribute defined in RFC 4145 is needed."

The SRTP-DTLS spec forbids the usage of the attribute:

"The endpoint MUST NOT use the connection attribute defined in [RFC4145]."

...and I can't think of a reason why we should deviate in the UDPTL-DTLS spec, so my suggestion would be to remove the Editor's Note, and explicitly indicate that the attribute must not be used (same as in RFC 5763).

Comments?

Regards,

Christer

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Thu, 21 Nov 2013 06:51:52 +0000

On Nov 19, 2013, at 2:40 AM, Christer Holmberg <[email-masked]> wrote:

> Hi,
>  
> One of the open issues (indicated in an Editor’s Note) in the UDPTL-DTLS draft is regarding the usage of the SDP connection attribute:
>  
> “Editor's note: FFS if connection attribute defined in RFC 4145 is needed.”
>  
> “The endpoint MUST NOT use the connection attribute defined in [RFC4145].”
>  
> …and I can’t think of a reason why we should deviate in the UDPTL-DTLS spec, so my suggestion would be to remove the Editor’s Note, and explicitly indicate that the attribute must not be used (same as in RFC 5763).
>  
> Comments?

I agree with the change to MUST NOT.  No reason I can think of to deviate from SRTP-DTLS with regards to usage of the connection attribute.

Gonzalo

>  
> Regards,
>  
> Christer
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic