Subject: [MMUSIC] Default candidates

From: Martin Thomson <[email-masked]>
Date: Mon, 4 Nov 2013 10:33:32 -0800

The text is currently a little vague in RFC 5245 on what you select here:

is it the candidate most likely to succeed?

or

is it the candidate most like to be selected?

---

From: Emil Ivov <[email-masked]>
Date: Mon, 4 Nov 2013 20:11:30 +0100

Relayed candidates are currently RECOMMENDED, which sounds reasonable.

Still, if those are not available, 5245 recommends server reflexive. This
may be problematic in cases where servers that perform latching only do it
for addresses they consider "private".

--sent from my mobile
On 4 Nov 2013 19:34, "Martin Thomson" <[email-masked]> wrote:

> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 4 Nov 2013 13:14:54 -0800

I interpreted it to be the one "most likely to used" when the ICE completes
thus forming the default destination for media reception..

---

From: Ari Keränen <[email-masked]>
Date: Tue, 5 Nov 2013 09:48:30 -0800

Hi,

The ICE default candidate should be such that there's a good chance for 
it to work even without ICE. Hence relayed candidates are suggested, as 
Emil pointed out.

But apparently Martin was very much correct about the fact that this 
should be clarified.

The current text says:

>    It is RECOMMENDED that default candidates be chosen based on the
>    likelihood of those candidates to work with the peer that is being
>    contacted.  It is RECOMMENDED that the default candidates are the
>    relayed candidates (if relayed candidates are available), server
>    reflexive candidates (if server reflexive candidates are available),
>    and finally host candidates.

Perhaps the first sentence should be extended with " [...] even if ICE 
is not used"?

Cheers,
Ari

On 11/4/13 1:14 PM, Suhas Nandakumar wrote:
> I interpreted it to be the one "most likely to used" when the ICE
> completes thus forming the default destination for media reception..
>
>
>
>
> On Mon, Nov 4, 2013 at 10:33 AM, Martin Thomson
> <[email-masked] <mailto:[email-masked]>> wrote:
>