Subject: [MMUSIC] draft-ejzak-mmusic-data-channel-sdpneg: Allignment with draft-ietf-mmusic-sctp-sdp-06

From: Christer Holmberg <[email-masked]>
Date: Wed, 26 Feb 2014 13:04:16 +0000

Hi,

In the latest version (-06) of draft-ietf-mmusic-sctp-sdp it is no more allowed (at least that is my reading when comparing the 05->06 diff) to assign multiple SDP sctpmap attributes to a single m- line.

I guess that doesn't affect the mechanism in draft-ejzak-mmusic-data-channel-sdpneg as such (eventhough some text may not be needed anymore). But, at least the example/note in section 4 should be aligned.

Example:

m=application 54111 DTLS/SCTP 5000 5001 5002
c=IN IP4 79.97.215.79
                a=sctpmap:5000 webrtc-datachannel
                a=sctpmap:5001 bfcp
                a=sctpmap:5002 t38

...should be:

m=application 54111 DTLS/SCTP 5000
c=IN IP4 79.97.215.79
                a=sctpmap:5000 webrtc-datachannel

(If you want to use multiple sctpmap attributes, I guess you would need to assign one m- line for each).

In addition, perhaps the SCTP port number is not needed in the extension attributes (dcmap, dcsa) defined in the draft?

Regards,

Christer

---

From: Richard Ejzak <[email-masked]>
Date: Wed, 26 Feb 2014 07:59:34 -0600

Hi Christer,
Thanks for this input.  Clearly the example needs to be updated.  If the
group is certain that we don't want the flexibility to establish multiple
SCTP associations on the same 5-tuple, then we should definitely make the
change to simplify the dcmap and dcsa attributes.

BR, RIchard

On Wed, Feb 26, 2014 at 7:04 AM, Christer Holmberg <
[email-masked]> wrote:

>  Hi,
>
>
>
> In the latest version (-06) of draft-ietf-mmusic-sctp-sdp it is no more
> allowed (at least that is my reading when comparing the 05->06 diff) to
> assign multiple SDP sctpmap attributes to a single m- line.
>
>
>
> I guess that doesn't affect the mechanism in
> draft-ejzak-mmusic-data-channel-sdpneg as such (eventhough some text may
> not be needed anymore). But, at least the example/note in section 4 should
> be aligned.
>
>
>
> Example:
>
>
>
> In addition, perhaps the SCTP port number is not needed in the extension
> attributes (dcmap, dcsa) defined in the draft?
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
>
>
>
>
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 26 Feb 2014 14:23:10 +0000

Hi,

> Thanks for this input.  Clearly the example needs to be updated.  If the group is certain that we don't want the flexibility
> to establish multiple SCTP associations on the same 5-tuple

It MAY (we need to look into that) still be possible to do that with BUNDLE, but you would use separate m- lines for each SCTP association.

Regards,

Christer

On Wed, Feb 26, 2014 at 7:04 AM, Christer Holmberg <[email-masked]> wrote:
Hi,

 
Example:

.should be:

 
 
Regards,
 
Christer