Subject: [MMUSIC] I-D Action: draft-ietf-mmusic-sctp-sdp-06.txt

From: [email-masked]
Date: Thu, 13 Feb 2014 06:20:37 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

        Title           : Stream Control Transmission Protocol (SCTP)-Based Media Transport in the Session Description Protocol (SDP)
        Authors         : Salvatore Loreto
                          Gonzalo Camarillo
	Filename        : draft-ietf-mmusic-sctp-sdp-06.txt
	Pages           : 14
	Date            : 2014-02-13

Abstract:
   SCTP (Stream Control Transmission Protocol) is a transport protocol
   used to establish associations between two endpoints.  This document
   describes how to express media transport over SCTP in SDP (Session
   Description Protocol).  This document defines the 'SCTP', 'SCTP/DTLS'
   and 'DTLS/SCTP' protocol identifiers for SDP.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mmusic-sctp-sdp/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-mmusic-sctp-sdp-06

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-sctp-sdp-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Fri, 14 Feb 2014 20:59:57 +0000

>4.1        a=sctpmap:5000 webrtc-datachannel max-message-size=100000 streams=16
>9.3        a=sctpmap:5000 webrtc-DataChannel max-message-size=100000 streams=16
>11.1   'app' parameter and register as first value "webrtc-datachannel" for
[Raju]
Above three types of representations of "webrtc-datachannel" should use a single value;
The value may be based on the outcome from discussion that is going on a different thread.

> a=sctpmap:5000 webrtc-DataChannel max-message-size=100000 streams=16
[Raju] Instead of putting webrtc data channel attributes on the same line (which gets long), 
how about using existing a=fmtp? as in:
a=fmtp:5000 max-message-size=100000 streams=16
or how about even further shortening it to?
a=fmtp:5000 mms=100000; streams=16

Then these attributes of 'app' protocol can be defined either in rtcweb-data-channel
and then IANA (section 11.1) will have a reference to it. Any such attributes defined 
for this or any generic 'app' protocol are carried in a=fmtp line transparently.

Regards
Raju

> -----Original Message-----
> From: mmusic [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Thursday, February 13, 2014 8:21 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [MMUSIC] I-D Action: draft-ietf-mmusic-sctp-sdp-06.txt
> 
> 
>         Title           : Stream Control Transmission Protocol (SCTP)-Based
> Media Transport in the Session Description Protocol (SDP)
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic