Subject: [MMUSIC] BUNDLE and RFC 4091 ANAT Semantics

From: Suhas Nandakumar <[email-masked]>
Date: Wed, 12 Feb 2014 11:09:59 -0800

Hello All,

I am trying to analyze the multiplexing categorization for media streams
that has ANAT semantics.

Say we have the below SDP example

v=0
o=bob 280744730 28977631 IN IP4 host.example.com
s=
t=0 0
a=group:ANAT 1 2
a=group:ANAT 3 4
m=audio 25000 RTP/AVP 0
c=IN IP6 2001:DB8::1
a= <ICE-encoded additional IPv6 addresses (and ports)>
a=mid:1
m=audio 22334 RTP/AVP 0
c=IN IP4 192.0.2.1
a= <ICE-encoded additional IPv4 addresses (and ports)>
a=mid:2
m=video 25112 RTP/AVP 0
c=IN IP6 2001:DB8::1
a= <ICE-encoded additional IPv6 addresses (and ports)>
a=mid:3
m=video 24544 RTP/AVP 0
c=IN IP4 192.0.2.1
a= <ICE-encoded additional IPv4 addresses (and ports)>
a=mid:4

Here we have audio stream with IPV6 and IPV6 network address, video
streams doing the same as well.

Now if we want to BUNDLE these m=lines, one possible way is to split
BUNDLE into groups that belong to the same network address type (IPV4
or IPV6) as shown below

v=0
o=bob 280744730 28977631 IN IP4 host.example.com
s=
t=0 0
a=group:ANAT 1 2
a=group:ANAT 3 4
a=group:BUNDLE 1 3     // BUNDLE IPv4 audio and video streams
a=group:BUNDLE 2 4     // BUNDLE IPv6 audio and video streams.
m=audio 25000 RTP/AVP 0
c=IN IP6 2001:DB8::1
a= <ICE-encoded additional IPv6 addresses (and ports)>
a=mid:1
m=audio 22334 RTP/AVP 0
c=IN IP4 192.0.2.1
a= <ICE-encoded additional IPv4 addresses (and ports)>
a=mid:2
m=video 25112 RTP/AVP 0
c=IN IP6 2001:DB8::1
a= <ICE-encoded additional IPv6 addresses (and ports)>
a=mid:3
m=video 24544 RTP/AVP 0
c=IN IP4 192.0.2.1
a= <ICE-encoded additional IPv4 addresses (and ports)>
a=mid:4

Any thoughts if this sounds like the right approach ?

Cheers

Suhas

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Feb 2014 11:26:45 -0800

On 12 February 2014 11:09, Suhas Nandakumar <[email-masked]> wrote:
> ANAT semantics

Since RFC 4091 is obsolete, is this really that important?

---

From: Suhas Nandakumar <[email-masked]>
Date: Wed, 12 Feb 2014 11:31:45 -0800

> Since RFC 4091 is obsolete, is this really that important?

Good point. I feel we should just assign NOT RECOMMENDED in the Mux draft
and leave it there.

Cheers
Suhas