Subject: [MMUSIC] BUNDLE and SCTP

From: Christian Groves <[email-masked]>
Date: Tue, 08 Apr 2014 14:14:46 +1000

Hello

Currently the BUNDLE draft focuses of the use of BUNDLE wrt to RTP. 
However a recent email from Paul K highlighted a potential use for SCTP, 
e.g.

/Bundling would apply in a case such as in section 10.1 of 
draft-ietf-mmusic-sdp-bundle-negotiation-05. That example would be 
rewritten as follows: //
////
//  a=group:BUNDLE dc bfcp t38 //
//  m=application 12345 DTLS/SCTP webrtc-datachannel \ //
//          sctp-port#5000 streams#16 max-message-size#100000 //
//  c=IN IP4 example.com //
//  a=mid:dc //
//  m=application 12345 DTLS/SCTP bfcp \ //
//          sctp-port#5001 streams#1 max-message-size#16384 //
//  c=IN IP4 example.com //
//  a=mid:bfcp //
////
//  m=application 12345 DTLS/SCTP t38 \ //
//          sctp-port#5002 streams#1 max-message-size#65536 //
//  c=IN IP4 example.com //
//  a=mid:t38 /

Clause 7.1/draft-ietf-mmusic-sdp-bundle-negotiation-06 indicates several 
mechanisms that need to be described by a specification for new 
protocols (e.g. SCTP). I wonder if we should add a clause to 
draft-ietf-mmusic-sctp-sdp-06 to document the relation of the SCTP SDP 
to BUNDLE usage?

Regards, Christian

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 8 Apr 2014 06:32:16 +0000

Hi,

In the example below, SCTP is running on top of DTLS, and BUNDLE does describe how to distinguish between DTLS and (S)RTP.

Now, if you run multiple SCTP associations on top of that DTLS connection, you would use the SCTP port number to distinguish them.

The general agreement has been that we, within the BUNDLE draft, describe what is needed for RTCWEB (the main "customer" for BUNDLE at the moment), but that we allow extensibility.

Regards,

Christer

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Christian Groves
Sent: 8. huhtikuuta 2014 7:15
To: mmusic mailing list
Subject: [MMUSIC] BUNDLE and SCTP

Hello

Currently the BUNDLE draft focuses of the use of BUNDLE wrt to RTP. 
However a recent email from Paul K highlighted a potential use for SCTP, e.g.

/Bundling would apply in a case such as in section 10.1 of draft-ietf-mmusic-sdp-bundle-negotiation-05. That example would be rewritten as follows: // //// //  a=group:BUNDLE dc bfcp t38 // //  m=application 12345 DTLS/SCTP webrtc-datachannel \ //

Clause 7.1/draft-ietf-mmusic-sdp-bundle-negotiation-06 indicates several mechanisms that need to be described by a specification for new protocols (e.g. SCTP). I wonder if we should add a clause to
draft-ietf-mmusic-sctp-sdp-06 to document the relation of the SCTP SDP to BUNDLE usage?

Regards, Christian

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Martin Thomson <[email-masked]>
Date: Tue, 8 Apr 2014 14:18:25 -0700

> Now, if you run multiple SCTP associations on top of that DTLS connection, you would use the SCTP port number to distinguish them.

Or the PPID on individual frames.  The data channels draft doesn't
really describe what to do with unknown PPIDs, but it could.

> The general agreement has been that we, within the BUNDLE draft, describe what is needed for RTCWEB (the main "customer" for BUNDLE at the moment), but that we allow extensibility.

Sounds like a good candidate for a new internet draft to me.

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 9 Apr 2014 09:27:28 +0000

Hi,

> Or the PPID on individual frames.  The data channels draft doesn't really describe what to do with unknown PPIDs, but it could.

Actually, if you have multiple SCTP associations within a BUNDLE group, none of the above would work. Because, you could end up using the same SCTP port numbers in each SCTP association.

> Sounds like a good candidate for a new internet draft to me.

Yes.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 09 Apr 2014 10:28:53 -0400

> Actually, if you have multiple SCTP associations within a BUNDLE group, none of the above would work. Because, you could end up using the same SCTP port numbers in each SCTP association.

If "two" SCTP associations have the same 5-tuple and the same SCTP ports 
on both ends then they are not really separate SCTP associations.

If the goal is to have two in the same bundle group, sharing the same 
5-tuple, then there must be a different SCTP port to distinguish them. 
That would have to be part of the rule for associating packets with 
m-lines in the bundle group.

If you wanted to associate to m-lines based on PPID, then you would need 
PPID-specific media sections. We don't currently have a way to do that.

	Thanks,
	Paul