Subject: [MMUSIC] Draft new version: draft-ietf-mmusic-sdp-bundle-negotiation-07

From: Christer Holmberg <[email-masked]>
Date: Wed, 23 Apr 2014 09:54:50 +0000

Hi,

I've submitted a new version of BUNDLE, with some fixes based on the comments given on the -06 version.

The biggest change is the removal of text talking about multiple RTP sessions within a BUNDLE group.

Note that the title of the document has been clarified, and is now:

"Negotiating Media Multiplexing Using the Session Description Protocol (SDP)"

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 23 Apr 2014 11:27:50 -0400

Christer,

This update has pretty much addressed my issues.

I have one *possible* issue remaining:

I previously noted that while you had adopted the RFC 3264 structure for 
documenting O/A behavior, your usage of the terms "Initial Offer" and 
"Initial Answer" was inconsistent with 3264.

I see that for this version you have made an explicit statement that 
this is what you are doing, and otherwise left the structure alone.

IMO one motivation for for using a common style for documenting O/A is 
so that all the independently defined extensions can be understood in a 
consistent way. Retaining the style while changing the definition of the 
terms doesn't provide that consistency.

OTOH, viewed independently, the descriptions as you have them work well 
to describe the intended behavior for bundle. And doing something 
different, to align better with 3264 would be hard.

I can live with this, but I hope others will give it some thought and 
comment if this is acceptable.

	Thanks,
	Paul

On 4/23/14 5:54 AM, Christer Holmberg wrote:
> Hi,
>
> I’ve submitted a new version of BUNDLE, with some fixes based on the
> comments given on the -06 version.
>
> “Negotiating Media Multiplexing Using the Session Description Protocol
> (SDP)”
>
> Regards,
>
> Christer
>
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 24 Apr 2014 12:11:39 +0000

Hi,

>I previously noted that while you had adopted the RFC 3264 structure for documenting O/A behavior, your usage of the terms "Initial Offer" and "Initial Answer" was inconsistent with 3264.
>
> I see that for this version you have made an explicit statement that this is what you are doing, and otherwise left the structure alone.

I don't use "Initial Answer", do I?

> IMO one motivation for for using a common style for documenting O/A is so that all the independently defined extensions can be understood in a 
> consistent way. Retaining the style while changing the definition of the terms doesn't provide that consistency.
>
> OTOH, viewed independently, the descriptions as you have them work well to describe the intended behavior for bundle. And doing something different, to align better with 3264 would be hard.

I am not sure there is a misalignment with 3264. At least not a BUNDLE specific one.

Because, I think that, for *any* SDP extension, "Initial Offer" refers to the Offer where the extension is initially used (in one way or another). It may, or may not, be the first Offer within the session. 

In 3264 "Initial Offer" of course always refers to the first Offer within the session, as 3264 talks about the whole SDP (you can't send an Offer without SDP :), not a specific SDP extension.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 24 Apr 2014 10:40:59 -0400

> I don't use "Initial Answer", do I?

maybe not.

> In 3264 "Initial Offer" of course always refers to the first Offer within the session, as 3264 talks about the whole SDP (you can't send an Offer without SDP :), not a specific SDP extension.

I guess that is a judgement call. 3264 didn't give specific instructions 
on how to document the o/a behavior of an extension. People are simply 
looking to it as an example and extrapolating how to apply that to an 
extension. And we aren't all extrapolating in the same way.

As I said, I am ok with this draft as you have done it, with the clear 
specification of what is meant by "initial offer", even though I might 
have done it differently if I was doing it. But I think it is important 
for those who are acting as "O/A police" and requesting the use of this 
format to think about whether this is what they want.

	Thanks,
	Paul