Subject: [MMUSIC] [Technical Errata Reported] RFC5245 (3952)

From: RFC Errata System <[email-masked]>
Date: Fri, 4 Apr 2014 04:42:08 -0700 (PDT)

The following errata report has been submitted for RFC5245,
"Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer Protocols".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5245&eid=3952

--------------------------------------
Type: Technical
Reported by: Suresh Tummala <[email-masked]>

Section: 15.1

Original Text
-------------
priority = 1*10DIGIT

Corrected Text
--------------

Notes
-----
priority = 1*10DIGIT

Here the maximum value it can hold is "9999999999"(ten-nines)(priority is of maximum length 10 DIGIT as per grammar in sec 15.1).

The number of bits required to hold the maximum value(ten-nines) is 34. Which requires a "double" value instead of integer of 32 bit.

Can i know why the priority is maximum of 10 DIGIT length? If possible we may decrease to 9 DIGIT, so that the value will be fit into integer of 32bit.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5245 (draft-ietf-mmusic-ice-19)
--------------------------------------
Title               : Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer Protocols
Publication Date    : April 2010
Author(s)           : J. Rosenberg
Category            : PROPOSED STANDARD
Source              : Multiparty Multimedia Session Control
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: Martin Thomson <[email-masked]>
Date: Fri, 4 Apr 2014 08:37:09 -0700

> Can i know why the priority is maximum of 10 DIGIT length? If possible we may decrease to 9 DIGIT, so that the value will be fit into integer of 32bit.

I don't think that the ABNF has to be perfectly prescriptive.  There
is text that covers the actual limit (2^32-1).  An exact ABNF would be
much harder to understand.

Anyone using ABNF and only ABNF to validate syntax is welcome to
construct a more precise grammar for their needs.  What is described
here is perfectly adequate for an RFC.

---

From: Ari Keränen <[email-masked]>
Date: Wed, 9 Apr 2014 15:30:19 +0300

> here is perfectly adequate for an RFC.

I agree with Martin and to clarify: you need up to 10 decimal digits to 
express the whole range of 32 bit integers and hence "1*9 DIGIT" would 
not be sufficient.

Cheers,
Ari

---

From: Richard Barnes <[email-masked]>
Date: Wed, 9 Apr 2014 10:51:45 -0400

Thanks for the quick feedback.  I have marked this as Rejected.

On Wed, Apr 9, 2014 at 8:30 AM, Ari Keränen <[email-masked]>wrote:

>>> Can i know why the priority is maximum of 10 DIGIT length? If possible
>>> we may decrease to 9 DIGIT, so that the value will be fit into integer of
>>> 32bit.
>>>
>>
> express the whole range of 32 bit integers and hence "1*9 DIGIT" would not
> be sufficient.
>
>
> Cheers,
> Ari
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>