Subject: [MMUSIC] [Editorial Errata Reported] RFC4583 (4111)

From: RFC Errata System <[email-masked]>
Date: Sun, 14 Sep 2014 19:30:01 -0700 (PDT)

The following errata report has been submitted for RFC4583,
"Session Description Protocol (SDP) Format for Binary Floor Control Protocol (BFCP) Streams".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4583&eid=4111

--------------------------------------
Type: Editorial
Reported by: Christian Groves <[email-masked]>

Section: 9

Original Text
-------------
For the purpose of brevity, the main portion of the session
   description is omitted in the examples, which only show 'm' lines and
   their attributes.

   The following is an example of an offer sent by a conference server
   to a client.

   m=application 50000 TCP/TLS/BFCP *
   a=setup:passive
   a=connection:new
   a=fingerprint:SHA-1 \
        4A:AD:B9:B1:3F:82:18:3B:54:02:12:DF:3E:5D:49:6B:19:E5:7C:AB
   a=floorctrl:s-only
   a=confid:4321
   a=userid:1234
   a=floorid:1 m-stream:10
   a=floorid:2 m-stream:11
   m=audio 50002 RTP/AVP 0
   a=label:10
   m=video 50004 RTP/AVP 31
   a=label:11

...

Corrected Text
--------------
For the purpose of brevity, the main portion of the session
   description is omitted in the examples, which only show 'm' lines and
   their attributes.

   The following is an example of an offer sent by a conference server
   to a client.

   m=application 50000 TCP/TLS/BFCP *
   a=setup:passive
   a=connection:new
   a=fingerprint:SHA-1 \
        4A:AD:B9:B1:3F:82:18:3B:54:02:12:DF:3E:5D:49:6B:19:E5:7C:AB
   a=floorctrl:s-only
   a=confid:4321
   a=userid:1234
   a=floorid:1 mstrm:10
   a=floorid:2 mstrm:11
   m=audio 50002 RTP/AVP 0
   a=label:10
   m=video 50004 RTP/AVP 31
   a=label:11

...

Notes
-----
In section 6 of the RFC the ABNF for the "floorid" attribute is:
  floor-id-attribute = "a=floorid:" token [" mstrm:" token *(SP token)]

The text string " mstrm:" is used to reference the media stream rather than "m-stream" that appears in the examples.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4583 (draft-ietf-mmusic-sdp-bfcp-03)
--------------------------------------
Title               : Session Description Protocol (SDP) Format for Binary Floor Control Protocol (BFCP) Streams
Publication Date    : November 2006
Author(s)           : G. Camarillo
Category            : PROPOSED STANDARD
Source              : Multiparty Multimedia Session Control
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: Tom Kristensen <[email-masked]>
Date: Tue, 16 Sep 2014 09:11:30 +0200

Well spotted!

This is addressed and fixed in rfc4583bis.
https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis (a new version of
this draft will be submitted very soon).

Cf. Section 6, where this paragraph is added:

    "Note: In [15
<https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-09#ref-15>]
'm-stream' was erroneously used in Section 10
<https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-09#section-10>.

   Although the example was non-normative, it is implemented by some
   vendors and occurs in cases where the endpoint is willing to act as
   an server.  Therefore, it is RECOMMENDED to support parsing and
   interpreting 'm-stream' the same way as 'mstrm' when receiving."

In the example pointed to in the errate, we are now using the correct
string for the floorid attribute:

  "a=floorid:1 mstrm:10
   a=floorid:2 mstrm:11"

-- Tom

On 15 September 2014 04:30, RFC Errata System <[email-masked]>
wrote:

> The text string " mstrm:" is used to reference the media stream rather
> than "m-stream" that appears in the examples.
>
> Instructions:
> -------------
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

-- 
# Cisco                         |  http://www.cisco.com/telepresence/
## [email-masked]  |  http://www.tandberg.com
###                               |  http://folk.uio.no/tomkri/

---

From: Christian Groves <[email-masked]>
Date: Tue, 16 Sep 2014 23:47:01 +1000

Hello Tom,

Ah, I missed the bis document. Good to see it's addressed. RFC5239 also 
has the same issue in clause 8.4 where it uses m-stream. Its probably 
worth an errata also.

Regards, Christian

On 16/09/2014 5:11 PM, Tom Kristensen wrote:
> https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis (a new 
> version of this draft will be submitted very soon).
>
> In the example pointed to in the errate, we are now using the correct string for the floorid attribute:
>    "a=floorid:1 mstrm:10
>     a=floorid:2 mstrm:11"
> -- Tom
>
> On 15 September 2014 04:30, RFC Errata System 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Reported by: Christian Groves <[email-masked]
>     <mailto:[email-masked]>>
>
>     Section: 9
>
>     Original Text
>     -------------
>     The text string " mstrm:" is used to reference the media stream
>     rather than "m-stream" that appears in the examples.
>
>     Instructions:
>     -------------
>     Title               : Session Description Protocol (SDP) Format
>     for Binary Floor Control Protocol (BFCP) Streams
>     [email-masked] <mailto:[email-masked]>
> ## [email-masked] <mailto:[email-masked]>  | 
> http://www.tandberg.com

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 19 Sep 2014 19:43:42 +0000

Yes, please do. The BFCPBIS WG does not have plans to update RFC 5239, so
an errata would be helpful.

Cheers,
Charles

---

From: Richard Barnes <[email-masked]>
Date: Sun, 21 Sep 2014 20:41:27 -0400

Since the -bis document is going to obsolete RFC 4583, I'm just going to
mark this one "Rejected", since it will be addressed in the -bis.

Christian: Please do go ahead and submit an erratum on RFC 5239, and I'll
mark it Verified.

On Fri, Sep 19, 2014 at 3:43 PM, Charles Eckel (eckelcu) <[email-masked]>
wrote:

> >><https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-09#section-10
> >
> >>.

---

From: Christian Groves <[email-masked]>
Date: Mon, 22 Sep 2014 10:58:28 +1000

Hello Richard and Charles,

No problem. I've submitted the errata on RFC5239.

Regards, Christian

On 22/09/2014 10:41 AM, Richard Barnes wrote:
> Since the -bis document is going to obsolete RFC 4583, I'm just going 
> to mark this one "Rejected", since it will be addressed in the -bis.
>
> Christian: Please do go ahead and submit an erratum on RFC 5239, and 
> I'll mark it Verified.
>
>
>
> On Fri, Sep 19, 2014 at 3:43 PM, Charles Eckel (eckelcu) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     On 9/16/14, 6:47 AM, "Christian Groves"
>     <[email-masked] <mailto:[email-masked]>>
>     wrote:
>
>     >Hello Tom,
>     >
>     >> <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>     >>
>     >>     Reported by: Christian Groves
>     <[email-masked] <mailto:[email-masked]>
>     >>     <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>     >>
>     >>     Section: 9
>     >>
>     >>     Original Text
>     >>     -------------
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >> ## [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>> |
>     >> http://www.tandberg.com

---

From: Richard Barnes <[email-masked]>
Date: Sun, 21 Sep 2014 22:00:25 -0400

... and I have marked as Verified.

On Sun, Sep 21, 2014 at 8:58 PM, Christian Groves <
[email-masked]> wrote:

>> On Fri, Sep 19, 2014 at 3:43 PM, Charles Eckel (eckelcu) <
>> [email-masked] <mailto:[email-masked]>> wrote:
>>
>>     <[email-masked] <mailto:[email-masked]
>> >>
>>
>>     wrote:
>>
>>     >Hello Tom,
>>     >
>>     <https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-09#ref-15
>> >]
>>     >><https://tools.ietf.org/html/draft-ietf-bfcpbis-
>> rfc4583bis-09#section-10>
>>     >>.