Subject: [MMUSIC] BUNDLE: How to process bundled m- lines when no address fulfills the criteria for being selected as the offerer BUNDLE address?

From: Christer Holmberg <[email-masked]>
Date: Wed, 17 Dec 2014 19:14:27 +0000

Hi,

We currently have the following text in BUNDLE, when the answerer selects the offerer BUNDLE address:

                "If one or more of the criteria are not fulfilled, the answerer MUST select the next
                identification-tag in the identification-tag list, and perform the same criteria
                check for the "m=" line associated with that identification-tag. If there are no
                more identification-tags in the identification-tag list, the answerer MUST NOT
                create the BUNDLE group."

Now, as the text says, if there is no bundled "m=" line address in the offer which fulfills
the criteria for being selected as the offerer BUNDLE address, the answer MUST NOT
create the offerer BUNDLE group. So far so good.

However, I think it would be good to have some text on what the answerer DOES with
the "m=" lines (in case the answerer doesn't reject the whole offer, that is).

So, I suggested to append the following text to the paragraph:

"Unless the answerer rejects the whole offer, the answerer  MUST apply the answerer
procedures for moving an "m=" line out of a BUNDLE group to each  bundled "m=" line
in the offer when creating the answer."

This basically means that, if the "m=" line had a shared address, or a bundle-only attribute, it will be
rejected. If the "m=" line had a unique address, the answerer will assign a unique address in the answer.

Comments?

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 17 Dec 2014 16:11:08 -0500

This sounds good to me.

	Thanks,
	Paul

On 12/17/14 2:14 PM, Christer Holmberg wrote:
>                  “If one or more of the criteria are not fulfilled, the
> answerer MUST select the next
>
>                  create the BUNDLE group.”
>
> Now, as the text says, if there is no bundled “m=” line address in the
> offer which fulfills
>
> the “m=” lines (in case the answerer doesn’t reject the whole offer,
> that is).
>
> “Unless the answerer rejects the whole offer, the answerer  MUST apply
> the answerer
>
> in the offer when creating the answer.”
>
> This basically means that, if the “m=” line had a shared address, or a
> bundle-only attribute, it will be
>
> rejected. If the “m=” line had a unique address, the answerer will
> assign a unique address in the answer.
>
> Comments?
>
> Regards,
>
> Christer
>
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Martin Thomson <[email-masked]>
Date: Wed, 17 Dec 2014 14:16:00 -0800

On 17 December 2014 at 11:14, Christer Holmberg
<[email-masked]> wrote:
> “Unless the answerer rejects the whole offer, the answerer  MUST apply the
> answerer
>

This statement, out of context, reads as "don't negotiate bundle".
Though I guess that it is hard to get all the conditions right.  After
all, bundle-only sections don't get moved out either.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 18 Dec 2014 13:52:44 +0000

Hi Martin,

>> the answerer procedures for moving an "m=" line out of a BUNDLE group to each  
>> bundled "m=" line in the offer when creating the answer.”
>
> Though I guess that it is hard to get all the conditions right.  After all, bundle-only sections don't get moved out either.

I guess I should have copied more text into the original e-mail.

This is related to the case where the offerer has offered BUNDLE, but none of the bundled m- line addresses fulfil the criteria for being selected as the offerer BUNDLE address by the answerer.

Regards,

Christer

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Thu, 18 Dec 2014 15:52:36 +0000

I have no objections.
Please see a minor comment inline.

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Wednesday, December 17, 2014 1:14 PM

Hi,

"Unless the answerer rejects the whole offer, the answerer  MUST apply the answerer
procedures for moving an "m=" line out of a BUNDLE group to each  bundled "m=" line
in the offer when creating the answer."
<Raju>
I believe ".. moving an "m=" line out of a BUNDLE group..." also includes rejecting the m= line by setting port to 0. Do we need some text to clarify this?
</Raju>

BR
Raju

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 18 Dec 2014 17:36:42 +0000

Hi,

The section on moving an "m=" line out of a BUNDLE group describes the case when the "m=" line must be rejected.

Regards,

Christer