Subject: [MMUSIC] BUNDLE: bundle-only attribute with non-zero port value?

From: Christer Holmberg <[email-masked]>
Date: Tue, 2 Dec 2014 12:54:30 +0000

Hi,

Currently  BUNDLE allows usage of the SDP bundle-only attribute in any offer - even if the associated m- line contains a negotiated BUNDLE address.

As we know, the purpose of the attribute is to ensure that the answerer rejects the associated m- line if the answerer does not support BUNDLE, or if the answerer does not keep the m- line within the BUNDLE group.

Once the BUNDLE address have been negotiated, the offerer can ensure the same thing by assigning the BUNDLE address to an m- line. If the answerer does not want to keep it within the BUNDLE group, it will reject the m- line (per BUNDLE procedures).

So, the question is: is there a need to use the bundle-attribute in m- lines with a non-zero port value? It would simply the procedures by specifying that the attribute can only be used together with port zero.

Regards,

Christer

---

From: "Stach, Thomas" <[email-masked]>
Date: Fri, 5 Dec 2014 13:56:13 +0000

Christer,

I don't think there is a use case for the bundle-only attribute with a non-zero port value that you can't achieve with port=0.

Regards
Thomas

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Dienstag, 2. Dezember 2014 13:55
To: [email-masked]
Subject: [MMUSIC] BUNDLE: bundle-only attribute with non-zero port value?

Hi,

So, the question is: is there a need to use the bundle-attribute in m- lines with a non-zero port value?
It would simply the procedures by specifying that the attribute can only be used together with port zero.

Regards,

Christer