Subject: [MMUSIC] draft-ejzak-mmusic-data-channel-sdpneg: make "subprotocol" optional in dcmap

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Tue, 2 Dec 2014 16:30:45 +0000

Section 5.1.1.3 says "subprotocol" is a mandatory parameter.
However, "5.1.  DATA_CHANNEL_OPEN Message" of draft-ietf-rtcweb-data-protocol (DCEP) says the subprotocol can be empty (i.e. unspecified).

We also foresee draft-ejzak-mmusic-data-channel-sdpneg to be used for cases where stream id is negotiated while subprotocol is unspecified.

To align it with DCEP and to allow the above use case, we want to make the subprotocol optional in dcmap.
Existing text in 5.1.1.3 
"Subprotocol is a mandatory parameter."
will be changed to
"Subprotocol is a an optional parameter. If the subprotocol parameter is not present, then its value defaults to empty string"

Please let us know if you have any objections to this.

Thanks
Raju

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 2 Dec 2014 16:54:10 +0000

Hi,

If "subprotocol" is optional in DCEP then I think it should be optional also in draft-sdpneg.

Regards,

Christer

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Makaraju, Maridi Raju (Raju)
Sent: 02 December 2014 18:31
To: [email-masked]
Subject: [MMUSIC] draft-ejzak-mmusic-data-channel-sdpneg: make "subprotocol" optional in dcmap

Thanks
Raju

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic