Subject: Re: [MMUSIC] SCTP-SDP: Mux category for SDP sctp-port and max-message-size attributes - Suggested text

From: Christer Holmberg <[email-masked]>
Date: Mon, 23 Feb 2015 10:29:12 +0000

Hi,

I drafted some text regarding the mux categories for the attributes.

In each section defining an attribute I've added a sub-section, which provides detailed information regarding the mux categories.

In the IANA registration section I've added, for each attribute, the mux category value.

Read - think - feel - love - comment.

-----------

Main text (sctp-port):

5.3.  Mux Category

   The mux category [I-D.ietf-mmusic-sdp-mux-attributes] for the SDP
   'sctp-port' attribute is SPECIAL.  Usage of the attribute
   is only applicable when associated with 'UDP/DTLS/SCTP' and
   'TCP/DTLS/SCTP' proto value m- lines.

                    +---------------+----------------+
                    |     Proto     |  Mux category  |
                    +---------------+----------------+
                    |      SCTP     | Not applicable |
                    |   SCTP/DTLS   | Not applicable |
                    | UDP/DTLS/SCTP |    SPECIAL     |
                    | TCP/DTLS/SCTP |    SPECIAL     |
                    +---------------+----------------+

              Table 1: SDP 'sctp-port' attribute mux category

   NOTE: As the usage of multiple SCTP associations on top of a single
   DTLS connection is outside the scope of this specification, a SPECIAL
   mux category value, with no associated rule definitions, is defined
   for SDP 'sctp-port' attributes associated with 'UDP/DTLS/SCTP' and
   'TCP/DTLS/SCTP' proto value m- lines.  Future extensions, that define
   how to negotiate multiplexing of multiple SCTP associations of top of
   a single DTLS connection, need to also define the mux rules for the
   attribute.

-----------

Main text (max-message-size):

6.3.  Mux Category

   The mux category [I-D.ietf-mmusic-sdp-mux-attributes] for the SDP
   'max-message-size' attribute is SPECIAL, as the category depends on the
   proto value of the associated m- line.

                     +---------------+--------------+
                     |     Proto     | Mux category |
                     +---------------+--------------+
                     |      SCTP     |  TRANSPORT   |
                     |   SCTP/DTLS   |  TRANSPORT   |
                     | UDP/DTLS/SCTP |   SPECIAL    |
                     | TCP/DTLS/SCTP |   SPECIAL    |
                     +---------------+--------------+

          Table 2: SDP 'max-message-size' attribute mux category

   NOTE: As the usage of multiple SCTP associations on top of a single
   DTLS connection is outside the scope of this specification, a SPECIAL
   mux category value, with no associated rule definitions, is defined
   for SDP 'max-message-size' attributes associated with 'UDP/DTLS/SCTP'
   and 'TCP/DTLS/SCTP' proto value m- lines.  Future extensions, that
   define how to negotiate multiplexing of multiple SCTP associations of
   top of a single DTLS connection, need to also define the mux rules
   for the attribute.

-----------

IANA Registration:

15.2.1.  sctp-port

   [RFC EDITOR NOTE: Please replace RFCXXXX with the RFC number of this
   document.]

   This document defines a new SDP media-level attribute,'sctp-port', as
   follows:

       Attribute name:     sctp-port
       Type of attribute:  media
       Mux category:       SPECIAL
       Subject to charset: No
       Purpose:            Indicate the SCTP port value associated
                           with the SDP Media Description.
       Appropriate values: Integer
       Contact name:       Christer Holmberg
       Contact e-mail:     [email-masked]
       Reference:          RFCXXXX

15.2.2.  max-message-size

   [RFC EDITOR NOTE: Please replace RFCXXXX with the RFC number of this
   document.]

   This document defines a new SDP media-level attribute,'max-message-
   size', as follows:

       Attribute name:     max-message-size
       Type of attribute:  media
       Mux category:       SPECIAL
       Subject to charset: No
       Purpose:            Indicate the maximum message size that
                           an SCTP endpoint is willing to receive
                           on the SCTP association associated
                           with the SDP Media Description.
       Appropriate values: Integer
       Contact name:       Christer Holmberg
       Contact e-mail:     [email-masked]
       Reference:          RFCXXXX

Regards,

Christer

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 23 February 2015 06:52
To: Paul Kyzivat; [email-masked]
Subject: Re: [MMUSIC] SCTP-SDP: Mux category for SDP sctp-port and max-message-size attributes

Hi,

>>>> I've been asked to include the MUX category (as defined in
>>>> draft-ietf-mmusic-sdp-mux-attributes) for the SDP attributes
>>>> defined in the SCTP-SDP draft: sctp-port and max-message-size.
>>>>
>>>> For 'SCTP' and 'SCTP/DTLS' I assume it is rather straight forward.
>>>> The sctp-port attribute is not used to begin with, and the
>>>> max-message-size applies to the transport layer SCTP association.
>>>>
>>>> '(UDP | TCP)/DTLS/SCTP' is a little different.  The draft says (or,
>>>> **will** say, based on the agreement in Honolulu) that multiple
>>>> SCTP associations over a single '(UDP | TCP)/DTLS' connection is
>>>> outside the scope of the document, which means it is not possible
>>>> to have multiple '(UDP | TCP)/DTLS/SCTP' m- lines within a BUNDLE group.
>>>>
>>>> Currently, unless I've missed something, there is however no
>>>> category for attributes that can't be bundled, eventhough one could
>>>> perhaps claim that the NOT RECOMMENDED category fits. So, I see three options:
>>>>
>>>> 1)Allocate SPECIAL category, with a description saying that they
>>>> can't be bundled
>>>>
>>>> 2)Allocate NOT RECOMMENDED category
>>>>
>>>> 3)Define a new mux category, for attributes that can't be bundled
>>>>
>>>> Comments? My personal preference would be either 2) or 3).
>>>
>>> As you say, the bundle draft currently forbids multiplexing these.
>>
>> I don't think the bundle draft forbids it, but the SCTP-SDP drafts
>> says that the negotiation of multiple SCTP associations on a >single DTLS connection is outside the scope of the draft.
>>
>>> Suppose an extension was done to allow multiple '(UDP |
>>> TCP)/DTLS/SCTP' in a bundle. In that case it clearly would be
>>> necessary for them to be distinguished by sctp-port. And that would presumably be specified in the document that defines that behavior.
>>>
>>> So why not just classify this attribute as SPECIAL? That covers the case, both now and in the future.
>>
>> That is one option.
>>
>> However, any future extension would perhaps need to change the value.
>>
>> For example, I assume the value for the sctp-port attribute would be
>> UNIQUE - which is another category that currently doesn't exist :)
>>
>> And, I guess the max-message-size would be NORMAL, as different values may be used on each SCTP association.
>
> If there was a UNIQUE category then it could be used. But certainly SPECIAL can continue to be used.

Perhaps it would be useful to define a UNIQUE category no matter what, but that's a separate issue.

>> But, in any case: it seems like we, for the same attribute, need to
>> register different category values depending on the proto value. How would we do that?
>
> Yes, that is something new that must be dealt with.
>
> OR, again it can simply be defined as SPECIAL, and all these rules can be defined in this document.

Yes.

Then, exactly where are the rules defined? Do they need to be in the IANA template? Or, is the category value enough as far as IANA is concerned, and the rules are then defined somewhere else in the document?

Regards,

Christer

>> SCTP:
>>
>> =====
>>
>> Attribute:                          Mux category:
>>
>> sctp-port                           Not applicable
>>
>> max-message-size          TRANSPORT
>>
>> SCTP/DTLS:
>>
>> ==========
>>
>> sctp-port                           Not applicable
>>
>> max-message-size          TRANSPORT
>>
>> (UDP | TCP)/DTLS/SCTP:
>>
>> =====================
>>
>> Attribute:                          Mux category:
>>
>> sctp-port                           SPECIAL | New category
>>
>> max-message-size          SPECIAL | New category
>>
>> Regards,
>>
>> Christer
>>
>>
>>
>> _______________________________________________
>> mmusic mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/mmusic
>>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 24 Feb 2015 12:52:39 -0500

Ahh, forget my reply in the other thread. This was what you were asking 
if I had read. (And I hadn't, until now.)

On 2/23/15 5:29 AM, Christer Holmberg wrote:
> In each section defining an attribute I've added a sub-section, which
> provides detailed information regarding the mux categories.
> *Main text (**sctp-port**):*
> 5.3.  Mux Category

It seems odd to me that after the IANA considerations section registers 
this attribute as being SPECIAL in general, in this section you then 
also use SPECIAL here on a per-proto basis.

IMO it would be clearer without the table. E.g.

    As the usage of multiple SCTP associations on top of a single
    DTLS connection is outside the scope of this specification,
    no mux rules are needed.  Future extensions, that define
    how to negotiate multiplexing of multiple SCTP associations of top of
    a single DTLS connection, need to also define the mux rules for the
    attribute.

> -----------
> *Main text (max-message-size):*
> 6.3.  Mux Category

Similar comment to above.

> *Mux category:       SPECIAL*
> *Mux category:       SPECIAL*

This seems good.

	Thanks,
	Paul

> Then, exactly where are the rules defined? Do they need to be in the
> IANA template? Or, is the category value enough as far as IANA is
> concerned, and the rules are then defined somewhere else in the document?
> Regards,
> Christer
>>> SCTP:
>>>
>>> =====
>>>
>>> Attribute:                          Mux category:
>>>
>>> sctp-port                           Not applicable
>>>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 25 Feb 2015 07:21:14 +0000

Hi,

> It seems odd to me that after the IANA considerations section registers this attribute as being SPECIAL in general, in this section you then also use SPECIAL here on a per-proto basis.
>

Works for me.

> Similar comment to above.

Well, this case is a little different, because we actually have two different values: TRANSPORT and SPECIAL.

So, should we include BOTH values in the IANA register template?

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 25 Feb 2015 09:41:38 -0500

> So, should we include BOTH values in the IANA register template?

ISTM that the registration template only covers a single value per 
attribute, not a value per proto. So my inclination is to simply 
register as SPECIAL, and then detail the per-proto behavior in the 
draft. In the text you could say that for SCTP and SCTP/DTLS the rules 
are the same as for TRANSPORT.

Alternatively, the registration for mux-categories in general could be 
expanded to allow per-proto registration. But I think that is overkill.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 25 Feb 2015 14:52:14 +0000

Hi,

>>>> In each section defining an attribute I've added a sub-section, 
>>>> which provides detailed information regarding the mux categories.
> ISTM that the registration template only covers a single value per attribute, not a value per proto. So my inclination is to simply register as SPECIAL, and then detail the per-proto behavior in the draft. In the text you could say that for SCTP and SCTP/DTLS the rules are the same as for TRANSPORT.
>
> Alternatively, the registration for mux-categories in general could be expanded to allow per-proto registration. But I think that is overkill.

I agree.

So, something like:

     "The mux category [I-D.ietf-mmusic-sdp-mux-attributes] for the SDP
     'max-message-size' attribute is SPECIAL. The mux rules depends
     on the proto value of the associated m- line. If the proto value is
    'SCTP' or 'SCTP/DTLS' the rules are identical to the rules associated
     with the TRANSPORT mux category. 

     As the usage of multiple SCTP associations on top of a single
     DTLS connection is outside the scope of this specification,
     no mux rules are specified for the 'UDP/DTLS/SCTP'  and 
     'TCP/DTLS/SCTP'  proto values."

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 25 Feb 2015 10:34:33 -0500

WFM