Subject: [MMUSIC] RTP Retransmission, FID and BUNDLE

From: Magnus Westerlund <[email-masked]>
Date: Tue, 17 Feb 2015 12:04:15 +0100

MMUSIC,
(CC AVTCORE but please reply to MMUSIC only)

In draft-ietf-avtcore-multi-media-rtp-session-06 we have the following
open issue in Section 7.1:

   Open Issue: When using SDP to signal retransmission for one RTP
   session with multiple media types and one RTP session for the
   retransmission data will cause a situation where one will have
   multiple m= lines grouped using FID and the ones belonging to
   respective RTP session being grouped using BUNDLE.  This usage might
   contradict both the FID semantics [RFC5888] and an assumption in the
   RTP retransmission specification [RFC4588].

What I understand the concern relates to the correct usage of FID to
avoid breaking the semantics of FID when declaring an RTP session that
would contain one audio, one video source bundled but a separate RTP
session for the retransmission of both these media sources.

Lets exemplify with what I believe is the only possible offer for this
in regards to FID usage.

   SDP Offer (3)

       v=0
       o=alice 2890844526 2890844526 IN IP4 atlanta.example.com
       s=
       c=IN IP4 atlanta.example.com
       t=0 0
       a=group:BUNDLE foo bar
       a=group:FID foo zoo
       a=group:FID bar zoo
       m=audio 10000 RTP/AVP 0
       b=AS:200
       a=mid:foo
       a=rtpmap:0 PCMU/8000
       a=extmap 1 urn:ietf:params:rtp-hdrext:sdes:mid
       m=video 10000 RTP/AVP 31
       b=AS:1000
       a=mid:bar
       a=rtpmap:31 H261/90000
       a=extmap 1 urn:ietf:params:rtp-hdrext:sdes:mid
       m=application 40000 RTP/AVPF 99 100
       a=rtpmap:99 rtx/90000
       a=fmtp:99 apt=0;rtx-time=3000
       a=rtpmap:100 rtx/90000
       a=fmtp:199 apt=31;rtx-time=3000
       a=mid:zoo

I think the important aspect here is that one MUST use one FID line per
m= line one groups with the retransmission session to avoid the FID MUST
NOT have the same address that Roni brought up back in December.

Have I missed any limitation or does the above example appear
reasonable. If it does then we can write a small informational
description about this into the multiple media types document.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 17 Feb 2015 12:19:51 +0100

Hi,

I realize that there is another likely configuration here, and that is
one where one has one corresponding m= line per source media source also
in the retransmission RTP session which would result in an example SDP
like this:

       v=0
       o=alice 2890844526 2890844526 IN IP4 atlanta.example.com
       s=
       c=IN IP4 atlanta.example.com
       t=0 0
       a=group:BUNDLE foo bar
       a=group:BUNDLE zoo kelp
       a=group:FID foo zoo
       a=group:FID bar kelp
       m=audio 10000 RTP/AVP 0
       b=AS:200
       a=mid:foo
       a=rtpmap:0 PCMU/8000
       a=extmap 1 urn:ietf:params:rtp-hdrext:sdes:mid
       m=video 10000 RTP/AVP 31
       b=AS:1000
       a=mid:bar
       a=rtpmap:31 H261/90000
       a=extmap 1 urn:ietf:params:rtp-hdrext:sdes:mid
       m=audio 40000 RTP/AVPF 99
       a=rtpmap:99 rtx/90000
       a=fmtp:99 apt=0;rtx-time=3000
       a=mid:zoo
       a=extmap 1 urn:ietf:params:rtp-hdrext:sdes:mid
       m=video 40000 RTP/AVPF 100
       a=rtpmap:100 rtx/90000
       a=fmtp:199 apt=31;rtx-time=3000
       a=mid:kelp
       a=extmap 1 urn:ietf:params:rtp-hdrext:sdes:mid

So, please provide input on which way you think is the most correct and
based on what is written in the BUNDLE and other specs

Cheers

Magnus

On 2015-02-17 12:04, Magnus Westerlund wrote:
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
> 

-- 

Magnus Westerlund