Subject: Re: [MMUSIC] Review of 4566bis

From: "Roni Even" <[email-masked]>
Date: Tue, 2 Jun 2015 00:39:17 +0300

Hi,
I do not think that general media level overrides session level value works
for the b= attribute
Roni

> -----Original Message-----
> From: mmusic [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: 31 May, 2015 8:43 PM
> To: [email-masked]
> Subject: Re: [MMUSIC] Review of 4566bis
> 
> On 5/31/15 9:38 AM, Christer Holmberg wrote:
> 
> Good list Christer!
> 
> I have comments on a few of your issues:
> 
> > Q6_2:
> >
> > In some of the sub-sections, it is indicated that a media-level
> > attribute value overrides a session-level attribute value. As far as I
> > know, that applies to all attributes (that can be present both on the
> > session-level and media-level), so there should be a generic statement
> > about that.
> >
> > This is similar to the comment on the c= line.
> 
> I used to think this, but I think there are some exceptions. (But I don't
offhand
> remember what they are.)
> 
> > Section 6.7:
> >
> > ---------------
> >
> > Q6-7_1:
> >
> > The text says:
> >
> >     "If any one of these appears in a media section then it applies
> > for
> >
> >     that media section.  If none appear in a media section then the
> > one
> >
> >     from session level, if any, applies to that media section."
> >
> > There should be a general statement in the draft about session level
> > information applying to the media level.
> 
> I wish there could be a general statement, but it is hard, given
exceptions.
> Perhaps there could be a general statement with note that it can be
overridden
> in particular cases.
> 
> But in any case, *this* is different, because it says that the presence of
any
> *one* of four different attributes at media level overrides the presence
of any
> one of those four at session level.
> 
> > Section 6.11:
> >
> > -----------------
> >
> > The text says that the attribute "specifies the language" of the
> > session description.
> >
> > There has been some confusion about what that really means, so I think
> > it would be good to clarify that it applies to any textual information
> > that may be provided within the description.
> >
> > It would also be good to explicitly indicate that the attribute is not
> > related to languages used in the actual media streams.
> 
> +1
> 
> 	Thanks,
> 	Paul
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 2 Jun 2015 09:02:03 +0000

Hi Roni,

>I do not think that general media level overrides session level value works for the b= attribute Roni

b= is not an attribute :)

Anyway, my suggestion would be that the DEFAULT RULE for all SDP elements that can occur both on session and media level should be that the media level overrides the session level. Then, in cases where it does not apply, it should be explicitly stated. 

Regards,

Christer

> > attribute value overrides a session-level attribute value. As far as 
> > I know, that applies to all attributes (that can be present both on 
> > the session-level and media-level), so there should be a generic 
> > statement about that.
> >
offhand
exceptions.
overridden
any
of any
> > There has been some confusion about what that really means, so I 
> > think it would be good to clarify that it applies to any textual 
> > information that may be provided within the description.
> >
> > It would also be good to explicitly indicate that the attribute is 
> > not related to languages used in the actual media streams.
> 
> +1
> 
> 	Thanks,
> 	Paul
>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Tue, 2 Jun 2015 09:05:30 +0000

>Anyway, my suggestion would be that the DEFAULT RULE for all SDP elements that can occur both on session and media level should be that the media level overrides the session level. Then, in cases wh…

We can do this, but naturally I will ask everyone to let me know which ones are the exceptions.

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 2 Jun 2015 09:08:52 +0000

Hi,

>We can do this, but naturally I will ask everyone to let me know which ones are the exceptions.

I think it should also be added to the pieces of information that must be provided when defining a new information element that can occur both on session- and media level.

Regards,

Christer

>> > attribute value overrides a session-level attribute value. As far 
>> > as I know, that applies to all attributes (that can be present both 
>> > on the session-level and media-level), so there should be a generic 
>> > statement about that.
>> >
>> > There should be a general statement in the draft about session 
>> > level information applying to the media level.
>>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 2 Jun 2015 10:36:53 +0000

Hi,

Q6_2:

> I used to think this, but I think there are some exceptions. (But I don't offhand remember what they are.)

I commented on this elsewhere, but it needs to be clear (no matter how we do it) in the spec in which case overriding applies, and in which case it doesn't.

 Section 6.7:
 ---------------

 Q6-7_1:

>> The text says:
>>
>>     "If any one of these appears in a media section then it applies for
>>     that media section.  If none appear in a media section then the one
> I wish there could be a general statement, but it is hard, given exceptions. Perhaps there could be a general statement with note that it can be overridden in particular cases.
>
> But in any case, *this* is different, because it says that the presence of any *one* of four different attributes at media level overrides the presence of any one of those four at session level.

Correct. I wish it would have been a single attribute, with different values :)

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 02 Jun 2015 09:50:47 -0400

> Anyway, my suggestion would be that the DEFAULT RULE for all SDP elements that can occur both on session and media level should be that the media level overrides the session level. Then, in cases w…

I do think this *would have been* the right thing to do from the 
beginning. But I am uncertain if it is the right thing to do *now*, for 
backward compatibility reasons.

Before doing so we will need to do an exhaustive study of all current 
attribute definitions that are registered in IANA as valid at both 
session and media level - to ensure that their meaning won't be changed 
by this.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 2 Jun 2015 15:24:30 +0000

Hi,

>> Anyway, my suggestion would be that the DEFAULT RULE for all SDP elements that can occur both on 
>> session and media level should be that the media level overrides the session level. Then, in cases where 
>> it does not apply, it should be explicitly stated.
>
> I do think this *would have been* the right thing to do from the beginning. But I am uncertain 
> if it is the right thing to do *now*, for backward compatibility reasons.
>
> Before doing so we will need to do an exhaustive study of all current attribute definitions that are registered 
> in IANA as valid at both session and media level - to ensure that their meaning won't be changed by this.

I agree.

And, I am not saying we shall apply the media-overrides-session rule to all attributes - I am saying that it needs to be clear to which attributes the rule applies, and to which it doesn't.

Leaving it unspecified will not bring compatibility, and the whole purpose of a bis is to correct bugs and clarify things which are unclear :)

I would assume that, in most cases, the media-overrides-session rule DOES apply.

And, we must make sure that, when new attributes are defined, it is indicated whether the rule applies or not.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 02 Jun 2015 12:10:20 -0400

> And, we must make sure that, when new attributes are defined, it is indicated whether the rule applies or not.

OK. I agree with all this.

	Thanks,
	Paul