Subject: [MMUSIC] Draft new version: BUNDLE-21

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Jun 2015 16:15:54 +0000

Hi,

I've submitted a new version (-21) of BUNDLE.

It contains a couple of clarifications, based on comments from Jens and Flemming.

Happy Reading! :)

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 15 Jun 2015 13:14:10 -0400

One comment, on section 9.1:

    This document describes a mechanism to identify the protocol of a
    received packet among the STUN, DTLS and SRTP protocols (in any
    combination), when UDP is used as transport-layer protocol, but does
    not describe how to identify different protocols transported on DTLS.
    While the mechanism is generally applicable to other protocols and
    transport-layers protocols, any such use requires further
    specification around how to multiplex multiple protocols on a given
    transport-layer protocols, and how to associate received packets with
    the correct protocols.

ISTM that something is still missing from this section. It *assumes* 
that the transport protocol packages things into packets, and that each 
such packet can be associated with one of the application protocols 
sharing it.

Consider TCP: while it uses packets on the network, it is a stream 
oriented transport. Upper layers built for TCP may not have any notion 
of packets. It is probably infeasible to multiplex m-lines for such 
protocols using BUNDLE.

The protocols we have been thinking of either don't work over stream 
oriented protocols, or else define a way to packetize.

This could get complex. The simple thing to do is to specify that 
stream-oriented transports are out of scope for this document.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Jun 2015 18:21:48 +0000

Hi Paul,

The "received packets" text was not added in this version.

But, I hear what you are saying, so perhaps we instead should say "received data"? 

Regards,

Christer

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 15 June 2015 20:14
To: [email-masked]
Subject: Re: [MMUSIC] Draft new version: BUNDLE-21

ISTM that something is still missing from this section. It *assumes* that the transport protocol packages things into packets, and that each such packet can be associated with one of the application protocols sharing it.

Consider TCP: while it uses packets on the network, it is a stream oriented transport. Upper layers built for TCP may not have any notion of packets. It is probably infeasible to multiplex m-lines for such protocols using BUNDLE.

The protocols we have been thinking of either don't work over stream oriented protocols, or else define a way to packetize.

This could get complex. The simple thing to do is to specify that stream-oriented transports are out of scope for this document.

	Thanks,
	Paul

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 15 Jun 2015 14:42:09 -0400

> The "received packets" text was not added in this version.

Fair enough. But the point remains.

> But, I hear what you are saying, so perhaps we instead should say "received data"?

That would fix it here. But the usage is elsewhere, with the same concern.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Jun 2015 18:47:39 +0000

Hi,

> That would fix it here. But the usage is elsewhere, with the same concern.

The only other place where I can find "packets" being used is in relation to RTP/RTCP, and as far as I know we always talk about "RTP packets" and "RTCP packets", don't we?

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 15 Jun 2015 14:52:51 -0400

> The only other place where I can find "packets" being used is in relation to RTP/RTCP, and as far as I know we always talk about "RTP packets" and "RTCP packets", don't we?

It also is used at least in the prior (old) paragraph of this section. 
The change you propose would work throughout this section.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Jun 2015 19:12:37 +0000

Hi,

>> The only other place where I can find "packets" being used is in relation to 
>> RTP/RTCP, and as far as I know we always talk about "RTP packets" and "RTCP packets", don't we?
>

Correct, I'll change all instances in that section.

Thanks!

Regards,

Christer