Subject: [MMUSIC] I-D Action: draft-ietf-mmusic-ice-dualstack-fairness-01.txt

From: [email-masked]
Date: Mon, 22 Jun 2015 05:06:44 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

        Title           : ICE Multihomed and IPv4/IPv6 Dual Stack Fairness
        Authors         : Paal-Erik Martinsen
                          Tirumaleswar Reddy
                          Prashanth Patil
	Filename        : draft-ietf-mmusic-ice-dualstack-fairness-01.txt
	Pages           : 8
	Date            : 2015-06-22

Abstract:
   This document provides guidelines on how to make Interactive
   Connectivity Establishment (ICE) conclude faster in multihomed and
   IPv4/IPv6 dual-stack scenarios where broken paths exist.  The
   provided guidelines are backwards compatible with the original ICE
   specification.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mmusic-ice-dualstack-fairness/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-mmusic-ice-dualstack-fairness-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-ice-dualstack-fairness-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Tue, 23 Jun 2015 08:49:29 +0000

Hi,

This is a small update to reflect the feedback from both on list and off list reviewers.
Thanks to Dan Wing and Ole Trøan for review and comments.

The diffs:
- Tried to incorporate the multi-homed text more into the various sections.
- Added some text to the introduction explaining it is up to the agent to choose the active candidate pair. This document does not alter that.
- Tried to reword the multi-homed section to be somewhat clearer in the sense of what kind of multihoming we are talking about. I do not want to go into detail what other types of multihoming there is, but just want to make sure if a person that knows “a lot of” multihoming stuff will not get confused (and angry).
- Added some text about the timings introduced in happy eyeballs are not appropriate for ICE.
- Added text from ICE RFC stating when the local_preference must be unique.
- Added a few new spelling errors. *sigh* (Why do I always notice them when I read the submitted version?)

The core of the draft is still:
- Take care if you are multihomed. You can optimise a bit if you want.
- Take care if you are dual-stacked. Some optimisation might be handy if you have a lot of v6 addresses.
- It is safe to play with the local_preference value. A lot of text explaining why. (It is all in the ICE spec)

The authors have no remaining issues. But a few more reviews would benefit the draft.
(Pull requests are welcome at https://github.com/Draft-Mafia/ICE-DualStackFairness)

.-.
Pål-Erik

On 22 Jun 2015, at 14:06, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic