Subject: [MMUSIC] New draft: draft-holmberg-mmusic-sdp-dtls-00

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Jun 2015 16:30:42 +0000

Hi DTLS lovers,

We have put together the initial version of a draft that defines the SDP Offer/Answer procedures for DTLS, putting much focus on the criteria and procedures associated with re-establishment of a DTLS association - when and how it can be done.

The issue initially came up during the SCTP-SDP discussions, and the idea was to address it in the SCTP-SDP draft. However, as the issue is general, we decided to write a separate draft, which DTLS usage specifications then can refer.

There is still work to do, but we wanted to submit the initial version as soon as possible, in order to have list discussions etc before Prague.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Jun 2015 17:58:29 +0000

And the document link:

https://tools.ietf.org/id/draft-holmberg-mmusic-sdp-dtls-00.txt

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 15 June 2015 19:31
To: mmusic
Cc: [email-masked]
Subject: [MMUSIC] New draft: draft-holmberg-mmusic-sdp-dtls-00

Hi DTLS lovers,

Regards,

Christer

---

From: "GUBALLA, JENS (JENS)" <[email-masked]>
Date: Wed, 17 Jun 2015 13:06:21 +0000

Hi Christer,

Especially regarding section 4:

What is described as "re-establishment" always implies changing the local
transport address and creating a new DTLS association. Thus there are two
distinct DTLS associations involved here, and thus "re-establishment of a
DTLS association" is misleading, IMO.

It might be better to say: "establishment of a new DTLS association which is
associated to the same/existing multimedia session".

Best regards,
Jens

> -----Original Message-----
> Sent: Montag, 15. Juni 2015 19:58
> To: mmusic
> Subject: Re: [MMUSIC] New draft: draft-holmberg-mmusic-sdp-dtls-00
> 
> And the document link:
> 
> 
> 
> We have put together the initial version of a draft that defines the SDP
> Offer/Answer procedures for DTLS, putting much focus on the criteria and
> procedures associated with re-establishment of a DTLS association - when
and
> how it can be done.
> 
> 
> 
> The issue initially came up during the SCTP-SDP discussions, and the idea
was
> to address it in the SCTP-SDP draft. However, as the issue is general, we
> decided to write a separate draft, which DTLS usage specifications then
can
> refer.
> 
> 
> 
> There is still work to do, but we wanted to submit the initial version as
soon
> as possible, in order to have list discussions etc before Prague.
> 
> 
> 
> Regards,
> 
> 
> 
> Christer

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 17 Jun 2015 13:17:57 +0000

Hi Jens,

> associated to the same/existing multimedia session".

I can do that.

Regards,

Christer

and
was
can
soon