Subject: [MMUSIC] Draft new version: .draft-holmberg-mmusic-4572-update-01

From: Christer Holmberg <[email-masked]>
Date: Mon, 21 Mar 2016 14:43:40 +0000

Hi,

I've submitted a new version (-01) of draft-holmberg-mmusic-4572-update.

The draft updates RFC 4572 in the following ways:

-          Defines the usage of multiple fingerprint attributes, for 1) providing fingerprints for multiple certificates and 2) providing multiple fingerprints (using different hash algorithms) for a single certificiate

-          Removes the requirement saying that the same hash algorithm that was used to calculated the certificate signature must also be used to calculate the certificate fingerprint

-          Updates the preferred cipher suite from SHA-1 to SHA-256 (to be aligned with DTLS).

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 21 Mar 2016 13:25:09 -0400

I am still struggling to precisely understand the threat you are trying 
to address with this change, and then how the change is expected to work.

Clearly both ends must understand the hash used in the certificate. The 
original requirement that the fingerprint use the same hash was intended 
so that no *additional* hashes had to be *mutually* understood by both ends.

IIUC you are concerned because someone might want to use a cert with a 
weak hash, but want to have a stronger hash for the fingerprint.

But that introduces something else that both ends have to mutually agree 
to. If both ends can be assumed to support a stronger hash for the 
fingerprint, why not for the cert too?

Allowing multiple fingerprints, using different hashes, for the same 
cert implies that there isn't an assumption of complete mutual 
agreement. But then presumably with multiple fingerprints, some will be 
stronger than others. Doesn't that introduce the possibility of a 
downgrade attack?

[Note: this is more addressed to Martin than to Christer. On this 
subject I think Christer is simply trying to channel Martin.]

     Thanks,
     Paul

On 3/21/16 10:43 AM, Christer Holmberg wrote:
> Hi,
>
> I’ve submitted a new version (-01) of draft-holmberg-mmusic-4572-update.
>
> -Defines the usage of multiple fingerprint attributes, for 1) providing
> fingerprints for multiple certificates and 2) providing multiple
> fingerprints (using different hash algorithms) for a single certificiate
>
> -Removes the requirement saying that the same hash algorithm that was
> used to calculated the certificate signature must also be used to
> calculate the certificate fingerprint
>
> -Updates the preferred cipher suite from SHA-1 to SHA-256 (to be aligned
> with DTLS).
>
> Regards,
>
> Christer
>
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>