Subject: [MMUSIC] Posted I-D on RTP failover

From: Martin Taylor <[email-masked]>
Date: Wed, 2 Mar 2016 18:20:19 +0000

I recently posted draft-taylor-mmusic-rtp-failover-problem-00.txt.  This offers a problem statement around RTP failover.  The TL;DR summary:

- VoIP networks typically contain network functions that terminate large numbers of RTP streams, such as session border controllers and conference bridges.

- Service providers typically require that such network functions have no single points of failure that could cause large numbers of media streams to be interrupted for more than a second or two.

- The usual solution for this is to deploy such network functions as an active / standby pair with a service IP address that can be moved between members of the pair, for example with the aid of a gratuitous ARP, in a manner analagous to VRRP.

- This solution suffers from a number of drawbacks including inefficient use of hardware resources and inability to deploy in environments where it is impractical to connect active and standby instances to the same L2 segment.  These drawbacks are causing network operators particular concern in network function virtualization environments.

We plan to propose a solution to the problem in another I-D, but would much appreciate any input from mmusic participants on the problem statement.  In particular, it would be interesting to hear if anyone feels that RTP over SCTP, with multi-homing, already provides a proven and satisfactory solution to the problem.

Martin

---

From: Simon Perreault <[email-masked]>
Date: Wed, 2 Mar 2016 16:30:59 -0500

Two other potential solutions that I feel are missing from your analysis:

- Multipath RTP
<https://tools.ietf.org/html/draft-ietf-avtcore-mprtp-01>

- ICE continuous nomination
<https://tools.ietf.org/html/draft-uberti-mmusic-nombis-00>

Simon

Le 2016-03-02 13:20, Martin Taylor a écrit :
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Martin Taylor <[email-masked]>
Date: Thu, 3 Mar 2016 09:25:31 +0000

Simon

Thank you very much for this extremely helpful suggestion.  The Multipath RTP draft proposes an approach which is very well aligned with what we had in mind for a solution.   It's a pity that the draft has expired.  I will try and bring avtcore into this discussion.

Martin

-----Original Message-----
From: Simon Perreault [mailto:[email-masked]] 
Sent: 02 March 2016 21:31
To: Martin Taylor <[email-masked]>; [email-masked]
Subject: Re: [MMUSIC] Posted I-D on RTP failover

- Multipath RTP

Simon