Subject: [MMUSIC] Bundle and "m=" line terminology [Re: Review of draft-ietf-mmusic-sdp-bundle-negotiation-32 (Part I)]

From: Flemming Andreasen <[email-masked]>
Date: Thu, 3 Nov 2016 23:31:52 -0400

Christer reminded me to pick up the part below:

On 10/3/16 10:00 AM, Eric Rescorla wrote:
>
>
> On Mon, Oct 3, 2016 at 4:01 AM, Christer Holmberg 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
<snip>
>
>         >S 10.3.1.1.
>
>         >   When an offerer generates an initial offer, the offerer MUST
>
>         >   associate either an SDP 'rtcp-mux' attribute [RFC5761] or
>         an SDP
>
>         >   'rtcp-mux-only' attribute [I-D.ietf-mmusic-mux-exclusive]
>         with each
>
>         >   bundled RTP-based "m=" line in the offer.  The offerer MUST
>         associate
>
>         >   an SDP 'rtcp-mux-only' attribute with each bundle-only "m="
>         line.  If
>
>         >   the offerer associates a 'rtcp-mux-only' attribute with an
>         "m=" line,
>
>         >   the offerer may also associate a 'rtcp-mux' attribute with
>         the same
>
>         >   "m=" line, as described in [I-D.ietf-mmusic-mux-exclusive].
>
>         >
>
>         > This is a particularly egregious case of associate disease
>         that could
>
>         > be easily solved by using "add" when referring to the attributes
>
>         > you put in the m= section.
>
>         People have previously said that you don’t “add” attributes to
>         m- lines: you add port values etc, but not attributes.
>
>         This is an example of where I’ve had to re-write big parts of
>         the documents a number of times already, because every time
>         someone else reads the document he/she is not happy with the
>         terminology. I just don’t want to do it again.
>
>
>     The terminology that JSEP uses is that "m= sections" include
>     attribute lines.
>
>     I think this is a lot clearer.
>
>      I don’t personally disagree, but there are people that have had
>     other opinions.
>
>      In general I think it would be really useful to have
>     common terminology in BUNDLE and JSEP, but I don’t want to
>     re-write the document once again, and then later be told to do it
>     again…
>
>
> Resolving the appropriate terminology seems like a chair issue.
>
RFC 4566 (SDP) Section 5 makes it pretty clear that a Media Description 
consists of an "m=" line optionally followed by a number of other lines 
(typically attribute lines). In other words, an "m=" line and a media 
description is generally not synonymous.

Earlier versions of bundle did not reflect that distinction properly, 
and about a year ago, I asked for the terminology to be aligned with RFC 
4566. There were a few off-list comments from other people that agreed 
with that view and the draft got updated accordingly (as of -24). That 
is what the current bundle draft does and I continue to believe that is 
what it should do.

Thanks

-- Flemming (with chair hat on)

> -Ekr
>
>
>     Regards,
>
>     Christer
>
>
>
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 6 Nov 2016 10:01:53 -0800

On Thu, Nov 3, 2016 at 8:31 PM, Flemming Andreasen <[email-masked]>
wrote:

> On Mon, Oct 3, 2016 at 4:01 AM, Christer Holmberg <
> [email-masked]> wrote:
>
> <snip>
>
> >S 10.3.1.1.
>>>
>>> >   associate either an SDP 'rtcp-mux' attribute [RFC5761] or an SDP
>>>
>>> >   'rtcp-mux-only' attribute [I-D.ietf-mmusic-mux-exclusive] with each
>>>
>>> >   bundled RTP-based "m=" line in the offer.  The offerer MUST associate
>>>
>>> >   an SDP 'rtcp-mux-only' attribute with each bundle-only "m=" line.  If
>>>
>>> >   the offerer associates a 'rtcp-mux-only' attribute with an "m=" line,
>>>
>>> >   the offerer may also associate a 'rtcp-mux' attribute with the same
>>>
>>> > This is a particularly egregious case of associate disease that could
>>>
>>> People have previously said that you don’t “add” attributes to m- lines:
>>> you add port values etc, but not attributes.
>>>
>>>
>>>
>>> This is an example of where I’ve had to re-write big parts of the
>>> documents a number of times already, because every time someone else reads
>>> the document he/she is not happy with the terminology. I just don’t want to
>>> do it again.
>>>
>>
>> The terminology that JSEP uses is that "m= sections" include attribute
>> lines.
>>
>>  I don’t personally disagree, but there are people that have had other
>> opinions.
>>
>>  In general I think it would be really useful to have common terminology
>> in BUNDLE and JSEP, but I don’t want to re-write the document once again,
>> and then later be told to do it again…
>>
>
> Earlier versions of bundle did not reflect that distinction properly, and
> about a year ago, I asked for the terminology to be aligned with RFC 4566.
> There were a few off-list comments from other people that agreed with that
> view and the draft got updated accordingly (as of -24). That is what the
> current bundle draft does and I continue to believe that is what it should
> do.
>

This message leaves me extremely puzzled because I'm not saying otherwise,
and that's why JSEP uses "m= section" for this concept. Media description
would also be fine. What is problematic is the use of "associated with an
m= line" to mean "part of a media description" or "part of an m= section".
That text is extremely confusing, especially when the word "associated" is
used in a number of other concepts. So, what I'm asking for is one of the
alternative terms I list here.

-Ekr

> mmusic mailing [email-masked]://www.ietf.org/mailman/listinfo/mmusic
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 7 Nov 2016 09:52:42 +0000

Hi,

As Ekr said, the issue is not “m= line” versus “media description”. It’s more whether e.g., an SDP attribute belongs to a media description, is within a media description, or is associated with a media description/m- line.

The reason I use “associated” is because I have many times been told that an attribute is not part of a media description/m- line (compared to e.g., the port and proto value).

Regards,

Christer

From: Eric Rescorla <[email-masked]<mailto:[email-masked]>>
Date: Sunday 6 November 2016 at 21:01
To: Flemming Andreasen <[email-masked]<mailto:[email-masked]>>
Cc: Christer Holmberg <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Bundle and "m=" line terminology [Re: [MMUSIC] Review of draft-ietf-mmusic-sdp-bundle-negotiation-32 (Part I)]

On Thu, Nov 3, 2016 at 8:31 PM, Flemming Andreasen <[email-masked]<mailto:[email-masked]>> wrote:

On Mon, Oct 3, 2016 at 4:01 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

<snip>
> you put in the m= section.

People have previously said that you don’t “add” attributes to m- lines: you add port values etc, but not attributes.

This is an example of where I’ve had to re-write big parts of the documents a number of times already, because every time someone else reads the document he/she is not happy with the terminology. I just don’t want to do it again.

The terminology that JSEP uses is that "m= sections" include attribute lines.

 I don’t personally disagree, but there are people that have had other opinions.

 In general I think it would be really useful to have common terminology in BUNDLE and JSEP, but I don’t want to re-write the document once again, and then later be told to do it again…

RFC 4566 (SDP) Section 5 makes it pretty clear that a Media Description consists of an "m=" line optionally followed by a number of other lines (typically attribute lines). In other words, an "m=" line and a media description is generally not synonymous.

Earlier versions of bundle did not reflect that distinction properly, and about a year ago, I asked for the terminology to be aligned with RFC 4566. There were a few off-list comments from other people that agreed with that view and the draft got updated accordingly (as of -24). That is what the current bundle draft does and I continue to believe that is what it should do.

This message leaves me extremely puzzled because I'm not saying otherwise, and that's why JSEP uses "m= section" for this concept. Media description would also be fine. What is problematic is the use of "associated with an m= line" to mean "part of a media description" or "part of an m= section". That text is extremely confusing, especially when the word "associated" is used in a number of other concepts. So, what I'm asking for is one of the alternative terms I list here.

-Ekr

Thanks

-Ekr

Regards,

Christer

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/mmusic

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 7 Nov 2016 08:08:36 -0800

On Mon, Nov 7, 2016 at 1:52 AM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> As Ekr said, the issue is not “m= line” versus “media description”. It’s
> more whether e.g., an SDP attribute belongs to a media description, is
> within a media description, or is associated with a media description/m-
> line.
>
> The reason I use “associated” is because I have many times been told that
> an attribute is not part of a media description/m- line (compared to e.g.,
> the port and proto value).
>

I had understood the difference between m= line and media description to
precisely be that the media description contained the attributes and the m=
line did not.

-Ekr

> Regards,
>
> Christer
>
> From: Eric Rescorla <[email-masked]>
> To: Flemming Andreasen <[email-masked]>
> Cc: Christer Holmberg <[email-masked]>, "[email-masked]"
> <[email-masked]>
> Subject: Re: Bundle and "m=" line terminology [Re: [MMUSIC] Review of
> draft-ietf-mmusic-sdp-bundle-negotiation-32 (Part I)]
>
>
>
>>>> People have previously said that you don’t “add” attributes to m-
>>>> lines: you add port values etc, but not attributes.
>>>>
>>>>
>>>>

---

From: Flemming Andreasen <[email-masked]>
Date: Mon, 7 Nov 2016 11:43:49 -0500

On 11/7/16 11:08 AM, Eric Rescorla wrote:
>
>
> On Mon, Nov 7, 2016 at 1:52 AM, Christer Holmberg 
>     As Ekr said, the issue is not “m= line” versus “media
>     description”. It’s more whether e.g., an SDP attribute belongs to
>     a media description, is within a media description, or is
>     associated with a media description/m- line.
>
>     The reason I use “associated” is because I have many times been
>     told that an attribute is not part of a media description/m- line
>     (compared to e.g., the port and proto value).
>
>
An attribute can indeed be part of a media description, however it 
cannot be part of an "m=" line.

> I had understood the difference between m= line and media description 
> to precisely be that the media description contained the attributes 
> and the m= line did not.
>
Exactly.

-- Flemming

> -Ekr
>
>     Regards,
>
>     Christer
>
>     From: Eric Rescorla <[email-masked] <mailto:[email-masked]>>
>     Cc: Christer Holmberg <[email-masked]
>     <mailto:[email-masked]>>, "[email-masked]
>     <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>     Subject: Re: Bundle and "m=" line terminology [Re: [MMUSIC] Review
>     of draft-ietf-mmusic-sdp-bundle-negotiation-32 (Part I)]
>
>
>
>     On Thu, Nov 3, 2016 at 8:31 PM, Flemming Andreasen
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>
>>                 > 'rtcp-mux-only' attribute
>>                 [I-D.ietf-mmusic-mux-exclusive] with each
>>
>>                 People have previously said that you don’t “add”
>>                 attributes to m- lines: you add port values etc, but
>>                 not attributes.
>>
>>                 This is an example of where I’ve had to re-write big
>>                 parts of the documents a number of times already,
>>                 because every time someone else reads the document
>>                 he/she is not happy with the terminology. I just
>>                 don’t want to do it again.
>>
>>
>>             common terminology in BUNDLE and JSEP, but I don’t want
>>             to re-write the document once again, and then later be
>>             told to do it again…
>>
>>
>         RFC 4566 (SDP) Section 5 makes it pretty clear that a Media
>         Description consists of an "m=" line optionally followed by a
>         number of other lines (typically attribute lines). In other
>         words, an "m=" line and a media description is generally not
>         synonymous.
>
>         Earlier versions of bundle did not reflect that distinction
>         properly, and about a year ago, I asked for the terminology to
>         be aligned with RFC 4566. There were a few off-list comments
>         from other people that agreed with that view and the draft got
>         updated accordingly (as of -24). That is what the current
>         bundle draft does and I continue to believe that is what it
>         should do.
>
>
>     This message leaves me extremely puzzled because I'm not saying
>     otherwise, and that's why JSEP uses "m= section" for this concept.
>     Media description would also be fine. What is problematic is the
>     use of "associated with an m= line" to mean "part of a media
>     description" or "part of an m= section". That text is extremely
>     confusing, especially when the word "associated" is used in a
>     number of other concepts. So, what I'm asking for is one of the
>>         <mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/mmusic
>>         <https://www.ietf.org/mailman/listinfo/mmusic>
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 7 Nov 2016 18:33:03 +0000

Hi,

An attribute can indeed be part of a media description, however it cannot be part of an "m=" line.

I had understood the difference between m= line and media description to precisely be that the media description contained the attributes and the m= line did not.

Exactly.

I have no problem with that, but I am pretty sure I have seen drafts that say things like “media description (m= line)”.

Regards,

Christer

-- Flemming

-Ekr

Regards,

Christer

-Ekr

Thanks

-Ekr

Regards,

Christer

mmusic mailing list