Subject: [MMUSIC] RFC5576 support in draft-ietf-mmusic-sdp-simulcast-06

From: "Roni Even" <[email-masked]>
Date: Wed, 2 Nov 2016 20:07:08 +0200

Hi,

I noticed that section 5 state that "It is possible, but not required to use
source-specific signaling [RFC5576 <https://tools.ietf.org/html/rfc5576> ]
with the proposed solution."
 
I was wondering what does it mean since if I try to add a=ssrc   to the
example in 6.6.1, there will be two a=sscr:xxx cname:[email-masked]
and a=sscr:yyy canme:[email-masked] but it is not clear which ssrc is
the HD and which is the thumbnail
 
Roni

---

From: Adam Roach <[email-masked]>
Date: Wed, 2 Nov 2016 14:59:44 -0500

On 11/2/16 13:07, Roni Even wrote:
>
> Hi,
>
> I noticed that section 5 state that “It is possible, but not required 
> to use source-specific signaling [RFC5576 
> <https://tools.ietf.org/html/rfc5576>] with the proposed solution.”
> I was wondering what does it mean since if I try to add a=ssrc   to 
> the example in 6.6.1, there will be two a=sscr:xxx 
> cname:[email-masked] and a=sscr:yyy canme:[email-masked] 
> but it is not clear which ssrc is the HD and which is the thumbnail

That's what RID is for.

/a

---

From: "Roni Even" <[email-masked]>
Date: Thu, 3 Nov 2016 18:11:53 +0200

Hi,

I am not sure how rid allows you to define an SSRC in the SDP and know in the SDP which SSRC is tied to each RTP payload subtype number explicitly.

Roni

From: Adam Roach [mailto:[email-masked]] 
Sent: Wednesday, November 02, 2016 10:00 PM
To: Roni Even; [email-masked]
Subject: Re: [MMUSIC] RFC5576 support in draft-ietf-mmusic-sdp-simulcast-06

Hi,

I noticed that section 5 state that “It is possible, but not required to use source-specific signaling [RFC5576 <https://tools.ietf.org/html/rfc5576> ] with the proposed solution.”
 
I was wondering what does it mean since if I try to add a=ssrc   to the example in 6.6.1, there will be two a=sscr:xxx cname:[email-masked] and a=sscr:yyy canme:[email-masked] but it is not clear which ssrc is the HD and which is the thumbnail

That's what RID is for.

/a

---

From: Bo Burman <[email-masked]>
Date: Tue, 8 Nov 2016 13:29:58 +0000

Hi Roni,

When would it be necessary to use “a=ssrc” to associate an SSRC with a particular simulcast stream already on SDP level?

Whenever the first RTCP SR is sent for a simulcast stream, it will contain both the SSRC reported on and an RtpStreamId SDES item, which uniquely associates that SSRC to an “a=rid” line. If the RTP SDES header extension is used, RtpStreamId can also be in RTP header extensions. Both methods should allow making this SSRC-to-RtpStreamId association before or at reception of the first RTP packet.

What “it is possible, but not required to use source-specific signaling” meant to say was that use of “a=ssrc” is not needed for use with “a=simulcast” (or “a=rid”), but also not conflicting with other (non-simulcast-related) usages of “a=ssrc”.

If you really want to use a static “a=ssrc” to RtpStreamId mapping in SDP, you can use a 1:1 mapping between RTP payload type and RtpStreamId (not same value, but a 1:1 mapping). It should, for example, be possible to use an SDP like:

a=ssrc:<x> cname:<c>
a=ssrc:<x> fmtp:<p>
a=rid:<r> pt=<p>

If “a=rid” was to be defined as source-level attribute (which it currently is not), you could maybe also use:
a=ssrc:<x> cname:<c>
a=ssrc:<x> rid:<r>
a=rid:<r> …

Cheers,
/Bo

From: mmusic [mailto:[email-masked]] On Behalf Of Roni Even
Sent: den 3 november 2016 17:12
To: 'Adam Roach' <[email-masked]>; [email-masked]
Subject: Re: [MMUSIC] RFC5576 support in draft-ietf-mmusic-sdp-simulcast-06

Hi,

From: Adam Roach [mailto:[email-masked]]
Sent: Wednesday, November 02, 2016 10:00 PM
To: Roni Even; [email-masked]<mailto:[email-masked]>
Subject: Re: [MMUSIC] RFC5576 support in draft-ietf-mmusic-sdp-simulcast-06

I noticed that section 5 state that “It is possible, but not required to use source-specific signaling [RFC5576<https://tools.ietf.org/html/rfc5576>] with the proposed solution.”

I was wondering what does it mean since if I try to add a=ssrc   to the example in 6.6.1, there will be two a=sscr:xxx cname:[email-masked]<mailto:cname:[email-masked]> and a=sscr:yyy canme:[email-masked]<mailto:canme:[email-masked]> but it is not clear which ssrc is the HD and which is the thumbnail

That's what RID is for.

/a

---

From: "Roni Even" <[email-masked]>
Date: Wed, 16 Nov 2016 04:42:56 +0200

Hi Bo,

Are you sure it is allowed to use a=ssrc:<x> fmtp:<p> without any format specific parameters?

Roni

From: Bo Burman [mailto:[email-masked]] 
Sent: Tuesday, November 08, 2016 3:30 PM
To: Roni Even; 'Adam Roach'; [email-masked]
Subject: RE: [MMUSIC] RFC5576 support in draft-ietf-mmusic-sdp-simulcast-06

Hi Roni,

a=ssrc:<x> cname:<c>

a=ssrc:<x> fmtp:<p>

a=rid:<r> pt=<p>

a=ssrc:<x> cname:<c>

a=ssrc:<x> rid:<r>

a=rid:<r> …

Cheers,

/Bo

Hi,

Roni

Hi,

That's what RID is for.

/a

---

From: Bo Burman <[email-masked]>
Date: Wed, 16 Nov 2016 10:36:56 +0000

Hi Roni,

I thought it was, but when looking a bit more closely it is clear that it is not allowed.
It would still be possible to use source-specific signaling and simulcast independently from one another, but it would not be possible to tell from the SDP which SSRC a specific simulcast stream will have. As said, one way to solve that could be to define source-specific usage of a=rid.

/Bo

From: Roni Even [mailto:[email-masked]]
Sent: den 16 november 2016 11:43
To: Bo Burman <[email-masked]>; 'Adam Roach' <[email-masked]>; [email-masked]
Subject: RE: [MMUSIC] RFC5576 support in draft-ietf-mmusic-sdp-simulcast-06

Hi Bo,

From: Bo Burman [mailto:[email-masked]]
Sent: Tuesday, November 08, 2016 3:30 PM
To: Roni Even; 'Adam Roach'; [email-masked]<mailto:[email-masked]>
Subject: RE: [MMUSIC] RFC5576 support in draft-ietf-mmusic-sdp-simulcast-06

Hi Roni,

a=ssrc:<x> cname:<c>
a=ssrc:<x> fmtp:<p>
a=rid:<r> pt=<p>

Cheers,
/Bo

From: mmusic [mailto:[email-masked]] On Behalf Of Roni Even
Sent: den 3 november 2016 17:12
To: 'Adam Roach' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [MMUSIC] RFC5576 support in draft-ietf-mmusic-sdp-simulcast-06

Hi,

That's what RID is for.

/a

---

From: "Roni Even" <[email-masked]>
Date: Wed, 16 Nov 2016 23:27:53 +0200

Hi Bo,

You can define rid usage but in my view this is a general problem of using ssrc attribute when there is more than one simultaneous stream in an m-line section. So maybe it should be addressed in an update to RFC5576 as a general solution.

Roni

From: Bo Burman [mailto:[email-masked]] 
Sent: Wednesday, November 16, 2016 12:37 PM
To: Roni Even; 'Adam Roach'; [email-masked]
Subject: RE: [MMUSIC] RFC5576 support in draft-ietf-mmusic-sdp-simulcast-06

Hi Roni,

/Bo

Hi Bo,

Roni

Hi Roni,

a=ssrc:<x> cname:<c>

a=ssrc:<x> fmtp:<p>

a=rid:<r> pt=<p>

a=ssrc:<x> cname:<c>

a=ssrc:<x> rid:<r>

a=rid:<r> …

Cheers,

/Bo

Hi,

Roni

Hi,

That's what RID is for.

/a

---

From: Bo Burman <[email-masked]>
Date: Thu, 17 Nov 2016 01:14:36 +0000

Yes, that would also work.

From: Roni Even [mailto:[email-masked]]
Sent: den 17 november 2016 06:28
To: Bo Burman <[email-masked]>; 'Adam Roach' <[email-masked]>; [email-masked]
Subject: RE: [MMUSIC] RFC5576 support in draft-ietf-mmusic-sdp-simulcast-06

Hi Bo,

Hi Roni,

/Bo

From: Roni Even [mailto:[email-masked]]
Sent: den 16 november 2016 11:43
To: Bo Burman <[email-masked]<mailto:[email-masked]>>; 'Adam Roach' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [MMUSIC] RFC5576 support in draft-ietf-mmusic-sdp-simulcast-06

Hi Bo,

Hi Roni,

a=ssrc:<x> cname:<c>
a=ssrc:<x> fmtp:<p>
a=rid:<r> pt=<p>

Cheers,
/Bo

Hi,

That's what RID is for.

/a