Subject: Re: [MMUSIC] New Version Notification for draft-ietf-mmusic-trickle-ice-sip-06.txt

From: Christer Holmberg <[email-masked]>
Date: Wed, 2 Nov 2016 08:56:40 +0000

Hi,

Thanks for taking my comments into consideration.

However, ³currently used² is probably not good wording, because it¹s
unclear what ³used² means. Most would probably think it means you are
currently sending data using those candidates, which is not the case. So
³active², or something similar, would probably be better.

Having said that, my preference and suggestion is still that the INFOs
only contain the NEW candidates.

Regards,

Christer

On 01/11/16 00:03, "mmusic on behalf of Thomas Stach"
<[email-masked] on behalf of [email-masked]> wrote:

>All,
>
>changes from draft-ietf-mmusic-trickle-ice-sip-05 include the following:
>
>    o  considered further comments from Christer Holmberg
>
>    o  editorial comments on section 3 addressed
>
>    o  moved section 3.1 to section 10.1 and applied some edits
>
>    o  replaced the term "previously sent candidates" with "currently
>       known and used candidates".
>
>Regards
>Thomas
>
>
>On 2016-10-31 23:01, [email-masked] wrote:
>> A new version of I-D, draft-ietf-mmusic-trickle-ice-sip-06.txt
>> has been successfully submitted by Thomas Stach and posted to the
>> IETF repository.
>>
>> Name:		draft-ietf-mmusic-trickle-ice-sip
>> Revision:	06
>> Title:		A Session Initiation Protocol (SIP) usage for Trickle ICE
>> Document date:	2016-10-31
>> Group:		mmusic
>> Pages:		38
>> URL:            
>>https://www.ietf.org/internet-drafts/draft-ietf-mmusic-trickle-ice-sip-06
>>.txt
>> Status:         
>>https://datatracker.ietf.org/doc/draft-ietf-mmusic-trickle-ice-sip/
>> Htmlized:       
>>https://tools.ietf.org/html/draft-ietf-mmusic-trickle-ice-sip-06
>> Diff:           
>>https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-trickle-ice-sip-06
>>
>> Abstract:
>>     The Interactive Connectivity Establishment (ICE) protocol describes
>>a
>>     Network Address Translator (NAT) traversal mechanism for UDP-based
>>     multimedia sessions established with the Offer/Answer model.  The
>>ICE
>>     extension for Incremental Provisioning of Candidates (Trickle ICE)
>>     defines a mechanism that allows ICE agents to shorten session
>>     establishment delays by making the candidate gathering and
>>     connectivity checking phases of ICE non-blocking and by executing
>>     them in parallel.
>>
>>     This document defines usage semantics for Trickle ICE with the
>>     Session Initiation Protocol (SIP).
>>
>>                 
>>           
>>
>>
>> Please note that it may take a couple of minutes from the time of
>>submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> The IETF Secretariat
>>
>
>_______________________________________________
>mmusic mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mmusic

---

From: Emil Ivov <[email-masked]>
Date: Mon, 7 Nov 2016 08:14:34 -0600

Hey Christer,

> only contain the NEW candidates.

Given the complexity of this draft, the very low amount of cycles the 
authors seem to have for it and how I personally don't see this solving 
a non-trivial problem then I'd strongly object to making such a major 
change so late in the life cycle of this draft.

(weren't you the one that actually suggested cumulative sending of 
candidates back in the day by the way? :) )

Emil

-- 
https://jitsi.org

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 7 Nov 2016 18:35:27 +0000

Hi,

>> However, "currently used" is probably not good wording, because it¹s 
>> currently sending data using those candidates, which is not the case. 
>> So "active", or something similar, would probably be better.
>>
> Given the complexity of this draft, the very low amount of cycles the authors seem to have
> for it and how I personally don't see this solving a non-trivial problem then I'd strongly object
> to making such a major change so late in the life cycle of this draft.

But, then the draft needs to be very clear on the semantics of the candidates included - and what it means if an active candidate for whatever reason is NOT included. 

> (weren't you the one that actually suggested cumulative sending of candidates back in the day by the way? :) )

I could be wrong, but I doubt that :)

Regards,

Christer

>>>     The Interactive Connectivity Establishment (ICE) protocol 
>>> describes a
>>>     multimedia sessions established with the Offer/Answer model.  
>>> The ICE
>>> submission until the htmlized version and diff are available at 
>>> tools.ietf.org.
>>>
>>> The IETF Secretariat
>>>
>>

--
https://jitsi.org