Subject: [MMUSIC] ICE-SIP-SDP and RFC6544

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 13 Mar 2017 01:53:27 -0700

Adam raised a valid point on the scope of RFC6544 in the context of
ice-sip-sdp.

We the authors did consider couple of options and would like the WG's
inputs to decide the next steps

1. Merge in RFC6544 into ice-sip-sdp and ice-bis
   This includes bringing in appropriate text from rfc6544 into ice-bis for
ice processing detail and ice-sip-sdp for candidate encoding + offer/answer
specifics

2. RFC6544bis
   Do a bis version of RFC6544 and make it refer to ICE-BIS and ICE-SIP-SDP
wherever appropriate.

3. Any other option ?

We prefer option 2 given the magnitude of RFC6544 merge plan , but are open
to suggestions from either or a new option altogether

please advise.

Cheers
Suhas

---

From: Roman Shpount <[email-masked]>
Date: Mon, 13 Mar 2017 14:54:01 -0400

It would probably be a good idea to have RFC6544bis. We can also use this
draft to define TLS ICE candidates.

One question I wanted to ask is do we need to maintain the same scope to
ICE TCP candidates? Do we really need simultaneous open TCP candidates? Are
there any plans of using TCP candidates to directly connection two end
points behind NAT or is it only going to be used in scenarios where one of
the end points is on the public IP? I think based on current usage patterns
RFC 6544 can be greatly simplified.

Regards,

_____________
Roman Shpount

On Mon, Mar 13, 2017 at 4:53 AM, Suhas Nandakumar <[email-masked]>
wrote:

>    This includes bringing in appropriate text from rfc6544 into ice-bis
> for ice processing detail and ice-sip-sdp for candidate encoding +
> offer/answer specifics
>
> 2. RFC6544bis
>    Do a bis version of RFC6544 and make it refer to ICE-BIS and
> ICE-SIP-SDP wherever appropriate.
>
> 3. Any other option ?
>
> We prefer option 2 given the magnitude of RFC6544 merge plan , but are
> open to suggestions from either or a new option altogether
>
> please advise.
>
>
> Cheers
> Suhas
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>