Subject: Re: [MMUSIC] Mirja Kühlewind's Discuss on draft-ietf-mmusic-sctp-sdp-23: (with DISCUSS)

From: "Ben Campbell" <[email-masked]>
Date: Wed, 01 Mar 2017 20:57:43 -0600

Hi all,

It seems like this conversation has not completed. What do we need to 
get to closure?

A few thoughts of my own:

- I'm not adverse to making non-ICE implementors look at the ICE specs 
for framing information, as long as the citations are precise enough 
that they don't need to read the entirety of ICE. (And the information 
is really there.)

- I am adverse to repeating normative text. I'm okay with adding 
informational text about non-ICE usage, as long as it is general enough 
to avoid confusion about where the authoritative text resides.

- If people think that ICE is not sufficiently specified, we can work on 
that. But I don't think the burden of doing that belongs to this draft.

- The draft is in fact IESG approved in its current state. Material 
changes should be kept to the minimum.

On 27 Feb 2017, at 7:06, Christer Holmberg wrote:

> Hi,
>
> ...
>
>> Also I¹m not sure if the ICE part is fully specified. In your 
>> previously
>> mail you wrote
>>
>> "As far as TCP/DTLS/SCTP transport tag is concerned, please note that 
>> ICE
>> end points are supposed to send a re-INVITE after nomination process 
>> is
>> completed with the selected candidate address in the m= line. So, if 
>> tcp
>> candidate is selected, re-INVITE must be sent with TCP/DTLS/SCTP
>> transport tag in the m= line. Also, any offers/answers after the ICE
>> nomination is complete, are supposed to send the currently selected
>> candidate in the m= line, which will also be TCP/DTLS/SCTP in case 
>> tcp
>> candidate is selected.³
>>
>> From what I understood from ekr, you might not in any case send an
>> re-invite; but maybe I understood this wrongly. I guess that could 
>> also
>> be further explained in the draft.
>
> Ekr was talking about the specific re-INVITE that is sent directly 
> after
> ICE nomination. *Other* re-INVITEs can always be sent during the 
> session.
> But, that is not specific to this draft.
>
> Regards,
>
> Christer

---

From: Roman Shpount <[email-masked]>
Date: Thu, 2 Mar 2017 00:25:02 -0500

Ben,

I have submitted the pull request to address these comments:
https://github.com/cdh4u/draft-sctp-sdp/pull/11

I hope that after Christer reviews and merges the pull request, we should
have the latest set of comments addressed.

If we need more information about framing, I believe it should go into
TCP/DTLS related draft, since all that draft-sctp-sdp is doing is reusing
the same framing for exactly the same reasons.

Regards,

_____________
Roman Shpount

On Wed, Mar 1, 2017 at 9:57 PM, Ben Campbell <[email-masked]> wrote:

> Hi all,
>
> It seems like this conversation has not completed. What do we need to get
> to closure?
>
> - I'm not adverse to making non-ICE implementors look at the ICE specs for
> framing information, as long as the citations are precise enough that they
> don't need to read the entirety of ICE. (And the information is really
> there.)
>
> informational text about non-ICE usage, as long as it is general enough to
> avoid confusion about where the authoritative text resides.
>
>> Also I¹m not sure if the ICE part is fully specified. In your previously
>>> mail you wrote
>>>
>>> "As far as TCP/DTLS/SCTP transport tag is concerned, please note that ICE
>>> end points are supposed to send a re-INVITE after nomination process is
>>> completed with the selected candidate address in the m= line. So, if tcp
>>> candidate in the m= line, which will also be TCP/DTLS/SCTP in case tcp
>>> candidate is selected.³
>>>
>>> re-invite; but maybe I understood this wrongly. I guess that could also
>> Ekr was talking about the specific re-INVITE that is sent directly after
>> ICE nomination. *Other* re-INVITEs can always be sent during the session.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 2 Mar 2017 10:28:20 +0000

Hi,

There may be some minor editorial nits, but in general I am ok with the pull request.

Regards,

Christer

From: Roman Shpount <[email-masked]<mailto:[email-masked]>>
Date: Thursday 2 March 2017 at 07:25
To: Ben Campbell <[email-masked]<mailto:[email-masked]>>
Cc: Christer Holmberg <[email-masked]<mailto:[email-masked]>>, Mirja Kuehlewind <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Eric Rescorla <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Flemming Andreasen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Mirja Kühlewind's Discuss on draft-ietf-mmusic-sctp-sdp-23: (with DISCUSS)

Ben,

I have submitted the pull request to address these comments: https://github.com/cdh4u/draft-sctp-sdp/pull/11

I hope that after Christer reviews and merges the pull request, we should have the latest set of comments addressed.

If we need more information about framing, I believe it should go into TCP/DTLS related draft, since all that draft-sctp-sdp is doing is reusing the same framing for exactly the same reasons.

Regards,

_____________
Roman Shpount

On Wed, Mar 1, 2017 at 9:57 PM, Ben Campbell <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

It seems like this conversation has not completed. What do we need to get to closure?

- I'm not adverse to making non-ICE implementors look at the ICE specs for framing information, as long as the citations are precise enough that they don't need to read the entirety of ICE. (And the information is really there.)

- I am adverse to repeating normative text. I'm okay with adding informational text about non-ICE usage, as long as it is general enough to avoid confusion about where the authoritative text resides.

- If people think that ICE is not sufficiently specified, we can work on that. But I don't think the burden of doing that belongs to this draft.

- The draft is in fact IESG approved in its current state. Material changes should be kept to the minimum.

Hi,

...

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 6 Mar 2017 08:31:33 +0000

Hi,

I haven’t seen any objections to Roman’s pull request, so I intend to merge it and submit a new version of the draft.

Regards,

Christer

From: Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Thursday 2 March 2017 at 12:28
To: Roman Shpount <[email-masked]<mailto:[email-masked]>>, Ben Campbell <[email-masked]<mailto:[email-masked]>>
Cc: Mirja Kuehlewind <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Eric Rescorla <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Flemming Andreasen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Mirja Kühlewind's Discuss on draft-ietf-mmusic-sctp-sdp-23: (with DISCUSS)
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: Gonzalo Camarillo <[email-masked]<mailto:[email-masked]>>, Salvatore Loreto <[email-masked]<mailto:[email-masked]>>, Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Resent-Date: Thursday 2 March 2017 at 12:28

Hi,

Regards,

Christer

Ben,

Regards,

_____________
Roman Shpount

Hi,

...

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 9 Mar 2017 11:21:27 +0000

Hi,

Based on Roman’s pull request, I have submitted a new version (-24) of draft-ietf-mmusic-sctp-sdp.

Regards,

Christer

From: Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Monday 6 March 2017 at 10:31
To: Christer Holmberg <[email-masked]<mailto:[email-masked]>>, Roman Shpount <[email-masked]<mailto:[email-masked]>>, Ben Campbell <[email-masked]<mailto:[email-masked]>>
Cc: Mirja Kuehlewind <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Eric Rescorla <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Flemming Andreasen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Mirja Kühlewind's Discuss on draft-ietf-mmusic-sctp-sdp-23: (with DISCUSS)

Hi,

Regards,

Christer

Hi,

Regards,

Christer

Ben,

Regards,

_____________
Roman Shpount

Hi,

...

Regards,

Christer