Subject: [MMUSIC] I-D Action: draft-ietf-mmusic-ice-sip-sdp-12.txt

From: [email-masked]
Date: Mon, 13 Mar 2017 01:48:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multiparty Multimedia Session Control of the IETF.

        Title           : Using Interactive Connectivity Establishment (ICE) with Session Description Protocol (SDP) offer/answer and Session Initiation Protocol (SIP)
        Authors         : Marc Petit-Huguenin
                          Ari Keranen
                          Suhas Nandakumar
	Filename        : draft-ietf-mmusic-ice-sip-sdp-12.txt
	Pages           : 43
	Date            : 2017-03-13

Abstract:
   This document describes how Interactive Connectivity Establishment
   (ICE) is used with Session Description Protocol (SDP) offer/answer
   and Session Initiation Protocol (SIP).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mmusic-ice-sip-sdp/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-mmusic-ice-sip-sdp-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-ice-sip-sdp-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 13 Mar 2017 01:56:49 -0700

Version-12 address most of the review comments from Adam. For the questions
that needs more attention from the WG, I have sent individual issues as
emails

Cheers
Suhas

On Mon, Mar 13, 2017 at 1:48 AM, <[email-masked]> wrote:

>         Title           : Using Interactive Connectivity Establishment
> (ICE) with Session Description Protocol (SDP) offer/answer and Session
> Initiation Protocol (SIP)
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 13 Mar 2017 09:06:58 +0000

Hi,

Note that some decisions/actions also came out of Seoul.

https://www.ietf.org/proceedings/97/minutes/minutes-97-mmusic-00

Regarding the ’Transport Switch and O/A’ issue, I guess we can use more or less the same text (authored by Roman) that was added to draft-ietf-mmusic-sctp-sdp.

Regards,

Christer

From: mmusic <[email-masked]<mailto:[email-masked]>> on behalf of Suhas Nandakumar <[email-masked]<mailto:[email-masked]>>
Date: Monday 13 March 2017 at 10:56
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [MMUSIC] I-D Action: draft-ietf-mmusic-ice-sip-sdp-12.txt

Version-12 address most of the review comments from Adam. For the questions that needs more attention from the WG, I have sent individual issues as emails

Cheers
Suhas

On Mon, Mar 13, 2017 at 1:48 AM, <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 13 Mar 2017 02:15:00 -0700

Thanks Christer. Are you referring to use text from this section:
https://tools.ietf.org/html/draft-ietf-mmusic-sctp-sdp-23#section-12.2

Thanks
Suhas

On Mon, Mar 13, 2017 at 2:06 AM, Christer Holmberg <
[email-masked]> wrote:

> Regarding the ’Transport Switch and O/A’ issue, I guess we can use more or
> less the same text (authored by Roman) that was added to
> draft-ietf-mmusic-sctp-sdp.
>
> Regards,
>
> Christer
>
> From: mmusic <[email-masked]> on behalf of Suhas Nandakumar <
> [email-masked]>
> To: "[email-masked]" <[email-masked]>
> Version-12 address most of the review comments from Adam. For the
> questions that needs more attention from the WG, I have sent individual
> issues as emails
>
> Cheers
> Suhas
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 13 Mar 2017 09:17:51 +0000

Hi,

>Thanks Christer. Are you referring to use text from this section: https://tools.ietf.org/html/draft-ietf-mmusic-sctp-sdp-23#section-12.2

Wrong version – correct section :)

Regards,

Christer

On Mon, Mar 13, 2017 at 2:06 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

Cheers
Suhas

Abstract:

---

From: Roman Shpount <[email-masked]>
Date: Mon, 13 Mar 2017 14:38:39 -0400

Hi Suhas,

One more thing that was discussed with Christer but did not make to
sctp-sdp was what should be specified in session descriptions m= line
during the ICE nomination process. Christer correctly pointed out that this
belongs to ice-sip-sdp. As it stands right not it is unclear if default
candidates should attempt to match currently selected candidate pair or
continue to send the original default candidate. Trying to match currently
selected pair can be difficult, especially since it can change during the
signaling exchange and you can end up with m= line transport mismatch. My
proposal was:

Session descriptions sent during the ICE nomination process SHOULD include
all the candidates discovered during the ICE nomination process, ICE
candidates present in the session description that started the ICE
nomination MUST not be removed from the session description and the default
candidate MUST not change until ICE nomination process is complete.

Finally, there was a bunch of calls for defining ICE/ transport tag. Should
I propose the language for this for draft-ietf-mmusic-ice-sip-sdp or should
it go into the separate draft?

Regards,

_____________
Roman Shpount

On Mon, Mar 13, 2017 at 5:17 AM, Christer Holmberg <
[email-masked]> wrote:

>> Regarding the ’Transport Switch and O/A’ issue, I guess we can use more
>> or less the same text (authored by Roman) that was added to

---

From: Suhas Nandakumar <[email-masked]>
Date: Tue, 14 Mar 2017 20:49:05 -0700

Hello Roman

  Please see inline

Cheers
Suhas

On Mon, Mar 13, 2017 at 11:38 AM, Roman Shpount <[email-masked]> wrote:

> nomination MUST not be removed from the session description and the
> default candidate MUST not change until ICE nomination process is
> complete.
>
>
> Finally, there was a bunch of calls for defining ICE/ transport tag.
> Should I propose the language for this for draft-ietf-mmusic-ice-sip-sdp or
> should it go into the separate draft?
>

[Suhas] . It would be great if you can propose text to the ice-sip-sdp
draft since it needs to clarify on the transport tag and the default
candidate related issues that Christer brought out during IETF97. I have
the latest XML version pushed to github here

https://github.com/suhasHere/ice-drafts/tree/master/ice-sdp

Could you provide your proposals as PR here. I am happy to work with you to
incorporate them.

---

From: Roman Shpount <[email-masked]>
Date: Wed, 15 Mar 2017 13:47:00 -0400

Suhas,

I will try to provide the default candidate proposals in the  pull request.

Regards,

_____________
Roman Shpount

On Tue, Mar 14, 2017 at 11:49 PM, Suhas Nandakumar <[email-masked]>
wrote:

>> Session descriptions sent during the ICE nomination process SHOULD
>> include all the candidates discovered during the ICE nomination process,
>> ICE candidates present in the session description that started the ICE
> Could you provide your proposals as PR here. I am happy to work with you
> to incorporate them.
>
>
>
>
>>
>> Regards,
>>
>> _____________
>> Roman Shpount
>>