Subject: [MMUSIC] BUNDLE: media-level c= lines in bundle-only m= sections?

From: Christer Holmberg <[email-masked]>
Date: Thu, 4 Jan 2018 13:08:16 +0000

Hi,

BUNDLE doesn’t say much about c= lines, the assumption being that there are no BUNDLE-specific rules related to c= lines: one can use a session-level c= line, or media-level c= lines, also with BUNDLE. The BUNDLE address will use whatever IP address is associated (implicitly or explicitly) with the tagged m= section.

So far so good.

Now, Ekr raised a JSEP GitHub issue regarding media-level c= lines in bundle-only m= sections. As we know, BUNDLE currently specifies that a zero port value is assigned to bundle-only m= sections, but nothing is said about media-level c= lines.

https://github.com/rtcweb-wg/jsep/issues/843

(The GitHub issue was initially created because of another issue, but if you follow the discussion it will end up in this)

My suggestion would be that an offerer/answerer MUST NOT assign media-level c= lines to bundle-only m= sections.

Would people be ok with this? Does someone suggest something else?

Whatever the outcome, I think it would be good to clarify it in BUNDLE. I don't think we need to bring the document back to the WG in order to do that – if we can agree on the text I will implement it in a future update (e.g., based on the IESG reviews) of the draft.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 4 Jan 2018 10:32:35 -0500

On 1/4/18 8:08 AM, Christer Holmberg wrote:
> Hi,
> 
> BUNDLE doesn’t say much about c= lines, the assumption being that there 
> are no BUNDLE-specific rules related to c= lines: one can use a 
> session-level c= line, or media-level c= lines, also with BUNDLE. The 
> BUNDLE address will use whatever IP address is associated (implicitly or 
> explicitly) with the tagged m= section.
> 
> So far so good.
> 
> Now, Ekr raised a JSEP GitHub issue regarding media-level c= lines in 
> bundle-only m= sections. As we know, BUNDLE currently specifies that a 
> zero port value is assigned to bundle-only m= sections, but nothing is 
> said about media-level c= lines.
> 
> (The GitHub issue was initially created because of another issue, but if 
> you follow the discussion it will end up in this)
> 
> My suggestion would be that an offerer/answerer MUST NOT assign 
> media-level c= lines to bundle-only m= sections.

This makes sense to me. The bundle only sections are going to get their 
address from some other section so a c= line is at best redundant.

	Thanks,
	Paul

> Whatever the outcome, I think it would be good to clarify it in BUNDLE. 
> I don't think we need to bring the document back to the WG in order to 
> do that – if we can agree on the text I will implement it in a future 
> update (e.g., based on the IESG reviews) of the draft.
> 
> Regards,
> 
> Christer
> 
> 
> 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Thomas Stach <[email-masked]>
Date: Thu, 4 Jan 2018 17:19:04 +0100

Christer,

On 2018-01-04 16:32, Paul Kyzivat wrote:
>> BUNDLE doesn’t say much about c= lines, the assumption being that 
>> there are no BUNDLE-specific rules related to c= lines: one can use a 
>> BUNDLE address will use whatever IP address is associated (implicitly 
>> or explicitly) with the tagged m= section.
>>
>> So far so good.
>>
>> bundle-only m= sections. As we know, BUNDLE currently specifies that 
>> a zero port value is assigned to bundle-only m= sections, but nothing 
>> is said about media-level c= lines.
>>
>> (The GitHub issue was initially created because of another issue, but 
>> if you follow the discussion it will end up in this)
>>
> This makes sense to me. The bundle only sections are going to get 
> their address from some other section so a c= line is at best redundant.
>
>     Thanks,
>     Paul
+1
maybe together with " ... a offerer/answerer  MUST ignore a received 
c-line ...."
Regards
Thomas
>> Whatever the outcome, I think it would be good to clarify it in 
>> BUNDLE. I don't think we need to bring the document back to the WG in 
>> order to do that – if we can agree on the text I will implement it in 
>> a future update (e.g., based on the IESG reviews) of the draft.
>>
>> Regards,
>>
>> Christer
>>
>>
>>
>>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 4 Jan 2018 21:52:52 +0000

Hi,

>>> BUNDLE doesn't say much about c= lines, the assumption being that 
>maybe together with " ... a offerer/answerer  MUST ignore a received c-line ...."

The rules for selecting the offerer/answerer BUNDLE addresses will make sure they are "rejected", so I am not sure whether we need to say anything explicit.

Regards,

Christer

>> order to do that - if we can agree on the text I will implement it in