Subject: [MMUSIC] Reviving draft-ietf-mmusic-msrp-usage-data-channel

From: "Makaraju, Raju (Nokia - US/Naperville)" <[email-masked]>
Date: Mon, 11 Mar 2019 14:43:33 +0000

All,
After a pause, we are putting renewed efforts to revive, resume draft-ietf-mmusic-msrp-usage-data-channel<https://datatracker.ietf.org/doc/draft-ietf-mmusic-msrp-usage-data-channel/> and complete the document to make it as an RFC.
This document is complete for the most part with some remaining comments, alignment with drafts/RFCs it refers to to be incorporated.
3gpp refers to this draft for MSRP over data channels interworking with MSRP/TLS (or TCP) and Nokia has an active implementation on as part of 3gpp ePCSCF based on this draft as well for this. Without reviving this draft 3gpp will remove the reference, but sooner or later an equivalent draft may have to be written (thus need to start fresh).

Julien will be representing Nokia for this draft while Jose M Recio <[email-masked]<mailto:[email-masked]>>  (thank you both!) and I will be providing  support for the technical discussion and most of the technical updates to the draft.

As usual, please provide your comments, concerns on this revival.

Thanks for your support!
Raju

---

From: "Gonzalez, Gene (Nokia - US/Naperville)" <[email-masked]>
Date: Wed, 20 Mar 2019 18:44:16 +0000

Hello,

I also support reviving the work on this draft specification and I will review the document.

Gene Gonzalez

-----Original Message-----
From: mmusic <[email-masked]> On Behalf Of [email-masked]
Sent: Tuesday, March 12, 2019 4:30 AM
To: [email-masked]
Subject: mmusic Digest, Vol 179, Issue 10

Send mmusic mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://www.ietf.org/mailman/listinfo/mmusic
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of mmusic digest..."

Today's Topics:

   1. Re: Reviving draft-ietf-mmusic-msrp-usage-data-channel
      (Christer Holmberg)

----------------------------------------------------------------------

Message: 1
Date: Tue, 12 Mar 2019 09:30:07 +0000
From: Christer Holmberg <[email-masked]>
To: "Maisonneuve, Julien (Nokia - FR/Paris-Saclay)"
	<[email-masked]>, Flemming Andreasen
	<[email-masked]>, "Makaraju, Raju (Nokia - US/Naperville)"
	<[email-masked]>, "[email-masked]"
	<[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [MMUSIC] Reviving
	draft-ietf-mmusic-msrp-usage-data-channel
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="utf-8"

>> As part of that process, the chairs would like to see a reasonable level of interest and contributions from more than just a couple of people. Indeed.
 >
>One of the main reasons to complete this work is that it is referenced and reused in a 3GPP specification (TS 24.371 ?Web Real-Time Communications (WebRTC) access to the IP Multimedia (IM) >Core Network (CN) subsystem (IMS); Stage 3; Protocol specification? https://www.etsi.org/deliver/etsi_ts/124300_124399/124371/15.00.00_60/ts_124371v150000p.pdf ).
>
>As a result, a number of companies having implemented this specification may be interested to see the draft standardized.

Things don?t just ?get standardized? ? actual people need to do the work. That applies to IETF, 3GPP and every other SDO out there ?

>The good news is that the draft was successfully implemented and that it should not be far from completion.

That?s what I was told when I took over ICEbis? ?

Seriously, I personally think it?s great if someone wants to finalize this. However, I hope that the new editors haven?t agreed to the task based on an assumption that ?it should not be far from completion?. Maybe that will be the case, but one always have to assume that issues may come up.

>The death of the draft was likely due to the imperfect coordination between IETF and 3GPP spec streams, along with the natural movement of authors.
>It could have been avoided, but it is fixable.

There was nothing wrong with the coordination. Everyone in IETF knew the draft was an 3GPP dependency. The problem was that there was nobody willing to finalize it.

Regards,

Christer

From: mmusic <[email-masked]> On Behalf Of Flemming Andreasen
Sent: Monday, March 11, 2019 7:45 PM
To: Christer Holmberg <[email-masked]>; Makaraju, Raju (Nokia - US/Naperville) <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [MMUSIC] Reviving draft-ietf-mmusic-msrp-usage-data-channel

That is correct. As part of that process, the chairs would like to see a reasonable level of interest and contributions from more than just a couple of people.

Thanks

-- Flemming (with chair hat on)
On 3/11/19 2:08 PM, Christer Holmberg wrote:
Hi,

As far as I understand, the WG will have to agree to continue the work, as the draft has been declared ?dead? and removed from the list of deliverables.

Regards,

Christer

From: mmusic <[email-masked]><mailto:[email-masked]> on behalf of "Makaraju, Raju (Nokia - US/Naperville)" <[email-masked]><mailto:[email-masked]>
Date: Monday, 11 March 2019 at 15.44
To: "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>, "[email-masked]"<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject: [MMUSIC] Reviving draft-ietf-mmusic-msrp-usage-data-channel

All,

Thanks for your support!
Raju

_______________________________________________

mmusic mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/mmusic

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailarchive.ietf.org/arch/browse/mmusic/attachments/20190312/219f89dd/attachment.html>

------------------------------

Subject: Digest Footer

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

------------------------------

End of mmusic Digest, Vol 179, Issue 10
***************************************

---

From: "Henrikson, Eric (Nokia - US)" <[email-masked]>
Date: Wed, 20 Mar 2019 19:49:10 +0000

Hi,

I support reviving the work for draft-ietf-mmusic-msrp-usage-data-channel.  I will review it.

Regards,
Eric Henrikson

-----Original Message-----
From: mmusic <[email-masked]> On Behalf Of [email-masked]
Sent: Tuesday, March 12, 2019 4:30 AM
To: [email-masked]
Subject: mmusic Digest, Vol 179, Issue 10

When replying, please edit your Subject line so it is more specific than "Re: Contents of mmusic digest..."

Today's Topics:

Message: 1

Regards,

Christer

Thanks

Regards,

Christer

All,

Thanks for your support!
Raju

mmusic mailing list

-------------- next part --------------

Subject: Digest Footer