Subject: [MMUSIC] Addressing comment from IANA on draft-ietf-mmusic-data-channel-sdpneg-25

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 11 Apr 2019 10:34:08 +0000

Hi,
I got the following comment from IANA:

Third, Section 9.3 of the current document appears to request the creation of a new registry in the Session Description Protocol (SDP) Parameters registry located at:

https://www.iana.org/assignments/sdp-parameters/

IANA Question --> The new registry might be modeled upon the existing att-field (. . . level) registries but instead be a registry for att-field (dcsa level). Is this correct? Would the new registry have the same characteristics as other att-field registries on the registry page? Could the draft be revised to explicitly create the registry, if this is correct? Are there any initial registrations in this new registry?

My response was

We are not asking for a new registry,  see https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-33#section-8.5 for  the Reorganization of the att-field Registries.  I now think that this third action is not really needed since it is now defined in rfc4566bis section 8.5 and 8.4

So I suggest to remove section 9.3 and add to the end of section section 5.2.1

A data channel specific usage of a subprotocol attribute is expected to be specified

   in the same document that registers the subprotocol's identifier for

   data channel usage.

        SDP attributes that are only defined for use at the

   dcsa usage level, SHALL use the dcsa usage level when registering the

   attribute.  If existing media attributes are used in a datachannel

   subprotocol specific way, then a new dcsa usage level

   MUST be defined for the existing media attribute.  Where the SDP

  attribute is applicable to a particular subprotocol/s this SHALL also

   be registered by indicating the applicable subprotocol identifiers

   (see https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-34#section-8.5) along with the dcsa usage level.

Roni Even

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 11 Apr 2019 12:31:43 -0400

On 4/11/19 6:34 AM, Roni Even (A) wrote:
> Third, Section 9.3 of the current document appears to request the 
> creation of a new registry in the Session Description Protocol (SDP) 
> Parameters registry located at:
> 
> IANA Question --> The new registry might be modeled upon the existing 
> att-field (. . . level) registries but instead be a registry for 
> att-field (dcsa level). Is this correct? Would the new registry have the 
> same characteristics as other att-field registries on the registry page? 
> Could the draft be revised to explicitly create the registry, if this is 
> correct? Are there any initial registrations in this new registry?
> 
> My response was
> 
> We are not asking for a new registry,  see 
> https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-33#section-8.5 
> for  the Reorganization of the att-field Registries.  I now think that 
> this third action is not really needed since it is now defined in 
> rfc4566bis section 8.5 and 8.4
> 

ISTM we actually got a little ahead of ourselves in 4566bis by 
mentioning dcsa and msrp-usage-datachannel.

While 4566bis reorganizes the attribute registries so that we don't need 
a new registry for dcsa, is is draft-ietf-mmusic-data-channel-sdpneg 
that defines the dcsa usage level. The publication of it should result 
in addition of a reference to it in the attribute registry. So I think 
we need an IANA action just to accomplish that.

And maybe the references to dcsa and msrp-usage-data-channel should be 
removed from 4566bis if it isn't too late to do so.

I don't find section 5.2.1 to be an appropriate place for this kind of 
information.

	Thanks,
	Paul

>     (see 
> https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-34#section-8.5) 
> along with the dcsa usage level.
> 
> Roni Even
> 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: "Roni Even (A)" <[email-masked]>
Date: Sun, 14 Apr 2019 05:37:13 +0000

Hi Paul,
Section 8.2.4.1 of https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-33#section-8.2.4 (normative reference in SDPNEG) registers usage level dcsa and dcsa (subprotocol) for the IANA att-field and point at the data-channel-sdpneg document for the definition. I think it will be simple to keep as is and just have the definition  in sdpneg but I have no strong feeling. So just decide, if you change RFC4566bis , we will need to keep section 9.3 in data-channel-sdpneg and just clarify what we register.

Roni

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: Thursday, April 11, 2019 7:32 PM
To: [email-masked]
Subject: Re: [MMUSIC] Addressing comment from IANA on draft-ietf-mmusic-data-channel-sdpneg-25

On 4/11/19 6:34 AM, Roni Even (A) wrote:
> att-field (dcsa level). Is this correct? Would the new registry have 
> the same characteristics as other att-field registries on the registry page?
> Could the draft be revised to explicitly create the registry, if this 
> is correct? Are there any initial registrations in this new registry?
> 
> My response was
> 
> https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-33#section-8.
> 5 for  the Reorganization of the att-field Registries.  I now think 
> that this third action is not really needed since it is now defined in 
> So I suggest to remove section 9.3 and add to the end of section 
> section
> 5.2.1

ISTM we actually got a little ahead of ourselves in 4566bis by mentioning dcsa and msrp-usage-datachannel.

While 4566bis reorganizes the attribute registries so that we don't need a new registry for dcsa, is is draft-ietf-mmusic-data-channel-sdpneg
that defines the dcsa usage level. The publication of it should result in addition of a reference to it in the attribute registry. So I think we need an IANA action just to accomplish that.

And maybe the references to dcsa and msrp-usage-data-channel should be removed from 4566bis if it isn't too late to do so.

I don't find section 5.2.1 to be an appropriate place for this kind of information.

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 14 Apr 2019 15:26:03 -0400

> Section 8.2.4.1 of https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-33#section-8.2.4 (normative reference in SDPNEG) registers usage level dcsa and dcsa (subprotocol) for the IANA att-field…

Duh, you are right. I forgot we put the dependency in there.

	Sorry,
	Paul