Subject: [MMUSIC] Mirja Kühlewind's No Objection on draft-ietf-mmusic-data-channel-sdpneg-25: (with COMMENT)

From: Mirja Kühlewind via Datatracker <[email-masked]>
Date: Fri, 05 Apr 2019 09:18:13 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-mmusic-data-channel-sdpneg-25: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-mmusic-data-channel-sdpneg/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for quickly addressing the comments from the TSV-ART review regarding
interactions with SCTP (and thanks Micheal T. for the review!)!

One minor, more editorial comment on max-time parameter:
draft-ietf-rtcweb-data-protocol says "This life-time starts when providing the
user message to the protocol stack.". While a reference to
draft-ietf-rtcweb-data-protocol is given respectively, I would recommend to
also clarify in this draft which time frame is meant given this time frame
includes and end-to-end delays.

As a side note: not sure it is necessary to expand IETF (Internet Engineering
Task Force) (see sec 5.2) in an IETF RFC but the RFC editor might tell you...

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 5 Apr 2019 11:21:46 -0500

> Task Force) (see sec 5.2) in an IETF RFC but the RFC editor might tell you...

It's marked as "well-known" at
https://www.rfc-editor.org/materials/abbrev.expansion.txt :)

-Ben

---

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 11 Apr 2019 09:50:19 +0000

Hi Mirja,
Thanks

See inline
Roni

-----Original Message-----
From: Mirja Kühlewind via Datatracker [mailto:[email-masked]] 
Sent: Friday, April 05, 2019 7:18 PM
To: The IESG
Cc: [email-masked]; Bo Burman; [email-masked]; [email-masked]; [email-masked]
Subject: Mirja Kühlewind's No Objection on draft-ietf-mmusic-data-channel-sdpneg-25: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Thanks for quickly addressing the comments from the TSV-ART review regarding interactions with SCTP (and thanks Micheal T. for the review!)!

One minor, more editorial comment on max-time parameter:
draft-ietf-rtcweb-data-protocol says "This life-time starts when providing the user message to the protocol stack.". While a reference to draft-ietf-rtcweb-data-protocol is given respectively, I would recommend to also clarify in this draft which time frame is meant given this time frame includes and end-to-end delays.
[RE] are you suggesting to repeat the text from the RTCweb document " A user message will no longer be transmitted or retransmitted after a  specified life-time given in milliseconds in the 'max-time' parameter. The life-time starts
         when providing the user message to the protocol stack."

As a side note: not sure it is necessary to expand IETF (Internet Engineering Task Force) (see sec 5.2) in an IETF RFC but the RFC editor might tell you...
[RE] will remove

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 11 Apr 2019 14:15:24 +0200

Hi Roni,

Yes, I think more or less repeating the text from the RTCweb doc could be useful here.

Mirja

> On 11. Apr 2019, at 11:50, Roni Even (A) <[email-masked]> wrote:
> 
> Hi Mirja,
> Thanks
> 
> See inline
> Roni
>