Subject: [MMUSIC] Getting draft-ietf-mmusic-sdp-uks-04 ready for PubReq

From: Bo Burman <[email-masked]>
Date: Fri, 17 May 2019 15:18:57 +0000

I think we can consider all changes from WGLC comments addressed by -04,
except for the editorial changes mentioned below.
We are now planning to move forward with Publication Request.

If you have any concerns with proceeding, please send a note to that effect
to the chairs, authors and the MMUSIC list no later than May 24, 2019.

Thanks,

Bo (MMUSIC co-chair)

> -----Original Message-----
> From: Martin Thomson <[email-masked]>
> Sent: den 8 maj 2019 04:14
> To: Flemming Andreasen <[email-masked]>; Bo Burman
> <[email-masked]>; mmusic <[email-masked]>; Jon Peterson
> <[email-masked]>; Cullen Jennings <[email-masked]>; 'Eric
> Rescorla' <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [MMUSIC] WGLC on draft-ietf-mmusic-sdp-uks-03
> 
> Thanks Flemming, I've applied the two editorial updates to my tree.  They
are
> minor enough that I'll wait for the next opportunity to include them in
> revised draft.  I'm sure that I'll get a chance.
> 
> On Wed, May 8, 2019, at 12:07, Flemming Andreasen wrote:
> > I took another look at the "chair review update" version at
> > https://martinthomson.github.io/sdp-uks/chair-review/draft-ietf-mmusic-
> sdp-uks.html (I see you just posted an -04 as well - not sure if there are
any
> differences between those two).
> 
> They were identical, aside for dates.
> 
> >  Thanks for the patience in all the discussion on this.
> 
> And you.   I'm sure that this is much better for the effort.

---

From: Roman Shpount <[email-masked]>
Date: Fri, 24 May 2019 20:02:55 -0400

Hi All,

Sorry for the late question, but is there a scenario where party is
communicating with attacker but believes that it communicates with patsy?

In all the described attacks, all I see is that  one of the attacked
parties is communicating with another but thinks it is communicating with
the attacker. What is the risk associated with this? How this is different
then just setting up a communication channel with attacker who is
re-encoding the data?

Regards,
_____________
Roman Shpount

On Fri, May 17, 2019 at 11:19 AM Bo Burman <[email-masked]> wrote:

> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 27 May 2019 14:45:15 +1000

> communicating with attacker but believes that it communicates with 

I don't think so.  I think that would require failures in parts of the system that we are assuming to be OK (the IdP in one case, the signaling system in the other).  The attacker can swap another entity into a call, but not vice versa.

> parties is communicating with another but thinks it is communicating 
> with the attacker. What is the risk associated with this? How this is 
> different then just setting up a communication channel with attacker 
> who is re-encoding the data?

This is different because a recipient is able to authenticate the source of the media as being the victim.  It is very much like relaying media by instantiating a new session and forwarding media, but if context (or ambient authority) is used in interpreting that data, the attacker might gain something.

Imagine the following conversation: 

victim: I will buy 10.
response: Are you quite sure?
victim: Yes. Please charge to my account.

If the attacker is selling boxes of cookies and the target is selling refrigerators, the result might be surprising.

---

From: Roman Shpount <[email-masked]>
Date: Wed, 29 May 2019 18:45:01 -0400

I have reviewed the document and I have confirmed that the document is
clear and my understanding is correct.

Thank you, Martin.
_____________
Roman Shpount

On Mon, May 27, 2019 at 12:45 AM Martin Thomson <[email-masked]> wrote:

> I don't think so.  I think that would require failures in parts of the
> system that we are assuming to be OK (the IdP in one case, the signaling
> system in the other).  The attacker can swap another entity into a call,
> but not vice versa.
>
> This is different because a recipient is able to authenticate the source
> of the media as being the victim.  It is very much like relaying media by
> instantiating a new session and forwarding media, but if context (or
> ambient authority) is used in interpreting that data, the attacker might
> gain something.
>
> If the attacker is selling boxes of cookies and the target is selling
> refrigerators, the result might be surprising.
>