Subject: [MMUSIC] 4566bis-36: Minor editorial comments regarding line descriptions in section 5

From: Christer Holmberg <[email-masked]>
Date: Wed, 24 Jul 2019 10:13:01 +0000

Hi,

I had a look at section 5, and I have a couple of minor editorial comments:

Q1:

Section 5.6. says:

   “If an email address or phone number is present, it MUST be specified before the first media description.”

I don’t think we need that statement. We define elsewhere (both in Section 5 and in the syntax) the order of the letters.

---

Q2:

Section 5.4 says:

“At most one "i=" line can be used for each media description.”

…while section 5.5 says:

“This line is OPTIONAL. No more than one "u=" line is allowed per session description.”

…while section 5.6 says:

“Inclusion of an email address or phone number is OPTIONAL.”

I assume “at most one” and “no more than one” means the same thing, and if we want to explicitly indicate that something is OPTIONAL we should use it in all places where it applies. So, I think it would be good to have aligned terminology, e.g.,:

“This X line is OPTIONAL, and at most one X line can be included in a media/session description”

---

Q3:

In section 5.4 the text says twice that there can be at most one “i=” line in a media description. Do we need to repeat?

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 26 Jul 2019 13:08:03 -0400

Christer,

It seems to me that these are all minor editorial things. Since the 
document has already had its IESG review I am reluctant to make such 
optional changes. If I were to start I can imagine some further back and 
forth on the details of the wording. But I can do these if Adam wants them.

	Thanks,
	Paul

On 7/24/19 6:13 AM, Christer Holmberg wrote:
>     “If an email address or phone number is present, it MUST be 
> specified before the first media description.”
> 
> I don’t think we need that statement. We define elsewhere (both in 
> Section 5 and in the syntax) the order of the letters.
> 
> ---
> 
> Q2:
> 
> Section 5.4 says:
> 
> I assume “at most one” and “no more than one” means the same thing, and 
> if we want to explicitly indicate that something is OPTIONAL we should 
> use it in all places where it applies. So, I think it would be good to 
> have aligned terminology, e.g.,:
> 
> In section 5.4 the text says twice that there can be at most one “i=” 
> line in a media description. Do we need to repeat?
> 
> Regards,
> 
> Christer
> 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 26 Jul 2019 17:12:01 +0000

Hi,

>It seems to me that these are all minor editorial things. Since the document has already had its IESG review I am >reluctant to make such optional changes. If I were to start I can imagine some further back and forth on the >details of the wording. But I can do these if Adam wants them.

In my opinion the changes are such minor, and pure editorial, that they don't require a new IESG review etc.

But, I'll leave it up to you to decide. I should have commented earlier, but I was overwhelmed with other drafts.

Regards,

Christer

On 7/24/19 6:13 AM, Christer Holmberg wrote:
> I assume “at most one” and “no more than one” means the same thing, 
> and if we want to explicitly indicate that something is OPTIONAL we 
> should use it in all places where it applies. So, I think it would be 
> good to have aligned terminology, e.g.,:
>

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 26 Jul 2019 16:12:08 -0400

> But, I'll leave it up to you to decide. I should have commented earlier, but I was overwhelmed with other drafts.

And I'll leave it to Adam. I do have to make a change regarding IANA 
instructions. So it could go in then.

	Thanks,
	Paul