Subject: [MMUSIC] Data channel dcsa attribute usage and IANA

From: Christer Holmberg <[email-masked]>
Date: Wed, 28 Aug 2019 10:33:25 +0000

Hi,

Section 7.2 of draft-ietf-mmusic-msrp-usage-data-channel updates the IANA registry for the SDP ‘setup’ attribute, by indicating that it can be used inside an SDP ‘dcsa’ attribute.

Do we really need to update the IANA registry for all SDP attributes that can be included in an ‘dcsa’ attribute???

There is no text in draft-mmusic-data-channel-neg about having to modify the IANA registry for such attributes.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 28 Aug 2019 10:24:00 -0400

On 8/28/19 6:33 AM, Christer Holmberg wrote:
> Hi,
> 
> Section 7.2 of draft-ietf-mmusic-msrp-usage-data-channel updates the 
> IANA registry for the SDP ‘setup’ attribute, by indicating that it can 
> be used inside an SDP ‘dcsa’ attribute.
> 
> Do we really need to update the IANA registry for all SDP attributes 
> that can be included in an ‘dcsa’ attribute???

I think so. Look at RFC4566bis for the revised attribute registry.

The way to avoid this would be to remove "Usage Level" from the registry 
and thus force people to consult the defining documents for the 
attribute in order to learn this. But it is seriously late in the cycle 
to update 4566bis.

	Thanks,
	Paul

> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 28 Aug 2019 14:45:09 +0000

Hi,

> The way to avoid this would be to remove "Usage Level" from the registry and thus force 
> people to consult the defining documents for the attribute in order to learn this. But it is 
> seriously late in the cycle to update 4566bis.

I think it can be seen in two different ways, that have no impact on 4566bis.

1) If the usage level is "media", that doesn't change inside a dcsa attribute. From an SDP perspective it is still "media", as it is part of an m= line. If you place a "session" level attribute inside a dcsa attribute that changes, but I don't think we do that; or

2) From an SDP perspective, only the dcsa attribute is used. What's inside is "application specific", and has nothing to do with SDP.

Regards,

Christer

	Thanks,
	Paul

> There is no text in draft-mmusic-data-channel-neg about having to 
> modify the IANA registry for such attributes.
> 
> Regards,
> 
> Christer
> 
>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 28 Aug 2019 11:27:24 -0400

> 2) From an SDP perspective, only the dcsa attribute is used. What's inside is "application specific", and has nothing to do with SDP.

I think you are mixing two things here:

- what currently is required based on the specs as written (including 
4566bis);

- what would be the ideal way for it to work.

Based on the current specs I think the registry must be updated. And I 
think that was always expected during the development of the dcsa attribute.

What is most important is that people have a well defined way to 
determine whether an attribute can be used in dcsa in a particular case. 
If they are expected to find this in a document defining the attribute, 
then the document had better provide an answer.

If you feel a change is needed to 4566bis then we will have to figure 
out if and how to accomplish that. It is already at the editor.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 28 Aug 2019 16:24:46 +0000

Hi,

>>>> IANA registry for the SDP ‘setup’ attribute, by indicating that it 
>>>> can be used inside an SDP ‘dcsa’ attribute.
>>>>
>>> The way to avoid this would be to remove "Usage Level" from the 
>>> registry and thus force people to consult the defining documents for 
>>> the attribute in order to learn this. But it is seriously late in the cycle to update 4566bis.
>> 
>> 1) If the usage level is "media", that doesn't change inside a dcsa 
>> attribute. From an SDP perspective it is still "media", as it is part 
>> of an m= line. If you place a "session" level attribute inside a dcsa 
>> attribute that changes, but I don't think we do that; or
>> 
> - what currently is required based on the specs as written (including 4566bis);
>
> Based on the current specs I think the registry must be updated. And I think that was always expected during the development of the dcsa attribute.

draft-mmusic-data-channel-sdpneg doesn't say anything (unless I've missed it) about updating the IANA registry, so I am not sure what specs you are referring to.

>What is most important is that people have a well defined way to determine whether an attribute can be used in dcsa in a particular case. 

Sure, but that is defined in the data channel usage specs (e.g., the MSRP usage spec and the T.140 usage spec).

>If they are expected to find this in a document defining the attribute, then the document had better provide an answer.

We are not updating the documents defining the attributes.

>If you feel a change is needed to 4566bis then we will have to figure out if and how to accomplish that. It is already at the editor.

I don't think a change is needed for 4566bis.  But, if an IANA registry update is required for attributes used with dcsa I think it should be said in draft-mmusic-data-channel-sdpneg (unless it's already there and I've missed it...)

Regards,

Christer

---

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 29 Aug 2019 08:08:42 +0000

Hi Christer,
To add to Paul’s response
Look at the last 2 paragraphs of section 5.2.1   https://tools.ietf.org/html/draft-ietf-mmusic-data-channel-sdpneg-28#section-5.2.1

Roni

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Wednesday, August 28, 2019 1:33 PM
To: [email-masked]
Cc: [email-masked]
Subject: [MMUSIC] Data channel dcsa attribute usage and IANA

Hi,

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 29 Aug 2019 08:27:12 +0000

Hi,

Thanks for the information! The last paragraph clarifies it.

So, draft-t140-usage-data-channel will update the IANA registry for the SDP attributes used inside the SDP dcsa attribute.

Regards,

Christer

From: "Roni Even (A)" <[email-masked]>
Date: Thursday, 29 August 2019 at 11.08
To: Christer Holmberg <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: Data channel dcsa attribute usage and IANA

Hi Christer,

Roni

Hi,

Regards,

Christer