Subject: Re: [MMUSIC] Data channel dcsa attribute usage and IANA

From: Christer Holmberg <[email-masked]>
Date: Thu, 29 Aug 2019 09:25:03 +0000

Hi,

One question for clarification:

Section 8.2.4.1 of RFC4566bis says:

      “Usage Level: Usage level(s) of the attribute.  This MUST be one or
      more of the following: session, media, source, dcsa and
      dcsa(subprotocol).”

…and in the Table in Section 8.2.4 it says:

“dcsa,dcsa(msrp)”

Q1: Why does it need to say both ‘dcsa’ and ‘dcsa(subprotocol)’? Isn’t it enough with ‘dcsa(subprotocol)’?

Regards,

Christer

From: mmusic <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Thursday, 29 August 2019 at 11.27
To: "Roni Even (A)" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [MMUSIC] Data channel dcsa attribute usage and IANA

Hi,

Thanks for the information! The last paragraph clarifies it.

So, draft-t140-usage-data-channel will update the IANA registry for the SDP attributes used inside the SDP dcsa attribute.

Regards,

Christer

From: "Roni Even (A)" <[email-masked]>
Date: Thursday, 29 August 2019 at 11.08
To: Christer Holmberg <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: Data channel dcsa attribute usage and IANA

Hi Christer,
To add to Paul’s response
Look at the last 2 paragraphs of section 5.2.1   https://tools.ietf.org/html/draft-ietf-mmusic-data-channel-sdpneg-28#section-5.2.1

Roni

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Wednesday, August 28, 2019 1:33 PM
To: [email-masked]
Cc: [email-masked]
Subject: [MMUSIC] Data channel dcsa attribute usage and IANA

Hi,

Section 7.2 of draft-ietf-mmusic-msrp-usage-data-channel updates the IANA registry for the SDP ‘setup’ attribute, by indicating that it can be used inside an SDP ‘dcsa’ attribute.

Do we really need to update the IANA registry for all SDP attributes that can be included in an ‘dcsa’ attribute???

There is no text in draft-mmusic-data-channel-neg about having to modify the IANA registry for such attributes.

Regards,

Christer

---

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 29 Aug 2019 09:49:59 +0000

Hi,
I think that dcsa(subprotocol) would have been enough, at least based on channel-sdpneg document, maybe Paul can help

Roni

From: Christer Holmberg [mailto:[email-masked]]
Sent: Thursday, August 29, 2019 12:25 PM
To: Roni Even (A); [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [MMUSIC] Data channel dcsa attribute usage and IANA

Hi,

“dcsa,dcsa(msrp)”

Regards,

Christer

From: mmusic <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 29 August 2019 at 11.27
To: "Roni Even (A)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [MMUSIC] Data channel dcsa attribute usage and IANA

Hi,

Regards,

Christer

From: "Roni Even (A)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 29 August 2019 at 11.08
To: Christer Holmberg <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Data channel dcsa attribute usage and IANA

Hi Christer,

Roni

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Wednesday, August 28, 2019 1:33 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [MMUSIC] Data channel dcsa attribute usage and IANA

Hi,

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 29 Aug 2019 10:07:46 -0400

On 8/29/19 5:49 AM, Roni Even (A) wrote:
> Hi,
> 
> I think that dcsa(subprotocol) would have been enough, at least based on 
> channel-sdpneg document, maybe Paul can help

I'm sorry that this is coming up so late. In retrospect I think it 
deserved more discussion about how this is to work. IIRC this got tucked 
in quite some time ago, early in the definition of dcsa.

I don't recall why both forms are shown. I don't know what "dcsa" alone 
would mean. The guess it could be a wildcard meaning that it can be used 
with all subprotocols. But that doesn't make any sense to me.

So I'm inclined to only use the "dcsa(subprotocol)" form. Perhaps we 
should file an errata against rfc4566bis as soon as it becomes an RFC.

	Thanks,
	Paul

> Roni
> 
> *From:*Christer Holmberg [mailto:[email-masked]]
> *Sent:* Thursday, August 29, 2019 12:25 PM
> *To:* Roni Even (A); [email-masked]; [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: [MMUSIC] Data channel dcsa attribute usage and IANA
> 
> Hi,
> 
>        more of the following: session, media, source, *dcsa and*
> 
> *      dcsa(subprotocol)*.”
> 
> *From: *mmusic <[email-masked] 
> <mailto:[email-masked]>> on behalf of Christer Holmberg 
> <[email-masked] <mailto:[email-masked]>>
> *Date: *Thursday, 29 August 2019 at 11.27
> *To: *"Roni Even (A)" <[email-masked] 
> <mailto:[email-masked]>>, "[email-masked] 
> <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> *Cc: *"[email-masked] <mailto:[email-masked]>" 
> <[email-masked] <mailto:[email-masked]>>
> *Subject: *Re: [MMUSIC] Data channel dcsa attribute usage and IANA
> 
> Hi,
> 
> So, draft-t140-usage-data-channel will update the IANA registry for the 
> SDP attributes used inside the SDP dcsa attribute.
> 
> Regards,
> 
> Christer
> 
> *From: *"Roni Even (A)" <[email-masked] <mailto:[email-masked]>>
> *Date: *Thursday, 29 August 2019 at 11.08
> *To: *Christer Holmberg <[email-masked] 
> <mailto:[email-masked]>>, "[email-masked] 
> <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> *Cc: *"[email-masked] <mailto:[email-masked]>" 
> <[email-masked] <mailto:[email-masked]>>
> *Subject: *RE: Data channel dcsa attribute usage and IANA
> 
> Hi Christer,
> 
> Look at the last 2 paragraphs of section 5.2.1 
> https://tools.ietf.org/html/draft-ietf-mmusic-data-channel-sdpneg-28#section-5.2.1
> 
> Roni
> 
> *From:*mmusic [mailto:[email-masked]] *On Behalf Of *Christer 
> Holmberg
> *Sent:* Wednesday, August 28, 2019 1:33 PM
> *To:* [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>
> *Subject:* [MMUSIC] Data channel dcsa attribute usage and IANA
> 
> Hi,
> 
> Section 7.2 of draft-ietf-mmusic-msrp-usage-data-channel updates the 
> IANA registry for the SDP ‘setup’ attribute, by indicating that it can 
> be used inside an SDP ‘dcsa’ attribute.
> 
> Do we really need to update the IANA registry for all SDP attributes 
> that can be included in an ‘dcsa’ attribute???
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 29 Aug 2019 14:20:39 +0000

Hi,

>    with all subprotocols. But that doesn't make any sense to me.
  
I was also first thinking whether dcsa without subprotocol it was some kind of "wildcard", but there is no such thing defined in data-channel-sdpneg: each subprotocol will have to define register its usage of attributes inside dcsa.

>    should file an errata against rfc4566bis as soon as it becomes an RFC.
  
Isn't this a fix that the RFC Editor can be requested to do? There is no reason to bring the draft back to the WG etc.

After all, this is not a technical change, only an administrative.

Regards,

Christer

---

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 29 Aug 2019 14:46:15 +0000

Hi,
I think that it does not make sense to a usage level as dcsa without the subprotocol. 
 If there was such usage it should have been defined in the draft-ietf-mmusic-data-channel-sdpneg document or in a non subprotocol specific document for general use.
Roni

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: Thursday, August 29, 2019 5:08 PM
To: [email-masked]
Subject: Re: [MMUSIC] Data channel dcsa attribute usage and IANA

On 8/29/19 5:49 AM, Roni Even (A) wrote:
> Hi,
> 
> I think that dcsa(subprotocol) would have been enough, at least based 
> on channel-sdpneg document, maybe Paul can help

I'm sorry that this is coming up so late. In retrospect I think it deserved more discussion about how this is to work. IIRC this got tucked in quite some time ago, early in the definition of dcsa.

I don't recall why both forms are shown. I don't know what "dcsa" alone would mean. The guess it could be a wildcard meaning that it can be used with all subprotocols. But that doesn't make any sense to me.

So I'm inclined to only use the "dcsa(subprotocol)" form. Perhaps we should file an errata against rfc4566bis as soon as it becomes an RFC.

	Thanks,
	Paul

> So, draft-t140-usage-data-channel will update the IANA registry for 
> the SDP attributes used inside the SDP dcsa attribute.
> 
> Regards,
> 
> Christer
> 
> There is no text in draft-mmusic-data-channel-neg about having to 
> modify the IANA registry for such attributes.
> 
> Regards,
> 
> Christer
> 
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 29 Aug 2019 11:49:09 -0400

> After all, this is not a technical change, only an administrative.

Yes, I think so.

I was just now reviewing IANA changes for 4566bis, and asked them to 
change "dcsa, dcsa(setup)" to "dcsa(setup)".

	Thanks,
	Paul