Subject: Re: [MMUSIC] T140: Usage of "-"fmt value in dcsa encapsulated fmtp attribute - the pull request

From: Christer Holmberg <[email-masked]>
Date: Tue, 17 Dec 2019 07:39:27 +0000

Hi,

I have created a pull request that makes to change from "-" to "t140".

(The pull request also an editorial addition, as requested by the chairs)

https://github.com/cdh4u/draft-datachannel-t140/pull/54

Regards,

Christer

On 16/12/2019, 21.23, "mmusic on behalf of Christer Holmberg" <[email-masked] on behalf of christer.holmberg=[email-masked]> wrote:

    Roni, note that this impacts you.
    
    Regards,
    
    Christer
    
    On 16/12/2019, 18.10, "mmusic on behalf of Paul Kyzivat" <[email-masked] on behalf of [email-masked]> wrote:
    
        On 12/16/19 11:05 AM, Christer Holmberg wrote:
        > Hi,
        > 
        > I'd be ok with the subchannel identifier.
        > 
        > I do think it would be good to add some generic text to sdpneg, though, saying that whenever the media description format or PT number would normally be used in an attribute (e.g., the fmtp attribute), when encapsulated in a dcsa attribute the subchannel identifier is used instead.
        
        +1
        
        > Regards,
        > 
        > Christer
        > 
        > 
        > On 16/12/2019, 17.58, "mmusic on behalf of Paul Kyzivat" <[email-masked] on behalf of [email-masked]> wrote:
        > 
        >      On 12/16/19 10:34 AM, Flemming Andreasen wrote:
        >      
        >      >> Also, I think we should aim at being aligned with the RTP usage when it comes to SDP attributes.
        >      > Agreed again. I think the "fmtp" attribute is the right one to use here
        >      > - the question is simply what format value we use. I'm leaning towards
        >      > "t140", but we should get some general text in sdpneg to account for
        >      > additional media formats in the future.
        >      
        >      IIUC you are proposing that the format value in fmtp attributes for data
        >      subchannels should be the subchannel identifier. Is that right?
        >      
        >      While that is redundant I won't oppose that.
        >      
        >      	Thanks,
        >      	Paul
        >      
        >      	
        >      
        >      _______________________________________________
        >      mmusic mailing list
        >      [email-masked]
        >      https://www.ietf.org/mailman/listinfo/mmusic
        >      
        > 
        > _______________________________________________
        > mmusic mailing list
        > [email-masked]
        > https://www.ietf.org/mailman/listinfo/mmusic
        > 
        
        _______________________________________________
        mmusic mailing list
        [email-masked]
        https://www.ietf.org/mailman/listinfo/mmusic

    _______________________________________________
    mmusic mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/mmusic

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 18 Dec 2019 14:43:26 +0000

Hi,

I intend to merge the pull request tomorrow (Thursday), so please let me know if you have any issues with it - or in general with the approach of using the sub-protocol value instead of "-" in dcsa encapsulated fmtp attribute. So far nobody has objected to such approach.

Regards,

Christer

On 17/12/2019, 9.39, "Christer Holmberg" <christer.holmberg=[email-masked]> wrote:

    Hi,

    
    https://protect2.fireeye.com/v1/url?k=d16336e8-8db73a19-d1637673-864685b2085c-1da2d27c922df7f1&q=1&e=42e0e4a7-de1a-4834-96a7-a8778b2d7bb3&u=https%3A%2F%2Fgithub.com%2Fcdh4u%2Fdraft-datachannel-t140%2Fpull%2F54
    
    Regards,
    
    Christer

    
        
        Regards,
        
        Christer

            
            +1