Subject: [MMUSIC] [Technical Errata Reported] RFC4566 (6022)

From: RFC Errata System <[email-masked]>
Date: Mon, 16 Mar 2020 12:27:43 -0700 (PDT)

The following errata report has been submitted for RFC4566,
"SDP: Session Description Protocol".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6022

--------------------------------------
Type: Technical
Reported by: Megan Ruggiero <[email-masked]>

Section: 9

Original Text
-------------
   ; sub-rules of 'e=', see RFC 2822 for definitions
   email-address        = address-and-comment / dispname-and-address
                          / addr-spec
   address-and-comment  = addr-spec 1*SP "(" 1*email-safe ")"
   dispname-and-address = 1*email-safe 1*SP "<" addr-spec ">"

   ; sub-rules of 'p='
   phone-number =        phone *SP "(" 1*email-safe ")" /
                         1*email-safe "<" phone ">" /
                         phone

Corrected Text
--------------
   ; sub-rules of 'e=', see RFC 2822 for definitions
   email-address        = address-and-comment / dispname-and-address
                          / addr-spec
   address-and-comment  = addr-spec 1*SP "(" 1*email-safe ")"
   dispname-and-address = 1*email-safe 1*SP "<" addr-spec ">"

   ; sub-rules of 'p='
   phone-number =        phone *SP "(" 1*email-safe ")" /
                         1*email-safe 1*SP "<" phone ">" /
                         phone

Notes
-----
There's an inconsistency between the definitions of dispname-and-address and phone-number. I am not sure if this is intentional or not, and in practice this doesn't change what's matched (as email-safe includes spaces), but I thought it'd be worth mentioning since I myself got tripped up when translating the grammar.

Alternatively, perhaps 1*SP should be removed from dispname-and-address.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4566 (draft-ietf-mmusic-sdp-new-26)
--------------------------------------
Title               : SDP: Session Description Protocol
Publication Date    : July 2006
Author(s)           : M. Handley, V. Jacobson, C. Perkins
Category            : PROPOSED STANDARD
Source              : Multiparty Multimedia Session Control RAI
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 16 Mar 2020 15:58:05 -0400

Inline...

> "SDP: Session Description Protocol".

I just checked, and this remains in rfc4566bis.

Since this has no practical impact I see no reason to change anything.

	Thanks,
	Paul

> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Megan Ferguson <[email-masked]>
Date: Mon, 16 Mar 2020 14:46:10 -0700

Hi Megan,

Both the RPC and the verifier of the erratum have the ability to edit the report.

If you *do* want to submit a change to an erratum, you can send your changes to the RPC with Old/New format clearly specified and we can update and repost for you to review.

Thanks.

RFC Editor/mf

---

From: Megan Ruggiero <[email-masked]>
Date: Mon, 16 Mar 2020 19:48:57 +0000

I have no idea how to write a comment or correction on an errata I already submit, so hopefully "Reply All" is the correct thing (and absolutely apologies if it's not).

As a correction, this change would make a difference since it changes whether or not the space is mandatory. As it is, it's mandatory in dispname-and-address but not in phone-number. My suggested correction would make it mandatory in both, and the alternative would make it optional in both.

I'm sorry for the oversight.

Megan Ruggiero
________________________________
From: RFC Errata System <[email-masked]>
Sent: Monday, March 16, 2020 3:27 PM
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: [Technical Errata Reported] RFC4566 (6022)

Section: 9

Original Text
-------------

   ; sub-rules of 'p='

Corrected Text
--------------

   ; sub-rules of 'p='

Notes
-----

Instructions:
-------------