Subject: Re: [MMUSIC] draft-ietf-rtcweb-mdns-ice-candidates

From: Justin Uberti <[email-masked]>
Date: Thu, 15 Oct 2020 12:40:05 -0700

This fell off my radar, will update the draft shortly though.

On Fri, Sep 18, 2020 at 9:13 AM Flemming Andreasen <fandreas=
[email-masked]> wrote:

> It looks like we have at least 5 people interested in and willing to
> contribute to the work. Based on this, the chairs will work with our AD on
> getting a new milestone added.
>
> I see that the current draft has expired though - can we get an updated
> version submitted first ?
>
> Thanks
>
> -- Flemming (as MMUSIC co-chair)
>
>
>
> On 9/2/20 2:57 PM, Qingsi Wang wrote:
>
> I am interested and willing to contribute to this document too.
>
> Best,
> Qingsi
>
> On Wed, Sep 2, 2020 at 11:51 AM Youenn Fablet <youenn=
> [email-masked]> wrote:
>
>> I am interested and willing to contribute to the document.
>> The proposal being implemented by various parties, having this document
>> be reviewed and ironed out as much as possible is valuable.
>>
>> Thanks,
>> Y
>>
>> On 2 Sep 2020, at 20:09, Flemming Andreasen <[email-masked]> wrote:
>>
>> So far I've only seen 2 people expressing an interest in this document.
>>
>> Is anybody else interested, and if so, are you willing to contribute
>> and/or review the document ?
>>
>> Thanks
>>
>> -- Flemming (as MMUSIC co-chair)
>>
>> On 7/31/20 12:16 AM, Roman Shpount wrote:
>>
>> I am strongly in favor of adopting this draft to MMUSIC and getting it
>> completed.
>> _____________
>> Roman Shpount
>>
>>
>> On Thu, Jul 30, 2020 at 7:33 PM Justin Uberti <juberti=
>> [email-masked]> wrote:
>>
>>> Hi all,
>>>
>>> With the closure of rtcweb, we have been advised to find a new forum for
>>> https://tools.ietf.org/html/draft-ietf-rtcweb-mdns-ice-candidates-04,
>>> and MMUSIC seems like the best home for it.
>>>
>>> I believe this document is in fairly good shape and should be ready for
>>> last call soon. Any objections to taking it on in this working group?
>>>
>>> Justin
>>> _______________________________________________
>>> mmusic mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/mmusic
>>>
>>
>> _______________________________________________
>> mmusic mailing [email-masked]://www.ietf.org/mailman/listinfo/mmusic
>>
>>
>>
>> _______________________________________________
>> mmusic mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/mmusic
>>
>
> _______________________________________________
> mmusic mailing [email-masked]://www.ietf.org/mailman/listinfo/mmusic
>
>
>

---

From: Justin Uberti <[email-masked]>
Date: Mon, 19 Oct 2020 17:08:10 -0700

New draft posted (now with -mmusic name) and waiting for approval.

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 20 Oct 2020 22:47:02 -0400

Thanks Justin. What do the authors view as a realistic timeframe for 
getting the draft ready for publication ?

Cheers

-- Flemming

On 10/19/20 8:08 PM, Justin Uberti wrote:
> On Thu, Oct 15, 2020 at 12:40 PM Justin Uberti <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     On Fri, Sep 18, 2020 at 9:13 AM Flemming Andreasen
>     <fandreas=[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         It looks like we have at least 5 people interested in and
>         willing to contribute to the work. Based on this, the chairs
>         will work with our AD on getting a new milestone added.
>
>         I see that the current draft has expired though - can we get
>         an updated version submitted first ?
>
>         Thanks
>
>>         On Wed, Sep 2, 2020 at 11:51 AM Youenn Fablet
>>         <youenn=[email-masked]
>>         <mailto:[email-masked]>> wrote:
>>
>>             The proposal being implemented by various parties, having
>>             this document be reviewed and ironed out as much as
>>             possible is valuable.
>>
>>             Thanks,
>>             Y
>>
>>>             On 2 Sep 2020, at 20:09, Flemming Andreasen
>>>             <[email-masked] <mailto:[email-masked]>> wrote:
>>>
>>>             Is anybody else interested, and if so, are you willing
>>>             to contribute and/or review the document ?
>>>
>>>             Thanks
>>>
>>>>             I am strongly in favor of adopting this draft to
>>>>             MMUSIC and getting it completed.
>>>>             _____________
>>>>             Roman Shpount
>>>>
>>>>
>>>>             On Thu, Jul 30, 2020 at 7:33 PM Justin Uberti
>>>>             <juberti=[email-masked]
>>>>             <mailto:[email-masked]>> wrote:
>>>>
>>>>                 Hi all,
>>>>
>>>>                 I believe this document is in fairly good shape and
>>>>                 should be ready for last call soon. Any objections
>>>>                 to taking it on in this working group?
>>>>
>>>>                 Justin
>>>>                 [email-masked] <mailto:[email-masked]>
>>>>             [email-masked]  <mailto:[email-masked]>
>>             [email-masked] <mailto:[email-masked]>
>>         [email-masked]  <mailto:[email-masked]>

---

From: Qingsi Wang <[email-masked]>
Date: Tue, 20 Oct 2020 19:55:47 -0700

Hi Flemming,

I'm sorry for not being familiar with the process. In addition to editorial
revisions and addressing comments, are there other prerequisites for
publication?

Thanks,
Qingsi

On Tue, Oct 20, 2020 at 7:47 PM Flemming Andreasen <[email-masked]>
wrote:

>>>>> I believe this document is in fairly good shape and should be ready
>>>>> for last call soon. Any objections to taking it on in this working group?
>>>>>
>>>>> Justin

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 21 Oct 2020 10:33:52 -0400

It all depends on how mature the draft is, especially in terms of its 
technical content. Also, we will need a few reviewers to look closely at 
the draft to see if there are any issues the authors may not have 
thought of.

Cheers

-- Flemming

On 10/20/20 10:55 PM, Qingsi Wang wrote:
> Hi Flemming,
>
> I'm sorry for not being familiar with the process. In addition to 
> editorial revisions and addressing comments, are there other 
> prerequisites for publication?
>
> Thanks,
> Qingsi
>
> On Tue, Oct 20, 2020 at 7:47 PM Flemming Andreasen <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Thanks Justin. What do the authors view as a realistic timeframe
>     for getting the draft ready for publication ?
>
>     Cheers
>
>     -- Flemming
>
>>     On Thu, Oct 15, 2020 at 12:40 PM Justin Uberti
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>             willing to contribute to the work. Based on this, the
>>             chairs will work with our AD on getting a new milestone
>>             added.
>>
>>             I see that the current draft has expired though - can we
>>             get an updated version submitted first ?
>>
>>             Thanks
>>
>>>                 The proposal being implemented by various parties,
>>>                 having this document be reviewed and ironed out as
>>>                 much as possible is valuable.
>>>
>>>                 Thanks,
>>>                 Y
>>>
>>>>                 Is anybody else interested, and if so, are you
>>>>                 willing to contribute and/or review the document ?
>>>>
>>>>                 Thanks
>>>>
>>>>>                     I believe this document is in fairly good
>>>>>                     shape and should be ready for last call soon.
>>>>>                     Any objections to taking it on in this working
>>>>>                     group?
>>>>>
>>>>>                     Justin

---

From: Youenn Fablet <[email-masked]>
Date: Wed, 21 Oct 2020 16:48:38 +0200

I am also fuzzy about what it means to publish the draft.
It seems to me the document is ready for another version to be published.
To produce the final version that we expect to go to validation, we should probably finish resolving the 8 remaining issues and update the spec according the resolutions of these 8 issues.

> On 21 Oct 2020, at 16:33, Flemming Andreasen <[email-masked]> wrote:
> 
> It all depends on how mature the draft is, especially in terms of its technical content. Also, we will need a few reviewers to look closely at the draft to see if there are any issues the authors may not have thought of. 
> 
> Cheers
> 
> -- Flemming 
> 
> 
> 
>> I'm sorry for not being familiar with the process. In addition to editorial revisions and addressing comments, are there other prerequisites for publication?
>> 
>> Thanks,
>> Qingsi
>> 
>> On Tue, Oct 20, 2020 at 7:47 PM Flemming Andreasen <[email-masked] <mailto:[email-masked]>> wrote:
>> Thanks Justin. What do the authors view as a realistic timeframe for getting the draft ready for publication ? 
>> 
>> Cheers
>> 
>> -- Flemming 
>> 
>>> On Thu, Oct 15, 2020 at 12:40 PM Justin Uberti <[email-masked] <mailto:[email-masked]>> wrote:
>>> On Fri, Sep 18, 2020 at 9:13 AM Flemming Andreasen <fandreas=[email-masked] <mailto:[email-masked]>> wrote:
>>> It looks like we have at least 5 people interested in and willing to contribute to the work. Based on this, the chairs will work with our AD on getting a new milestone added. 
>>> 
>>> I see that the current draft has expired though - can we get an updated version submitted first ? 
>>> 
>>> Thanks 
>>> 
>>>> On Wed, Sep 2, 2020 at 11:51 AM Youenn Fablet <youenn=[email-masked] <mailto:[email-masked]>> wrote:
>>>> The proposal being implemented by various parties, having this document be reviewed and ironed out as much as possible is valuable.
>>>> 
>>>> Thanks,
>>>> 	Y
>>>> 
>>>>> On 2 Sep 2020, at 20:09, Flemming Andreasen <[email-masked] <mailto:[email-masked]>> wrote:
>>>>> 
>>>>> Is anybody else interested, and if so, are you willing to contribute and/or review the document ? 
>>>>> 
>>>>> Thanks 
>>>>> 
>>>>>> I am strongly in favor of adopting this draft to MMUSIC and getting it completed.
>>>>>> _____________
>>>>>> Roman Shpount
>>>>>> 
>>>>>> 
>>>>>> On Thu, Jul 30, 2020 at 7:33 PM Justin Uberti <juberti=[email-masked] <mailto:[email-masked]>> wrote:
>>>>>> Hi all,
>>>>>> 
>>>>>> With the closure of rtcweb, we have been advised to find a new forum for https://tools.ietf.org/html/draft-ietf-rtcweb-mdns-ice-candidates-04 <https://tools.ietf.org/html/draft-ietf-rtcweb-mdns-ice-candidates-04>, and MMUSIC seems like the best home for it.
>>>>>> 
>>>>>> I believe this document is in fairly good shape and should be ready for last call soon. Any objections to taking it on in this working group?
>>>>>> 
>>>>>> Justin
>>>>>> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
>>>>>> 
>>>>>> 
>>>>>> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
>>>>> 
>>>> 
>>>> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
>>>> 
>>>> 
>>>> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
>>> 
>> 
>> 
>> 
>> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
>

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 21 Oct 2020 11:03:34 -0400

By publication we mean that the draft is considered to be in the final 
ready state with no known issues, whether technical or editorial. At 
that point, the Working Group chairs will do (another) thorough review 
of the document, and if it looks ready then ask for publication of the 
document, which means it will be sent to the responsible Area Director 
for review, and subsequently to the IESG for further review and 
eventually it's published as an RFC.

Thanks

-- Flemming

On 10/21/20 10:48 AM, Youenn Fablet wrote:
> To produce the final version that we expect to go to validation, we 
> should probably finish resolving the 8 remaining issues and update the 
> spec according the resolutions of these 8 issues.
>
>> On 21 Oct 2020, at 16:33, Flemming Andreasen <[email-masked] 
>> technical content. Also, we will need a few reviewers to look closely 
>> at the draft to see if there are any issues the authors may not have 
>> thought of.
>>
>> Cheers
>>
>> -- Flemming
>>
>>
>>
>>> On Tue, Oct 20, 2020 at 7:47 PM Flemming Andreasen 
>>>>             It looks like we have at least 5 people interested in
>>>>             and willing to contribute to the work. Based on this,
>>>>             the chairs will work with our AD on getting a new
>>>>             milestone added.
>>>>
>>>>             I see that the current draft has expired though - can
>>>>             we get an updated version submitted first ?
>>>>
>>>>             Thanks
>>>>
>>>>>>>                     shape and should be ready for last call
>>>>>>>                     soon. Any objections to taking it on in this
>>>>>>>                     working group?
>>>>>>>
>>>>>>>                     Justin

---

From: Roman Shpount <[email-masked]>
Date: Wed, 21 Oct 2020 11:46:45 -0400

I would like to see if there any implementations of this draft on mobile
networks. I think this draft's interactions with mobile network deployment
scenarios, such as 464XLAT, should be examined in detail before this draft
is ready for publication. Also, mDNS is not currently supported on Android,
which represents a significant portion of this draft use case, making some
of the implementation details a bit fuzzy. My main concern here is if the
mDNS name which is associated with one IP address always resolves to the
same IP address with the same address family when resolved on the same
network.

Best Regards,
_____________
Roman Shpount

On Wed, Oct 21, 2020 at 11:04 AM Flemming Andreasen <fandreas=
[email-masked]> wrote:

> ready state with no known issues, whether technical or editorial. At that
> point, the Working Group chairs will do (another) thorough review of the
> document, and if it looks ready then ask for publication of the document,
> which means it will be sent to the responsible Area Director for review,
> and subsequently to the IESG for further review and eventually it's
> published as an RFC.
>
> Thanks
>
> -- Flemming
>
> To produce the final version that we expect to go to validation, we should
> probably finish resolving the 8 remaining issues and update the spec
> according the resolutions of these 8 issues.
>
> the draft to see if there are any issues the authors may not have thought
> of.
>
> Cheers
>
> -- Flemming
>
>
>
> editorial revisions and addressing comments, are there other prerequisites
> for publication?
>
> Thanks,
> Qingsi
>
>>>>> The proposal being implemented by various parties, having this
>>>>> document be reviewed and ironed out as much as possible is valuable.
>>>>>
>>>>> Thanks,
>>>>> Y
>>>>>

---

From: Justin Uberti <[email-masked]>
Date: Wed, 21 Oct 2020 22:54:50 -0700

This is currently supported in Safari iOS, and we are working to bring this
to Chrome Android as well.

On Wed, Oct 21, 2020 at 8:47 AM Roman Shpount <[email-masked]> wrote:

>> should probably finish resolving the 8 remaining issues and update the spec

---

From: Flemming Andreasen <[email-masked]>
Date: Mon, 26 Oct 2020 20:20:26 -0400

Going back to the original question: What do the authors view as a 
realistic timeframe for getting the draft ready for publication ?

Thanks

-- Flemming

On 10/22/20 1:54 AM, Justin Uberti wrote:
> This is currently supported in Safari iOS, and we are working to bring 
> this to Chrome Android as well.
>
> On Wed, Oct 21, 2020 at 8:47 AM Roman Shpount <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     I would like to see if there any implementations of this draft on
>     mobile networks. I think this draft's interactions with mobile
>     network deployment scenarios, such as 464XLAT, should be examined
>     in detail before this draft is ready for publication. Also, mDNS
>     is not currently supported on Android, which represents a
>     significant portion of this draft use case, making some of the
>     implementation details a bit fuzzy. My main concern here is if the
>     mDNS name which is associated with one IP address always resolves
>     to the same IP address with the same address family when resolved
>     on the same network.
>
>     Best Regards,
>     _____________
>     Roman Shpount
>
>
>     On Wed, Oct 21, 2020 at 11:04 AM Flemming Andreasen
>         By publication we mean that the draft is considered to be in
>         the final ready state with no known issues, whether technical
>         or editorial. At that point, the Working Group chairs will do
>         (another) thorough review of the document, and if it looks
>         ready then ask for publication of the document, which means it
>         will be sent to the responsible Area Director for review, and
>         subsequently to the IESG for further review and eventually
>         it's published as an RFC.
>
>         Thanks
>
>         -- Flemming
>
>>         To produce the final version that we expect to go to
>>         validation, we should probably finish resolving the 8
>>         remaining issues and update the spec according the
>>         resolutions of these 8 issues.
>>
>>>         On 21 Oct 2020, at 16:33, Flemming Andreasen
>>>         It all depends on how mature the draft is, especially in
>>>         terms of its technical content. Also, we will need a few
>>>         reviewers to look closely at the draft to see if there are
>>>         any issues the authors may not have thought of.
>>>
>>>         Cheers
>>>
>>>         -- Flemming
>>>
>>>
>>>
>>>>         I'm sorry for not being familiar with the process. In
>>>>         addition to editorial revisions and addressing comments,
>>>>         are there other prerequisites for publication?
>>>>
>>>>         Thanks,
>>>>         Qingsi
>>>>
>>>>             Thanks Justin. What do the authors view as a realistic
>>>>             timeframe for getting the draft ready for publication ?
>>>>
>>>>             Cheers
>>>>
>>>>             -- Flemming
>>>>
>>>>>                     It looks like we have at least 5 people
>>>>>                     interested in and willing to contribute to the
>>>>>                     work. Based on this, the chairs will work with
>>>>>                     our AD on getting a new milestone added.
>>>>>
>>>>>                     I see that the current draft has expired
>>>>>                     though - can we get an updated version
>>>>>                     submitted first ?
>>>>>
>>>>>                     Thanks
>>>>>
>>>>>>                         The proposal being implemented by various
>>>>>>                         parties, having this document be reviewed
>>>>>>                         and ironed out as much as possible is
>>>>>>                         valuable.
>>>>>>
>>>>>>                         Thanks,
>>>>>>                         Y
>>>>>>
>>>>>>>                         On 2 Sep 2020, at 20:09, Flemming
>>>>>>>                         Andreasen <[email-masked]
>>>>>>>                         Is anybody else interested, and if so,
>>>>>>>                         are you willing to contribute and/or
>>>>>>>                         review the document ?
>>>>>>>
>>>>>>>                         Thanks
>>>>>>>
>>>>>>>>                         I am strongly in favor of adopting this
>>>>>>>>                         draft to MMUSIC and getting it completed.
>>>>>>>>                         _____________
>>>>>>>>                         Roman Shpount
>>>>>>>>
>>>>>>>>
>>>>>>>>                             With the closure of rtcweb, we have
>>>>>>>>                             been advised to find a new forum
>>>>>>>>                             for
>>>>>>>>                             I believe this document is in
>>>>>>>>                             fairly good shape and should be
>>>>>>>>                             ready for last call soon. Any
>>>>>>>>                             objections to taking it on in this
>>>>>>>>                             working group?
>>>>>>>>
>>>>>>>>                             Justin
>>>>>>>>                             <mailto:[email-masked]>