Subject: Re: [MMUSIC] draft-holmberg-mmusic-rfc8843bis

From: Paul Kyzivat <[email-masked]>
Date: Fri, 2 Apr 2021 13:31:29 -0400

Regarding the following in section 7.3:

    ... In order to be backward compatible with
    offerers that implement that version of the specification, an
    answerer needs to accept such offers.

This isn't normative. Is it intended that this is non-normative - to 
simply be advisory to that want to be backward compatible?

And similar text in 7.4.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 2 Apr 2021 18:45:17 +0000

Hi,

> This isn't normative. Is it intended that this is non-normative - to simply be advisory to that want to be backward compatible?

That's one thing (maybe the only thing) where we may need some discussion. 

When I wrote the text, I was also thinking about a normative STRONGLY RECOMMENDED.

I don't know whether MUST or SHOULD would make much sense, as we know there are endpoints that don't implement it.

Regards,

Christer

---

From: Roman Shpount <[email-masked]>
Date: Fri, 2 Apr 2021 15:23:20 -0400

I would suggest that we make the processing of  m= lines with port zero and
a=bundle-only a SHOULD for all offers and answers. The reason for SHOULD is
that you probably can skip this if you know that all endpoints
which communicate with you implement the new specification, but there is
no strong reason for your endpoint not to support this. Implementation
wise, it should not be a big burden to implement support for port zero and
a=bundle-only everywhere.

Do you know any endpoints that generate m= lines with a=bundle-only and do
not support port zero in m= line in the answer? I am not aware of any.

Finally, in section 7.3.4: "The answerer includes an SDP 'bundle-only'
attribute in, and assigns a zero port value to, the video "m=" section." I
think this is no longer accurate.
_____________
Roman Shpount

On Fri, Apr 2, 2021 at 2:45 PM Christer Holmberg <christer.holmberg=
[email-masked]> wrote:

> I don't know whether MUST or SHOULD would make much sense, as we know
> there are endpoints that don't implement it.
>
> Regards,
>
> Christer
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 2 Apr 2021 20:22:26 +0000

Hi,

>I would suggest that we make the processing of  m= lines with port zero and a=bundle-only a SHOULD for all offers and answers. The reason for SHOULD is that you probably
>can skip this if you know that all endpoints which communicate with you implement the new specification, but there is no strong reason for your endpoint not to support this.
>Implementation wise, it should not be a big burden to implement support for port zero and a=bundle-only everywhere.

I don’t have a strong opinion – whatever makes the community happy.

>Do you know any endpoints that generate m= lines with a=bundle-only and do not support port zero in m= line in the answer? I am not aware of any.

I am not aware of such endpoint either.

>Finally, in section 7.3.4: "The answerer includes an SDP 'bundle-only' attribute in, and assigns a zero port value to, the video "m=" section." I think this is no longer accurate.

Correct. Good catch. I’ll fix that in the next version.

Regards,

Christer

On Fri, Apr 2, 2021 at 2:45 PM Christer Holmberg <christer.holmberg=[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic