Subject: RE: [Mobike] issue 34 proposal

From: [email-masked]
Date: Thu, 15 Sep 2005 07:54:00 -0400

Just to clarify...

If one does detect NAT change at ESP layer, what does one do?

Do we do a return routability check on the new address before updating
it's SADB?  It would seem logical, but just want to make sure we're on
the same page.

Stephane. 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Thursday, September 15, 2005 7:23 AM
> To: [email-masked]
> Subject: RE: [Mobike] issue 34 proposal
> 
> Jari Arkko wrote:
> > 
> > Tero Kivinen wrote:
> > 
> > >So perhaps we should say you MUST NOT do automatic update 
> with IKEv2 
> > >packets (breaks the probing), but you MAY do it for ESP packets?
> > >  
> > >
> > This would work for me (and the complexity cost would be 
> only on those 
> > implementations that actually do the MAY).
> 
> Sounds reasonable to me as well.
> 
> Best regards,
> Pasi
> _______________________________________________
> Mobike mailing list
> [email-masked]
> https://www.machshav.com/mailman/listinfo.cgi/mobike
> 
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Thu, 15 Sep 2005 13:02:27 -0700

I am assuming NAT change at ESP layer follows IKEv2 NAT-T i.e no return routability
check. Otherwise, the speedup obtained by the traditional IKEv2 NAT-T is lost and
there is no point in having this mechanism at all.

-mohan

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; "Tero Kivinen" <[email-masked]>; "Jari Arkko" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, September 15, 2005 4:54 AM
Subject: RE: [Mobike] issue 34 proposal

Just to clarify...

Stephane.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 15 Sep 2005 23:20:25 +0300

I think most of the speedup is in the detection part.

--Jari

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Thu, 15 Sep 2005 21:40:48 -0700

> I think most of the speedup is in the detection part.
Eventually, you want to recover faster too, right ? If it is going to take a roundtrip
extra compared to IKEv2 NAT-T before you can use the address, how slower
it is compared with the explicit update ?

-mohan

---

From: Francis Dupont <[email-masked]>
Date: Tue, 20 Sep 2005 12:27:27 +0200

In your previous mail you wrote:

   
=> this is not logical at all! The SADB should be updated ASAP and
the RR check doesn't help at all: it only adds delay, if the new address
is bad the next packet with a good address will fix the SADB.

Regards

[email-masked]
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Francis Dupont <[email-masked]>
Date: Tue, 20 Sep 2005 13:11:45 +0200

Mohan Parthasarathy wrote:
   
   >I am assuming NAT change at ESP layer follows IKEv2 NAT-T i.e no
   >return routabilitycheck. Otherwise, the speedup obtained by the
   >traditional IKEv2 NAT-T is lost and there is no point in having
   >this mechanism at all.

=> I believe you mean the detection is more efficient because there are
more ESP traffic, because the return routability check cost is one
full RTT (without RR check the delay is the mean time between two ESP
packets + 1/2 RTT).

Regards

---

From: Jari Arkko <[email-masked]>
Date: Tue, 27 Sep 2005 12:15:32 +0300

>it is compared with the explicit update ?
I would note that the return routability text is already
being performed based on policy (as agreed upon in
earlier issues). So it isn't clear to me that we need to
have an answer here.

--Jari