Subject: RE: [Mobike] RE: issue 34 -- ESP vs. IKE based NAT reboot detection

From: "Stephane Beaulieu (stephane)" <[email-masked]>
Date: Fri, 2 Sep 2005 07:59:04 -0400

> reboot detection
> 
> Tero Kivinen wrote:
> 
> >
> >This is the case with alternative 3. I.e. they are not 
> periodic, they 
> >are only sent when the host behind NAT (initiator) detects 
> that it is 
> >not receiving anything (snip)
> >
> True. But I guess you could say that when your device is 
> idle, the probes are being sent and are periodic... how much 
> that matters is a matter of opinion.

I don't understand why this has to be the case.  With DPD, if you have
no packets to send (i.e. you are idle), you don't do DPD.  You only do
DPD if you've sent X number of packets in the last Y seconds, and have
not received any in the same span of time.  The only situation where
this ends up being periodic is when you're sending uni-directional
traffic (which is rare in the real world).

Stephane.

> --Jari
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Jari Arkko <[email-masked]>
Date: Fri, 02 Sep 2005 15:05:50 +0300

>traffic (which is rare in the real world).
Sorry, I wasn't quite correct. It seems that we have
one timer for the case that there is traffic but we don't
seem to be getting answers. If we have no traffic to send
then we also have a timer, but the frequency of the
probes is much higher, and perhaps less likely to be
an issue. Finally, we have NAT keepalive
but that's a separate issue.

--Jari