Subject: RE: [Mobike] Issue 41: Mandate NAT prevention if not doing NAT-T?

From: <[email-masked]>
Date: Mon, 12 Sep 2005 18:10:59 +0300

Jari Arkko wrote:

> Is there an IPv6 - IPv4 translation type where the middle
> ground would be useful even for an IPv6 host?
> 
> If not, I would suggest leaving the middle ground away
> from v6 but allowing it in v4. ("NAT preventation SHOULD
> be enabled by default in IPv6 if NAT traversal is not enabled.")
> 
> If yes, then I think the current text might suffice.

To me it looks like IKEv2 w/tunnel mode IPsec could work through
"Basic-NAT-PT" type v4/v6 translation [RFC2766] (even if the
implementations don't support IKEv2 NAT-T).

(But I haven't gone through all the details.)

Best regards,
Pasi
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Francis Dupont <[email-masked]>
Date: Mon, 19 Sep 2005 17:15:01 +0200

In your previous mail you wrote:

   
=> for instance how the NAT-PT translates the inner header (:-).

[email-masked]
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike