Subject: RE: [Mobike] Issue 41: Mandate NAT prevention if not doing NAT-T?

From: <[email-masked]>
Date: Mon, 19 Sep 2005 18:42:06 +0300

Francis Dupont wrote:

>  In your previous mail you wrote:
> 
>    I'm curious, how exactly does RFC 3519 mitigate this issue?
>    
> => short lifetimes (so the attacker has to stay and increases its
> chance to be caught). The whole thing is explained in the security
> considerations...
> 
> [email-masked]
> 
> PS: mobike has no binding lifetimes (nor in fact bindings, its 
> support is for readdressing not mobility).

There's also an important difference to MIP4: there the tunnel
is not encrypted, so redirecting the traffic allows the attacker
to eavesdrop and modify the packets. 

In MOBIKE, this is mainly a DoS thing, and although we don't
have binding lifetimes, we do have dead peer detection and 
return routability check that force the attacker to stay there
to continue the attack forever.

Best regards,
Pasi
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Francis Dupont <[email-masked]>
Date: Mon, 19 Sep 2005 17:58:03 +0200

=> the main attack is to redirect a lot of traffic to a third party
in order to overload it or its access network... BTW IPsec doesn't
imply encrypted (even to encrypt is usually no more expensive so
the option is very often taken by default).

   In MOBIKE, this is mainly a DoS thing,

=> yes, and for DoS to be encrypted is better! I am afraid the common
traffic between two SGs is larger than between MN and HA.

   and although we don't

=> dead peer detection can be less than enough (cf bogus keepalive
stuff in RFC 3519).

=> yes, mobile ip and mobike have different weapons. My concern is
they share the same issue but the WGs react in very different ways.

Regards

---

From: Sami Vaarala <[email-masked]>
Date: Mon, 19 Sep 2005 22:27:10 +0300

Hi,

> they share the same issue but the WGs react in very different ways.

A quick comment:  if the attacker stays on the path, doing NAT
forever (i.e. allows peers to exchange packets), then it's not
really an attack.  It's just plain NAT.

At least in the MIPv4 context this becomes a relevant attack
*only* if the attacker (a) intervenes in the binding establishment
stage (acting as a NAT), and (b) then leaves the path.  The result
is either a defunct binding or a traffic flow redirected to a
victim.  If the attacker stays on and continues to perform the
NAT function, traffic flow is not changed.

Is there a difference in MOBIKE?  I.e. is this an attack if the
attacker stays on the path?

Best,

-Sami

---

From: Francis Dupont <[email-masked]>
Date: Tue, 20 Sep 2005 09:09:53 +0200

=> what I call the transient pseudo-NAT differs from a real NAT on:
 - it stays on the path only for the attack (transient)
 - it modifies only some packets belonging to a signaling protocol
 - it redirects a large bunch of traffic controlled by this signaling
   protocol.

   At least in the MIPv4 context this becomes a relevant attack
   *only* if the attacker (a) intervenes in the binding establishment
   stage (acting as a NAT), and (b) then leaves the path.

=> yes, this is the idea. One unpleasant property is the attack works
better if the signaling is more efficient (i.e., uses less messages).

   The result
   
=> the attack I describe is not the bogus NAT one. In mine
a small action has a great effect.

   Is there a difference in MOBIKE?

=> there is no real difference between IKE and MIP, both are signaling
which can be attacked as soon as NAT traversal is enabled.

   I.e. is this an attack if the attacker stays on the path?
   
=> yes but this is a different one.

BTW the implicit update of NAT traversal is a good defense against the
attack: as soon as a packet from the end behind the NAT is not modified,
its peer jumps to the right address. This is one of the reasons I believe
the SHOULD for the implicit update can be made stronger.

Regards

PS: I explain the attack in draft-dupont-transient-pseudonat-04.txt
(expired because my interest is not in the attack itself but to get
proper defense in signalings).
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike