Subject: (mobile-ip) Newbie Question re Mobile IP and ARPing

From: Christopher H Mills <[email-masked]>
Date: Thu, 26 Mar 98 13:13:19 -0500

If a Home Agent may use gratuitous ARP to reflect the
fact that a mobile has roamed away from its home subnet,
why can't a Foreign Agent when a mobile roams away from
the foreign subnet back home? Couldn't the FA just 
gratuitously ARP, and from then on receive and forward
packets on that sub-net over to whatever agent currently
was serving the mobile?  I understand that's not an ideal 
scenario, but it seems to me that the benefit of allowing
a mobile to ARP on a foreign network might outway the 
downsides.
     Chris Mills
     Communication Technologies Center
     M/A-COM, An AMP Corporation
     [email-masked]

-----------------------------------------------------------------------------
IETF Mobile IP Working Group Mailing List - Archives:  software.watson.ibm.com
Unsubscribe:	unsubscribe mobile-ip		(as message body, not subject)
Direct all administrative requests to [email-masked]

---

From: Xinhua Zhao <[email-masked]>
Date: Thu, 26 Mar 1998 13:32:53 -0800

> a mobile to ARP on a foreign network might outway the 

Is the mobile host using the care-of address provided by the foreign
agent? If so, packets addressed to the mobile host's home address
will be tunneled to the foreign agent first (i.e. the destination
address field in the outer IP header is the IP address of the foreign
agent) by the home agent or the correspondent host directly if routing
optimization is implemented. Therefore, the packets will be delivered 
to the foreign agent with no need for gratuitous ARPs.

-- Xinhua Zhao 
MosquitoNet Project on Mobile and Wireless Computing
Stanford University
http://MosquitoNet.Stanford.EDU

---

From: "Wolfgang Sch�nfeld" <[email-masked]>
Date: Fri, 27 Mar 1998 09:09:59 +0100

>      M/A-COM, An AMP Corporation

You may have a look at the Globecomm '97 paper by
Alessandra Giovanardi and Gianluca Mazzini, "Transparent Mobile Ip: an
Approach and Implementation" 
which elaborates a similar (?) idea.
-- 
Wolfgang Schoenfeld
GMD-IPSI, Dolivostr. 15, Zimmer 118, D-64293 Darmstadt
+49-6151-869-865 (Phone), -818 (FAX)
-----------------------------------------------------------------------------
IETF Mobile IP Working Group Mailing List - Archives:  software.watson.ibm.com
Unsubscribe:	unsubscribe mobile-ip		(as message body, not subject)
Direct all administrative requests to [email-masked]

---

From: Chan Kwang Mien <[email-masked]>
Date: Sat, 28 Mar 1998 22:03:36 +0800 (SST)

hi all,

   Can anyone tell me where i can get papers related to the Bi-directional
Tunnelling scheme for multicasting as stated in RFC 2002 ?

   Thanks.

regards,
KWang Mien

---

From: Dave Johnson <[email-masked]>
Date: Sat, 28 Mar 1998 15:13:56 -0500

>a mobile to ARP on a foreign network might outway the 

A mechanism similar to this is part of the Route Optimization
extensions to the Mobile IP protocol, and is a built-in part of
the Mobile IPv6 protocol.  However, ARPing is not necessary, since
the foreign agent already gets all the packets addressed to the
mobile node, tunneled to it either by the correspondent node
or by the mobile node's home agent.  The hard part of all of this, 
though, is authenetication: how does the foreign know where to
forward the mobile node's packets?  Who tells it the new location,
and why should the foreign agent believe this when told?  If
this is not done securely, the protocol is then open to attackers
who could trick a foreign agent into forwarding a mobile node's
packets to anywhere of the attacker's choice.  Route Optimization
and Mobile IPv6 have the necessary authentication in the protocol.

					Dave

--
David B. Johnson                      E-mail: [email-masked]
Assistant Professor                   Home page: http://www.cs.cmu.edu/~dbj/
Computer Science Department           Phone: (412) 268-7399
Carnegie Mellon University            Fax: (412) 268-5576
5000 Forbes Avenue
Pittsburgh, PA  15213-3891

---

From: Chan Kwang Mien <[email-masked]>
Date: Sun, 29 Mar 1998 11:23:02 +0800 (SST)

Hello Dave,

> and Mobile IPv6 have the necessary authentication in the protocol.

   I would like to know how reliable is the authentication used in Mobile
IPv6 and Route Optimization ? Are there any overheads incurred if such an
authentication is being used ?

rgds,
Kwang Mien