Subject: [MOBILE-IP] Mobile-IP DIAMETER Extension - New rev

From: [email-masked]
Date: Thu, 5 Aug 1999 14:16:02 -0700

First, I want to appologize for the cross-post, but it seemed like a good idea.

I have just finished cleaning up the Mobile-IP Extension draft, and it is now
available at www.diameter.org. I would like to appologize for the poor state that the web page is in, but I really have not had time to clean it up very much (hey, it's only been a day).

Most of the fixes in the draft were related to issues and clarifications needed as a result of the bake-off. However, there are a few that are a result of minor changes to the base protocol, which is also available on the web site.

I would like to get initial feedback before I send it out to the secretariat.

I am including a list of the changes made to the spec below.

PatC

1.2  Changes in version -03

   The following are the changes done to version 03 of the draft:

      - Cleaned up the AVP Header flags

      - The Command Code sections now show an optional Proxy-State AVP
      as part of the message format.

      - The previous version required that the MIP-Registration-Reply be
      present in the AMA, but the AVP could not be present if the AAAH
      could not service the request. The AVP is now only mandatory if
      the AMA is successful.

      - Cleaned up the description of the various key and SPI AVPs.

      - Added text in section 4.1 that describes how the AAAH can cache
      the keys directed for the AAAF so they can be included in the
      message when the response is received by the HA. This was the
      point that cause interoperability at the bake-off due to the fact
      that it was quite unclear.

      - Section 4.1 now correctly states that the Home-Address AVP MUST
      be present and MAY have a value of 0.0.0.0.

      - Section 4.1 now also states that the Mobile-IP FA-HA and the MN-
      HA authentication extensions must be used.

      - Added a reference to ESP

      - Added IANA Considerations

---

From: Haseeb Akhtar <[email-masked]>
Date: Thu, 5 Aug 1999 16:28:13 -0500

Pat,

What about merging AMR/HAR and AMA/HAA together into just two messages? That
is leave AMR and AMA, delete HAR and HAA? AAA server does not need to create
a state to remember that AMR will have to be mapped into HAR and vice versa.
All the functionality of HAR/HAA can easily be deployed with AMR/AMA.

What do you think?

Regards,

Haseeb

> -----Original Message-----
> From: [email-masked] [SMTP:[email-masked]]
> Sent: Thursday, August 05, 1999 4:16 PM
> To:   [email-masked]
> Subject:      [MOBILE-IP] Mobile-IP DIAMETER Extension - New rev
>
> available at www.diameter.org. I would like to appologize for the poor
> state that the web page is in, but I really have not had time to clean it
> up very much (hey, it's only been a day).
>
> Most of the fixes in the draft were related to issues and clarifications
> needed as a result of the bake-off. However, there are a few that are a
> result of minor changes to the base protocol, which is also available on
> the web site.
>

---

From: [email-masked]
Date: Thu, 5 Aug 1999 16:28:06 -0700

>All the functionality of HAR/HAA can easily be deployed with AMR/AMA.

Haseeb,

Yes I do remember talking about this and I tentatively agreed to make the change. This was obviously not part of the bake-off. I have no real issue with making this change, but I want to make sure that everyone else (that cares) is also in agreement.

Any comments, objections, flames from the rest of the WG?

PatC

---

From: [email-masked]
Date: Fri, 6 Aug 1999 10:00:56 -0700

Haseeb,

I have been thinking a little about this one, and I do have a question. The AMR and the HAR both require different AVPs to be present, as does the HAA and the AMA. Therefore, if we combine both of these messages into one, it would increase the complexity of the implementation in trying to determine the intent of such a message.

Could you provide me with a reasonable argument for merging both command codes. I am sorry to bring this up so late in the game, but this just occurred to me.

BTW, It is not clear to me that this is the correct forum to discuss design of DIAMETER extensions given that the WG has not yet accepted any specific protocols, but I also cannot think of where else it could be discussed. Perhaps the DIAMETER mailing list?

Thanks

PatC

---

From: Russ Coffin <[email-masked]>
Date: Mon, 9 Aug 1999 09:46:44 -0500

Pat - I am impressed by the amount of testing, fixing, and re-protocoling
was done at the bakeoff - I think all participants should be thanked and
congratulated. I believe that the bakeoff results will be key in the
deployment ramp of IP Mobility.

Cheers - Russ

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, August 05, 1999 04:16 PM
To: [email-masked]
Subject: [MOBILE-IP] Mobile-IP DIAMETER Extension - New rev

First, I want to appologize for the cross-post, but it seemed like a good
idea.

I have just finished cleaning up the Mobile-IP Extension draft, and it is
now
available at www.diameter.org. I would like to appologize for the poor state
that the web page is in, but I really have not had time to clean it up very
much (hey, it's only been a day).

Most of the fixes in the draft were related to issues and clarifications
needed as a result of the bake-off. However, there are a few that are a
result of minor changes to the base protocol, which is also available on the
web site.

I would like to get initial feedback before I send it out to the
secretariat.

PatC