Subject: [MOBILE-IP] THEMA and GRE

From: "G. Ensuque" <[email-masked]>
Date: Thu, 19 Aug 1999 11:02:32 +0100

Hi all

This is a question to the THEMA gurus.

I don't really understand why we need Tunnel IDs in THEMA. Is this to make
it look more like GPRS's GTP?

Also, in what field exactly are Tunnel IDs inserted in the GRE header?

Thanks in advance for all answers

Guilhem Ensuque

Mobility Futures Unit                           [email-masked]
B55-131B
BT Advanced Communications Technology Centre
Adastral Park, Martlesham Heath
IPSWICH IP5 3RE                              Tel: +44 1473 645 232
UK                                                   Fax: +44 1473 646 885

---

From: Pete McCann <[email-masked]>
Date: Tue, 24 Aug 1999 11:52:08 -0500

Hi, Guilhem,

"G. Ensuque" <[email-masked]> (GE) writes:

GE> Hi all
GE> This is a question to the THEMA gurus.

GE> I don't really understand why we need Tunnel IDs in THEMA. Is this to make
GE> it look more like GPRS's GTP?

Not really - the Tunnel IDs are to distinguish MNs that might have
overlapping private addresses.  Any similarity to GTP is purely
coincidental.

GE> Also, in what field exactly are Tunnel IDs inserted in the GRE header?

In the Key field of the GRE header.

-Pete