Subject: Re: [MOBILE-IP] 3G RAN and IP mobility

From: "G. Ensuque" <[email-masked]>
Date: Fri, 27 Aug 1999 10:28:30 +0100

Andrew,

Sorry for the irony, I don't want to ignite a flame war and I should have
acknowledged the fact Cellular IP comes from Columbia.

Especially that I totally agree with your views and have great hopes for
technologies like cellular IP which I think have the potential to provide a
unified IP mobility mechanism for the future heterogeneous wireless
environment where macro CDMA (FDD) will co-habit with both kegacy TDMA 2G
and pico cellular '4G' such as TDD-CDMA, Hiperlan (1 and 2), IEEE 802.11 at
5GHz, Bluetooth...

My comment came from the fact that I find AAL2 switching horrible and that
the rationale behind it is supported by people from the same Hungarian team
as Andras Valko:

see 'Applying ATM/AAL2 as a Switching Technology in 3rd Generation Mobile
Access Networks' IEEE Comms Mag, June 99, by G. Eneroth, G. Fodor, G.
Leijonhufvud, A. Racz, I. Szabo

A paper by Andras Valko is even referenced to support AAL2 switching ('Voice
QoS in 3rd Generation Mobile Systems' by A. Valko, A. Racz and G. Fodor, to
appear in JSAC)

Guilhem

> -----Original Message-----
> From: Andrew T. Campbell [SMTP:[email-masked]]
> Sent: 27 August 1999 13:26
> To:   [email-masked]
> Cc:   [email-masked];
> [email-masked]
> Subject:      Re: [MOBILE-IP] 3G RAN and IP mobility
>
>
> Hello  Guilhem:
>
> "G. Ensuque" wrote:
> >
> > Hi all
> >
> > on the question of 3G frame selection/distribution...
> >
> > I find it a bit ironical that it is the same team that has proposed AAL2
> > switching for the RAN in UMTS (I don't know how this is handled in
> > Cdma2000), and Cellular IP in this working group (Ericsson Traffic
> Analysis
> > and Network Performance Laboratory, Budapest, Hungary).
> >
>
> For the record your irony is tadd misplaced old chap.
>
> Cellular IP is a project between Columbia University
> with support from industry. Cellular IP has no notion of
> circuits/ adaptation layers or influence there of. Its a layer
> 3 routing protocol that supports fast handoff
> and passive connectivity for packet data developed at
> Columbia initially with Andras Valko (Ericsson) and other Ph.D.
> students including Javier Gomez, Chieh-Yih Wan and
> Sanghyo Kim. It is a key part of Andras'
> thesis which he completed at Columbia. His thesis
> will be available later this fall on the Cellular IP
> web page - once he is through the process.
>
> The Cellular IP Project at Columbia
> has nothing to do with AAL2 or the push for
> that in RAN. Cellular IP and ATM/AAL2 in
> the same breath - what a slur ;-)
>
> As a footnote Columbia University will release the source code
> for Cellular IP to the public domain this fall and hope to
> demonstrate the network at MOMUC99. The code for the testbed and
> NS2 environments will be available as freeware. The Cellular IP Project
> at Columbia is broadly investigating the notion of a
> "IP-based mobile telecommunication networks" that take a different
> tact from 2.5/3G approaches. We are working on support for
> wireless IP QOS and middleware services. The Cellular IP project
> is more broadly supported by Ericsson, Intel and IBM.
>
> On a *personal* note I think ATM/signaling is a very poor choice for the
> RAN
> and wireless in general. Cellular IP's soft-state
> routing/switching would give good handoff performance
> and one can build wireless IP QOS on that foundation too.
> In addition there is no explicit signaling; so
> SS7 et al evaporates. I have always considered
> that Cellular IP could be refined for the mobile, RAN, core and
> gateways as a basic transport and (in-band) signaling technology.
>
> We have recently published a paper on some simulation results
> of the protocol. We hope to publish results from our testbed
> demonstrator (which are very promising in terms of performance)
> in due course.
>
> The NS2 paper is not on our project page but you will find the
> PDF file on my pubs page. Look for:
>
> "On the Analysis of Cellular IP Access Networks" , Proc. 6th IFIP
> International
> Workshop on Protocols for High Speed Networks , Salem, 25-27 August
> 1999.
>
> Thanks for listening.
>
> --
> Andrew
> http://comet.columbia.edu/~campbell

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Fri, 27 Aug 1999 05:47:42 -0700

I once worked on ATM, before that x.25, before that I
built sand castles on the beach an Blackpool. So what!