Subject: [MOBILE-IP] Cellular IP Source Code Distribution

From: "Andrew T. Campbell" <[email-masked]>
Date: Fri, 19 Nov 1999 10:27:27 -0800

Recent initiatives to add mobility to the Internet
and packet data services to third generation cellular
systems are being considered by mobile service providers
as possible candidate technologies for the delivery
of IP data to mobile users. Both of these candidate
technologies have shortcomings, however. Mobile IP represents
a simple and scalable global mobility solution but lacks
support for fast handoff control and real-time
location tracking  found in cellular networks today. In contrast,
third generation cellular systems offer seamless
mobility support but are built on complex and costly
connection-oriented networking infrastructure
that lacks the inherent flexibility, robustness
and scalability found in IP networks.

Cellular IP attempts to combine the strengths of both
approaches without inheriting their weaknesses. Cellular IP
provides micro-mobility support interworking
with Mobile IP (which provides macro-mobility support).
Cellular IP also inherits a number of important
cellular system design principles which we consider
fundamental to the development of wireless ISPs.

The source code distribution for Cellular IP is freely
available and can be found at:

  http://comet.columbia.edu/cellularip/

The release is for FreeBSD. New Aironet and WaveLAN
device drivers for the high speed wireless access (i.e.,
10 Mpbs) are provided too with low level APIs.

The web page shows how a Cellular IP testbed
can be constructed from off-the-shelf
computer kit to support Cellular IP gateways,
base stations and mobile hosts: no need to
buy expensive MSCs/BSCs to get up an running ;-)

The web page provides extensive documentation on
the protocol, programming environment
and testbed construction and performance
including the latest Internet-Draft presented
last week at IETF.

--
Andrew
http://comet.columbia.edu/~campbell

---

From: Charles Perkins <[email-masked]>
Date: Fri, 19 Nov 1999 09:08:37 -0800

Hello Andrew,

I have a bone to pick with you (and with others who have
made similar statements) ...

>                                   Mobile IP represents
> location tracking  found in cellular networks today.

This statement, which I have heard from many people, is
not technically correct.  It would be better to say
that "Mobile IP does not _mandate_ fast handoff", and
that "Mobile IP allows wide latitude for the time granularity
of location tracking".  I hope you will agree that the
two formulations are essentially different.  The result
of your formulation is, I think, misleading to many
people.  Reading your formulation, people might think
that Mobile IP _inherently_ suffers from poor handoff
performance.  They might think that Mobile IP _inherently_
has poor real-time performance.  Both of these are false.

As an example, using eager cell switching (ECS), we managed to
make Mobile IP work with smooth handovers, losing _zero_
packets.  Depending upon the characteristics of the physical
medium, it's no problem, and follows naturally from RFC 2002
(with the appropriate interpretation to allow the use of ECS).

Any statement containing the words "real time" is, as you
well know, a red flag begging for clarification and delineation
of the desired real-time behavior.  As an example of how
Mobile IP enables very tight real-time behavior without any
changes to RFC 2002, suppose we have a good layer 2
protocol that supplies timely information about media
conditions.  This is permitted, of course, by RFC 2002 --
in fact, it is encouraged and the protocol was specifically
designed to support such layer 2 protocols.

Then getting Mobile IP to work in real time is just a matter
of system design.  It is possible (in fact likely) that managing
tunnel drivers to work well, and getting authentication to work
well, will need close attention in the system design.  But that
is not really a problem with RFC 2002.

Thus, I strongly request that you modify your advertisement for
Cellular IP to reflect these considerations about how it might
possibly be misleading to uninitiated observers.

> with Mobile IP (which provides macro-mobility support).

This statement might imply that Mobile IP is inappropriate
for handling "micro-mobility".  I have seen no such evidence.
It is true that Mobile IP can be _replaced_ in some scenarios
by other protocols that may _already_ be doing the job of
Mobile IP in those scenarios.  I have not seen evidence to
indicate that those replacement protocols do a _better job_
than could be done by Mobile IP, except insofar as traversing
the Internet for interaction with the home agent can take too
long.  For reducing that delay, very simple modifications to
the Mobile IP registration request message are appropriate,
and all schemes posit the existence of a local agent that
has proxy registration authority to relieve the need for
delivering registration packets over the Internet.

Thus, I would replace "micro-mobility" management with
"localized registration" management, to more precisely
focus on the right problem.

Thanks for listening to my requests for clarification!

Regards, and have a great day!
Charlie P.

---

From: Behcet Sarikaya <[email-masked]>
Date: Sat, 20 Nov 1999 12:28:44 +0900

Hi Charlie,
  Thanks for your views.
  I think that Cellular IP and later Hawaii propose to use host-based
routing (host-based routing and paging caches)
in order to solve the deficiencies of
the base protocol, Mobile IP applied to cellular networks. Both
approaches also came up with a different signalling
which represented complete redesign of Mobile IP. This certainly raises
a lot of concerns when Mobile IP was just beginning
to be deployed seriously. I think that Hawaii somewhat corrected the
problem by making their protocol Mobile IP compatible.
   I have some questions basically aiming at further clarifications on
this issue:
You have not made any statement on the Hawaii approach which is quite
similar to the Cellular IP,
do you think that by incorporating Mobile IP signalling compatibility,
such proposals become more acceptable?

--
Behcet Sarikaya

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Wed, 24 Nov 1999 12:00:45 -0800

Hi Charlie:

Thanks for you your note.

Apologies for the delay in responding. I have just returned
from what seemed like endless back-to-back meetings.

Let me try and address your comments 'shotgun' style.

First, let me say that I think Mobile IP is a very neat
protocol and represents great effort on behalf of the
working group - and you and Dave and others should be
congratulated for that. My note was not intentionally
disparaging toward the protocol - if it was then
many apologies. I would like to see Mobile IP
widely deployed and widely used. Getting it widely
deployed is easy, getting widely used more problematic.
Let me rant at little here to explain my line of
thought. Apologies if I offend .. in advance.

Second, there has been a wealth of proposals on
micro-mobility protocols that interwork with Mobile
IP. You among others have authored an I-D in this area. The
protocols are too numerous to list, (e.g., HFA, Hawaii,
Cellular IP, and others). These protocols are motivated
by well known limitations (some contentious some red herrings
some right-on) of Mobile IP al la RFC 2002. Charlie
there is no smoke without fire, right?

Let be straight here. When Mobile IP was initially
designed there was no urgency for fast handoff in support of
pico cellular/PAN environments for example. There was a need to
make as few assumptions about the radio environment as possible.

Others including myself have called for more broad
support of other requirements, e.g., scalable tracking
that can differentiate between active and idle users:
in the case of Cellular IP that means using per mobile
routing soft-state at the edge networks in support
of fast and scalable handoff and implicit paging for quickly finding
idle mobile hosts. (Many of the proposals have commonalties).

Other protocols address the scaling issues
to do with the excessive generation of control messaging in
support of a Mobile IP everywhere and fast handoff.
Still others target private addressing schemes.
Others want to emulate the cellular system
as it stands today. Still others think
Mobile IP can be tailored to operate globally and
scalably in different settings (scaling from micro
to macro support). There is a broad church of
interest and proposals that indicate Mobile IP is
not set in stone. The question is: can Mobile IP
be simply made configurable and as new requirement come
along all we need to do is tune a few knobs and
viola we are in business? I think not.

Some of the micro-mobility proposals are evolutionary
variants of Mobile IP operating at multiple levels others more
revolutionary (this is a bad term) seeking broader
support beyond fast handoff requirements. For example, Cellular IP
can handoff in 4 msec between bases wihout loosing a packet at 60
handoffs/
second (using semi-soft/delay devices handoff). But we are also
interested
in other issues beyond fast handoff. A protocol that could operate at L2
and L3
for example. Support for active/idle users. Support for QOS, etc.
Again our agenda at Columbia is not simply fast handoff. One can achieve
fast handoff with Mobile IP (as you indicate) when it is
tuned accordingly: setting appropriate timers, driving handoff based
on the radio conditions. And that is what some of the more
synergistic macro-mobility protocols call for. I think
fast handoff is part of the picture but not the end game.

-- Warning what follows may irritate - these are my opinions only --

Its consensus time. If we feel Mobile IP is
all set and can handler future mobile user, wireless ISP's and
celcos/vendors
needs then the WG should kill the micro-mobility initiative.
Clearly the new charter which I think is excellent does
not indicate its lights out time.

However, I believe that we understand issues in 99/00 that
were not evident in the early 90's when Mobile IP was
emerging.

If we do not addresses these issues I believe we
will end up in the following end game: i) the celcos
- who on the whole don't really understand packet networks (apologies
celcos I
have my asbestos pants on ready to go ;) - will follow
their 3G noses and we will end up with gateways to core and edge access
networks based on the costly, inefficient and defunct
connection-oriented
paradigm (please don't come back with what about GPRS please, else
you miss the point) - many of these guys can't think beyond this; and
ii) the IETF don't understand or appreciate the amazing success of
cellular and
how well these networks are engineered and the paradigms
that make them tick (apologies Mobile IP WG I
have my asbestos pants on ready to go ;) - you may appreciate this
now you are with Nokia ;-) The working group on the whole
do not appreciate the radioheads view of the world (that is not
to say I am any the wiser Charlie).

If these two groups don't communicate and understand and
appreciate each others views, business goals
and agendas we will end up with: i) Mobile IP being
the most widely deployed protocol next to RSVP
that is rarely used; and  ii) Wireless
Internet will degenerate to 3G gateways to cellular networks built on
circuits, ATM and WAP and all that ...

-- end of warning --

Happy Thanksgiving Charlie.

Best,
Andrew

---

From: Charles Perkins <[email-masked]>
Date: Wed, 24 Nov 1999 10:13:09 -0800

Hello Andrew,

> disparaging toward the protocol

I did not take your advertisement as disparaging to Mobile IP
in general.  I only thought that it might have been interpreted
to mean certain things that I don't think are true.  Specifically,
I would like to see clarifications in consideration of my following
claims:

1. Mobile IP is not _necessarily_ prone to dropping packets, and
2. Mobile IP _can_ meet the delay bounds required by some
   real-time applications.

I wish this had been clearer in my previous note.

> there is no smoke without fire, right?

As I understand it, the proposals are aimed at improving
Mobile IP's performance in specific situations that amount
to pre-existing conditions.  That's different than claiming
that Mobile IP has the inherent limitations that are sometimes
imputed to it.

> make as few assumptions about the radio environment as possible.

Rather, I would say that _any_ layer 3 protocol should be designed
to work in the general setting appropriate for most layer 2 protocols,
and then specific adjustments made for particular layer 2 protocols.
In this context, I think the works you cite can be better understood.