Subject: [MOBILE-IP] THEMA & 3Gwireless

From: Zhao Ji-An <[email-masked]>
Date: Sat, 6 Nov 1999 11:41:43 +0800

Hello All,

When comparing

Transparent Hierarchical Mobility Agents (THEMA) and

Mobile IP Based Mocro Mobility Management Protocol in
the Third Generation Wireless Network (3Gwireless),

we can find there are much similarities.
In my understanding, the function of PDSN in 3Gwireless
is just the same as that of foreign agent SA in THEMA,
except that in 3Gwireless there is only one hop
from the FA to MN
while in THEMA there might be several hops.

My question is, if we have THEMA, do we have any
advantage to use 3Gwireless?
Also, it seems 3Gwireless provides a solution to
integrate CDMA2000 radio networks with Mobile IP,
but actually the micro mobility is managed within
the CDMA2000 networks.
Is it more appropriate to change the 3Gwireless
title to

Integration of the Third Generation Wireless Network
with Mobile IP

Please correct me if my understanding is wrong.
Thanks,

Zhao Jian

Department of Computer Science
Hong Kong University of Science & Technology
Hong Kong

---

From: Pete McCann <[email-masked]>
Date: Mon, 8 Nov 1999 09:52:34 -0600

Hi, Zhao,

You are right, THEMA and the 3Gwireless draft are very similar in many
respects.  The main difference is that in the 3Gwireless proposal,
link-layer data is tunneled to the FA instead of plain IP packets.
This enables a more transparent form of mobility within a domain than
with THEMA, in that a user's PPP state machine is not disturbed as a
MN moves from one RAN to another.

As MNs become more tolerant of PPP resetting itself, the 3Gwireless
draft would allow you to terminate PPP earlier (in the RAN) and to
tunnel plain IP packets.  Then the situation looks almost identical to
THEMA.  However, it is currently a requirement in the 3G cellular
environment to give a "reasonable" level of mobility service to MNs
that lack Mobile IP clients and that do not tolerate PPP reset very
well.  This means extending the coverage area of a PPP session to
be somewhat more than that of a single RAN.

You are right to point out that we are really "integrating" cdma2000
networks with Mobile IP.  Neither THEMA nor 3Gwireless is designed to
be an inter-domain mobility solution; rather, they are intended to be
used as standard interfaces to a Mobile IP FA within one carrier's (or
a small, mututally trustworthy group of carriers') network.  I don't
know if the title should be changed, but we can certainly discuss this
more during (well, hopefully after) the draft's presentation.

-Pete

Zhao Ji-An <[email-masked]> (ZJ) writes:

ZJ> Hello All,
ZJ> When comparing

ZJ> Transparent Hierarchical Mobility Agents (THEMA) and

ZJ> Mobile IP Based Mocro Mobility Management Protocol in
ZJ> the Third Generation Wireless Network (3Gwireless),

ZJ> we can find there are much similarities.
ZJ> In my understanding, the function of PDSN in 3Gwireless
ZJ> is just the same as that of foreign agent SA in THEMA,
ZJ> except that in 3Gwireless there is only one hop
ZJ> from the FA to MN
ZJ> while in THEMA there might be several hops.

ZJ> My question is, if we have THEMA, do we have any
ZJ> advantage to use 3Gwireless?
ZJ> Also, it seems 3Gwireless provides a solution to
ZJ> integrate CDMA2000 radio networks with Mobile IP,
ZJ> but actually the micro mobility is managed within
ZJ> the CDMA2000 networks.
ZJ> Is it more appropriate to change the 3Gwireless
ZJ> title to

ZJ> Integration of the Third Generation Wireless Network
ZJ> with Mobile IP

ZJ> Please correct me if my understanding is wrong.
ZJ> Thanks,

ZJ> Zhao Jian

ZJ> Department of Computer Science
ZJ> Hong Kong University of Science & Technology
ZJ> Hong Kong