Subject: Re: [MOBILE-IP] Reverse Tunneling updates?

From: Vipul Gupta <[email-masked]>
Date: Thu, 18 Nov 1999 16:29:47 -0800

If we take this sort of reasoning to the next level, we would
  want to mandate that that *all* Mobile IP FA's *always* enable
  reverse tunneling and always *require* mobile nodes to use
  reverse tunneling. I hope we agree that an IETF standard should
  not dictate such configuration.

  Like I said before, it is perfectly ok for TR45.6 or another
  consumer of Mobile IP technology to come up with a requirements
  profile that is more stringent than the RFC. If tomorrow we
  find a deployment scenario where support for simultaneous
  bindings is very useful, is that justification enough to
  make that a requirement for *all* HAs?

  Am I the only one who feels this way :-)

  vipul

> Vipul
> The concern is dual mode device roaming between wireless WAN and wireless LAN.
> This wont work.
>
> --Yingchun
>
>
>
>
> Vipul Gupta <[email-masked]> on 11/18/99 02:14:09 PM
>
> Please respond to Vipul Gupta <[email-masked]>
>
> Sent by:  Vipul Gupta <[email-masked]>
>
>
> To:   [email-masked]
> cc:    (Yingchun Xu/MW/US/3Com)
> Subject:  Re: [MOBILE-IP] Reverse Tunneling updates?
>
>
>
>
> > Hi, Vipul,
> > At 08:56 AM 11/18/99 -0800, Vipul Gupta wrote:
> > >> So my opinion is that mandating reverse tunnelling support at the HA
> > >> is okay but should be optional at the FA.
> > >>
> > >> -Basavaraj
> > >
> > >  I agree. I also don't understand the stance that because some
> > >  feature is felt to be important for mobile ip deployment in
> > >  one scenario (TR45.6 in this case), it become an absolute
> > >  requirement for the protocol itself. For wireless LANs within
> > >  an organization (think of a company network that has many
> > >  802.11 cells), mandatory reverse tunneling represents an
> > >  unnecessary processing burden.
> > >
> > >  It is perfectly ok for TR45.6 specs to call out requirements
> > >  that are more stringent than RFC 2002.
> >
> > I belive that this *mandatory* is for FA's implementation(FA needs to
> > support this feature), not in the sense that FA still does the Reverse
> > Tunneling even the MN doesn't acquire it.
>
>    Yes, I realize this but the point is FAs that do not implement
>    reverse tunneling are still useful and I don't see the need to
>    make this a requirement.
>
>    vipul
>
> > Correct me if wrong
> >
> > BR,
> > Qiang
> >
> >
> > >
> > >  vipul
> > >
> > >
> >
>
>
>
>

---

From: Gopal Dommety <[email-masked]>
Date: Thu, 18 Nov 1999 17:36:01 -0800

Implementing Reverse Tunneling at the FA is different from saying that
everyone  has  to reverse tunnel.  IETF  should  not dictate  that all
mobiles have to always use reverse tunnenling. However, there can be a
way of indicating to the   mobile that reverse tunneling is  mandatory
(e.g, in the advertisement). By this method PDSNs can enforce (if they
like) that all registrations have reverse tunnel bit set.

-Gopal

>   Am I the only one who feels this way :-)

I agree with you. Just have been swamped with work :)

-Gopal