Subject: [MOBILE-IP] Reverse Tunneling updates?

From: Charles Perkins <[email-masked]>
Date: Fri, 12 Nov 1999 12:55:44 -0800

Hello,

During the recent Mobile IP working group meeting, I raised the
question about whether Reverse Tunneling should be considered
a mandatory feature for implementation by mobility agents.  There
are several considerations that bear discussion.

First, the question can be subdivided.  It would be simple to
require that all home agents support reverse tunneling.  I think
we should impose this requirement.  Very little additional
implementation burden is created, and the payoff is considerable.

In addition, we could consider requiring foreign agents to support
reverse tunneling.  This is a bit more work.  I'm still in favor
of it, but on the other hand I'm sympathetic to the argument that
doing so would cause existing foreign agents to become noncompliant.
Perhaps reverse tunneling can be specified as a SHOULD.

Secondly, there is a matter of timing for any such additional
specification.  If we cycle Mobile IP as a Proposed Standard
with the recent clarifications, then I think that would be a
good time to put in any upgrades for Reverse Tunneling.  If this
does not happen, then it would be difficult to put in at any
later time, because doing so would insert yet another delay as
the Mobile IP base specification would again have to cycle at
Proposed Standard.

Comments and discussion is invited.

Your hard-typing editor,
Charlie P.

---

From: Tom Hiller <[email-masked]>
Date: Mon, 15 Nov 1999 16:04:49 -0600

Hi everyone -

Comments on reverse tunneling and the FA:

As a data point from a Mobile IP user, TR45.6 requires that the FAs to be
deployed in cdma2000 networks (i.e. our so called PDSN) MUST support reverse
tunneling.  The decision to invoke reverse tunneling remains with the mobile. We
considered that reverse tunneling is important when the HA is in a private
network due to private addresses of correspondent nodes as well as security
associations existing between the FA and HA necessary to traverse a firewalls.
Reverse tunneling is also important if ingress filtering is deployed by ISPs or
other networks attached to the Internet.

If the MIP WG leaves the requirement as a SHOULD, some users will experience
problems when they roam to an "RFC compliant" FA when their HA is in a private
network, or if ingress filtering becomes widely deployed.

To promote ubiquitousness, the reverse tunneling requirement for the FA should
be a MUST.

Tom

---

From: Wolfgang Schoenfeld <[email-masked]>
Date: Tue, 16 Nov 1999 13:33:18 +0100

> tunneling.  The decision to invoke reverse tunneling remains with the mobile. We

If the mobile may choose to invoke reverse tunneling or not ....

> To promote ubiquitousness, the reverse tunneling requirement for the FA should

is a SHOULD for the FA not just a logical consequence?
Assume that all mobiles choose never to invoke reverse tunneling,
why then have it supported by the foreign agents?
Or do I miss something in Tom's arguments?

Regards
--
Wolfgang Schoenfeld
GMD-IPSI, Dolivostr. 15, Room 118, D-64293 Darmstadt
+49-6151-869-865 (Phone), -818 (FAX)
+49-170-2285450 (Mobile Phone)

---

From: Tom Hiller <[email-masked]>
Date: Tue, 16 Nov 1999 07:45:48 -0600

Hi,

If all mobiles never use reverse tunneling then reverse tunneling is a waste to
eever implement, or even specify.  The point I am making regards SHOULD versus
MUST is that the cdma2000 camp thinks reverse tunneling will be used often
because it is useful for private network access, i.e. to tunnel to HAs in
private networks; reverse tunneling will also be useful if ingress filtering is
deployed by ISPs or by networks attached to the Interent.

Having FAs that do not support reverse tunneling will pose problems for users
(and Mobile IP) if either or both of these are true.

Tom

---

From: Wolfgang Schoenfeld <[email-masked]>
Date: Tue, 16 Nov 1999 17:45:06 +0100

> (and Mobile IP) if either or both of these are true.

Dear Tom,

I did not want to argue against reverse tunneling.
Instead, I wanted to express that
it is hard to give arguments in favour of it
if, at the same time, free decisions of the mobile are accepted.
The effects of not using reverse tunneling are the same -
independent of whether the mobile decided against it
or the foreign agent was not capable to support it.

Hence, I'm arguing against free mobile decisions
in the presence of the reasons you present.

Yours - Wolfgang