Subject: Re: [MOBILE-IP] Is MIPv6 leaking some location information?

From: Thomas Eklund <[email-masked]>
Date: Mon, 29 Nov 1999 19:00:47 +0100

Yes of course, that because route optimazation is applied in default, then
you route the nearest way and do not tunnel via the home network. In other
words your network presence is topological correct, which means that you
wont have any problems with ingress-filtering routers.

You will also have the same leaking problems in mobile IPv4 if you apply
route opt. But I dont see it as problems I see it as a nice feature. But on
the other hand if you claim that setting up a tunnel from your homenetwork
is better, than using a local topological correct address.

And if people claim that its easy to track a mobile node since it in most
cases uses the MAC address to calculate the new CoA, there are solutions
that solve this
(http://www.ietf.org/internet-drafts/draft-ietf-ipngwg-addrconf-privacy-01.t
xt) which is very similar to how its done within GSM today using IMSI and a
Temprorary IMSI (TMSI).

I dont see that IPv6 itself introduces any more leaking than the current
mobileIPv4 based solutions. You will always be trackable, either through DNS
or through your IP-address. This is NOT an IPv6/IPv4 issue.

Also, IPv6 has mandatory IPsec which means that you will secure your binding
updates and have route opt in default.

/Thomas Eklund

> -----Original Message-----
> From: Casati, Alessio (Alessio) [mailto:[email-masked]]
> Sent: Monday, November 29, 1999 3:39 PM
> To: [email-masked]
> Subject: [MOBILE-IP] Is MIPv6 leaking some location information?
>
>
> In MIPv6 one reads
>
> - Support is also integrated into Mobile
> IPv6 -- and into IPv6 itself --
> for allowing mobile nodes and Mobile
> IP to coexist efficiently with routers
> that perform "ingress filtering" [6].
> A mobile node now uses its care-of
> address as the Source Address in the
> IP header of packets it sends, allowing
> the packets to pass normally through
> ingress filtering routers.
> The home address of the mobile node is
> carried in the packet in a Home Address
> destination option, allowing the use of
> the care-of address in the packet to
> be transparent above the IP layer.
> The ability to correctly process a Home
> Address option in a received packet is
> required in all IPv6 nodes, whether
> mobile nor stationary, whether host or router.
>
>
> isn't this leaking some location information?
> Or, mor exactly, some user location within the
> Internet v6 topology?
>
> alessio
>

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Mon, 29 Nov 1999 18:33:56 -0000

> wont have any problems with ingress-filtering routers.
Somebody may see it as a feature, others may be annoyed about it.

I'm not saying I would be annoyed, but there are people that are
not pleased at knowing that when one is roaming in the UK its cellfone
number
sends the typically british ringing tone. Perhaps IPv6 can provide even
more detailed information to the nosy correspondent node :). Is it something
we can avoid?

alessio

---

From: Thomas Eklund <[email-masked]>
Date: Mon, 29 Nov 1999 19:32:29 +0100

What do you mean with that?
If you mean home address, then you cant use home address option as part of
the route opt which is mandatory to support in every ipv6 node.

Sure you can set up an IPsec tunnel in transport mode, but that does not
solve the problem of topological addresses. Because then the question become
how do you route to your tunnel endpoint without "leaking" any topological
info?

As I said before I dont see how this introduces something that IPv4 dont
have...

/Thomas Eklund
> From: Mat Ford [mailto:[email-masked]]
> Sent: Monday, November 29, 1999 7:18 PM
> Subject: Re: [MOBILE-IP] Is MIPv6 leaking some location information?
>
>
> If users wish to protect their HA in MIPv6 they will need to
> use something
> like IPsec in transport mode.
>
> Mat Ford.
> ----- Original Message -----
> From: "Casati, Alessio (Alessio)" <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, November 29, 1999 2:38 PM

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Mon, 29 Nov 1999 19:03:48 -0000

> As I said before I dont see how this introduces something that IPv4 dont
Well, in IPv4, the reverse tunnel to the HA
solves the problem. The Home Address is always used as a source
address for MN's IP packets. Thus no correspondent node knows
which is the MN's current COA. From this perspective MIPv4 may
be more welcome by people afraid to reveal their current COA.

alessio

---

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Mon, 29 Nov 1999 19:59:12 +0100

>  As I said before I dont see how this introduces something

It is a question of Route Opt., therefore MIPv4 without route opt.
makes it harder (not impossible) for a user to be located.

/Karim

---

From: Thomas Eklund <[email-masked]>
Date: Mon, 29 Nov 1999 20:02:47 +0100

And which operator will use mobile IP without route opt???

/Thomas

> From: Karim El-Malki (ERA) [mailto:[email-masked]]
> Sent: Monday, November 29, 1999 7:59 PM
> To: 'Thomas Eklund'; [email-masked]
> Subject: RE: [MOBILE-IP] Is MIPv6 leaking some location information?
>
>