Subject: [MOBILE-IP] Is MIPv6 leaking some location information?

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Mon, 29 Nov 1999 14:38:40 -0000

In MIPv6 one reads

- Support is also integrated into Mobile
IPv6 -- and into IPv6 itself --
for allowing mobile nodes and Mobile
IP to coexist efficiently with routers
that perform "ingress filtering" [6].
A mobile node now uses its care-of
address as the Source Address in the
IP header of packets it sends, allowing
the packets to pass normally through
ingress filtering routers.
The home address of the mobile node is
carried in the packet in a Home Address
destination option, allowing the use of
the care-of address in the packet to
be transparent above the IP layer.
The ability to correctly process a Home
Address option in a received packet is
required in all IPv6 nodes, whether
mobile nor stationary, whether host or router.

isn't this leaking some location information?
Or, mor exactly, some user location within the
Internet v6 topology?

alessio

---

From: Mat Ford <[email-masked]>
Date: Mon, 29 Nov 1999 18:17:55 -0000

If users wish to protect their HA in MIPv6 they will need to use something
like IPsec in transport mode.

Mat Ford.