Subject: Re: [MOBILE-IP] Reverse Tunneling updates?

From: Thomas Eklund <[email-masked]>
Date: Tue, 16 Nov 1999 15:04:50 +0100

If you use mobileIPv6 this is not a problem in default.
Mobile IPv6 use of binding caches/binding update list/home address option is
a superior solution compared to mobileIPv4's reverse tunneling.

So why not use MobileIPv6 instead where its solved?

/Thomas E

> -----Original Message-----
> From: Tom Hiller [mailto:[email-masked]]
> Sent: Tuesday, November 16, 1999 2:46 PM
> To: [email-masked]
> Subject: Re: [MOBILE-IP] Reverse Tunneling updates?
>
>
> Hi,
>
> If all mobiles never use reverse tunneling then reverse
> tunneling is a waste to
> eever implement, or even specify.  The point I am making
> regards SHOULD versus
> MUST is that the cdma2000 camp thinks reverse tunneling will
> be used often
> because it is useful for private network access, i.e. to
> tunnel to HAs in
> private networks; reverse tunneling will also be useful if
> ingress filtering is
> deployed by ISPs or by networks attached to the Interent.
>
> Having FAs that do not support reverse tunneling will pose
> problems for users
> (and Mobile IP) if either or both of these are true.
>
>
> Tom
>
>
> Wolfgang Schoenfeld wrote:
> >
> > Tom Hiller wrote:
> > >
> > > Hi everyone -
> > >
> > > Comments on reverse tunneling and the FA:
> > >
> > > As a data point from a Mobile IP user, TR45.6 requires
> that the FAs to be
> > > deployed in cdma2000 networks (i.e. our so called PDSN)
> MUST support reverse
> > > tunneling.  The decision to invoke reverse tunneling
> remains with the mobile. We
> >
> > If the mobile may choose to invoke reverse tunneling or not ....
> >
> > > considered that reverse tunneling is important when the
> HA is in a private
> > > network due to private addresses of correspondent nodes
> as well as security
> > > associations existing between the FA and HA necessary to
> traverse a firewalls.
> > > Reverse tunneling is also important if ingress filtering
> is deployed by ISPs or
> > > other networks attached to the Internet.
> > >
> > > If the MIP WG leaves the requirement as a SHOULD, some
> users will experience
> > > problems when they roam to an "RFC compliant" FA when
> their HA is in a private
> > > network, or if ingress filtering becomes widely deployed.
> > >
> > > To promote ubiquitousness, the reverse tunneling
> requirement for the FA should
> > > be a MUST.
> >
> > is a SHOULD for the FA not just a logical consequence?
> > Assume that all mobiles choose never to invoke reverse tunneling,
> > why then have it supported by the foreign agents?
> > Or do I miss something in Tom's arguments?
> >
> > Regards
> > --
> > Wolfgang Schoenfeld
> > GMD-IPSI, Dolivostr. 15, Room 118, D-64293 Darmstadt
> > +49-6151-869-865 (Phone), -818 (FAX)
> > +49-170-2285450 (Mobile Phone)
>

---

From: Tom Hiller <[email-masked]>
Date: Tue, 16 Nov 1999 08:54:27 -0600

cdma2000 wireless data does not pursue IPv6 support initially for a couple of
reasons.  (1) There is not a lot of IPv6 deployed and we're not sure when we'll
see significant use of IPv6 in private networks. (2) Mobile IP with IPv6 will
require more overhead than with IPv4 on the scarce and expensive air
interfaces.  The need to minimize overhead on air interfaces is one of the
driving forces behind our including support for FA COA in cdma2000. (Note: We
also support collocated COA via the user simply acquiring a dynamic address via
PPP).

Tom Hiller