Subject: Re: [MOBILE-IP] Route Optimization draft comments

From: Yingchun Xu <[email-masked]>
Date: Tue, 16 Nov 1999 15:03:26 -0600

Hi, Charles,
In the "Route Optimization draft", there is an in-flying traffic retunneling
function, which tunnels in-flying  traffic
 from old mobility agent to new mobility agent for smooth handoff. I personally
feel that the function is not that much
useful for the following reasons:
1. If the traffic is delay sensitive such as Voice traffic, I would prefer it
being dropped than delayed. The retunneling will cause delay.

2. If the traffic is non-delay sensitive, upper layer protocol such as TCP will
resend it anyway whether is delayed or lost.

Any comments?

--Yingchun.

---

From: Charles Perkins <[email-masked]>
Date: Wed, 17 Nov 1999 07:07:41 -0800

Hello Yingchun,

> being dropped than delayed. The retunneling will cause delay.

The traffic isn't delayed all that long, depending upon the
network distance between the old foreign agent and new foreign
agent.  Thus, it quite often is useful, even for voice.

For video and other applications, my intuition is that the traffic
could be even more useful, and not delayed too much.

> resend it anyway whether is delayed or lost.

Results show that TCP interactions are not as nice as you might like.
Look for papers by Ramon Caceres on this point.

Regards,
Charlie P.