Subject: Re: [MOBILE-IP] Document Action: Mobile IP Network Access Identif ier Extension to Experimental

From: Basavaraj Patil <[email-masked]>
Date: Mon, 1 Nov 1999 09:36:15 -0600

>
> > The IESG has approved the Internet-Draft 'Mobile IP Network Access
> > Identifier Extension' <draft-ietf-mobileip-mn-nai-05.txt> as an
> > Experimental Protocol.  This document is the product of the
> IP Routing
>   ^^^^^^^^^^^^
> > for Wireless/Mobile Hosts Working Group.  The IESG contact
> persons are
> > David Oran and Rob Coltun.
>
> I am a little confused by this e-mail. The charter states:
>
> Jun 99       Submit Internet-Draft for NAI support in Mobile
> IP to IESG for
>              consideration as a Proposed Standard.
>                                 ^^^^^^^^^^^^^^^^^
>
> Was experimental the intended track for the relatively simple
> document?
>
> PatC
>

Pat,

Although not the intent, the I-D has been approved as an experimental
protocol.
Based on subsequent implementations, deployments and interop testing we can
get the status changed to proposed standard. For now I believe the status of
the
I-D is fine.

-Basavaraj

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 1 Nov 1999 11:17:11 -0800

> get the status changed to proposed standard. For now I believe the status of

If it works for the WG, it works for me.

Thanks,

PatC

---

From: "Kent K. Leung" <[email-masked]>
Date: Wed, 3 Nov 1999 11:45:04 -0800

I agree with the assessment of the draft.  That implementation, deployment,
and interop testing is required before proposed standard.

Some questions on this draft, most having to deal with
registration request with nonzero Home Address and NAI ext.

1) Draft doesn't explain when MN would want to put a nonzero
   Home Address when using NAI ext.  I assume initially, MN
   uses zero HomeAddr to obtain an IP address.  Then subsequent
   registrations SHOULD/MAY contain nonzero HomeAddr?  If MN
   just booted up and remembers its last HomeAddr, should it
   try that in its new registration?

2) Sect 3 FA Considerations does not cover how an FA deal with
   a registration request that has a nonzero Home Address and
   NAI ext.  Does FA authenticate MFAE based on NAI or HomeAddr
   or both in some order?  I would assume FA authenticate based
   on NAI if it exist regardless of the HomeAddr field, which is
   a hint to the HA.

3) Draft doesn't explain how HA deal with nonzero HomeAddr and
   NAI ext.  It should authenticate based on NAI as the MN
   identity only?  Does the nonzero HomeAddr mean reject
   registration if MN can't get this IP addr?  I assume it's
   a hint for HA to confirm this IP addr is available or in
   use by this MN.

4) Should there be an error code when HA cannot hand back
   an available IP address to the MN?  This could happen
   if NAI MN was not configured properly or IP address pool
   was depleted.

   HA can reply with zero Home Address so FA can send MISSING_HOMEADDR?
   But in the co-located COA case, MN should get rejection too.

5) MN MUST/SHOULD/MAY? attach NAI ext for re-registrations?  I
   would expect MN using NAI to always attach NAI ext for FA and
   HA to properly identify MN for authentication.  But it is not
   clear in the draft since it does not mandate MN MUST attach
   NAI ext in all registrations.

6) There were some confusion on this text in sect 2.

   "The Mobile Node NAI extension MUST appear in the
   Registration Request before both the Mobile-Home Authentication
   extension and Mobile-Foreign Authentication extension, if present."

   Maybe more clear if rephrased?  If that's suppose the be the
   meaning.

   "The Mobile Node NAI extension, if present,  MUST appear in the
   Registration Request before both the Mobile-Home Authentication
   extension and optional Mobile-Foreign Authentication extension."

7) Want to shed more light on how Home Address is suppose to be
   allocated by HA?

-- Kent --

--
     |          |                         Kent Leung
    :|:        :|:                        Software Engineer
   :|||:      :|||:                       IOS Development
.:|||||||:..:|||||||:.                    408.526.5030
c i s c o S y s t e m s                   [email-masked]