Subject: RE: [mobile-ip] MIPv6 "granted lifetime" problem

From: Moter Du <[email-masked]>
Date: Mon, 9 Jul 2001 17:11:52 +0800

Sorry but I have to point out your problem is not the same as Ra's.  With
the latest draft v.14 I think your problem regarding Sequence Number has
been solved.  More comments are inserted below...

Ra's question is basically an implementation issue of granted lifetime
calculation at the receipt of BA responding to a **retransmiting** BU.  To
meet the requirement of Sec. 10.13 we have to store every BU lifetime
(initial or retransmiting) sent to HA, in order to get accurately granted
lifetime.  Seems not efficient for a MN implementation...

Regards,
Moter

> -----Original Message-----
> From: Keiichi SHIMA [mailto:[email-masked]]
> Sent: Monday, July 09, 2001 4:28 PM
> To: [email-masked]
> Cc: Ra Chen
> Subject: Re: [mobile-ip] MIPv6 "granted lifetime" problem
> 
> 
> Hi,
> 
> Ra Chen wrote:
> > 
> > However, according to Sec. 4.6,
> >          for multiple Binding Updates sent to the same destination
> >          address, the Binding Update List contains only the 
> most recent
> >          Binding Update (i.e., with the greatest Sequence 
> Number value)
> >          sent to that destination. 
> > Now if the BA for the initial BU is received after a BU 
> retransmission,
> > the mobile node has no information about L_update,
> > which has been overwritten by the BU retransmission,
> > and doing the calculation correctly is impossible.
> 
> I have met the same problem. The problem is more serious when
> de-registrating I think. 
> 
> 0. MN sends BU with seqno n.
> 1. MN resends BU with seq n+1 bacause BA with seq n did not come
>    in a BINDACK_TIMEOUT time.
> 2. HA receives BU with seq n. de-register, send back an BA with
>    seqno n to MN.
> 3. MN receives BA with seq n but MN silently discards it because
>    the seqno is not the same to the BU's seqno MN sent last time.

No.  MN should not silently discard it.  It's correct to MN because the
sequence number matches in ack window (size: modulo 2^16 in v.13, module 2^8
in v.14)... 

> 4. HA receives BU with seqno n+1. but discards it and send BA to MN
>    with errcode NOT_A_HOMEAGENT
> 
> If we don't increment seqno when retransmitting BU, are there any
> vulnerabilities? If seqno remains same until matching BA received,
> those problem will not occur. and it is easier than holding all
> sending BUs in a BU list.
> 
> ---
> Keiichi SHIMA <[email-masked]>
> Internet Initiative Japan Inc.
>

---

From: Ra Chen <[email-masked]>
Date: Wed, 11 Jul 2001 10:42:04 +0800

> From: Vijay Devarapalli [mailto:[email-masked]]
> 
> this BA is dropped. only the BA with the sequence number matching
> the most recent BU is accepted.
 
I don't think so.  According to 10.13,

        Upon receiving a packet carrying a Binding Acknowledgement, a mobile
        node MUST validate the packet according to the following tests:
         -  ...
         -  ...
         -  The Sequence Number field matches the Sequence Number sent by
the
            mobile node to this destination address in an outstanding
Binding
            Update.

The indefinite article "an" is used here.
My interpretation is that a BA matching any outstanding BU should be
accepted.
If actually the draft requires MN to accept only the BA matching the most
recent BU,
it should state it more clearly.

Ra