Subject: RE: [mobile-ip] WG feedback on bicasting

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Tue, 24 Jul 2001 18:16:22 +0200

Hello Wolfgang

> Another (the only?) way is guessing the emergence of a new link,
> i.e. taking outer "oracles" like layer 2 events, statistics 
> etc. into account.

That's the approach taken in FMIP (low-latency & fast handover drafts).
I wouldn't consider link-layer "triggers" as statistics or guesses.
They are messages from/at L2 which can "warn" the receiver in
anticipation of a handoff event. So it's not a guess, the handoff
will be or is being performed at L2. Note that an L2 handoff does
not always mean a L3 handoff, so it is up to the L3 receiver of
the trigger to determine whether FMIP is needed. The anticipation
time instead will be dependent on the L2 system.

> In this case, bicasting can indeed make sense
> if the guess does not give a unique answer:
> Just multicast to all nodes which the guess predicts.
> (Broadcast would result from the most vague guess.)
> This increases the probability that all packets reach MN.

You can have simultaneous bindings with multiple COAs.
So that gives the same result as multicasting without
the need to join groups.

> 
> Note however that multicast is concerned only with vagueness 
> of guesses -
> if they are precise, multicasting does have not have any effect.
> Hence, fast handover without bicasting 
> (your original question) does make sense.
> 
> I'm not sure whether the above is now "gap-free". Hence, 
> please comment.

It is not gap free since, assuming anticipated triggers and
registrations (i.e. FMIP) you have no knowledge as to when the
L2 handoff event occurs with respect to the moment the HA or
local HA receives the BU/registration. So if the COA is updated
too late or too early with respect to the L2 handoff event,
the MN will find itself unable to communicate. That is what
FMIP is trying to avoid. 

Regards
/Karim

---

From: Wolfgang Schoenfeld <[email-masked]>
Date: Thu, 26 Jul 2001 11:59:08 +0200

> time instead will be dependent on the L2 system.

Maybe, "oracle" is more appropriate than "guess"
since its meaning is well-known:
The operations of the model your are considering (here: Layer 3 handoff)
are affected by some information/trigger from the outside.

> So that gives the same result as multicasting without

Are you sure? Simultaneous binding is a matter of FA's
whereas multicasting can originate soemwhere else.

> the MN will find itself unable to communicate. That is what

If you assume that the predictions of the L2 "oracle" are imprecise,
i.e. the "oracle" is unsure WHERE a link will come up,
then, from what I said, it follows that
bicasting will in general have an effect on L3 handoff.

On the other hand, unsureness of WHEN L2 "oracle" acts
does not suffice as a justification for bicasting.

Wolfgang

-- 
Wolfgang Schoenfeld, Fraunhofer IPSI, Dolivostr. 15, D-64293 Darmstadt
Office: +49-6151-869-865 FAX: -6847 Mobile: +49-174-7093455