Subject: [mobile-ip] WG feedback on bicasting

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Fri, 20 Jul 2001 17:00:03 +0200

Hello folks

We'd like to have feedback on the following draft:
http://www.ietf.org/internet-drafts/draft-elmalki-mobileip-bicasting-v6-00.txt
This describes a technique to reduce packet loss during
the handover (i.e. smoothing) and to support l2-handover
failure or ping-pong. This is meant for addition to the
fast handover v6 draft. It was discussed in the fast handover
mipv6 design team and it was decided to ask the WG for feedback
on whether to include this in the fastv6 draft. The equivalent
draft for MIPv4 (low latency v4) already includes this technique
so we're proposing to include this optional function in v6 as well.
What do people think about this?

Regards
/Karim 

> -----Original Message-----
> From: Phil Roberts [mailto:[email-masked]]
> Sent: den 20 juli 2001 16:17
> To: [email-masked]'
> Subject: RE: [mobile-ip] proposed agenda
> 
> 
> Hi,
> 
>    the draft has now appeared in the directories.  It would be good to
> start a dialog on the draft stating what you'd like to do with it,
> why it is important, and why the working group
> should take action on it.  Everyone can go read it and if there is
> sufficient interest and need some time may be allocated to discuss
> it in London.
> 
> Phil
> 
> 
> > -----Original Message-----
> > From: Karim El-Malki (ERA) [mailto:[email-masked]]
> > Sent: Wednesday, July 18, 2001 1:15 PM
> > To: [email-masked]'
> > Subject: RE: [mobile-ip] proposed agenda
> > 
> > 
> > Hello Phil
> >  
> > > v6 Fast Handover draft-ietf-mobileip-fast-mipv6-01.txt
> > >    BETH addition? James 10 minutes draft-kempf-beth-ipv6-01.txt
> > >    Implementation experience report Rajeev Koodli 10 minutes
> > 
> > This round there are 2 proposals for addition to v6 fast handoffs
> > which are BETH (which also addresses BET w/bicasting: BETB) and a
> > bicasting addition to the current fastv6 draft:
> > draft-elmalki-mobileip-bicasting-v6-00.txt.
> > Why is the bicasting draft not in the agenda? It is an 
> unsolved issue
> > from the v6 design team which we had planned to get WG feedback on
> > as it did not make it into the draft.
> > 
> > Rgds
> > /Karim
> > 
>

---

From: Wolfgang Schönfeld <[email-masked]>
Date: Sat, 21 Jul 2001 14:22:25 +0200

> What do people think about this?

Karim,

I'm not able to comment on mobileip WG issues,
but I believe that the role of bicasting for handover
is not yet fully understood, both in MIPv4 and MIPv6.
Considerations like the following for MIPv4
might help to decide.

Obviously, bicasting makes sense only if MN is able 
to maintain more than one link simultaneously,
say to oFA and nFA.
Now assume that this is the case
and consider handover without bicasting.
Handover involves, among others, these events:

(A) MN detects a link to nFA and issues a BU message to HA.
(B) HA receives BU and updates binding of MN.
(C) MN looses the link to oFA.

How is a stream of packets from some CN to MN affected by handover?
(A) does not affect the stream, but (B) does:
Before (B), packets travel to oFA,
and after (B), they travel to nFA 
(assume that HA buffers during (B)).
Packets passing HA after (B) will reach MN, 
but what about those
which pass HA before (B) and after (A)?
Let us call them "critical" packets.

If (C) happens only after all critical packets 
have passed the link from oFA to MN,
then there is no packet loss at all.
(However, the stream may be out of order.)
On the other hand, 
if (C) happens before all critical packets have reached MN via oFA,
oFA will discard some of them.
(Note there are proposals to, instead, forward them to nFA.)

Now, what could bicasting improve?
Non-critical packets need not be bicasted -
they will reach MN anyhow.
And critical packets cannot be bicasted 
because HA is not yet aware of (A) !
(except HA is able to guess)

To summarize, 
simultaneous use of two links to MN - if they exist -
is somehow "built-in" and can happen
even if simultaneous bindings are switched off.
Hence I believe that bicasting makes sense
only if HA is able to predict (A).
But mobility prediction is, as far as I understand, 
not an issue for MIPv4 or for MIPv6.

Regards,
Wolfgang
-- 
Wolfgang Schoenfeld, FhG IPSI, +49 6151 869 865, +49 174 7093455