Subject: RE: [mobile-ip] Handover Smoothing - What to Do?

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 30 Jul 2001 13:35:13 +0200

Hello Rajeev, 

> >         There are so many mails I hope no one else made the same
> >         comments that I'm about to make.
> >
> > > I don't understand your viewpoint. Just because you have not heard from
> > > buffering advocates does not imply that the alternative is the way to go. There
> > > are at least two things to consider. First, you are proposing to add a
> > > particular smoothing technique to FMIPv6. I am registering my complaint saying
> > > that it is not the right thing to do.
> > >
> >         => You're making a statement that is not backed by a reason. See more below.
> >
> >
> 
> On the contrary, I was reasoning that when FMIP can progress without having to rely on
> any particular smoothing technique.
> 
	=> See an answer below.

> > > FMIPv6 must be able to work independently
> > > of bicasting.
> > >
> >         => Why ?
> >
> >
> 
> Why not ? FMIP can work without any dependency.
> 
	=> It _does_not. The draft clearly states that there are cases (like ping pong)
	where the current solution does not work. We've said this many 
	times and it's in the FMIPv6 draft.

>  Besides, the smoothing techniques by
> themselves are not well-understood to be part of a standard. I mentioned this (in the
> same thread somewhere) didn't I ?
> 
	=> This is handwaving, I'd prefer if you point out specific issues. 
	I don't think HC and CT has any role here. Bicasting adds nothing 
	to the complexity of the HC CT (which is already very complex
	and of unproven value as it is). We can't build a solution taking into 
	consideration a solution that does not exist or even agreed on.

> >
> > > Second, taking up smoothing as a
> > > topic by itself, it is not a foregone conclusion that bicasting/simultaneous
> > > binding are the only means. This is an open area and we need discussion and
> > > *real experimental* evidence. Also, the header compression example hold here as
> > > well.
> > >
> >         => Well other proposals are also welcome. But I'm sure you can appreciate
> >         that new ideas come up all the time, that doesn't mean we don't make
> >         any decisions. We have to decide on what we have now. Unless you've
> >         done some experiments on bicasting and saw that it's bad for some
> >         reason.
> >
> 
> We are now talking about handling smoothing techniques on their own.
> As I mentioned above, this topic by itself needs a lot of discussion before we can make
> decisions. I am not convinced that we can draw definitive conclusions on smoothing
> techniques to progress them on a standardization path.
> 
	=> Frnkly I'm not interested in the discussion of documents and 
	which doc contains what. I'm more interested in the technical 
	evaluation of a proposal. It seems like people are avoiding 
	this topic. 

	Regards,
	Hesham

---

From: Wolfgang Schoenfeld <[email-masked]>
Date: Mon, 30 Jul 2001 15:48:48 +0200

Hesham,

to a certain extend, I understand your impatience -
you want to go on with your idea.
But let me, in order to illustrate the gravity of the situation,
develop an analogy:

Assume that you have a gun
and you want to shoot a bullet (i.e. data packet) to a target.
If the target is stationary - no problem.
If it is mobile, you have to perform quite complicated computations
which take velocity of bullet 
and velocity as well as direction of target into account.

Since you don't know the latter (neither the former),
you may take a machine gun which produces
lots of copies of the bullet/packet.
Obviously, this increases the probabilty that you hit the target.

Alternatively, you may introduce 'redirection guns'
which intercept your packet
and redirect it to some new position of the target.
Or you may use retardation devices
to hold back the packet if it is too early.
(Maybe, there are acceleration devices, too.)
You may also combine all these mechanisms into 'enhanced machine guns'.
And the final solution would be to 'broadcast' everywhere -
at least one bullet/packet would reach the target in any case.

Well, you can do that.
However, because of possible collateral damages,
you have to carefully analyze what you are doing.
Where is such an analysis?
Note that an analysis is the harder
the more complicated your mechanism is.
You have to take into account not only velocity and direction of the bullet,
but also the effects of all the intermediate devices.
Do you really believe that 'practical tests' are sufficient?

Wolfgang

PS:
Question to Phil's recent email:
Is the following understand right?
fast handover = very quickly adjust the gun to a new position
smooth handover = try all the other means mentioned above

-- 
Prof. Dr. Wolfgang Schoenfeld, Fraunhofer IPSI, Dolivostr. 15, D-64293 Darmstadt
Office: +49-6151-869-865 FAX: -6847 Mobile: +49-174-7093455