Subject: Re: [mobile-ip] Handover Smoothing - What to Do?

From: Pat Calhoun <[email-masked]>
Date: Mon, 30 Jul 2001 10:09:50 -0700

>  I am not saying you are wrong, but a detrimental increase
> in duplicates is possible, and given the complete lack
> of bounds on the behaviour of handover, it would seem 
> imprudent to say that there is no issue.

I didn't meant to say there is no issue. I was just stating that we
are building a solution for a handoff, which already has overhead, and
complexity. Adding dups, buffering or anyother solution is trivial.
Since dups already occur in the 'net, and clients already have to handle
them (and they don't, hence the proposed fix), then bicasting seems 
an appropriate option to consider. 

Of course, I won't dispute that a more thorough analysis of bicasting and
buffering is needed.

PatC

---

From: "Gary Kenward" <[email-masked]>
Date: Mon, 30 Jul 2001 13:08:26 -0400

Pat:

 What is "infrequent"? Just for the sake of the discussion,
if on average 0.5 packets are duplicated per handoff (e.g.
ever second handover produces a duplicate), is this
a big increase in duplicates? Obviously, it would depend
upon the rate of handover, and if I'm dealing with 1Km
cells and pedestrian traffic, this may not be a big issue.
What if the cells are 100m? 10m? 0.5 packet duplicates per
handoff is not extreme - it could easily happen.

Gary

> -----Original Message-----
> From: Pat Calhoun [mailto:[email-masked]]
> Sent: July 30, 2001 10:00
> To: [email-masked]
> Subject: Re: [mobile-ip] Handover Smoothing - What to Do?
> 
> 
> > So what's my position on this?  It seems that there are 
> fairly obvious
> > cases in which bicasting introduces packet duplicates with 
> potentially
> > unknown
> > effects in the network.  It doesn't seem the network agents 
> will have the
> > information needed to prevent this from happening.
> 
> Just for clarification, duplicate packets already occur in 
> the network.
> 
> So, why is the possibility of creating duplicates at the 
> edges, during a 
> handoff - which is infrequent - now become a real problem, when they 
> already occur in the network without handoffs?
> 
> PatC
>