Subject: RE: [mobile-ip] draft-tkn-mobileip-qosbinding-mipv6-00.txt

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 19 Jul 2001 17:43:23 +0200

Hello Hemant,

> You draft says that the QoS object can be transferred from old AR to new AR 
> by context tranfer framework. In that case, who sends BU to MAP? In other 
> words, it is not possible that the MN sends BU and AR "fills in" the QoS 
> object h-b-h option as it changes IP packet length and disturbs the 
> authentication calculation.
> 
	=> This is one way of doing it and we are puttnig it in the appendix 
	of HMIPv6:

	- oAR triggers the handover by sending a Prrtradv
	- In the mean time the oAR does the CT. Note that the oAR should already
	  have the QoS objects/attributes.
	- The MN sends a BU, not to the oAR but to the MAP before
	  it moves. This BU can include a H-B-H option. 

	On another note, I'd like to ask you and the authors a stupid question :) why can't we 
	reuse the router alert option for this instead of having a new option ?

	Regards,
	Hesham

---

From: Xiaoming Fu <[email-masked]>
Date: Fri, 20 Jul 2001 09:52:22 +0200

Hi Hesham,

>         reuse the router alert option for this instead of having a new option ?
The router alert option allows only a 2-octet value field in addition to
the 
type field. To notify the nodes in the new path should be notified with 
a certain list of QoS requirements which cannot fulfiled by the router 
alert option.

Regards,
Xiaoming