Subject: Re: [mobile-ip] Handover Smoothing - What to Do?

From: Rajeev Koodli <[email-masked]>
Date: Thu, 26 Jul 2001 10:40:31 -0700

James,

Could you be more specific ? I mentioned that the new-AR *could* do it if it
got the context (e.g., via CT). But that's not it. It means dual contexts at
the MN for downlink. And, synchronization issue for uplink contexts (since
the MN is communicating with old-AR).

Again, here is the point: these are the issues surrounding how to get
bicasting to work with FMIPv6. This MUST NOT be part of FMIPv6. More
generally, FMIPv6 must not depend on a particular smoothing technique.

I hope you understand and agree as well!

Regards,

-Rajeev

James Kempf wrote:

> Right, having the new AR compress was what I had in mind.
>
>                 jak
>
> >Gary Kenward writes:
> > > Rajeev:
> > >
> > >   Is one answer that the old AR could send uncompressed packets
> > > to the new AR, and the new AR would then compress the packets or
> > > not, depending on whether it had the context (there is a an case
> > > to be made here for proactive ct ;^}). Depending on what was actually
> > > sent over the air, this could create a tricky problem to solve
> > > at the MN, as it may need to process the two streams before it could
> > > even attempt duplicate removal, and this would require two compression
> > > state machines, buffers, etc., etc. Not nice.
> >
> >   It may not be nice, but I believe it comes with the
> >   territory. The alternative is to miss packets during
> >   the transition that you might have otherwise been
> >   able to recover. For mobile initiated
> >   break-before-make scenarios, you obviously
> >   don't want to allow any otherwise valid packets
> >   to be dropped making the situation worse.
> >
> >                Mike

---

From: Michael Thomas <[email-masked]>
Date: Thu, 26 Jul 2001 10:48:56 -0700 (PDT)

> generally, FMIPv6 must not depend on a particular smoothing technique.

   Well, I guess I'm glad to hear that you finally come
   around to agreeing that buffering shouldn't be a part 
   of the FMIP draft either.

	  Mike

---

From: James Kempf <[email-masked]>
Date: Thu, 26 Jul 2001 09:12:56 -0700

jak

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 26 Jul 2001 11:01:14 -0700

>    of the FMIP draft either.

Interesting statement.. Not that I agree with its formulation! FYI, buffering is
optional in FMIPv6.

-Rajeev