Subject: RE: [mobile-ip] How does HA use routing table?

From: Lewis Adam-CAL022 <[email-masked]>
Date: Fri, 27 Jul 2001 16:32:54 -0500

Hi,

I realize this is an old thread but I just came across it and don't understand the confusion.  The way I understood it was that the binding cache in the home agent is independent of the routing table.  A binding cache functions to map a node's home address to a care-of address; the routing table is used to determine which next hop to send that packet to in order to reach and address (in this case the care-of address.)  The way I look at it they are totally seperate, independent entities.  My only stipulation would be that the binding cache would have to be referenced before forwarding the packet, but then again I thought that was how it worked all along.  To start placing conditions on what one must have based on the other is very confusing to me.  

Any thoughts?

-----Original Message-----
From: James Kempf [mailto:[email-masked]]
Sent: Monday, June 04, 2001 2:05 PM
To: [email-masked]
Subject: Re: [mobile-ip] How does HA use routing table?

How about;

	The Home Agent MUST assure that the information in the binding
	cache is consistent with routing tables for the local subnet.
	If the Mobile Node as an entry in the routing table for the
	local subnet, then it MUST not have an entry in the binding
	cache, and vice versa.
	
			jak
	
>X-Delivered-For: <[email-masked]>
>X-mProtect: Mon, 4 Jun 2001 11:29:57 -0700 Nokia Silicon Valley Messaging 
Protection
>Date: Mon, 04 Jun 2001 11:29:56 -0700
>From: "Charles E. Perkins" <[email-masked]>
>To: [email-masked]
>Subject: Re: [mobile-ip] How does HA use routing table?
>
>Hello,
>
>First, I concur with Ichiro Okajima's assessment of the intention
>of the home agent procedure.
>
>If the home agent has a binding for the mobile node, then that is
>authoritative.  If there is a clash between the home agent's
>routing table and its Binding Cache entry for the mobile node,
>then that means something has gone wrong.  In fact, if the
>home agent doesn't have a binding cache entry for the mobile
>node, it typically shouldn't get the packet at all except insofar
>as the home agent is a default router for the home network.
>In that case, then its action is well defined, and typically it
>still wouldn't have a host-specific route for the mobile node.
>
>I usually consider the Binding Cache to be like a part of
>the routing table anyway, with special flags.
>
>Can someone suggest an improvement to the wording of the
>Mobile IPv6 specification to clarify this?
>
>Regards,
>Charlie P.
>
>
>Qiang Zhang wrote:
>> 
>> I think for Agent to deliever the packet, the implication is that it should
>> follow the routing table, even there is a binding cache for a packet. Does
>> MIP have to address the issue?
>> 
>> ----- Original Message -----
>> From: "Ichiro Okajima" <[email-masked]>
>> To: <[email-masked]>
>> Sent: Monday, June 04, 2001 1:11 AM
>> Subject: [mobile-ip] How does HA use routing table?
>> 
>> > Hello all,
>> >
>> > I would appreciate it if anyone would answer my question.
>> > I think that the HA of Mobile IPv6 has a routing table as well as
>> > Binding Cache since it is a kind of router. It seems to me that
>> > Mobile IPv6 I-D does not say the relationship between the Binding
>> > Cache and the routing table, and how to use the routing table.
>> > My guess is as follows:
>> >
>> > 1) When the HA receives a packet, it firstly checks the Binding
>> > Cache whether a binding for the destination address of the packet
>> > exists or not.
>> >
>> > 2) If no binding exist in the Binding Cache, it secondly checks
>> > the routing table to find the best route for the packet.
>> >
>> > Is my understanding correct?
>> >
>> > Ichiro
>> >

---

From: "Alper" <[email-masked]>
Date: Sat, 28 Jul 2001 11:59:13 -0700

Hello,

This is geting into implementation details, but let me answer this based on
my implementation experience.

When home agent recevies a binding update, it creates a tunnel entry between
home agent and the care-of address. Also it installs a routing entry, that
says all packet sent to home_address1 should be forwarded through this newly
created tunnel.

Note that this "host specific" routing entry co-exists with less-specific
entry that says "all the packets sent to addresses in prefix1 should be
forwarded on interface1".

So now, when home agent receives a packet destined to home_address1, it'll
use this host specific routing entry to forward it through tunnel. For other
mobile nodes which are at "home", since there won't be such host specific
routes, packets will be forwarded on to interface1.

So, having a binding cache entry creates a matching routing entry which
takes care of forwarding. Home agent doesn't have to check the binding cache
when it receives packets to be forwarded.

alper

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Lewis
Adam-CAL022
Sent: Friday, July 27, 2001 2:33 PM
To: [email-masked]
Subject: RE: [mobile-ip] How does HA use routing table?

Hi,

I realize this is an old thread but I just came across it and don't
understand the confusion.  The way I understood it was that the binding
cache in the home agent is independent of the routing table.  A binding
cache functions to map a node's home address to a care-of address; the
routing table is used to determine which next hop to send that packet to in
order to reach and address (in this case the care-of address.)  The way I
look at it they are totally seperate, independent entities.  My only
stipulation would be that the binding cache would have to be referenced
before forwarding the packet, but then again I thought that was how it
worked all along.  To start placing conditions on what one must have based
on the other is very confusing to me.

Any thoughts?

-----Original Message-----
From: James Kempf [mailto:[email-masked]]
Sent: Monday, June 04, 2001 2:05 PM
To: [email-masked]
Subject: Re: [mobile-ip] How does HA use routing table?

How about;

			jak

Protection