Subject: RE: [mobile-ip] draft-tkn-mobileip-qosbinding-mipv6-00.txt

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 20 Jul 2001 17:30:33 +0200

> > > >     => This is one way of doing it and we are puttnig it in the appendix
> > > >     of HMIPv6:
> > > >
> > > >     - oAR triggers the handover by sending a Prrtradv
> > > >     - In the mean time the oAR does the CT. Note that the oAR should already
> > > >       have the QoS objects/attributes.
> > > >     - The MN sends a BU, not to the oAR but to the MAP before
> > > >       it moves. This BU can include a H-B-H option.
> > > >
> > >
> > > [Hemant] This BU MUST go through new AR towards MAP, so that it follows the
> > > same path as the packets would follow from the new AR. Is this satisfied in
> > > the above scheme?
> > >
> >         => No. If you want it to go through the nAR then you can use the Network
> >         determined model in the Fast Handoffs draft and send the BU to the
> >         MAP after you move.
> >         However, this goes back to my question about the use of the router
> >         alert option. Would something like the following work:
> > 
> >         - oAR sends Prrtradv
> - What's Prrtradv? Prefix Router Renumbering advertisement or...?
> 
	=> Proxy router advertisement (in the Fast Handoffs draft)..

> - To whom? If I'm right you're intending to use this message to notify
>   nAR to pre-configure its operation for upcoming CT? Why not CT
> protocol
	=>It's sent to the MN to notify it that a handover is about to occur.

> >         - oAR does the CT to nAR
> >         - MN sends a normal BU to the MAP (no QoS)
> >         - nAR does a proxy RSVP to the MAP to set the outbound link
> >         - For inbound traffic it is more difficult, perhaps one handwaving idea
> >           would be to get oAR to do transfer the QoS context to the MAP as well ?
> Using bi-directional QoS objects only once from nAR to MAP (whether via
> CT or 
> not) is enough, since we can setup the QoS status for downlink (as well
> as uplink) 
> traffic while the QoS option travels towards the MAP.
> 
	=> OK. I haven't read your draft in detail but I was assuming an
	asymmetric RSVP-like model.

> > 
> >         I'm just not sure whether linking everything to the BU is useful.
> Agreed. But we think BU+QoS is a nice feature to atomize the operation.
> And when multiple hirarchies of MAPs are used - if QoS check failed
> somewhere
> the closest next MAP may reject this binding.
> 
> 
	=> Ok but you should consider the Fast Handoffs case where the BU is sent 
	through the old AR. Can the CT be done between the oAR and the 
	MAP as well so that the MAP can setup the down link somehow ?

	Hesham

---

From: Xiaoming Fu <[email-masked]>
Date: Fri, 20 Jul 2001 18:17:54 +0200

>         =>It's sent to the MN to notify it that a handover is about to occur.
ok. Thanks for clarification.

>         MAP as well so that the MAP can setup the down link somehow ?
We didn't consider the case of Fast Handoff - in this case I agree to
do CT(oAR->MAP) when BU is sent through oAR. 

Xiaoming