Subject: Re: [seamoby] RE: [mobile-ip] Agent Discovery during handover

From: James Kempf <[email-masked]>
Date: Thu, 12 Jul 2001 09:39:18 -0700 (PDT)

Hesham,

The current draft focusses on AR discovery, because, from the viewpoint
of an IP network, APs are transparent bridges. Of course, it possible,
even likely, that APs may have an IP address but I think they
would then be likely classified as hosts since they do not perform
a routing function (the subnet is the same on both sides). 

Do you think that APs should be included?

		jak

>Delivered-To: [email-masked]
>From: "Hesham Soliman  \(ERA\)" <[email-masked]>
>To: "[email-masked]'" <[email-masked]>, 
[email-masked]
>Subject: [seamoby] RE: [mobile-ip] Agent Discovery during handover
>Date: Thu, 12 Jul 2001 17:17:46 +0200
>
>Pat, 
>
>Is it strictly AP discovery or is it a mix of AP/AR discovery 
>that Seamoby is looking into ?
>I think the distinction is important because the solution will
>vary considerably. 
>
>Hesham
>
>
>> -----Original Message-----
>> From:	Pat Calhoun [SMTP:[email-masked]]
>> Sent:	Thursday, 12 July 2001 4:35
>> To:	[email-masked]
>> Subject:	Re: [mobile-ip] Agent Discovery during handover
>> 
>> The Seamoby WG is working on defining handoff candidates discovery based
>> on certain characteristics or required features. In MIP, the fact that 
>> you've received an agent advertisement is sufficient.
>> 
>> So I suggest you send e-mail to the seamoby list.
>> 
>> Thanks,
>> 
>> PatC
>> On Thu, Jul 12, 2001 at 03:14:26PM +0100, Tanis, Michael (Michael) wrote:
>> > Hello all,
>> > 
>> > I am currently doing my MSc project in simulating the Agent Discovery
>> > process in OPNET. There is a critical point where the MN is receiving
>> > advertisements from two or more Agents. What should be the reaction of the
>> > MN? Should it start registration according to the signal power received,
>> > according to the Lifetime field or to the services offered ?
>> > 
>> > I would really appreciate it if someone could answer the question or point
>> > me to the suitable document
>> > 
>> > Thanks in advance,   
>> > 
>> > 
>> > --------------------------------
>> > Michael Tanis
>> > 
>> > O Lucent Technologies UMTS-SAE
>> > Optimus Building
>> > Windmill Hill Business Park
>> > Swindon
>> > Wilts SN5 6PP  
>> > United Kingdom
>> > 
>> > Work Tel: +44 1793 897856
>> > Mobile  : +44 7779 032004
>> > e-mail  : [email-masked]
>> >

---

From: James Kempf <[email-masked]>
Date: Thu, 12 Jul 2001 10:21:47 -0700 (PDT)

Hesham,

>	=> I'm not really sure !
>	The APs can't always give all the necessary information
>	anyway. If more than one AP are connected to the same 
>	AR then it might be easier to get the information from the 
>	AR. The tricky part though is how the AR will be able 
>	to send different sets of information to different nodes !
>

Right, the problem is when there are APs from multiple radio
technologies connected under the same AR. The AR can advertise
that it has multiple radio technology APs, but there isn't really
any way, within IP, for a MN or AR that wants to handoff to a different
technology to do it, because all the MN or AR sees is the AR.

It's different if the AR is also an AP or only has APs of a single
radio technology.

>	Sounds like a combination of the L2 API and the L3 
>	information from the AR would provide the right sets
>	of information for the MN to be able to make an intelligent
>	decision. 
>

Yes, I think that's probably so.

>	I haven't really gone through all y semoby mail for a while. 
>	Can you point me to the problem statement draft if it 
>	exists ?

It hasn't been posted yet. I think Hemant will be posting it today or
tomorrow.

		jak