Subject: Re: [mobile-ip] Registration revocation issues

From: Steven Glass - Solaris Software <[email-masked]>
Date: Wed, 11 Jul 2001 20:03:21 -0400 (EDT)

>On Wed, Jul 11, 2001 at 07:21:29PM -0400, Steven Glass - Solaris Software 
wrote:
>>     I'm just about done updating the revocation draft, and I have a few 
>> questions to ask the group:
>>     
>>     1) How do people feel about an "I understand revocations" registration 
>> extension?

>To which [email-masked] sez:
>
>I prefer this than simply assuming it does.
...
>The way I see it, I see no reason to send a new message type to an FA that
>may not recognize it. Chances are that an implementation will simply drop the
>message, causing the HA to retransmit, and eventually give up.
>
>If an FA advertises itself as supporting this extension, then you know that
>lack of response means that FA is really not reachable.

    The idea is a revocation is sent only once (or twice for the fixated), and a 
response is sent (with a swapped ID and new authenticator) back to the revoker.  
I see your point, though, how do you tell between someone who doesn't 
understand, and someone who's already not listening (for whatever reason)?  A 
good argument to have it in.

>Further, revocations MUST NOT be sent upon a binding expiration, right? It's
>only sent if a binding is revoked prior to lifetime expiration.

     True.

>>     2) I'm removing the lifetime field. 
...

>lifetimes are out, IMHO. A revocation means the session is terminated. If the
>MN wants to renew service, it can send a new registration request.

    Agreed.
    
                              Cheers,
                                  Steve

---

From: "Madhavi W. Chandra" <[email-masked]>
Date: Thu, 12 Jul 2001 11:30:01 -0400

Steve,

> >>     1) How do people feel about an "I understand revocations" registration 

We obviously are in favor of such an extension.

> good argument to have it in.

Sounds like a good argument for an Acknowledgment mechanism also.  I
guess that's what your above paragraph is suggesting anyway.

> >MN wants to renew service, it can send a new registration request.

Yes, as we've discussed before we also support the removal of the
lifetime field.

Regards,
Madhavi

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 12 Jul 2001 08:25:44 -0700

> guess that's what your above paragraph is suggesting anyway.

Correct, a reply *is* required, unless best-effort is sufficient, which
I seriously doubt it is.

PatC