Subject: RE: [mobile-ip] Handover Smoothing - What to Do?

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 27 Jul 2001 12:42:23 +0200

There are so many mails I hope no one else made the same 
	comments that I'm about to make. 

> I don't understand your viewpoint. Just because you have not heard from
> buffering advocates does not imply that the alternative is the way to go. There
> are at least two things to consider. First, you are proposing to add a
> particular smoothing technique to FMIPv6. I am registering my complaint saying
> that it is not the right thing to do. 
> 
	=> You're making a statement that is not backed by a reason. See more below.

> FMIPv6 must be able to work independently
> of bicasting. 
> 
	=> Why ?

> I have provided the problems stemming from header compression as
> an example to illustrate the added complexity. 
> 
	=> Context transfer for HC is extrermely complex in itself and controversial. 
	Yet if you want it, I don't see how bicasting can make it worse. In fact
	with bicasting you can establish the down link context earlier since 
	the process happens before the MN attaches to the nAR. Either way,
	why are we discussing CT and HC again ? Haven't we already agreed
	that this is out of scope for the MIP WG.

> Second, taking up smoothing as a
> topic by itself, it is not a foregone conclusion that bicasting/simultaneous
> binding are the only means. This is an open area and we need discussion and
> *real experimental* evidence. Also, the header compression example hold here as
> well.
> 
	=> Well other proposals are also welcome. But I'm sure you can appreciate
	that new ideas come up all the time, that doesn't mean we don't make 
	any decisions. We have to decide on what we have now. Unless you've 
	done some experiments on bicasting and saw that it's bad for some 
	reason.

	Hesham

> > >George has also asserted (and speaking for myself personally I also agree
> > >with)
> > >that implementations in some environments at least can solve this without
> > >any kind
> > >of protocol support at layer 3.
> > >
> >
> > I agree also.
> >
> > >Does this seem to summarize everyone's position accurately?  Does this
> > >answer your question
> > >enough, Jim?
> > >
> >
> > Yes, thanx.
> >
> > >Of course, others contributing to the conversation COULD help,
> >
> > Agree.
> >
> >                 jak

---

From: Rajeev Koodli <[email-masked]>
Date: Fri, 27 Jul 2001 12:03:16 -0700

Hello Hesham,

>         => You're making a statement that is not backed by a reason. See more below.

On the contrary, I was reasoning that when FMIP can progress without having to rely on
any particular smoothing technique.

> > FMIPv6 must be able to work independently

Why not ? FMIP can work without any dependency. Besides, the smoothing techniques by
themselves are not well-understood to be part of a standard. I mentioned this (in the
same thread somewhere) didn't I ?

>         that this is out of scope for the MIP WG.

It is not as simple as you seem to imply, or else I would like you to educate me. The
context at old-AR and new-AR is not the same if you do this, and special actions are
needed to handle the complexity. The additional complexity must not be coupled to FMIP.

>         done some experiments on bicasting and saw that it's bad for some

We are now talking about handling smoothing techniques on their own.
As I mentioned above, this topic by itself needs a lot of discussion before we can make
decisions. I am not convinced that we can draw definitive conclusions on smoothing
techniques to progress them on a standardization path.

Regards,

-Rajeev