Subject: [mobile-ip] A question about 'traceroute'

From: [email-masked]
Date: Thu, 26 Jul 2001 14:45:05 +0200

> Good morning!
> I would like to know a little bit more about the troubles to run "traceroute" for MIPv4. Is there someone who can answer me? I have read a mail, posted in this list. But it's not very clear.
> Thank you.
> 
> Best regards,
> Yolanda Benito
> 
> 
> Assumpte: [mobile-ip] "Traceroute" in MIPv4
> Data: Thu, 12 Jul 2001 10:32:47 -0500
> De: Sridhar Gurivireddy <[email-masked]>
> Respon a: [email-masked]
> Organització: Alcatel USA
> A: [email-masked]
> 
> "Traceroute" program works by incrementing TTL value from 1 to 255 and
> by sending ICMP echo_request packet in the payload....The source lists
> all the routers which send "ICMP_TTL_exceeded" to trace the route to IP
> host....I guess "Traceroute" does not work in MIPv4
> 
> Let CN run "traceroute" program to find the route to MN...
> 
> Case 1: Alternate CoA used
> After the FA decapsulates the packet and finds that  TTL=0 , it sends
> "TTL exceeded" message back to HA. HA manupulates this packet and
> changes the packet to ICMP_HOST_UNREACHABLE..{As per Mobile Ipv4
> specification)  When the CN gets this packet, it is going to stop the
> "traceroute" program..So, I guess "traceroute" does not work...
> 
> Case 2: Co-located CoA used:
> Even in this case it does not work for the same reason....
> 
> --
> Sridhar Guriviredddy,
> Ph:  972.996.2048
> 
> 
> 
> Yolanda Benito
> Active Networks and Mobility (EB23.4)
> T-Systems
> T-Nova Deutsche Telekom Innovationsgesellschaft mbH 
> Berkom
> Goslarer Ufer 35
> D-10589 Berlin
> phone: +49-(0)30-3497-3296 fax: +49-(0)30-3497-3297
> E-Mail: [email-masked]
> 
> 
>

---

From: Sridhar Gurivireddy <[email-masked]>
Date: Thu, 26 Jul 2001 09:04:15 -0500

Traceroute program works by sending "ICMP_Echo_request" packets and incrementally increasing TTL value from 1 to 255 until it finds Destination...Traceroute program  lists the address of the nodes
which send "ICMP TTL exceeded" .....It stops when it gets ICMP_ECHO_REPLY from destination.

If a CN runs "traceroute" program to MN
But in MIpv4," ICMP TTL Exceeded" message from MN/FA is translated to "ICMP Destination unreachable" by HA. This translated ICMP error is sent back to CN
So, the traceroute will stop either at MN or at FA , but the program will never end up finding the mobile host...Even when it reaches MN, the packet will not be sent to the "ping" program because
TTL=0....Usually  "Traceroute" program ends when the node receives a "Ping" packet with TTL=1

"ping" in the above paragraph refers to the name of program which responds to "ICMP_ECHO_REQUEST" packets

Sridhar.

--
Sridhar Guriviredddy,
Alcatel- Network Strategic Group,
Richardson,
TX-75080

Ph:  972.996.2048

---

From: "Kim Taeyong" <[email-masked]>
Date: Fri, 27 Jul 2001 09:02:25 +0900

Hi. 

I think traceroute program works. But wholl path not detectable.
Nodes exists in FA-HA tunnel can not be traced.

ex)
CN send ICMP packet by incrementing TTL=1, 2, 3, ....(TTL decrease )
Then HA encapsulate ICMP message do not decrease TTL, and send the packet
through the tunnel between HA and FA(TTL decrease )

FA decapsulate the packet and send to MN,(TTL decrease )

Finally, MN send ICMP Port Unreachable message to CN.
Then traceroute ends.

---

From: "Kim Taeyong" <[email-masked]>
Date: Sat, 28 Jul 2001 09:30:35 +0900

Dear Chae-yong.

>Some confusion. "encapsulate ICMP message do not decrease TTL" What does it mean?
>Does it mean that HA does not decrease the TTL value of original packet?(ICMP echo request)

>RFC2003 said that the encapsulator decrease the TTL value of inner packet.

Yes. It's correct. 
HA encapsulate the packet with reduce TTL of inner packet. 
Then, encapsulated packet is sended to FA with not reducing TTL of inner packet but outer packet.

fugure.

Assume Initial TTL is 4 for inner, outer packet.
                      
                                MN -- FA --node A -- node B -- HA -- CN
TTL of inner packet :   1        2          2             2           3        4
TTL of outer packet :                        3             3           4 

Although, there are some node between HA and FA, more than 1hop, CN knows there is no more node between HA and FA, because TTL of inner packet is decreased by 1.

Tae-yong

---

From: "Kim Taeyong" <[email-masked]>
Date: Sat, 28 Jul 2001 11:33:52 +0900

Yes. You are right.
But I  think, To know Intermediate nodes informaiton from HA to FA
is not meaningless for security.

Assume there is bad guy(?) that want to do replay attack or IP packet spoofing...etc.
IF CN know whole node on tunnel, CN can prepare against a possible attack and some bad nodes.

My subject is route tracing of tunnel is significant and certain way to know Intermediate nodes is needed.

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Saturday, July 28, 2001 9:53 AM
Subject: Re: [mobile-ip] A question about 'traceroute'

Hi.

Yes, the question is that whether CN want to know the intermedia nodes in path
from HA to FA where CN's packet is forwarded in tunneling.
I think the MN is always on "Home Network" for CN's point. That's what Mobile IP
provide to nodes. Moreover it is not possible for CN to know where MN is located 
without routing optimization. If so, Intermediate nodes informaiton from HA to FA
is meaningless to CN. I think... 

Regards
Chae-yong

---

From: "Chae-yong Chong" <[email-masked]>
Date: Sat, 28 Jul 2001 11:03:24 +0900

Oops some typo in the previous message

In the first line ,
intermedia -> intermediate

---

From: "Chae-yong Chong" <[email-masked]>
Date: Sat, 28 Jul 2001 08:42:36 +0900

Hi

I have some question about your message.

----- Original Message ----- 
From: "Kim Taeyong" <[email-masked]>
To: <[email-masked]>
Sent: Friday, July 27, 2001 9:02 AM
Subject: Re: [mobile-ip] A question about 'traceroute'

Regards
Chae-yong

---

From: "Chae-yong Chong" <[email-masked]>
Date: Sat, 28 Jul 2001 09:53:34 +0900

Hi.

Regards
Chae-yong