Subject: RE: [mobile-ip] Concerns about draft-mipv6-14 section 4.8

From: "Glenn Morrow" <[email-masked]>
Date: Mon, 6 Aug 2001 15:17:37 -0500

I don't really see these issues and points as solely being related to mobile
networks, however.   

-----Original Message-----
From: Michael Thomas [mailto:[email-masked]]
Sent: Monday, August 06, 2001 12:04 PM
To: [email-masked]
Subject: Re: [mobile-ip] Concerns about draft-mipv6-14 section 4.8

Ok, here's the problem I see. What gives me the
right to assert a routing table modification for a
prefix larger than I'm authorized to route? The
current crop of proposals expect that if I can
route back to where the BU came from (either to
the MN or HA), that is sufficient check to accept
the BU. However, that only guarantees that I can
currently protect one address: the source address
of the BU. Thus if I am a resident on x/8, but am
only authorized for x.y.z/24, I better not be able
to send a BU for x/8. With the current return
routability proposals, I don't believe this is
possible. Nor does having a home agent
*necessarily* help: the home agent may be in
collusion with the MN and not trustable (think
of some script kiddie with their home linux box 
acting as a home agent with their hacked up 
mobile router). 

As far as I can tell, the only thing that
knows about whether the scope is too broad
is some router, potentially serveral hops
upstream, of the home agent. This is a problem.

I'll go on record here as voicing some scalability
concerns with the prospect of large server banks
with potentially large binding caches. These are
essentially unaggregated host routes across the
Internet with is sort of unsettling. This is a
general concern with regular BU's, I'll admit, but
it sort of points out that the CN is not
necessarily the best place to send a BU from a
scaling or messaging standpoint. Indeed, it seems
that the optimal place to send a BU is with the
joining router in the path between the HA and MN's
current CoA.

	    Mike

Thierry Ernst writes:
 > As far as Mobile IPv6 is concerned toghether with the
 > process of sending BUs to HA and CNs, yes there is an
 > AUTHORIZATION issue as previously debated on this
 > mailing list about one year ago. The authorization
 > problem is exactly the reason why our draft "Prefix
 > Scope Binding Updates"
 > (draft-ernst-mobileip-v6-network-02.txt - sorry that I
 > keep pointing to my drafts but I don't want the people
 > to be confused about which draft I am talking about -
 > there are 2 of them)was not widely accepted, and also
 > the reason why I advocate any MIPv6 extensions about
 > network mobility support to be kept away from the
 > MIPv6 specification.
 > 
 > Anyway, t6here is a section in our draft that is
 > tackling with the AUTHORIZATION issue.  Our view is
 > that what we need a certificate that says that a
 > router is AUTHORIZED to send a BU for a particular
 > prefix. The section is rather short, but it is here to
 > open the discussion. I would therefore be more than
 > happy to have comments on this; that would avoid
 > everyone to keep repeating and arguying the same
 > things.  Having feedback on a draft is the reason to
 > write a draft, If we wanted to keep the discussion for
 > ourselves we wouldn't have written it.  Then, all you
 > interested people, please comment on the draft. If
 > there is something wrong, please speak up.
 > 
 > 
 > Thierry.
 > Motorola Labs and INRIA Rhone-Alpes
 > 
 > 
 > 
 > __________________________________________________
 > Do You Yahoo!?
 > Make international calls for as low as $.04/minute with Yahoo! Messenger
 > http://phonecard.yahoo.com/

---

From: Michael Thomas <[email-masked]>
Date: Tue, 7 Aug 2001 06:19:30 -0700 (PDT)

> I don't really see these issues and points as solely being related to mobile

   In what way? As a general issue with tunnel establishment?

      Mike

 > <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
 > <HTML>
 > <HEAD>
 > <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
 > <META NAME="Generator" CONTENT="MS Exchange Server version 5.5.2654.89">
 > <TITLE>RE: [mobile-ip] Concerns about draft-mipv6-14 section 4.8</TITLE>
 > </HEAD>
 > <BODY>
 > 
 > <P><FONT SIZE=2>I don't really see these issues and points as solely being related to mobile networks, however.&nbsp;&nbsp; </FONT>
 > </P>
 > 
 > <P><FONT SIZE=2>-----Original Message-----</FONT>
 > <BR><FONT SIZE=2>From: Michael Thomas [<A HREF="mailto:[email-masked]">mailto:[email-masked]</A>]</FONT>
 > <BR><FONT SIZE=2>Sent: Monday, August 06, 2001 12:04 PM</FONT>
 > <BR><FONT SIZE=2>To: [email-masked]</FONT>
 > <BR><FONT SIZE=2>Subject: Re: [mobile-ip] Concerns about draft-mipv6-14 section 4.8</FONT>
 > </P>
 > <BR>
 > 
 > <P><FONT SIZE=2>Ok, here's the problem I see. What gives me the</FONT>
 > <BR><FONT SIZE=2>right to assert a routing table modification for a</FONT>
 > <BR><FONT SIZE=2>prefix larger than I'm authorized to route? The</FONT>
 > <BR><FONT SIZE=2>current crop of proposals expect that if I can</FONT>
 > <BR><FONT SIZE=2>route back to where the BU came from (either to</FONT>
 > <BR><FONT SIZE=2>the MN or HA), that is sufficient check to accept</FONT>
 > <BR><FONT SIZE=2>the BU. However, that only guarantees that I can</FONT>
 > <BR><FONT SIZE=2>currently protect one address: the source address</FONT>
 > <BR><FONT SIZE=2>of the BU. Thus if I am a resident on x/8, but am</FONT>
 > <BR><FONT SIZE=2>only authorized for x.y.z/24, I better not be able</FONT>
 > <BR><FONT SIZE=2>to send a BU for x/8. With the current return</FONT>
 > <BR><FONT SIZE=2>routability proposals, I don't believe this is</FONT>
 > <BR><FONT SIZE=2>possible. Nor does having a home agent</FONT>
 > <BR><FONT SIZE=2>*necessarily* help: the home agent may be in</FONT>
 > <BR><FONT SIZE=2>collusion with the MN and not trustable (think</FONT>
 > <BR><FONT SIZE=2>of some script kiddie with their home linux box </FONT>
 > <BR><FONT SIZE=2>acting as a home agent with their hacked up </FONT>
 > <BR><FONT SIZE=2>mobile router). </FONT>
 > </P>
 > 
 > <P><FONT SIZE=2>As far as I can tell, the only thing that</FONT>
 > <BR><FONT SIZE=2>knows about whether the scope is too broad</FONT>
 > <BR><FONT SIZE=2>is some router, potentially serveral hops</FONT>
 > <BR><FONT SIZE=2>upstream, of the home agent. This is a problem.</FONT>
 > </P>
 > 
 > <P><FONT SIZE=2>I'll go on record here as voicing some scalability</FONT>
 > <BR><FONT SIZE=2>concerns with the prospect of large server banks</FONT>
 > <BR><FONT SIZE=2>with potentially large binding caches. These are</FONT>
 > <BR><FONT SIZE=2>essentially unaggregated host routes across the</FONT>
 > <BR><FONT SIZE=2>Internet with is sort of unsettling. This is a</FONT>
 > <BR><FONT SIZE=2>general concern with regular BU's, I'll admit, but</FONT>
 > <BR><FONT SIZE=2>it sort of points out that the CN is not</FONT>
 > <BR><FONT SIZE=2>necessarily the best place to send a BU from a</FONT>
 > <BR><FONT SIZE=2>scaling or messaging standpoint. Indeed, it seems</FONT>
 > <BR><FONT SIZE=2>that the optimal place to send a BU is with the</FONT>
 > <BR><FONT SIZE=2>joining router in the path between the HA and MN's</FONT>
 > <BR><FONT SIZE=2>current CoA.</FONT>
 > </P>
 > 
 > <P>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <FONT SIZE=2>&nbsp;&nbsp;&nbsp; Mike</FONT>
 > </P>
 > <BR>
 > 
 > <P><FONT SIZE=2>Thierry Ernst writes:</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; As far as Mobile IPv6 is concerned toghether with the</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; process of sending BUs to HA and CNs, yes there is an</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; AUTHORIZATION issue as previously debated on this</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; mailing list about one year ago. The authorization</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; problem is exactly the reason why our draft &quot;Prefix</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; Scope Binding Updates&quot;</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; (draft-ernst-mobileip-v6-network-02.txt - sorry that I</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; keep pointing to my drafts but I don't want the people</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; to be confused about which draft I am talking about -</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; there are 2 of them)was not widely accepted, and also</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; the reason why I advocate any MIPv6 extensions about</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; network mobility support to be kept away from the</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; MIPv6 specification.</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; </FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; Anyway, t6here is a section in our draft that is</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; tackling with the AUTHORIZATION issue.&nbsp; Our view is</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; that what we need a certificate that says that a</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; router is AUTHORIZED to send a BU for a particular</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; prefix. The section is rather short, but it is here to</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; open the discussion. I would therefore be more than</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; happy to have comments on this; that would avoid</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; everyone to keep repeating and arguying the same</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; things.&nbsp; Having feedback on a draft is the reason to</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; write a draft, If we wanted to keep the discussion for</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; ourselves we wouldn't have written it.&nbsp; Then, all you</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; interested people, please comment on the draft. If</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; there is something wrong, please speak up.</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; </FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; </FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; Thierry.</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; Motorola Labs and INRIA Rhone-Alpes</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; </FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; </FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; </FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; __________________________________________________</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; Do You Yahoo!?</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; Make international calls for as low as $.04/minute with Yahoo! Messenger</FONT>
 > <BR><FONT SIZE=2>&nbsp;&gt; <A HREF="http://phonecard.yahoo.com/" TARGET="_blank">http://phonecard.yahoo.com/</A></FONT>
 > </P>
 > 
 > </BODY>
 > </HTML>