Subject: RE: [mobile-ip] Piggybacking

From: "Glenn Morrow" <[email-masked]>
Date: Tue, 7 Aug 2001 14:05:36 -0500

Michael, 

Please explain in more detail why you believe the performance would be
better without piggybacking. I would suspect the performance to be better
with piggybacking.

I would also have some severe reservations about having a snooping ROHC
compression strategy drive the more pure IP standard.

-----Original Message-----
From: Michael Thomas [mailto:[email-masked]]
Sent: Tuesday, August 07, 2001 8:28 AM
To: [email-masked]
Subject: [mobile-ip] Piggybacking

It isn't clear that there is in fact any clear win
with piggybacking. Indeed, piggybacking is almost
certainly going to be lossage with CRTP/ROHC. If
you consider layer two's which allow multiple
IP packets/frame (which is generally a Good Idea
for any slow/contentious upstream), then *not*
piggybacking would probably perform better.

Also: Alper already outlined many technical
deployment issues in IP stacks.

	   Mike

Charlie Perkins writes:
 > Hello folks,
 > 
 > One important thing to arrange is that mobile nodes should be allowed
 > to deliver Binding Updates "on-demand", and not upon every change
 > of care-of address, and not immediately after acquisition of a care-of
 > address.  This would in many case allow better a reduction in signalling.
 > There are reasonable ways to implement this, and I believe that the
 > ways to do this are also friendly to implementing piggybacking.
 > 
 > I think there is also value to allowing a mobile node to send fewer
 > packets, but of course this depends on traffic patterns and the mobility
 > factor.  Increasing the burden on bandwidth imposed by sending
 > Binding Updates effectively reduces their applicability, perhaps only
 > by some percentage, but percentage would be significant for some
 > bandwidths and traffic patterns.
 > 
 > Piggybacking has not been implemented much, but I think it has
 > enough advantages that it should be retained for improving the
 > future performance of the protocol.  Furthermore, according to
 > recent comments, the current state of implementation for Mobile
 > IPv6 is not the prime motivator for retaining or deleting protocol
 > features.  In fact, now it seems that no implementation is required
 > to attain Proposed Standard.
 > 
 > Regards,
 > Charlie P.
 > 
 > 
 > 
 >

---

From: Michael Thomas <[email-masked]>
Date: Sat, 11 Aug 2001 12:17:10 -0700 (PDT)

> better without piggybacking. I would suspect the performance to be better

   It obviously depends on the particular link layer.
   However, for one example that I'm pretty familiar
   with -- DOCSIS cable -- it would better to separate
   them into two packets because you would then be able
   to reap the benefit of payload header supression 
   (PHS) as well as use concatenation to place both 
   packets on the same upstream grant request. 

 > compression strategy drive the more pure IP standard.

   I don't understand what you mean here. ROHC would
   be greatly complicated if it had to consider
   piggybacking too. If we separate them, it could
   be made to look like a normal UDP packet which 
   ROHC already knows how to compress.

		Mike