Subject: Re: [mobile-ip] Heterogeneous Handover - How Would it Work?

From: James Kempf <[email-masked]>
Date: Fri, 10 Aug 2001 09:10:37 +0-100

>> Something like SUCV, that would allow an ISP to cryptographically identify
>> to what other ISP an address belonged, might be useful in this context.
>
>I didn't read the above in the SUCV draft. SUCV allows nodes to challenge
>the node with an SUCV address to show indicate that they have the private
>key corresponding to the address. This doesn't identify the ISP as far
>as I can tell.
>Or do you intend to infer the identity of the ISP from the high-order
>bits in the IPv6 address?
>

Right, the high order bits identify the ISP, the low order identify
the mobile node. 

I suppose there is an issue here in that a mobile node could manufacture
the high order bits and thus claim  it was from an ISV that it wasn't,
but the low order bits should provide proof. 

		jak

---

From: gabriel montenegro <[email-masked]>
Date: Fri, 10 Aug 2001 12:17:31 +0200

> but the low order bits should provide proof.

sucv addresses (as opposed to sucv id's) only give you a cryptographic assurance on the lower 64 bits.
the upper 64 are, of course, just the prefix which could give you some indication/assurance
as to the ISP. at any rate the nature of the assurance is not cryptographic, it's merely based
on return routability or some such soft binding.
if you want hard crypto assurance on all the bits then HIP (or sucv id's) can do this.
the hip draft talks about how to allow for HAA (host assigning authority) field. this is
what could relate to your ISP, for example.

but then you no longer have a routable entity.

-gabriel