Subject: [mobile-ip] RE: So what is bicasting vs. buffering

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 3 Aug 2001 00:40:51 +0200

So in my mind, I believe that the main difference between the bicasting
and buffering approaches is simply that the latter requires the mobile
to *request* packets.

Am I right?

=> Not at all :)
The proposal that Charlie mentioned IS bicasting
that is the point I'm trying to make. 
I don't understand why people assume that if you bicast 
then by definition you can't buffer. You can
delay packets destined to the new AR/FA based on some 
calculations of the average time for a handover. 

In addition you can bicast without a request from the 
MN (ie. by default in the AR). 
However, if you say I will send packets to the MN
at the current AR and send another copy to the new
AR then you ARE bicasting but just don't want to
say the word :))))))))
It doesn't matter how long you buffer or delay the 
packets destined to the new AR you are still sending
TWO copies. 

There are hidden assumptions if you do it by default 
in the AR though (without the MN's request). The 
assumption is that you know when the MN disconnects.
This is not generic of course so you still need 
to allow for the option of the MN requesting bicasting.

Hesham

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 2 Aug 2001 15:56:56 -0700

ok, so then the options are:

1. mobile initiated (mn signalling over the air)
2. network initiated (no over the air signalling)

and

1. don't buffer on NewAR
2. buffer on NewAR

So, it is always bicasting, but some proposals use different mixes
of the alternatives above.

PatC