Subject: RE: [mobile-ip] Heterogeneous Handover - where do i look

From: [email-masked]
Date: Sat, 11 Aug 2001 11:55:46 -0500

> 
> Coming back to the question of handover across heterogeneous wireless
> networks.  Can anyone advise me as to where i should look at?
> We are seeing a desire for handover between 802.11 and GPRS 
> networks.  Is there any group looking at the feasibility of this ? 
> 
> Thanks in advance
> 

Taking a very simplistic approach (and ignoring all the lower layer
complexities),
and assuming that you have Mobile IP client in your MN, an FA in your
GGSN
and MIPv4 support in the WLAN (FA in the WLAN), you could accomplish a 
handoff between the two based on the low-latency handoff solution
(current WG
I-D) between the two networks. However you need to deal with the
underlying
complexities of L2 triggers and a MN which is capable of both interfaces
etc.

-Basavaraj

> Anil Doradla
> SBC- Technology Resources, Inc.
> Austin, TX-78727
>  
> 
> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: Friday, August 10, 2001 3:57 AM
> To: [email-masked]; [email-masked]
> Cc: Peter.Dahl
> Subject: RE: [mobile-ip] Heterogeneous Handover - How Would it Work?
> 
> 
> Glenn,
> 
> I think Raj is right on here, sorry. There are enough technical issues
> involved in getting MIP to be deployable that the MIP group really
> needs to focus on. An example is this NAT question.
> 
> If there are any operational issues involved in handover 
> between operators
> that
> need resolution, they should probably be handled in a separate working
> group, like ROAMOPS. An example of such an issue might be advertising
> access routers between operators using something like the Seamoby
> CAR discovery protocol, which is just now getting off the ground.
> 
> 		jak
> >Raj,
> >
> >That's like saying that BGP doesn't deal with the routing 
> policy related to
> >business relationships between the owners of autonomous 
> systems. You are
> >shoe-holing the group into only dealing with an enterprise - not the
> >Internet. 
> >
> >-----Original Message-----
> >From: [email-masked] [mailto:[email-masked]]
> >Sent: Thursday, August 09, 2001 10:55 AM
> >To: mobile-ip
> >Cc: Peter.Dahl
> >Subject: RE: [mobile-ip] Heterogeneous Handover - How Would it Work?
> >
> >
> >Clearly, you are mixing roaming with seamless mobility across
> >heterogeneous
> >access types. The Mobile IP WG does not deal with aspects related to
> >roaming
> >agreements between operators or administrative domains. That 
> is NOT what
> >this WG is about.
> >
> >-Basavaraj
> >
> >> -----Original Message-----
> >> From: ext Dahl, Peter [mailto:[email-masked]]
> >> Sent: Wednesday, August 08, 2001 1:53 PM
> >> To: [email-masked]'
> >> Subject: RE: [mobile-ip] Heterogeneous Handover - How 
> Would it Work?
> >> 
> >> 
> >> ...not forgetting cdma2000.  I am not aware of any work in 
> >> 3GPP2 or IEEE,
> >> perhaps 3GPP ?
> >> 
> >> Pete
> >> 
> >> -----Original Message-----
> >> From: Brad Casemore [mailto:[email-masked]]
> >> Sent: Wednesday, August 08, 2001 11:29 AM
> >> To: [email-masked]
> >> Subject: RE: [mobile-ip] Heterogeneous Handover - How 
> Would it Work?
> >> 
> >> 
> >> If that is the case, then WECA's WISPr is dedicated to 
> >> 802.11b roaming,
> >> while the ETSI has assigned a group to address GPRS roaming. 
> >> Is there a
> >> group anywhere that is looking into the technical issues 
> >> associated with
> >> heterogeneous network roaming (such as between, 
> theoretically, 802.11b
> >> WLANs and GPRS)?
> >> 
> >> Brad 
> >> 
> >> > -----Original Message-----
> >> > From: [email-masked] [mailto:owner-mobile-
> >> > [email-masked]] On Behalf Of James Kempf
> >> > Sent: Wednesday, August 08, 2001 2:19 AM
> >> > To: [email-masked]; [email-masked]
> >> > Subject: Re: [mobile-ip] Heterogeneous Handover - How 
> Would it Work?
> >> > 
> >> > Pat,
> >> > 
> >> > I think they already have such a standard and I believe it 
> >> only works
> >> > with GPRS.
> >> > 
> >> > 		jak
> >> > 
> >> > >Also, I believe that ETSI is working on a standard 
> called GRX for
> >> GSM<-
> >> > >802.11
> >> > >roaming.
> >> > >
> >> > >PatC
> >> > >On Tue, Aug 07, 2001 at 09:32:58AM -0700, Dahl, Peter wrote:
> >> > >> FYI, the Wireless ISPs (WISPs) are already talking about such
> >> roaming
> >> > >> issues.
> >> > >>
> >> > >> There appear to be 2 emerging forums for these 
> discussions, one
> >> under
> >> > the
> >> > >> auspices of WECA (http://www.weca.net) known as the 
> WISPr group
> >> ('r'
> >> > being
> >> > >> for roaming), the other a yet to be finalized 'WISP Forum' the
> >> prime
> >> > mover
> >> > >> for which is a company in Luxembourg (www.excilan.com).
> >> > >>
> >> > >> Regards
> >> > >>
> >> > >> -----Original Message-----
> >> > >> From: James Kempf [mailto:[email-masked]]
> >> > >> Sent: Tuesday, August 07, 2001 8:58 AM
> >> > >> To: [email-masked]; 
> [email-masked]
> >> > >> Subject: Re: [mobile-ip] Heterogeneous Handover - How Would it
> >> Work?
> >> > >>
> >> > >>
> >> > >> >On the other hand, the home address must belong to some
> >> ISP/operator.
> >> > >> >That ISP must provide a home agent and an ip 
> address, and a CoA
> >> when
> >> > the
> >> > >> >MN is connected to other than the home subnet. Other 
> >> ISPs that are
> >> > used
> >> > >> >are only access providers, and would give the MN its 
> >> CoA. This of
> >> > course
> >> > >> >would cause political problems. Who are the ISPs that 
> >> are willing
> >> to
> >> > be
> >> > >> >access providers only, and who will be providing 
> home agent and
> >> home
> >> > >> >address as well?
> >> > >> >
> >> > >>
> >> > >> This is an issue. What happens if you have one access 
> provider on
> >> > >> one interface, say the wCDMA interface, and another on 
> >> another, say
> >> > 802.11?
> >> > >> There are now in the US a growing number of 802.11 access
> >> providers,
> >> > >> and I can imagine someone with a laptop having a 
> wCDMA modem and
> >> > >> an 802.11 card.
> >> > >>
> >> > >> Maybe something like the "roaming consortia" that 
> have sprung up
> >> > >> around ISP access might evolve, but the protocol 
> >> design/engineering
> >> > >> issue is whether there is any additional work (such 
> as the NAI in
> >> > >> the roaming consortia example) needed to enable 
> sharing of a home
> >> > >> address among interfaces for which different ISPs are 
> >> responsible.
> >> > >>
> >> > >> Something like SUCV, that would allow an ISP to 
> cryptographically
> >> > identify
> >> > >> to what other ISP an address belonged, might be useful in this
> >> context.
> >> > >>
> >> > >> 		jak
> >> 
>

---

From: James Kempf <[email-masked]>
Date: Mon, 13 Aug 2001 12:52:26 -0700 (PDT)

Doradla,

My understanding is that although the GPRS standard specifies MIP
for inter-GGSN handover, there has been very little effort to clarify
exactly how this would work and how it would interact with GTP-based
mobility, primarily, I'm told, due to lack of operator interest.
I do not know if manufacturers are even building MIP into their terminals.
So, prior to figuring out at the IP level how heterogeneous handover
would work, there is a need to figure out in GPRS how MIP and GPRS
will work together. 

		jak

>From: "Doradla, Anil" <[email-masked]>
>To: "[email-masked]'" <[email-masked]>
>Subject: [mobile-ip] Heterogeneous Handover - where do i look
>Date: Fri, 10 Aug 2001 11:28:03 -0500
>All: 
>
>We are seeing a desire for handover between 802.11 and GPRS networks.  Is
>there any group looking at the feasibility of this ? 
>
>Thanks in advance
>
>Anil Doradla
>If there are any operational issues involved in handover between operators
>that
>>That's like saying that BGP doesn't deal with the routing policy related to
>>business relationships between the owners of autonomous systems. You are
>>agreements between operators or administrative domains. That is NOT what
>>this WG is about.
>>
>>-Basavaraj
>>
>>> heterogeneous network roaming (such as between, theoretically, 802.11b
>>> WLANs and GPRS)?
>>> 
>>> Brad 
>>> 
>>> > Subject: Re: [mobile-ip] Heterogeneous Handover - How Would it Work?
>>> > 
>>> > Pat,
>>> > 
>>> > >Also, I believe that ETSI is working on a standard called GRX for
>>> GSM<-
>>> > >802.11
>>> > >roaming.
>>> > >
>>> > >PatC
>>> > >> There appear to be 2 emerging forums for these discussions, one
>>> under
>>> > the
>>> > >> auspices of WECA (http://www.weca.net) known as the WISPr group
>>> ('r'
>>> > being
>>> > >> >That ISP must provide a home agent and an ip address, and a CoA
>>> when
>>> > the
>>> > >> >access providers only, and who will be providing home agent and
>>> home
>>> > >> >address as well?
>>> > >> >
>>> > >>
>>> > >> This is an issue. What happens if you have one access provider on
>>> > >> and I can imagine someone with a laptop having a wCDMA modem and
>>> > >> an 802.11 card.
>>> > >>
>>> > >> Maybe something like the "roaming consortia" that have sprung up
>>> > >> issue is whether there is any additional work (such as the NAI in
>>> > >> the roaming consortia example) needed to enable sharing of a home
>>> > >> Something like SUCV, that would allow an ISP to cryptographically
>>> > identify

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Mon, 13 Aug 2001 21:04:00 +0100

It is feasible and 3G TS 29.061 and 3G TS 23.060 tell at a high level how to
do that.
This is an optional feature of UMTS and GPRS systems.

alessio

*>From: "Doradla, Anil" <[email-masked]>
*>To: "[email-masked]'" <[email-masked]>
*>Subject: [mobile-ip] Heterogeneous Handover - where do i look
*>Date: Fri, 10 Aug 2001 11:28:03 -0500
*>All: 
*>
*>Coming back to the question of handover across heterogeneous wireless
*>networks.  Can anyone advise me as to where i should look at?
*>We are seeing a desire for handover between 802.11 and GPRS 
*networks.  Is
*>there any group looking at the feasibility of this ? 
*>
*>Thanks in advance
*>
*>Anil Doradla
*>SBC- Technology Resources, Inc.
*>Austin, TX-78727
*> 
*>
*>-----Original Message-----
*>From: James Kempf [mailto:[email-masked]]
*>Sent: Friday, August 10, 2001 3:57 AM
*>To: [email-masked]; [email-masked]
*>Cc: Peter.Dahl
*>Subject: RE: [mobile-ip] Heterogeneous Handover - How Would it Work?
*>
*>
*>Glenn,
*>
*>I think Raj is right on here, sorry. There are enough technical issues
*>involved in getting MIP to be deployable that the MIP group really
*>needs to focus on. An example is this NAT question.
*>
*>If there are any operational issues involved in handover 
*between operators
*>that
*>need resolution, they should probably be handled in a separate working
*>group, like ROAMOPS. An example of such an issue might be advertising
*>access routers between operators using something like the Seamoby
*>CAR discovery protocol, which is just now getting off the ground.
*>
*>		jak
*>>Raj,
*>>
*>>That's like saying that BGP doesn't deal with the routing 
*policy related to
*>>business relationships between the owners of autonomous 
*systems. You are
*>>shoe-holing the group into only dealing with an enterprise - not the
*>>Internet. 
*>>
*>>-----Original Message-----
*>>From: [email-masked] [mailto:[email-masked]]
*>>Sent: Thursday, August 09, 2001 10:55 AM
*>>To: mobile-ip
*>>Cc: Peter.Dahl
*>>Subject: RE: [mobile-ip] Heterogeneous Handover - How Would it Work?
*>>
*>>
*>>Clearly, you are mixing roaming with seamless mobility across
*>>heterogeneous
*>>access types. The Mobile IP WG does not deal with aspects related to
*>>roaming
*>>agreements between operators or administrative domains. That 
*is NOT what
*>>this WG is about.
*>>
*>>-Basavaraj
*>>
*>>> -----Original Message-----
*>>> From: ext Dahl, Peter [mailto:[email-masked]]
*>>> Sent: Wednesday, August 08, 2001 1:53 PM
*>>> To: [email-masked]'
*>>> Subject: RE: [mobile-ip] Heterogeneous Handover - How 
*Would it Work?
*>>> 
*>>> 
*>>> ...not forgetting cdma2000.  I am not aware of any work in 
*>>> 3GPP2 or IEEE,
*>>> perhaps 3GPP ?
*>>> 
*>>> Pete
*>>> 
*>>> -----Original Message-----
*>>> From: Brad Casemore [mailto:[email-masked]]
*>>> Sent: Wednesday, August 08, 2001 11:29 AM
*>>> To: [email-masked]
*>>> Subject: RE: [mobile-ip] Heterogeneous Handover - How 
*Would it Work?
*>>> 
*>>> 
*>>> If that is the case, then WECA's WISPr is dedicated to 
*>>> 802.11b roaming,
*>>> while the ETSI has assigned a group to address GPRS roaming. 
*>>> Is there a
*>>> group anywhere that is looking into the technical issues 
*>>> associated with
*>>> heterogeneous network roaming (such as between, 
*theoretically, 802.11b
*>>> WLANs and GPRS)?
*>>> 
*>>> Brad 
*>>> 
*>>> > -----Original Message-----
*>>> > From: [email-masked] [mailto:owner-mobile-
*>>> > [email-masked]] On Behalf Of James Kempf
*>>> > Sent: Wednesday, August 08, 2001 2:19 AM
*>>> > To: [email-masked]; [email-masked]
*>>> > Subject: Re: [mobile-ip] Heterogeneous Handover - How 
*Would it Work?
*>>> > 
*>>> > Pat,
*>>> > 
*>>> > I think they already have such a standard and I believe it 
*>>> only works
*>>> > with GPRS.
*>>> > 
*>>> > 		jak
*>>> > 
*>>> > >Also, I believe that ETSI is working on a standard 
*called GRX for
*>>> GSM<-
*>>> > >802.11
*>>> > >roaming.
*>>> > >
*>>> > >PatC
*>>> > >On Tue, Aug 07, 2001 at 09:32:58AM -0700, Dahl, Peter wrote:
*>>> > >> FYI, the Wireless ISPs (WISPs) are already talking about such
*>>> roaming
*>>> > >> issues.
*>>> > >>
*>>> > >> There appear to be 2 emerging forums for these 
*discussions, one
*>>> under
*>>> > the
*>>> > >> auspices of WECA (http://www.weca.net) known as the 
*WISPr group
*>>> ('r'
*>>> > being
*>>> > >> for roaming), the other a yet to be finalized 'WISP Forum' the
*>>> prime
*>>> > mover
*>>> > >> for which is a company in Luxembourg (www.excilan.com).
*>>> > >>
*>>> > >> Regards
*>>> > >>
*>>> > >> -----Original Message-----
*>>> > >> From: James Kempf [mailto:[email-masked]]
*>>> > >> Sent: Tuesday, August 07, 2001 8:58 AM
*>>> > >> To: [email-masked]; 
[email-masked]
*>>> > >> Subject: Re: [mobile-ip] Heterogeneous Handover - How Would it
*>>> Work?
*>>> > >>
*>>> > >>
*>>> > >> >On the other hand, the home address must belong to some
*>>> ISP/operator.
*>>> > >> >That ISP must provide a home agent and an ip 
*address, and a CoA
*>>> when
*>>> > the
*>>> > >> >MN is connected to other than the home subnet. Other 
*>>> ISPs that are
*>>> > used
*>>> > >> >are only access providers, and would give the MN its 
*>>> CoA. This of
*>>> > course
*>>> > >> >would cause political problems. Who are the ISPs that 
*>>> are willing
*>>> to
*>>> > be
*>>> > >> >access providers only, and who will be providing 
*home agent and
*>>> home
*>>> > >> >address as well?
*>>> > >> >
*>>> > >>
*>>> > >> This is an issue. What happens if you have one access 
*provider on
*>>> > >> one interface, say the wCDMA interface, and another on 
*>>> another, say
*>>> > 802.11?
*>>> > >> There are now in the US a growing number of 802.11 access
*>>> providers,
*>>> > >> and I can imagine someone with a laptop having a 
*wCDMA modem and
*>>> > >> an 802.11 card.
*>>> > >>
*>>> > >> Maybe something like the "roaming consortia" that 
*have sprung up
*>>> > >> around ISP access might evolve, but the protocol 
*>>> design/engineering
*>>> > >> issue is whether there is any additional work (such 
*as the NAI in
*>>> > >> the roaming consortia example) needed to enable 
*sharing of a home
*>>> > >> address among interfaces for which different ISPs are 
*>>> responsible.
*>>> > >>
*>>> > >> Something like SUCV, that would allow an ISP to 
*cryptographically
*>>> > identify
*>>> > >> to what other ISP an address belonged, might be useful in this
*>>> context.
*>>> > >>
*>>> > >> 		jak
*>>> 
*>
*

---

From: "Shaheen, Kamel M." <[email-masked]>
Date: Tue, 14 Aug 2001 08:55:03 -0400

GPRS standards (i.e., 23.060) do not specify MIP for inter-GGSN handover. 

 -----Original Message-----
From: 	James Kempf [mailto:[email-masked]] 
Sent:	Monday, August 13, 2001 3:52 PM
To:	[email-masked]
Subject:	Re: [mobile-ip] Heterogeneous Handover - where do i look

Doradla,

		jak

---

From: "Doradla, Anil" <[email-masked]>
Date: Tue, 14 Aug 2001 08:49:54 -0500

Thanks for replying to my enquiry. I have looked at the 3GPP documents.  MIP
has been incorporated as an option for mobility management (i think it is
document 3GPP TS 29.023??).  Basically, there were three options laied out.
They are:
1.  Incorporating MIP totally in a 3GPP core
2.  Incorporate MIP and GTP together
3.  Make enhancements to GTP for mobility management.

You do bring up a good point that we need to understand how vendors are
implementing MIP in GPRS networks.  My 2 cents is that present GPRS networks
that are being deployed across the world do not incorporate MIP. 
As far as handsets are concered, we have not looked at them closely.  
BTW, do you have any references that you can lead me on to ??

Thanaks a lot

Anil 

----------------------------------------------------------------------------
------------
Wireless Communications Division
SBC Technology Resources, Inc.
9505 Arboretum Blvd
Austin, TX-78759
(512) 372-5805
FAX: (512) 372-5891

This e-mail and any files transmitted with it are the property of SBC, are
confidential, and are intended solely for the use of the individual or
entity to whom this e-mail is addressed.  If you are not one of the named
recipient(s) or otherwise have reason to believe that you have received this
message in error, please notify the sender at 512 372-5805 and delete this
message immediately from your computer.  Any other use, retention,
dissemination, forwarding, printing, or copying of this e-mail is strictly
prohibited.

 -----Original Message-----
From: 	James Kempf [mailto:[email-masked]] 
Sent:	Monday, August 13, 2001 3:52 PM
To:	[email-masked]
Subject:	Re: [mobile-ip] Heterogeneous Handover - where do i look

Doradla,

		jak

---

From: "Shaheen, Kamel M." <[email-masked]>
Date: Tue, 14 Aug 2001 10:51:44 -0400

Now it make sense! 

 -----Original Message-----
From: 	Xiaofeng Xu [mailto:[email-masked]] 
Sent:	Tuesday, August 14, 2001 12:37 PM
To:	[email-masked]
Subject:	Re: [mobile-ip] Heterogeneous Handover - where do i look

It should be TR 23.923.

Xiaofeng Xu wrote:

> TR 29.023 v3.0.0 is a Technical Report, not a TS. You may find it here:
> http://www.3gpp.org/ftp/Specs/2001-03/R1999/23_series/
>
> GGSN is the anchor point of a registered PDP context, no handover is
needed if
> MS stays in the GPRS network.
>
> Regards,
> Xiaofeng
>
> "Shaheen, Kamel M." wrote:
>
> > I searched for 29.023 but did not find a document under this number in
R99,
> > R4, nor R5.
> > Would you kindly refer me to where this document can be found.
> >
> > The working document for GPRS is 23.060. It has all related procedures
> > including mobility management.
> > One thing I am sure is not there is Inter-GGSN handoff (Hand-over)
> > procedures.
> >
> > Further,  If my memory serves me well, I recall reading that this issue
is
> > out of the scope of this document.
> >
> > If this issue is to come up, I believe 3GPP SA2 will be the place to
raise
> > this issue.
> > Regards,
> > Kamel
> > From:   Doradla, Anil [mailto:[email-masked]]
> > Sent:   Tuesday, August 14, 2001 9:50 AM
> > >>That's like saying that BGP doesn't deal with the routing policy
related
Work?
cryptographically

---

From: "Briancon, Alain C." <[email-masked]>
Date: Tue, 14 Aug 2001 10:57:46 -0400

does this change your view on sharif persoective?

-----Original Message-----
From: Shaheen, Kamel M. [mailto:[email-masked]]
Sent: Tuesday, 14 August, 2001 10:52
To: [email-masked]'
Subject: RE: [mobile-ip] Heterogeneous Handover - where do i look

Now it make sense! 

 -----Original Message-----
From: 	Xiaofeng Xu [mailto:[email-masked]] 
Sent:	Tuesday, August 14, 2001 12:37 PM
To:	[email-masked]
Subject:	Re: [mobile-ip] Heterogeneous Handover - where do i look

It should be TR 23.923.

needed if
R99,
is
raise
related
Work?
cryptographically