Subject: RE: [mobile-ip] Improvement in Proxy DAD functionality for Mobility Support in IPv6

From: "Patil Basavaraj (NET/Dallas)" <[email-masked]>
Date: Tue, 21 Aug 2001 11:47:23 -0500

>>Francis Dupont Wrote:
>> PS: the HA should flush the whole context too, including keys.
>
>Charles Perkins wrote:
>This would be bad for mobile nodes that want to sleep but use the same
>security association when they wake up a few hours later.
>

This seems to be an implementation issue. You could specify a large
lifetime for the binding and allow MNs to sleep. I think flushing the
entire context in case of lifetime expiry of a binding makes sense.

>Regards,
>Charlie P.

-Basavaraj

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 21 Aug 2001 09:57:27 -0700

Hello Basavaraj,

> entire context in case of lifetime expiry of a binding makes sense.

But these are two different things.  The binding has to do with
getting packets to go places.  The security association has to do
with authenticating bindings.  Just because the home agent is supposed
to stop redirecting packets doesn't mean that it needs to purge the
whole means by which binding updates are authenticated.

Why make them the same?  They aren't even managed in the same part
of the code.

Regards,
Charlie P.

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 21 Aug 2001 10:19:37 -0700

when the binding chache entry expires, you send a binding 
request for the mobile node. if the mobile node does not
respond you delete the binding cache entry and the proxy
neighbor cache entry. you do not delete the security
association the home agent shares with the mobile node. 
after deleting the proxy neighbor cache entry the home 
agent does not intercept packet, does not send out 
neighbor advertisements on behalf of the mobile node. 
this is the default behavior.

Vijay