Subject: Re: [mobile-ip] IPsec, IKE, MIPv6 and concensus

From: Mohan Parthasarathy <[email-masked]>
Date: Thu, 16 Aug 2001 16:34:03 -0700 (PDT)

> 
> So the questions that should be answered IMO are:
> 
> 1. Do we want to completely disallow the use of IKE ?
> 
> 2. Do we want to completely disallow the use of IPsec ?
> 
> I guess based on the WG concensus this should be reflected
> in the draft so we can get on with our implementations.
> 
> What do people think ?
> 
> My answer to both questions is No.

Agreed.

> I do believe that there will
> be cases where strong authentication will be required. Since 

Correct. We need this for communication between MN and HA.

-mohan

> there are ways of allowing the use of both IKE (as an option)
> and IPsec (whether its AH or ESP) then I don't see why we can't
> reuse them. 
> 
> Regards,
> Hesham
> 
> 
> 
> 
>

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 16 Aug 2001 16:53:53 -0700

IKE and 'authentication data suboption' is also strong
authentication IMHO

authentication data suboption = 
	hmac_md5("bu option + home address option",
		  len, key, key_len)

here the key is generated by IKE.

vijay