Subject: Re: [mobile-ip] Re: So what is bicasting vs. buffering

From: kempf <[email-masked]>
Date: Thu, 2 Aug 2001 16:08:51 -0700 (PDT)

Pat,

>ok, so then the options are:
>
>1. mobile initiated (mn signalling over the air)
>2. network initiated (no over the air signalling)
>
>and
>
>1. don't buffer on NewAR
>2. buffer on NewAR
>
>So, it is always bicasting, but some proposals use different mixes
>of the alternatives above.

1-2 is not exclusive. In FMIPv6, new AR discovers the handover
is happening via HI/HACK, so you could buffer on new AR even if the
handover is mobile initiated. In low latency MIPv4, you would have to buffer on 
old FA 'cause there is no HI/HACK required unless you optionally do a 
HRqst/HRply to inform new FA.

As to whether there is bicasting or not, if you buffer on old AR as
recommended in draft-krishnamurthi..., you don't have to bicast. 
You just buffer on old AR until the mobile sends an over the air BU to old AR,
then the mobile gets the buffer. No packets are sent through 
new AR until the mobile is done establishing its new CoA.

		jak

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 8 Aug 2001 01:09:14 +0200

> Isn't it possible for a network initiated handover to
> utilize signalling over the air to tell the mobile node
> to get moving?
> 
	=> It depends on which mode of the FMIPv6 you use 
	 especially if BETH is incorporated.

> > => Exactly. As for (1) above, I certainly prefer it
> > (or strongly propose) that we work within the current
> > Fast Handovers draft. Ie. The MN signals before
> > moving. Signalling after the movement would imply an
> > unnecessary RTT to release the buffers.
> 
> This is great as long as it is possible.  However, for some
> systems it may not be possible, and I don't see any reason
> to _restrict_ the smoothing request so that it could never
> be issued from the new AR.
> 
	=> Can you give an example of these systems or 
	 the reason for it not being possible ?
	Depending on the example above then if the oAR is 
	aware of the MN's mobility it can act accordingly, 
	if not then there is not point is any smoothing and 
	standard MIPv6 can apply.

> > In addition I don't think we need a buffer management
> > protocol. The calculation of buffer sizes and
> > release ...etc should be left to the oAR (or nAR if
> > needed).
> 
> Unfortunately, the details about how much to buffer and so
> on are application dependent, and not able to be reliably
> calculated by the access routers.  
> 
	=> Does that mean the AR's will have to look into packets and 
	determine separate buffers for different applications ?
	Sounds complex.

> There should probably be
> a default minimum capability, agreed.  Furthermore, buffering
> should be done without request only when it isn't being
> charged for, and when doing so doesn't affect the ability
> to offer buffering for other customers who might really 
> need it.
> 
	=> I find it hard to see charging for buffering as a business 
	case. Do you really think operators will sell and additional
	"buffering" service to subscribers ?

	Regs,
	Hesham

---

From: James Kempf <[email-masked]>
Date: Tue, 7 Aug 2001 23:35:35 -0700

Hesham,

>	standard MIPv6 can apply.

I think Charlie was thinking of 802.11. L3 on the MN only leans of
a handover after it has happened. Don't know if the AP L2 does default buffering
for a MN that has moved, as is the case for dormant mode MNs, however.

		jak