Subject: [mobile-ip] MN-FA/MN-HA Key Material clarification needed

From: "Mikael Wolf" <[email-masked]>
Date: Thu, 16 Aug 2001 08:24:08 +0200

draft-ietf-mobileip-aaa-key-08.txt, chapter 3,
specifies the algorithms to be used for producing
the authentication information included in the Mobile
Home Authentication extension or the Mobile Foreign
Authentication extension; one of them is SHA-1 (#3).

However, a hash function cannot be used as a MAC
since it does not rely on a secret key (contradictory to
what is stated in chapter 3).

Please clarify how SHA-1 should be used provide
authentication.

Thanks,
Mikael.

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 16 Aug 2001 16:45:56 -0700

Chapter 3 defines the hashing algorithms used in the computation
of the relevant authentication extensions, not how to encrypt the
key. So, the key material is used to create the key, and the key is
used to create the auth extensions.

Hope this is clearer,

PatC

---

From: "Mikael Wolf" <[email-masked]>
Date: Fri, 17 Aug 2001 07:11:48 +0200

But anyone can compute a correct digest using SHA-1, i.e.,
just using a hash function does not provide any authentication.

You mention that the key is used to create the authentication
extensions, but how the key should be used is not clear; SHA-1
in itself does not use a key. In contrast, HMAC-SHA-1 does
specifiy how to use a key together with SHA-1 to provide
authentication. Therefore, I would expect the Algorithm Identifier
to specify HMAC-SHA-1 ( and possibly SHA-1/prefix+suffix? )
as supported algorithm(s), and not SHA-1.

Mikael.

----- Original Message -----
From: "Pat Calhoun" <[email-masked]>
To: "Mikael Wolf" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Friday, August 17, 2001 1:45 AM
Subject: Re: MN-FA/MN-HA Key Material clarification needed

---

From: Pat Calhoun <[email-masked]>
Date: Mon, 20 Aug 2001 13:19:55 -0700

Will change to HMAC-SHA-1, instead of SHA-1.

PatC