Subject: Re: [mobile-ip] Concerns about draft-mipv6-14 section 4.8

From: Thierry Ernst <[email-masked]>
Date: Mon, 6 Aug 2001 09:13:11 -0700 (PDT)

--- Mattias Pettersson
<[email-masked]> wrote:
> I don't question an MR would be useful. The question
> is what functions
> we put in it.
> For me, what it boils down to is that I prefer not
> to have some nodes
> perform operations on behalf of other nodes. It's
> needed at times, but
> hopefully in static configurations (a home agent is
> rather static). I
> don't see a mobile network as (always) a static
> entity, so I would look
> for other solutions.
> 
> Also, the trust model for a mobile network with an
> MR doing registration
> on behalf of MNs is more complex than one where each
> MN is out on its
> own.

MN is quite a confusing term to me.  I used to speak
about MNNs in general, MNN being one of MR - LFN - VMN
- LMN. See my requirement draft.  The distinction is
useful to avoid confusion - I have noticed we don't
always speak about the same thing.

Then, do you want all MNNs in the network to register
a 128-128 binding with the MR's HA ?  Sounds odd to
me.

> Is there such a big need for sending BUs covering an
> entire prefix
> rather than /128? If a MH behind the MR needs to
> update a CN, there is
> pretty low probability that another MH behind the MR
> would be talking to
> the same CN and thus send a BU to that. So each MH
> should take care of
> sending BUs to CNs, and the MR should not aggregate
> them. So, we don't
> need to allow more than /128.

Yes there is a big need if you want:
- the MR's Home Agent to redirect all packets intended
to nodes behind the MR
- to limit the number of BUs in the network
- to keep mobility management relative to MR's
mobility away from the nodes behind the MR
- other ...

Thierry

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

---

From: Mattias Pettersson <[email-masked]>
Date: Tue, 07 Aug 2001 11:24:46 +0200

Hi Thierry,

> always speak about the same thing.

Sorry, I didn't have your draft at hand. I admit that I was using weak
definitions. I should really stick to your definitions. 

> a 128-128 binding with the MR's HA ?  Sounds odd to

The MNNs in the mobile network doesn't have the same HA as the MR. They
can have, but in general they could be VMNs with some arbitrary HA, or
be LMN and use some router on the mobile network itself (MR for
instance) as HA. The latter sounds like introducing a nesting problem.

Back to your question: I haven't studied the problem in detail, so I
can't say that all nodes in the mobile network (all MMNs) should use the
same HA. However, if they do, as you suggest, then I don't see a problem
doing prefix registrations. The HA at least should know what prefixes
are delegated to certain MRs. Or, each MNN could register to that HA on
its own, but that would be a waste of signalling.

> - the MR's Home Agent to redirect all packets intended

I agree, if you can convince me that all nodes behind the MR should use
that HA.

> - to limit the number of BUs in the network

Depending on the mobile-awareness the MNNs have, you can do different
things here. Mobile-aware MNNs could send /128 to CNs, mobile-unaware
MNNs could let MR send entire mobile network prefix to CNs.

> mobility away from the nodes behind the MR

If so, yes...

> Thierry

/Mattias

PS. I know v6-network-01.txt doesn't deal with MNNs that are moving with
regards to the MR. The monetv6-00.txt does addresses it though. I just
don't want to rule out these possibilities at this stage.

---

From: Thierry Ernst <[email-masked]>
Date: Tue, 7 Aug 2001 05:03:27 -0700 (PDT)

Hi Mattias,

--- Mattias Pettersson 

> instance) as HA. The latter sounds like introducing

What I advocate is that fixed nodes within the mobile
network (LMNs) are not changing their own attachment
point as a result of the MR's mobility.   Then, they
should be mobility-un-aware (if you want me to argue
whether they should be mobility aware or not, I can). 
Then, they don't have a HA, and shouldn't themselves
register the careof address of the MR to the MR's HA. 
Then, here is the need for a prefix registration.

Of course, you may allow visiting mobile nodes that
enters the mobile network (e.g. a train), what I call
VMNs.  This is a nested mobility instance.  These
nodes have their own HA, and it's not MR's HA.   VMNs
need to register with their HA, but what address ?
If they operate Mobile IPv6, they would register a
careof address that belongs to the mobile network,
i.e. an address that is only topologically correct
when the MR is attached on its home link.   Packet
would transit through the MR's HA, i.e. not optimal
routing unless you provide VMN's CN with the MR's
careof address too.   Alternatively, you may want to
use HMIPv6 Extended Mode where VMN obtains a more
topologically correct address.

> I agree, if you can convince me that all nodes

I don't say all, I'm just saying that the most general
case is where MNNs are only fixed nodes.  To me, I can
see more instances where MNNs are fixed (LFNs) than
mobile (VMNs).  In any case, there will always be LFNs
in a mobile network, not necessarily VMNs. Even in a
train. 

May be  you generalize the "VMN" case too much

> MNNs could let MR send entire mobile network prefix

You are not wrong, but I would be happy to hear from
you what address you put in the BU if MNNs send the BU
itself.

> don't want to rule out these possibilities at this
stage.

I do not want to rule these possibilities out either,
but I want to point out that this is a bit more
complicated in face of nested mobility. 
v6-network-02.txt keeps things simpler, and does not
pretend to rule anything out.   Draft monetv6-00 is
more important and aims to address all possibilities. 

Thierry
Motorola Labs and INRIA Rhone-Alpes.

---

From: Michael Thomas <[email-masked]>
Date: Tue, 7 Aug 2001 06:14:59 -0700 (PDT)

> Then, here is the need for a prefix registration.

   Agreed.

 > topologically correct address.

   I believe that this brings out the problem that
   I describied a while ago: since there are multiple
   BU's that would be arriving at the CN from different
   sources, how does the CN know how to *order* the 
   routing headers? You're not proposing that
   either one or the other send BU's exclusively,
   right?

   Also: when I was thinking about this, I scratched
   down a diagram and flows to make sense of this;
   I think that any discussion of this would help
   greatly if we had such a common reference  (half
   volunteering... :)

 > in a mobile network, not necessarily VMNs. Even in a

   Just a nit, but it there may be more instances
   of LFN's, but I certainly wouldn't consider the
   case of a VMN on a MR to be an uncommon case.
   Your friend's palm pilot gets into your car
   with its mobile router and voila...

 > you what address you put in the BU if MNNs send the BU

   It would clearly put the CoA of it's local
   attachment point as always, right? If we 
   hide mobility from LFN's, we would want
   to hide it from MN's, right (how could MR
   know)?

	Mike

---

From: Mattias Pettersson <[email-masked]>
Date: Tue, 07 Aug 2001 16:11:49 +0200

> Then, here is the need for a prefix registration.

I agree that this is one case. Maybe we should start with this simple
case and try to make it work. However, I fear that users will require
more things from their mobile networks than fixed subnets and one MR.

> topologically correct address.

Yes.

> May be  you generalize the "VMN" case too much

I just don't want to spend a lot of WG effort on standardising a
solution for mobile networks with support for only LFNs, unless this
solution can be extended later (if needed) to support mobile-aware MNNs
too, and also more complex versions of the structure of the mobile
network.

If a solution for only LFNs and one for arbitrary MNNs differ a lot,
then I think we should go for the latter one immediately.

> you what address you put in the BU if MNNs send the BU

You would need a topologically correct prefix to form CoAs from. The MR
could either request one for delegation from the AR (prefix delegation
I-D), or use something like multilink subnetting to extend the subnet
currently between AR and MR to also cover the mobile network.

> more important and aims to address all possibilities.

Yes, nested mobility could show to be so complex that it will in fact be
impossible.

/Mattias

---

From: Thierry Ernst <[email-masked]>
Date: Tue, 7 Aug 2001 07:47:44 -0700 (PDT)

--- Mattias Pettersson 

> more things from their mobile networks than fixed

I definitely agree.  This is the reason why I have
written the requirements draft.

> then I think we should go for the latter one

We can based solution on my 'Prefix Scope BU'
proposals and extend to the VMN case.  My proposal
works as is for VMNs, but packet would transit via the
MR's HA.  At least, that works.

> currently between AR and MR to also cover the mobile

Exactly.  Then, we agree that something else is needed
than simply masking use of Mobile IPv6.

Thierry
Motorola Labs and INRIA Rhone-Alpes

---

From: Mattias Pettersson <[email-masked]>
Date: Tue, 07 Aug 2001 16:54:13 +0200

Hi Mike,

>    either one or the other send BU's exclusively,

The CN would end up with two entries in its binding cache:
  1. VMN HoA -> VMN CoA at mobile network
  2. mobile network prefix -> MR's CoA

So CN would first match VMN HoA to entry 1. Next, it would need to know
that it should check the binding cache again, until it gets no more
hits. Second run it would match "VMN CoA at mobile network" to entry 2.
It would build a routing header (only one) and insert addresses in
reverse order, i.e. last hit first.

Not very standard, but hopefully works.

>    greatly if we had such a common reference  (half

I had to draw something myself because this is just impossible to keep
in order... :)

>    with its mobile router and voila...

Well, you wouldn't want to route traffic for anyone that are in range of
the MR. I'd be quite restrictive on how to pick my friends... :)

I also see that the mobile network could be partitioned and other
things.

/Mattias

---

From: Thierry Ernst <[email-masked]>
Date: Tue, 7 Aug 2001 08:04:50 -0700 (PDT)

--- Michael Thomas <[email-masked]> 
>    either one or the other send BU's exclusively,

Michael,

You are right in the sense that 'this problem would
exist if ...'.  Everyone knows that you could bottle
Paris with 'if's (French expression, attempt to
translate ...).  However, notice that the 'Prefix
Scope BUs' draft specifies that the solution is
limited to 'FIXED NODES' within the mobile network. 
This 'double BUs' problem is not in the right context
as there is no actual solution that proposes to send a
BU for a VMN, and another one for the MR.  I have
noticed the problem you are speaking about straight
from the beginning and I voluntary excluded the VMN
case from the 'Prefix Scope BUs' draft to avoid to
enter into details and to propose an easy to implement
solution.  This problem is only based on assumptions
that no one has ever been made.

The first target I have is to make people in this WG
aware that there are problems to solve, and I focused
on the trivial and most obvisous ones.  This target is
reached. Then, let's make today this subject a working
group item, let's discuss pbs and requirements and we
can propose solution that address a specific scope of
the problem.

>    with its mobile router and voila...

VMNs are in the requirement draft.

>    attachment point as always, right? If we 

Wrong: the Coa is not topologically correct, unless
the mobile network renumbers, which brings loads of
other issues ...

Thierry

---

From: Michael Thomas <[email-masked]>
Date: Tue, 7 Aug 2001 09:19:54 -0700 (PDT)

> that no one has ever been made.

   Well, I guess that I'm preceding from the assumption
   that if we do MR's, that we not limit them to stationary
   nodes behind a MR. The argument, such as it is, may
   just be requirements if the WG decides only to consider
   what you targeted, but until then, I think it's worthwhile
   to explore the problem space to see whether there's a
   technical reason to push back on creating a general
   solution. Part of my motivation here is that we not
   blindly add features to MIP that ultimately lead to
   engineering dead ends. This hypothetical network
   seems both plausible and should nicely demonstrate
   what a lot of the global implications of mobile
   networks are. Even though I generally support your
   general method of hinding mobility, the reason I 
   hedge is because the larger issues may inform us
   that that was short sighted. 
 
 > can propose solution that address a specific scope of

   Sure.
 
 > the mobile network renumbers, which brings loads of

   How does an access router which farther downstream
   from the MR find out which prefix it should hand out?

   Unrelated: there seems to be an assumption that
   there is only one uplink on the MR. To my mind,
   that doesn't seem like an especially good assumption
   for a generalized MR solution. It's not hard to
   imagine that an aircrash carrier would want to
   be multihomed, for example.

		  Mike