Subject: RE: [mobile-ip] IPsec, IKE, MIPv6 and concensus

From: [email-masked]
Date: Thu, 23 Aug 2001 00:10:35 +0300

Hesham wrote:
> > 
> > Sure this is a performance optimization only, and the 
> degree of the benefit
> > depends heavily on the type of L2's in both ends, feature 
> interaction with
> > HC, etc., but if done right there is nothing that would 
> make the standard
> > "only work sometimes". It is quite customary that standards 
> have options
> > that are not always used.
> > 
> 	=> The question is whether this complexity you mention above
> 	(L2 interaction, HC implications, Path MTU ....etc) are worth 
> 	the hassles. There is no foreseen benefit really if you're
> 	using ROHC for example. Do you think the perceived gain 
> 	actually outweighs the processing headache ?
> 	If it does then what you're suggesting would make a lot of sense.
> 

All that complexity of figuring out when it is worthwhile and possible to
piggyback lies on the engineer implementing piggybacking. If you rather not
bother, then do not piggyback. There is no added complexity for the
recipient.

Also, if you'd *know* piggybacking has absolutely no benefit, why'd you tell
your competitors that :-?

Seriously, you should piggyback only if you think it's worth the effort.

	Jarno

---

From: Michael Thomas <[email-masked]>
Date: Thu, 23 Aug 2001 09:55:51 -0700 (PDT)

> bother, then do not piggyback. There is no added complexity for the

   That's not completely true: if there is a requirement
   that *all* receivers accept piggybacking, then they
   share the burden. 

 > Seriously, you should piggyback only if you think it's worth the effort.

   I think we have an inversion of priorities going on
   here (and throughout the rest of the IETF, for that
   matter). The question should not be framed as
   if it's not a big deal, throw it in, it should
   be framed as why do we absolutely, positively
   _have_ to have this feature. The net is getting
   far too complicated, and the law of unintended
   consequences brought to the fore far too often.

   It's already been shown that there's a great
   deal of possibility for unintended consequences
   with piggybacking -- consequences I'll add
   which are quite possible regardless of whether
   IPsec is used or not. Unless somebody can show
   some concrete wins which cannot be achieved in
   any other way than L3 piggybacking, we should
   be prudent and defer that discussion for
   another day when we know more.

	       Mike