Subject: RE: [mobile-ip] Analysis of Latency Propagation with Buffering

From: Phillip Neumiller <[email-masked]>
Date: Wed, 1 Aug 2001 14:57:51 -0400

And it sure seems more logical to bicast since if you need it you
DONT have to ask for it and WAIT around the RTT!

-pdn

> -----Original Message-----
> From: Pat Calhoun [mailto:[email-masked]]
> Sent: Wednesday, August 01, 2001 1:28 PM
> To: [email-masked]
> Subject: Re: [mobile-ip] Analysis of Latency Propagation with 
> Buffering
> 
> 
> On Wed, Aug 01, 2001 at 10:32:30AM -0700, Charles E. Perkins wrote:
> > If a packet is received by the mobile node,
> > then presumably it would prefer not to receive the buffered copy of
> > that packet at any time in the future.
> 
> sure, otherwise that would sure look like bicasting :)
> 
> PatC
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 01 Aug 2001 12:42:14 -0700

Hello Phil,

If I order a pizza, and somebody brings me two, and
charges me twice, that's bad.

If I get two for one for free, that's better, but from
the standpoint of the restaurateur it would be nice
if the government didn't tell him he HAD to serve me
two for one.  Furthermore, if I'm tired of eating and
I still have to swallow the extra food, I might complain
even about the freebie.

If, on the other hand, I can buy just the pizza I want,
and if I have to leave before I finish the meal but
later I can ask for the slices that are still hot,
that sounds about right to me.

Regards,
Charlie P.

---

From: Pat Calhoun <[email-masked]>
Date: Wed, 1 Aug 2001 13:38:44 -0700

> that sounds about right to me.

But chances are you'll end up with the remaining slices, which
are now cold, and a new pizza that is warm as well.

So, if a packet stays around in a buffer long enough (and we're not
talking that long), the peer will most likely retransmit, and you'll
end up with dups anyways.

PatC

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 01 Aug 2001 13:58:41 -0700

Hello Pat,

> end up with dups anyways.

This is a matter for managing the probabilities for such occurrences,
and when it gets to that point the analogy cannot help any more.
But simulation and prototype indicate that the necessary data (slices
of pizza) can be consumed in enough time to help with voice.  And it
can be done in a way to avoid dups entirely.

I thought the analogy would be useful for illustrating points about
resource consumption and so on, but not for evaluating probabilities
or other engineering parameters.

Just to be clear, I am not categorically against bicasting, but I
think it's true realm of applicability is not large enough to be
mandated as part of fast handover protocol, and that there may often
be more economical approaches available.

Regards,
Charlie P.