Subject: RE: [mobile-ip] Mobile IPv6 draft revision

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 21 Aug 2001 03:39:04 +0200

Hi Charlie, 

A couple of questions/comments below

> - Reorganizing the Binding Update format so that:
>   = authentication data is able to be included as a suboption
> 
	=> Is this needed ? Based on the point below we can eliminate
	this completely. There was a concern on how this would 
	work with IKE. Will that be addressed ?

>   = Specify that the Binding Update needs a new header number
> 
	=> Should this one be kept for MIPv6 options as well ? 
	Like the home adderss option for example.

	Hesham

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 20 Aug 2001 18:45:58 -0700

Hello Hesham,

>         work with IKE. Will that be addressed ?

I don't know what to put in the draft about IKE.  I understand we're
not supposed to be messing with IKE, and I am pretty sure it's too
much work to mandate for all correspondent nodes.

>         Like the home adderss option for example.

The home address option does not have to be authenticated.
I reckon that the Binding Acknowledgement would need to have
a new header number also -- or else if there is a need to conserve
those numbers it could have the same header number as the
Binding Update.

Regards,
Charlie P.

---

From: Francis Dupont <[email-masked]>
Date: Wed, 22 Aug 2001 10:38:50 +0200

=> there is a difference : BU needs a final header number,
H@ needs an intermediate header number but:
 - at the winter IETF meeting, Steve Deering clearly stated
   this (new intermediate header number) should *not* be done
 - all IPv6 implementations must be changed in order to deal with
   a new intermediate header number
BTW, what to do for BAs (which have an unclear security requirement,
I believe the purpose in to protect BAs for home registration, not
all BAs ???) and BR...

Regards

[email-masked]