Subject: RE: [mobile-ip] RFC2002bis

From: [email-masked]
Date: Sun, 12 Aug 2001 15:23:45 -0500

Hi,
Some comments inline:

>>Hello folks,
>>
>>A new version of RFC2002bis has been prepared.  According
>>to the most recent guidance given by the IESG, a change in
>>the mandated authentication algorithm has been strongly
>>suggested.  Unfortunately, this will have the effect of
>>causing almost all previous implementations of Mobile IP
>>for IPv4 to become incompatible with the new specification.
>>
>>The working group chairs recently asked the working group,
>>by way of the mailing list, whether this incompatible
>>change would be acceptable.  The discussion was quite
>>limited, somewhat to my surprise.  This has been taken
>>as evidence that going with HMAC_MD5 is more-or-less
>>O.K.  Thus, it has been decided to go ahead with the
>>change.  On the other hand, it is conceivable that not
>>all interested parties have been notified of the possible
>>change, or have had time to reply.  If there are dissenters
>>to this change, now would be the time to express that
>>opinion.
>
>This could be an issue.  TIA/EIA IS-835 (the packet data standard for 
>CDMA2000) is going to be deployed in North America this fall.  It
specifies 
>the user of RFC 2002.  There are two major areas of incompatibilty in
RFC 
>2002bis:
>1) the inclusion of the SPI in the auth calculation
>2) HMAC_MD5 if that is decided on.
>

So IS-835 implemantations would  be compliant with RFC2002.  The SPI
interpretation in 2002 was a problem which was one of the reasons for
working on 2002bis. 

>Both of these things break 2002 - which means that the mobiles and 
>infrastructure that are 835 compliant will be obsoleted when RFC 2002
is 
>obsoleted.

Well, the IS835 implementations would still be compliant with RFC2002,
which would be obsoleted by a new RFC. The point is they would still
be compliant with RFC2002, but NOT the new RFC which supercedes it.

>I think that both of these fixes are good (the SPI was a bug that
slipped 
>through in 2002, and HMAC sounds like it is less vulnerable than vanila

>MD5) but they could cause issues in these planned network
>deployments.

The IS-835 network is not yet deployed on a commercial basis. And you
seem to agree that the above fixes would be good for the spec. Would
make sense to consider making these changes now than later when it is
deployed. 

>-----------------------------------
>Marcello (Wandering through France)
>

-Basavaraj

---

From: "Chae-yong Chong" <[email-masked]>
Date: Mon, 13 Aug 2001 08:16:16 +0900

Hi. 

This is just an information for you.

The IS-835 network is already deployed in Korea on a commercial basis.
If you asked that how many subscribers are using Mobile IP service, I am
sorry not to give you an exact answer. That answer could be given by
some guys of Operators, SK Telecom ro KTF :-)
I think you all just consider the situation of North American. :-(

As far as I know, there is no commercial product for
Mobile Node software. Okay. I agree that you could assume that
the current deployment in Korea could be regarded to a nothing.
(If the number of Mobile IP service subscriber is just trivial)
I just write this message to let you know that IS-835 is ALREADY deployed somewhere :-)

Chae-yong

---

From: Marcello Lioy <[email-masked]>
Date: Mon, 13 Aug 2001 17:03:05 +0200

>I think you all just consider the situation of North American. :-(

I know for a fact that the current IS835 deployment in Korea does not 
support Mobile IP - this will change in short order, as the infrastructure 
will be upgraded, when the new mobiles will have support for it.

I did not mean to disregard Korea - It is just that the only large scale 
M.IP deployment that was immanent was that in the U.S.

---

From: "Chae-yong Chong" <[email-masked]>
Date: Mon, 20 Aug 2001 13:48:13 +0900

Oops I'm late to reply your message -_-

However, could you explain about your statement "a fact that the current IS835 deployment in Korea
does not support Moblie IP"? Why do you think so?

As far as I know, the Mobile IP in SKT/KTF is just working. They only are lack of Mobile Node software. 

Chae-yong