Subject: RE: [mobile-ip] Improvement in Proxy DAD functionality for Mobility Support in IPv6

From: "Patil Basavaraj (NET/Dallas)" <[email-masked]>
Date: Tue, 21 Aug 2001 09:53:46 -0500

>Section 9.2 of the draft says that when the MN requests the HA to no
>longer serve as it's HA (returns home) :
>
>"In addition, the home agent MUST stop intercepting packets on the
>mobile node's home link addressed to the mobile node (Section 9.3)."...
>
>I feel this step should also apply for the HA when the binding cache
>entry expires.
>
>
>I would like to suggest that the draft be modified to say that when an
>entry in the binding cache expires, the home agent MUST stop
>intercepting packets on the mobile node's home link addressed to
>the mobile node.
>

I guess your suggestion is to add further clarification in section 9.2
detailing the behavior when the lifetime of a binding expires. If the
lifetime of the binding for an MN expires, does the HA send out a
"gratuitous" Neighbor Advertisement message on the home link?

>I would appreciate any comments on this issue.
>
>Thanks,
>
>- KK
>
>Krishna Kumar

-Basavaraj

---

From: "Krishna Kumar" <[email-masked]>
Date: Tue, 21 Aug 2001 08:57:50 -0700

Hi Basavaraj,

>detailing the behavior when the lifetime of a binding expires.

You are right. Currently, the behavior when the lifetime expires is to
just delete the binding entry. It can be modified to add that the home
agent MUST stop intercepting packets on the mobile node's home link
addressed to the mobile node.

> If the ifetime of the binding for an MN expires, does the HA send out a

No, that does not happen. The MN, if it is up and still needs mobility
support, would have sent a Binding Update to the HA before the entry
expired, but the HA doesn't assume the MN is up unless it gets a fresh
Binding Update.

Thanks,

- KK

---

From: "Patil Basavaraj (NET/Dallas)" <[email-masked]>
Date: Tue, 21 Aug 2001 12:57:14 -0500

> 
> when the binding chache entry expires, you send a binding 
> request for the mobile node. if the mobile node does not
> respond you delete the binding cache entry and the proxy
> neighbor cache entry. you do not delete the security
> association the home agent shares with the mobile node. 
> after deleting the proxy neighbor cache entry the home 
> agent does not intercept packet, does not send out 
> neighbor advertisements on behalf of the mobile node. 
> this is the default behavior.
> 
> Vijay
> 

Thanks for the clarification Vijay. It does make sense to leave
the SA associated with the MN intact even if the binding cache is
cleared. 

-BP