Subject: [mobile-ip] RE: So what is bicasting vs. buffering

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 3 Aug 2001 17:43:37 +0200

ok, so then the options are:

1. mobile initiated (mn signalling over the air)
2. network initiated (no over the air signalling)

and

1. don't buffer on NewAR
2. buffer on NewAR

So, it is always bicasting, but some proposals use different mixes
of the alternatives above.

=> Exactly. As for (1) above, I certainly prefer it 
(or strongly propose) that we work within the current
Fast Handovers draft. Ie. The MN signals before
moving. Signalling after the movement would imply an
unnecessary RTT to release the buffers. 
In addition I don't think we need a buffer management
protocol. The calculation of buffer sizes and 
release ...etc should be left to the oAR (or nAR if 
needed). 

Hesham

PatC
On Fri, Aug 03, 2001 at 12:40:51AM +0200, Hesham Soliman  (ERA) wrote:
>  
> So in my mind, I believe that the main difference between the
bicasting
> and buffering approaches is simply that the latter requires the mobile
> to *request* packets.
> 
> Am I right?
> 
> => Not at all :)
> The proposal that Charlie mentioned IS bicasting
> that is the point I'm trying to make. 
> I don't understand why people assume that if you bicast 
> then by definition you can't buffer. You can
> delay packets destined to the new AR/FA based on some 
> calculations of the average time for a handover. 
> 
> In addition you can bicast without a request from the 
> MN (ie. by default in the AR). 
> However, if you say I will send packets to the MN
> at the current AR and send another copy to the new
> AR then you ARE bicasting but just don't want to
> say the word :))))))))
> It doesn't matter how long you buffer or delay the 
> packets destined to the new AR you are still sending
> TWO copies. 
> 
> There are hidden assumptions if you do it by default 
> in the AR though (without the MN's request). The 
> assumption is that you know when the MN disconnects.
> This is not generic of course so you still need 
> to allow for the option of the MN requesting bicasting.
> 
> 
> Hesham

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 03 Aug 2001 09:34:32 -0700

Hello Hesham et al.,

> 2. network initiated (no over the air signalling)

Isn't it possible for a network initiated handover to
utilize signalling over the air to tell the mobile node
to get moving?

> 2. buffer on NewAR

Buffering at the OldAR should be an allowed option.

> unnecessary RTT to release the buffers.

This is great as long as it is possible.  However, for some
systems it may not be possible, and I don't see any reason
to _restrict_ the smoothing request so that it could never
be issued from the new AR.

> release ...etc should be left to the oAR (or nAR if

Unfortunately, the details about how much to buffer and so
on are application dependent, and not able to be reliably
calculated by the access routers.  There should probably be
a default minimum capability, agreed.  Furthermore, buffering
should be done without request only when it isn't being
charged for, and when doing so doesn't affect the ability
to offer buffering for other customers who might really 
need it.

Regards,
Charlie P.