Subject: RE: [mobile-ip] problem about deregistration of MIP

From: [email-masked]
Date: Fri, 26 Oct 2001 06:25:04 +0300

Thank you very much.

I have another question:
If the home address is allocated dynamilcally, that is to say, in
Registration Request, the home address is zero, and the allocated home
address is returned by Registration Reply.
Then if the MN deregistrater, must it fill the home address with
allocated home address?

Best regards
Le Yanqun

-----Original Message-----
From: ext Mohammad Akram [mailto:[email-masked]]
Sent: Thursday, October 25, 2001 9:47 PM
To: Le Yanqun (Nokia-RD/Beijing)
Subject: RE: [mobile-ip] problem about deregistration of MIP

Hi Le,

Comments inline.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 25, 2001 6:04 AM
To: [email-masked]
Subject: [mobile-ip] problem about deregistration of MIP

hi,

When a mobile node send Registration Request to a Mobile IP Agent, how
can the Agent decide whether the mobile node doing deregistration? By
which criterion below?

There are two cases to consider here:
Case 1: HA supports Simultaneous Bindings.
Case 2: HA DOES NOT supports Simultaneous Bindings.

Condition 1) care-of-address equal to its home address, 
Condition 2) registration lifetime equal to 0;

If both Condition1 & 2 are true then for both Case1 & 2 this means 
MN is at the Home network and wants to de-register.
HA removes ALL the mobility binding(s) associated to this MN.

If only condition 2 is true then -
In Case 1: HA removes ONLY the mobility binding associated to the CoA
address
		specified in the Registration Request. HA could have
other
active 
		mobility bindings for the MN ,with other CoA.
In Case 2: HA removes the single mobility binding permited. 
           But MN is not on the Home network.

Note: Condition 1 is true only when condition 2 is also true but not
vice
versa.

3) if NAI exists in Registration Request ,the realm part of NAI is the
same to the realm the Agent belongs to.

I am sorry, I don't know about the NAI.

Can every one be used to decide deregistration or the combination of
those?

Thanks 
Le Yanqun

Hope this helps.

Mohammad.

---

From: "Chae-yong Chong" <[email-masked]>
Date: Sat, 27 Oct 2001 12:50:29 +0900

why not do that?

Chae-yong