Subject: RE: [mobile-ip] MIPv6 - Focus of the security discussion

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Wed, 10 Oct 2001 11:41:35 +1000

Vijay, 

> IESG told us two things. ( I was there at the meeting with
> the security ADs at the San Diego IETF last December ).
> 
> 1. AH in its current form cannot be used for protecting the BU. 
> Develop an alternative solution. 
> 
	=>The way _MIPv6_ is using AH does not work. 
	That does not mean AH is not suited to MIPv6.
	I thought we've covered that in earlier discussions.

> 2. Develop a Key distribution mechanism for MN and CN.
> 
> For the first one, the Auth Data suboption is the solution.
> 
	=> Mike already answered this.

> For the second one, we have a requirements draft and a lot of
> competing proposals. We should be concentrating on this. and
> NOT how we can modify things (disable piggybacking, get a 
> new extension header) so that AH can be used for protecting
> the BU.
> 
> The MIPv6 draft will not have the key distribution mechanism
> embedded in it. It will just refer to another draft. 
> 
	=> Is this your own decision or the ADs/WG chairs ??
	I didn't see anything like this on the list before but 
	I might have missed something.

> It will 
> only specify how the BU can be protected. So if we agree 
> on the Auth Data suboption, we can conclude that the draft
> is complete. and no further changes need to be made. (maybe
> a few minor ones). thats what I meant by moving ahead.
> 
	=> Even if what you say above is correct, the draft can't 
	be an RFC when a normative reference is not.

> and from you mail, you seem to say the key distribution 
> mechanism is the main problem. great. thats what i wanted
> to hear from you. hope, you would stop talking about how
> AH can be used to protect the BU from now on.
> 
	=> No I won't. I want people to understand the real
	problem. I suggest you read Jari's draft when it comes out.

	Hesham

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 10 Oct 2001 10:20:07 -0700

> "Hesham Soliman (EPA)" wrote:
> 
>      Vijay,

>      I might have missed something.

if it is not obvious for you, I cant help it. it does not make
sense to have they key distribution mechanism for MN and CN
embedded in the MIPv6 draft. it has never been so. if you care 
to take a look at draft 15, it might make sense to you.

vijay

---

From: Michael Thomas <[email-masked]>
Date: Wed, 10 Oct 2001 10:24:31 -0700 (PDT)

> to take a look at draft 15, it might make sense to you.

   The problem with the -15 draft is that it points 
   to the null set. Quite literally. Nor is that likely
   to change in its current form.

   This is a problem.

	  Mike

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 10 Oct 2001 10:30:15 -0700

>    to change in its current form.

i am more optimistic. once the current proposals 
(BAKE/SUCV/PBK/whatever) are compared with the 
requirements draft, i am confident that we can 
come up with an acceptable solution. And this is 
what the WG should be concentrating on (IMHO).

vijay

---

From: Michael Thomas <[email-masked]>
Date: Wed, 10 Oct 2001 10:43:59 -0700 (PDT)

> what the WG should be concentrating on (IMHO).

   None of these provide for strong authentication.
   Nor should they; key distribution protocols for
   strong authentication are well beyond the scope
   of this working group.

   That leaves you with a hole in the requirements
   with -15.

	   Mike