Subject: RE: [mobile-ip] Draft 15

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Thu, 4 Oct 2001 15:56:58 +1000

> > 	This is really interesting ...some comments below.
> 
> You can find my paper on my HP, if you can understand Japanese :-)
> 
	=> I'll pass thanks :)
>  
> > > > Since there exists implementations of MIPv6 I wonder 1) how many of
> them
> > > > have implementing piggybacking and 
> > > 
> > > 	We support piggybacking for both directions (incoming,outgoing)
> > > 
> > > > 2) of those have any looked at
> > > > the effect of turning piggy-backing on and off.
> > > 
> > > 	We haven't tested piggybacking with other implementation, but
> > > 	among our HA,CN, MN, we normally enable piggybacking
> > > 	functionality and it works, even though our code is based on
> > > draft-13.
> > > 
> > 	=> But are you using IPsec ? if so then you must be protecting every
> > 
> > 	packet ?
> 
> Yes. I protect whole packets by AH, whenever BU is sent by using
> piggypacking.
> 
> If a packet has own SA, our MIP6 give the SA priority 
> over a SA for MIP6 packets (ie. BU, BA).
> I mean, when the packet is sent, MIP6 first check the SA for the packet
> itself.
> If it is found, MIP6 use the SA instead of MIP6 SA. 
> Otherwise, MIP6 uses the SA which is established for BU.
> 
	=> OK but I meant that you must protect _every_ packet
	whether it contains BU or not. 
	You seem to refer to MIP6 SA, did you add some code to
	the IPsec to make sure the selectors recognise the 
	BU option ? Or what do you mean by MIP6 SA ?

> And the movement detection of MN takes more time and it
> is the real bottleneck for TCP performance in our evaluation. 
> We currently do not support any seamless mobility scheme in our MIP6.
> That might be the problem...
> 
	=> Well on a BW-rich link (like ethernet :) ) you can do things 
	to speed up the movement detection It certainly should 
	take less than 1 sec. 
	Of course on more BW constrained links, you need other
	optimisations like the Fast Handoffs draft.

	Cheers,
	Hesham

---

From: Ryuji Wakikawa <[email-masked]>
Date: Thu, 04 Oct 2001 15:23:34 +0900

Hi Hesham

> 	BU option ? Or what do you mean by MIP6 SA ?

OK, let me explain more about this,,,
As you wrote in your mail, our implementation can handle the SA only for BU and BA 
which I call MIP6 SA. I modified the IPsec.
I assigned new protocol number for MIP6 binding messages. This number is not used as
the normal protocol number and it is just magic number for IPsec selectors. 
The MIP6 protocol number indicates that the SA is established for MIP6 BU and BA.

If you would configure SA by hand, it looks like this.

spdadd 3ffe::xx/64[any] 4ffe::yy/64[any] mip6 -P in ipesc
					      ^^^^
	ah/transport//require

> 	optimisations like the Fast Handoffs draft.

I agree with you. I guess handling layer 2 information in MIP6 layer is also requisite for
the movement detection. We plan to support one of the fast handoffs draft in near future

best regards,
ryuji

---

From: Francis Dupont <[email-masked]>
Date: Thu, 04 Oct 2001 14:09:22 +0200

As you wrote in your mail, our implementation can handle the SA
   only for BU and BA which I call MIP6 SA. I modified the IPsec.
   I assigned new protocol number for MIP6 binding messages. This
   number is not used as the normal protocol number and it is just magic
   number for IPsec selectors.
   The MIP6 protocol number indicates that the SA is established for
   MIP6 BU and BA.
   
=> I used the same kind of trick (the destination option processing
was modified and special selector is the destination option header code).
My code should be very similar (same platform and problem) but
I did't implement the sending side of piggybacking.

Thanks

Francis.Dupont@enst-bretagne

---

From: Mattias Pettersson <[email-masked]>
Date: Thu, 04 Oct 2001 16:56:21 +0200

> I did't implement the sending side of piggybacking.

I guess I should talk for Ericsson's MIP6 implementation in reply to
Erik's request:

First release (-09) of our code had piggybacking knob (on/off) on
sending side. No IPsec.

Second release (-13) had thrown piggybacking out to simplify the code.
Receiving is supported, though. IPsec support required DOI "any", e.g.
no special SA for MIP6 available.

/Mattias