Subject: RE: [mobile-ip] Draft 15

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Thu, 4 Oct 2001 14:44:57 +1000

This is really interesting ...some comments below.

> > Since there exists implementations of MIPv6 I wonder 1) how many of them
> > have implementing piggybacking and 
> 
> 	We support piggybacking for both directions (incoming,outgoing)
> 
> > 2) of those have any looked at
> > the effect of turning piggy-backing on and off.
> 
> 	We haven't tested piggybacking with other implementation, but
> 	among our HA,CN, MN, we normally enable piggybacking
> 	functionality and it works, even though our code is based on
> draft-13.
> 
	=> But are you using IPsec ? if so then you must be protecting every

	packet ?

> 	I evaluated the cost of sending BUs by piggybacking at my master
> thesis. 
> 	Unfortunately, it was written in Japanese, sorry guys, 
> 	but let me try to explain briefly.
> 
> 	This is the results of cost for piggyback processing in the kernel, 
> 	when MN sends BU with AH during flood ICMP6 Echo request/reply(data
> 16byte) to CN .
> 	These value was measured by pentium counter.
> 
> 			no piggyback (only BU)	/ piggyback
> 	sending cost	0.20 msec		/ 	0.23 msec
> 	receiving cost	0.29 msec		/	0.34 msec
> 
> 	I guess the overhead of piggyback is caused by IPsec processing, 
> 	because the size of the packet(BU+data) is larger than the single BU
> packet.
> 
> 	Our MIP6 waits default 1 sec (configurable) for some piggybacked
> data before sending BU.
> 
	=> Ok but 1 sec is probably not acceptable for TCP or real time
apps. 
	But that's an implementation issue I guess.
	Hesham

---

From: Ryuji Wakikawa <[email-masked]>
Date: Thu, 04 Oct 2001 14:46:06 +0900

Hi Hesham

> 	This is really interesting ...some comments below.

You can find my paper on my HP, if you can understand Japanese :-)
 
> 	=> But are you using IPsec ? if so then you must be protecting every

Yes. I protect whole packets by AH, whenever BU is sent by using piggypacking.

If a packet has own SA, our MIP6 give the SA priority 
over a SA for MIP6 packets (ie. BU, BA).
I mean, when the packet is sent, MIP6 first check the SA for the packet itself.
If it is found, MIP6 use the SA instead of MIP6 SA. 
Otherwise, MIP6 uses the SA which is established for BU.

> 	=> Ok but 1 sec is probably not acceptable for TCP or real time

Yes, but we do not think this interval will be bottleneck of MIP6 performance, 
because this interval value can be configured depending on 
network situation or communication condition.

And the movement detection of MN takes more time and it
is the real bottleneck for TCP performance in our evaluation. 
We currently do not support any seamless mobility scheme in our MIP6.
That might be the problem...

> 	But that's an implementation issue I guess.

Yes that's why I stay the value as configurable

regards,
ryuji

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 04 Oct 2001 11:21:27 -0700

Hesham,

> "Hesham Soliman (EPA)" wrote:
> 
>              Our MIP6 waits default 1 sec (configurable) for some
>      piggybacked data before sending BU.
> 

the BU is delayed by 1 sec and not the data packets. If no data 
appears within one sec, the BU is sent in a separate packet.

Vijay