Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

From: KASSI-LAHLOU Mohammed FTRD/DMI/CAE <[email-masked]>
Date: Thu, 25 Oct 2001 13:41:18 +0200

Hello,

If the MN and the HA are dual-stack, the solution could be the following:
On the home network, the MN receives an Ipv6 RA with the H bit set and an
Ipv4 RA with the H bit set.
When the MN arrives on the visited Ipv4 network, it acquires an Ipv4 CoA
(co-located CoA) and tunnels Ipv6 BU in Ipv4 packets to its HA.
The HA intercepts Ipv6 packets intended for the MN and tunnels them to the
MN in Ipv4 packets.
The MN tunnels Ipv6 packets intended for the CN in Ipv4 packets to the HA.
The HA decapsulates the packets and sends them directly to the CN.

The same solution can be used when the CN is Ipv4 and the visited network is
Ipv6.

I do not know any developments about this but it could be a new work item.

Kassi

-----Message d'origine-----
De : Eng Soo Guan [mailto:[email-masked]]
Envoyé : mercredi 24 octobre 2001 11:07
À : [email-masked]
Objet : Re: [mobile-ip] IPv4 and MIPv6 Transition

Thanx for your reply.

I read the SITT and DSTM draft. My question is that MN is using DSTM. But
there are possible cases where MN cannot obtain a "IPv4 Global Addresses".
As such, the SITT and DSTM solution is not what I am looking for.

If a MN visits a foreign IPv4 network running NAT and DHCP (and no 6to4,
Tunnel Broker or 6over4 stuff), how can the MN sends a Binding Update to its
Home Agent in IPv6? Can the MN uses some configuration information it has
when it was previously at home to access the 6Bone?

The best candidate I see it Shipworm. I'm wondering if anyone has come
across other proposals.

SG
Soo Guan, Eng
R&D Engineer (Software Lab)
Centre for Wireless Communications, NUS
http://www.cwc.nus.edu.sg
Tel (65) 8709330
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
----- Original Message -----
From: Hesham Soliman (EPA)
To: [email-masked]'
Sent: Wednesday, October 24, 2001 3:12 PM
Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

Hello Eng,
There is another draft you can find at:
http://standards.ericsson.net/hesham/draft-ietf-ngtrans-siit-dstm-00.txt
It's a WG draft in NGTRANS but it expired and I'll
resubmit it after adding some of the comments received.
Cheers,
Hesham

-----Original Message-----
From:   Eng Soo Guan [SMTP:[email-masked]]
Sent:   Wednesday, 24 October 2001 12:04
To:     [email-masked]
Subject:        [mobile-ip] IPv4 and MIPv6 Transition
Dear All,
I would like to know if any work has being done with regard to 'transiting'
to Mobile IPv6 with IPv4 Internet, especially with Mobile Node behing a NAT.
The closet drafts I find are "Mobile IPv4 Traversal Across NAT and VPN
Gateways" and "Mobility Support for IPv4 and IPv6 Interconnected Networks
based on Dual-Stack Model".
I read found the NGTRANS Shipworm draft attractive to be modified for MIPv6
in a IPv4 only network behind a NAT.
Warmest regards.
SG
Soo Guan, Eng
Centre for Wireless Communications, NUS
http://www.cwc.nus.edu.sg
~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: emanuel monticelli <[email-masked]>
Date: Thu, 25 Oct 2001 16:40:17 +0200

Hi,

Any news about Fast Handovers for MIPv6 other than the 02 draft ?
Do you know anyone that is trying to implement something in this area ?

Thanks

Emanuel Monticelli

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 25 Oct 2001 12:23:37 -0700

We have an implementation of the 02 draft. Rajeev Koodli did a 
presentation at the London IETF on a few issues that we encountered
while implementing it.

and take a look at the following journal paper. "Fast Handovers and
Context Transfer in Mobile Networks" to appear in  ACM Computer 
Communication Review (october 2001 issue). It has some performance
results from the Fast Handoff tests we did on our testbed.

and the results look very promising. Fast Handoffs (02 draft) does
not need any additional improvements/enhancements (IMHO). 

Vijay

> emanuel monticelli wrote:
> 
> Hi,
>

---

From: "Shiao-Li Charles Tsao" <[email-masked]>
Date: Fri, 26 Oct 2001 08:30:24 +0800

Hello, 

This approach was also addressed in "Moving in a Dual Stack Internet" <http://www.ietf.org/internet-drafts/draft-ietf-ngtrans-moving-00.txt>. 
It is a WG draft in NGTRANS. However, this approach can be only applied to a MN with a co-located IPv4 address in the visited IPv4 network. To work with NAT and DHCP in the visited IPv4 network, it seems a pratical scenario and should be further investigated. 

Charles Tsao

----- Original Message ----- 
From: "KASSI-LAHLOU Mohammed FTRD/DMI/CAE" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, October 25, 2001 7:41 PM
Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

Hello,

Kassi

-----Message d'origine-----
De : Eng Soo Guan [mailto:[email-masked]]
Envoyé : mercredi 24 octobre 2001 11:07
À : [email-masked]
Objet : Re: [mobile-ip] IPv4 and MIPv6 Transition

Thanx for your reply.

SG
Soo Guan, Eng
----- Original Message -----
From: Hesham Soliman (EPA)
To: [email-masked]'
Sent: Wednesday, October 24, 2001 3:12 PM
Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

Hello Eng,

-----Original Message-----
From:   Eng Soo Guan [SMTP:[email-masked]]
Sent:   Wednesday, 24 October 2001 12:04
To:     [email-masked]
Subject:        [mobile-ip] IPv4 and MIPv6 Transition
Dear All,

---

From: "Weishuai Yang" <[email-masked]>
Date: Fri, 26 Oct 2001 10:25:00 +0800

hi, folks,

I think adding Buffer Management for Fast Handovers is necessery, and I'm 
doing it right now. How do you think about it?

Weishuai Yang

---

From: "Eng Soo Guan" <[email-masked]>
Date: Fri, 26 Oct 2001 11:20:27 +0800

Dear All,

When I used GPRS, I discovered that the network assigns a private IP, and
uses NAT to route the packet to my Home Network. I have not tested with IPv6
yet, and am looking around for a possible solution. As Charles pointed out,
the draft "Moving in a Dual Stack Internet" is unsuitable for NAT & DHCP.

Warmest regards.

SG
Eng Soo Guan
----- Original Message -----
From: Shiao-Li Charles Tsao
To: [email-masked]
Cc: [email-masked]
Sent: Friday, October 26, 2001 8:30 AM
Subject: Re: [mobile-ip] IPv4 and MIPv6 Transition

Hello,

This approach was also addressed in "Moving in a Dual Stack Internet"
<http://www.ietf.org/internet-drafts/draft-ietf-ngtrans-moving-00.txt>.
It is a WG draft in NGTRANS. However, this approach can be only applied to a
MN with a co-located IPv4 address in the visited IPv4 network. To work with
NAT and DHCP in the visited IPv4 network, it seems a pratical scenario and
should be further investigated.

Charles Tsao

----- Original Message -----
From: "KASSI-LAHLOU Mohammed FTRD/DMI/CAE"
<[email-masked]>
To: <[email-masked]>
Sent: Thursday, October 25, 2001 7:41 PM
Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

Hello,

Kassi

---

From: "James kempf" <[email-masked]>
Date: Fri, 26 Oct 2001 08:42:48 -0700

> doing it right now. How do you think about it?

It depends on what algorithm you are using. You could also use bicasting for
smoothing. For FMIPv6, smoothing is probably needed in any case. For BETH,
it may or may not be needed,  depending on how much handover sequencing
information you have and how high the L2 latency is. If the L2 latency is
less than the packet interarrival time, there should be no need for
smoothing with BETH if you can time tunnel establishment to start
as soon as the L2 handover occurs.

        jak

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 26 Oct 2001 09:43:36 -0700

Hello,

We have implemented buffer management for fast handovers, and it
does work very well.

For some background, take a look at:

@INPROCEEDINGS{caceres-padman, 
        author = "Ramon Caceres and Venkata Padmanabhan",
        title = "{Fast and {S}calable {H}andoffs for {W}ireless
                 {I}nternetworks}",
        booktitle = "ACM Mobicom 96",
        month = nov,
        pages = {56-66},
        year = 1996,
}

and

@INPROCEEDINGS{perkins-wang,  
        author = "Charles E. Perkins and Kuang-Yeh Wang",
        title = {Optimized {S}mooth {H}andoffs in {M}obile {IP}},
        booktitle = "Proceedings of the Fourth IEEE Symposium on
                Computers & Communications (ISCC'99)",
        month = jul,
        pages = {340-346},
        year = 1999,
}

A version of the latter is available at:
	http://people.nokia.net/~charliep/iscc99/iscc99.ps

I hope you find these useful.

Regards,
Charlie P.

---

From: "Weishuai Yang" <[email-masked]>
Date: Sat, 27 Oct 2001 10:11:26 +0800

Hi Charles,

That file can't be found on your server.
Not Found
The requested URL /~charliep/iscc99/iscc99.ps was not found on this server.

and do you mean buffer management for FMIPv6 is implemented?

I can't find that draft on ietf.

Thank.

Weishuai Yang

---

From: "???" <[email-masked]>
Date: Mon, 29 Oct 2001 16:26:32 +0900

Also, we are working on this now. 
You can find our paper, which will be sent to IETF as a darft soon.
The tile is "requirements for 4to6 mobility transition using hierarchical mobility."

Up to date, since the effects of considering mobile node roaming in IPv4/IPv6 transition networks have not been investigated fully, we propose the requirements and analysis of diferent routing architecture of <IPv4/MIPv6 transition network.

We are working on the problem solving mechanism according to the requirements.

Please refer to:
http://hard.korea.ac.kr/~ccl/research/draft_kahng_ngtrans_hdsma-00.txt

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of Shiao-Li Charles Tsao
  Sent: Friday, October 26, 2001 9:30 AM
  To: [email-masked]
  Cc: [email-masked]
  Subject: (ngtrans) Re: [mobile-ip] IPv4 and MIPv6 Transition

  Hello, 

  Charles Tsao

  ----- Original Message ----- 
  From: "KASSI-LAHLOU Mohammed FTRD/DMI/CAE" <[email-masked]>
  To: <[email-masked]>
  Sent: Thursday, October 25, 2001 7:41 PM
  Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

  Hello,

  Kassi

  -----Message d'origine-----
  De : Eng Soo Guan [mailto:[email-masked]]
  Envoyé : mercredi 24 octobre 2001 11:07
  À : [email-masked]
  Objet : Re: [mobile-ip] IPv4 and MIPv6 Transition

  Thanx for your reply.

  SG
  Soo Guan, Eng
  ----- Original Message -----
  From: Hesham Soliman (EPA)
  To: [email-masked]'
  Sent: Wednesday, October 24, 2001 3:12 PM
  Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

  Hello Eng,

  -----Original Message-----
  From:   Eng Soo Guan [SMTP:[email-masked]]
  Sent:   Wednesday, 24 October 2001 12:04
  To:     [email-masked]
  Subject:        [mobile-ip] IPv4 and MIPv6 Transition
  Dear All,
  I would like to know if any work has being done with regard to 'transiting'
  to Mobile IPv6 with IPv4 Internet, especially with Mobile Node behing a NAT.
  The closet drafts I find are "Mobile IPv4 Traversal Across NAT and VPN
  Gateways" and "Mobility Support for IPv4 and IPv6 Interconnected Networks
  based on Dual-Stack Model".
  I read found the NGTRANS Shipworm draft attractive to be modified for MIPv6
  in a IPv4 only network behind a NAT.
  Warmest regards.
  SG
  Soo Guan, Eng