Subject: [mobile-ip] problem about deregistration of MIP

From: [email-masked]
Date: Thu, 25 Oct 2001 13:03:53 +0300

hi,

When a mobile node send Registration Request to a Mobile IP Agent, how
can the Agent decide whether the mobile node doing deregistration? By
which criterion below?
1) care-of-address equal to its home address, 
2) registration lifetime equal to 0;
3) if NAI exists in Registration Request ,the realm part of NAI is the
same to the realm the Agent belongs to.

Can every one be used to decide deregistration or the combination of
those?

Thanks 
Le Yanqun

---

From: "Qiang Zhang" <[email-masked]>
Date: Thu, 25 Oct 2001 10:02:44 -0400

Yanqun,

The requested reg life time =0 should be used to determine the
deregistration. 

Qiang

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 25, 2001 5:04 AM
To: [email-masked]
Subject: [mobile-ip] problem about deregistration of MIP

hi,

Thanks 
Le Yanqun

---

From: "Qiang Zhang" <[email-masked]>
Date: Sun, 28 Oct 2001 11:34:30 -0500

in
	Registration Request, the home address is zero, and the
allocated home
	address is returned by Registration Reply.
	Then if the MN deregistrater, must it fill the home address with
	allocated home address?

	=> That should be required, for example, it is not restricted
that MN can have obtained multiple home addresses either from one HA or
different HAs so that the MN actually tended to maintain multiple
bindings.  Unless otherwise the Home address is being conveyed, there
will be confusion for the HA and AAA server which try to maintain the
multiple bindings and accounting sessions. NAI is not unique in this
scenario, which only enables user level mobility.

	 Also just to tackle on the earlier discussion,  the
care-of-address sent by the Mobile node while-deregistration is not
trustable if put the MN in a context of private network or regional
registration network, care-of-addr for known to the MN may be different
from the COA known to the HA. 

	In short, combined credentials need to be used to locate the
uniqueness if you have a complicated environment. 

	There are two cases to consider here:
	Case 1: HA supports Simultaneous Bindings.
	Case 2: HA DOES NOT supports Simultaneous Bindings.
	
	Condition 1) care-of-address equal to its home address,
	Condition 2) registration lifetime equal to 0;
	
	If both Condition1 & 2 are true then for both Case1 & 2 this
means
	MN is at the Home network and wants to de-register.
	HA removes ALL the mobility binding(s) associated to this MN.
	
	If only condition 2 is true then -
	In Case 1: HA removes ONLY the mobility binding associated to
the CoA
	address
	                specified in the Registration Request. HA could
have
	other
	active
	                mobility bindings for the MN ,with other CoA.
	In Case 2: HA removes the single mobility binding permited.
	           But MN is not on the Home network.
	
	Note: Condition 1 is true only when condition 2 is also true but
not
	vice
	versa.

	3) if NAI exists in Registration Request ,the realm part of NAI
is the
	same to the realm the Agent belongs to.