Subject: RE: [mobile-ip] WG Last Call on Threat Model and Security Require ments for MIP v6

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Fri, 19 Oct 2001 01:29:09 +1000

>  > >    Ie, the host will forward to its stack, but not
>  > >    out another interface? This seems pretty consistant
>  > >    with the definition of hosts and routers.
>  > > 
>  > 	=> Exactly ! That's why I don't see the problem here. 
>  > 	In fact, this is what was done for the cellular host draft
>  > 	and it certainly does not break RFC 2460. It's an internal
>  > 	policy decision for those IPv6 nodes that do not want
>  > 	to act as reflectors. 
> 
>    Not having looked recently, I'm not sure that
>    I'd say that it's purely a policy knob on the
>    host that is needed here. We should have clear
>    requirements for both hosts and routers, and in
>    this case the behavior of how hosts treat routing
>    headers may be needed. It would be pretty unfortunate,
>    for example, if hosts just didn't implement routing
>    headers _at all_, which seems like a pretty likely
>    outcome unless there's something that says you MUST
>    if they will be forwarded to your stack...
> 
	=> Well, I think the only MUST we need to solve 
	this issue is to have something in RFC2460 saying 
	that it MUST be possible to configure nodes to 
	avoid forwarding packets to other hosts based on a 
	routing header. Wouldn't this knob be enough and 
	satisfy MIPv6 requirements and RFC2460 ?

	Hesham

---

From: Michael Thomas <[email-masked]>
Date: Thu, 18 Oct 2001 08:52:48 -0700 (PDT)

> 	satisfy MIPv6 requirements and RFC2460 ?

   No, I think there needs to be some verbiage
   (if not already present!) that says that a
   host MUST be able to forward to itself. Otherwise
   MIP and other uses of CoA's might not be
   implemented (eg, multihoming). That would be
   unfortunate. I think this is mainly an issue
   of MUST implement. Policy knobs are always an
   option beyond that :-)

		Mike