Subject: RE: [mobile-ip] Duplicate Address Detection

From: "Peter Grimstrup (TED)" <[email-masked]>
Date: Thu, 11 Oct 2001 18:18:09 +0200

Hi Brian,

Thanks for your answer
> 
> > Draft 15 and probably the earlier drafts says:
> > 
> > D bit MUST not be set without A and H bit (sec. 5.1)
> > 
> > Section 8.2 says nothing about what to do if D is set but H is not.
> > One could 1) discard packet or 2) ignore D-bit or ?
> 
> In my opinion, since section 5.1 says "This bit is only valid when the
> Home Registration (H) and Acknowledge (A) bits are also set...", we
> should ignore the bit.  This follows the general notion of being
> liberal in what we accept.

Agree, but why not whenever it is possible/easy write it explicitly, i.e.
change 5.1 to "D-bit is ignored if the H-bit is not set."

/Peter

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 11 Oct 2001 10:00:31 -0700

Hello Peter,

> change 5.1 to "D-bit is ignored if the H-bit is not set."

I don't see any problem with this.  Unless someone else can say
why not to do this, I will make the change.

Regards,
Charlie P.