Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

From: "Shahrier, Sharif M." <[email-masked]>
Date: Wed, 24 Oct 2001 10:34:18 -0400

I also believe that this is an important work item to persue, in view of the
fact that 3GPP has mandated using IPv6 as transport over the UTRAN. IPv6 is
also considered by other SDO's in other cellular networks as well. Thus, in
order to interconnect these systems, to the IP backbone, which currently
runs IPv4, solutions like the "dual stack model" will be very important.

I wonder if anybody can provide information if these knids of protocols is
currently implemented commercially.

-Sharif.

-----Original Message-----
From: Eng Soo Guan [mailto:[email-masked]]
Sent: Tuesday, October 23, 2001 10:04 PM
To: [email-masked]
Subject: [mobile-ip] IPv4 and MIPv6 Transition

Dear All,

I would like to know if any work has being done with regard to 'transiting'
to Mobile IPv6 with IPv4 Internet, especially with Mobile Node behing a NAT.

The closet drafts I find are "Mobile IPv4 Traversal Across NAT and VPN
Gateways" and "Mobility Support for IPv4 and IPv6 Interconnected Networks
based on Dual-Stack Model".

I read found the NGTRANS Shipworm draft attractive to be modified for MIPv6
in a IPv4 only network behind a NAT.

Warmest regards.

SG
Soo Guan, Eng
Centre for Wireless Communications, NUS
http://www.cwc.nus.edu.sg
~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Thu, 25 Oct 2001 14:00:22 +1000

> runs IPv4, solutions like the "dual stack model" will be very important.
	=> Transport level issues are not related to MIP. A dual stack
	model with 6-to-4 support or configured tunnels will do the job. 

	Hesham

---

From: "Shahrier, Sharif M." <[email-masked]>
Date: Thu, 25 Oct 2001 10:22:55 -0400

Yes, that is correct. I was actually referring to tunneling IPv6
packets coming from the UTRAN, over an IPv4 backbone.
 
            Sharif.

-----Original Message-----
From: Hesham Soliman (EPA) [mailto:[email-masked]]
Sent: Thursday, October 25, 2001 12:00 AM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

	I also believe that this is an important work item to persue, in
view of the 

	Hesham 

	-----Original Message----- 
From: Eng Soo Guan [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Tuesday, October 23, 2001 10:04 PM 
To: [email-masked] 
Subject: [mobile-ip] IPv4 and MIPv6 Transition 

	Dear All, 

	I would like to know if any work has being done with regard to
'transiting' 
to Mobile IPv6 with IPv4 Internet, especially with Mobile Node behing a NAT.

	The closet drafts I find are "Mobile IPv4 Traversal Across NAT and
VPN 
Gateways" and "Mobility Support for IPv4 and IPv6 Interconnected Networks 
based on Dual-Stack Model". 

	I read found the NGTRANS Shipworm draft attractive to be modified
for MIPv6 
in a IPv4 only network behind a NAT. 

	Warmest regards. 

	SG 
Soo Guan, Eng 
Centre for Wireless Communications, NUS 
http://www.cwc.nus.edu.sg <http://www.cwc.nus.edu.sg>  
~~~~~~~~~~~~~~~~~~~~~~~~~~~~