Subject: RE: [mobile-ip] WG Last Call on Threat Model and Security Require ments for MIP v6

From: "Glenn Morrow" <[email-masked]>
Date: Tue, 16 Oct 2001 11:03:49 -0500

I think we need to make sure that the SHOULDs and MUSTs of the security
threat draft and the MIP draft synch up. 

-----Original Message-----
From: Alexandru Petrescu [mailto:[email-masked]]
Sent: Tuesday, October 16, 2001 10:29 AM
To: [email-masked]
Cc: [email-masked]; Erik Nordmark
Subject: Re: [mobile-ip] WG Last Call on Threat Model and Security
Requirements for MIP v6

Alexandru Petrescu <[email-masked]> writes:
> Erik Nordmark <[email-masked]> writes:
> > When the HA option was designed there wasn't a good understanding
> > of reflectors for DoS attacks, thus the analysis of the HA option
> > security doesn't take this into account.
> > 
> > Do you expect the result of this is that HA options can not be used
unless
> > athenticated and authorized?
> 
> I would rather say that the HA options can not be used unless part of
> an authenticated BU or similar, and not independent.

Sorry for following on my message, my above comment is rather naïve
(where's the cancel key? :-)

Alex

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Fri, 19 Oct 2001 11:43:35 +1000

Hello Charlie, 

> >         No, I think there needs to be some verbiage
> >         (if not already present!) that says that a
> >         host MUST be able to forward to itself. Otherwise
> >         MIP and other uses of CoA's might not be
> >         implemented (eg, multihoming). That would be
> >         unfortunate. I think this is mainly an issue
> >         of MUST implement. Policy knobs are always an
> >         option beyond that :-)
> > 
> >      => I guess I wanted to say the same thing but
> >      you have the time difference advatange so you're
> >      saying it better :)
> >      MUST forward to itself,
> >      MUST have a knob for forwarding to other nodes
> >      OK ?
> 
> I tried to point out in a note last night that it is enough
> for relay nodes to follow directives about forwarding to
> the next node in the list.  In the case needed for Mobile IPv6,
> this is simple.  A node can authorize itself to forward
> packets to itself.  In the general case, more persuasion
> may be needed, but the principle would remain the same.
> 
> OK?
> 
	=> Yes I think we're basically saying the same thing. 
	To make this more concrete I was suggesting that 
	RFC 2460 states that a node forwarding to itself 
	is a MUST (as a default behaviour) but forwarding 
	to other nodes, based on a routing header, 
	MUST be configurable. 
	We did this for the cellular host draft and I think 
	it is compliant with RFC 2460, but the MUSTs 
	I was suggesting would ensure that implementors
	follow this rule. 
	To answer your question I agree with you and Mike. 

	Hesham