Subject: RE: [mobile-ip] MIPv6 - Focus of the security discussion

From: "Patil Basavaraj (NET/Dallas)" <[email-masked]>
Date: Mon, 8 Oct 2001 09:50:29 -0500

Michael Thomas [[email-masked]]wrote:
>
>Patil Basavaraj (NET/Dallas) writes:
>
>  [about relegating IPsec to low priority: ]
>
> >    (I am leaving the MN-HA SA out or the moment).
>
>   Why?
>
>   An attack against the MN/HA security would be
>   far more catastrophic than the MN/CN. There is
>   absolutely no reason why we should not have 
>   strong authentication for this security
>   association, and it should be a *mandatory*
>   part of any compliant MIPv6 implementation.
>
>	   Mike

Mike,

Completely agree with what you are saying and I did not mean to imply
that we should be ignoring the MN-HA security. 
Since the MN and HA share keys or certs or have other means of
establishing an SA, securing the BUs sent to the HA is considerably
easier. The MN->CN BUs are much more difficult to deal with and this
is what the IESG has expressed concerns about and what the WG sould be
focusing on.

-Basavaraj

---

From: Michael Thomas <[email-masked]>
Date: Mon, 8 Oct 2001 09:06:29 -0700 (PDT)

> is what the IESG has expressed concerns about and what the WG sould be

   The problem is that it isn't this simple. All of the
   same IPsec considerations that apply to the CN/MN
   also apply to HA/MN since I could, for example, have
   a telnet session to my HA while I'm mobile. Thus the
   piggybacking and authorization issues rear their head
   again.

   On the other hand, I believe that a small set of
   rules that have been discussed here ad infinitum
   should solve this problem for both, and that
   they can be added to the draft with minimal
   fuss. If they must be a separate draft, we
   should at least give them the same priority 
   for completion.

	Mike