Subject: [mobile-ip] Route optimization method in Mobile IP

From: Hiroyuki OHNISHI <[email-masked]>
Date: Wed, 03 Oct 2001 21:26:52 +0900

Hi all,

We wrote a draft about a route optimization method in Mobile IP.

http://search.ietf.org/internet-drafts/draft-ohnishi-mobileip-mbg-00.txt

This method is proposed from the viewpoint of a career that will provide
mobile ip services.
To provide mobile ip services, we think route optimization is needed to use network efficiently and reduce data transmission delay.

But existing "Route optimization in Mobile IP" needs all the CNs have to have Mobile IP functions and we have no control over all of the CNs in the Internet. I know this problem can be solved if all CNs become IPv6 nodes
(if current problem will be solved).
But we think it takes long time before all the CNs become the IPv6 nodes.
So we need the some solution to achieve route optimization before all the CNs have not been IPv6 nodes yet.
And we also need route optimization method that does not tell CoA to CNs directly for maintaining the location privacy.

In our proposal, we introduce the new Mobile IP agents that are located between a mobile ISP and other networks. This agent is called as MBG (Mobile IP Border Gateway).
MBG sends the Binding Requests to HA when it received the packets for MNs. After receiving the Binding Updates from HA, it maintains a binding cache and forwarded following packets directly to CoA of MNs by using the binding caches.
These MBGs are fully under the control of mobile ISPs and have security asociations with HAs.
So this solution does not suffer from SA issues. We have already had a prototype and had tests.
Our hope is to have some solution for route optimization that can be deployed at early time and co-exist with the end-to-end route optimization method for the future Mobile IPv6 deployment time.

I am looking forward to having many comments about this approach for
route optimization.

Sincerely,
Hiroyuki

---

From: Michael Thomas <[email-masked]>
Date: Mon, 22 Oct 2001 08:44:31 -0700 (PDT)

I have some questions about this draft:

1) How is it appreciatively different than HMIP?
   It sure seems to do similar things.

2) How does the MN discover the MBG? This is one
   of the things that last I checked wasn't one of
   HMIP's strong points.

3) The optimal placement of a MGB is at the join point 
   of a particular flow. If, for administrative reason say,
   you can't put the MBG there, it's still better to put
   the MGB as far along the path as possible. For all
   but the simplest topologies, there may be many such
   (close to) optimal points possible, and is clearly
   dependent on the CN you are talking to at any time.
   Have you considered this, or is this strictly static
   the way that HMIP works? 

4) Given the previous, MGB's at a peering point, say, 
   would end up proxying lots of MN's BU's. Can this
   scale? This is similar to the soft state that RSVP
   creates, and there's been a fair amount of concern
   about the scaling which has lead to the RSVP aggregation
   work. I expect that those same kinds of scaling 
   concerns would be relevant here too.
   
5) Related to 3 again, another of HMIP's
   weaknesses is redundancy. It seems to me that
   any scheme like this needs to be able to
   provide failover which is lockstep with the
   routing subsystem. That is, if the route 
   changes, the MN ought to be able to
   transparently discover the new MBR in the 
   path and reestablish the binding.

	  Mike

---

From: Hiroyuki OHNISHI <[email-masked]>
Date: Mon, 29 Oct 2001 11:33:08 +0900

Hello Mike,

Thank you for your reply.

>    It sure seems to do similar things.

In HMIP, a hierarchical information is sent to MNs by agent advertisements.
This method is not good for the carrier because the network structure can be
known by users (I am not sure why WG's HMIP approach is not one like "Dynamics
HUT MIP".)
MBG method does not show such kind of informations to users.
Only MBG and HA knows each other and achieve route optimization.
And the MBG which is used to optimize routes depends on the route packets 
for MNs pass
through,

>    of the things that last I checked wasn't one of

MN do not need to discover the MBG.

MBG have the information about MNs and HAs that the MNs belongs.
So if MBG detects the packets destined to a MN, MBG will send the binding request
to the HA that the MN belongs to.
Then HA send the binding update to MBG.

>    Have you considered this, or is this strictly static

I know there are better joint points to optimize the route.
As you mentioned, we can not put the MBG there.
But this method can optimize the route inside the network
surrounded by MBGs at least.
MBG works as same as flow driven shortcut. So we can use
the optimal one among them.

>    concerns would be relevant here too.

As you mentioned MBGs have to deal many MN' BUs.
But I think the MBG's processing is not so heavy as that of HAs located
at gateway point (such as 3GPP2 model).

>    path and reestablish the binding.

If the route changes, another MBG will send the binding request
to the HA.  Then HA send the binding update to the MBG.
MN does not need to know the MBG.

Hiroyuki

>  > To provide mobile ip services, we think route optimization is needed 
> to use network efficiently and reduce data transmission delay.
>  >
>  > But existing "Route optimization in Mobile IP" needs all the CNs 
> have to have Mobile IP functions and we have no control over all of the 
> CNs in the Internet. I know this problem can be solved if all CNs become 
> IPv6 nodes
>  > So we need the some solution to achieve route optimization before 
> all the CNs have not been IPv6 nodes yet.
>  > And we also need route optimization method that does not tell CoA to 
> CNs directly for maintaining the location privacy.
>  >
>  > In our proposal, we introduce the new Mobile IP agents that are 
> located between a mobile ISP and other networks. This agent is called as 
> MBG (Mobile IP Border Gateway).
>  > MBG sends the Binding Requests to HA when it received the packets 
> for MNs. After receiving the Binding Updates from HA, it maintains a 
> binding cache and forwarded following packets directly to CoA of MNs by 
> using the binding caches.
>  > Our hope is to have some solution for route optimization that can be 
> deployed at early time and co-exist with the end-to-end route 
> optimization method for the future Mobile IPv6 deployment time.
>  >

---

From: Greg Daley <[email-masked]>
Date: Mon, 29 Oct 2001 14:55:45 +1100

Response to Q1 below:

> And the MBG which is used to optimize routes depends on the route packets

	In HMIPv6, propagation of network structure information is only
	through the distance metric of map options  "dynamically learned"
	through Router Advertisements.

	In the case where static MAP options are defined this is overridden,
	so no topological information needs be disclosed, and in the case
	where Router Renumbering is used the metrics advertised by the 
	Access routers are exactly as sent in the Original Router Renumbering
	message (regardless of the number of hops traversed).

	Therefore topology need not be disclosed.
	This is all part of HMIPv6.

		Greg Daley