Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Wed, 24 Oct 2001 17:12:13 +1000

Hello Eng, 

There is another draft you can find at:
http://standards.ericsson.net/hesham/draft-ietf-ngtrans-siit-dstm-00.txt

It's a WG draft in NGTRANS but it expired and I'll
resubmit it after adding some of the comments received. 

Cheers,
Hesham

> -----Original Message-----
> From:	Eng Soo Guan [SMTP:[email-masked]]
> Sent:	Wednesday, 24 October 2001 12:04
> To:	[email-masked]
> Subject:	[mobile-ip] IPv4 and MIPv6 Transition
> 
> Dear All,
> 
> I would like to know if any work has being done with regard to
> 'transiting'
> to Mobile IPv6 with IPv4 Internet, especially with Mobile Node behing a
> NAT.
> 
> The closet drafts I find are "Mobile IPv4 Traversal Across NAT and VPN
> Gateways" and "Mobility Support for IPv4 and IPv6 Interconnected Networks
> based on Dual-Stack Model".
> 
> I read found the NGTRANS Shipworm draft attractive to be modified for
> MIPv6
> in a IPv4 only network behind a NAT.
> 
> Warmest regards.
> 
> SG
> Soo Guan, Eng
> Centre for Wireless Communications, NUS
> http://www.cwc.nus.edu.sg
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: "Eng Soo Guan" <[email-masked]>
Date: Wed, 24 Oct 2001 17:07:22 +0800

Thanx for your reply.

I read the SITT and DSTM draft. My question is that MN is using DSTM. But
there are possible cases where MN cannot obtain a "IPv4 Global Addresses".
As such, the SITT and DSTM solution is not what I am looking for.

If a MN visits a foreign IPv4 network running NAT and DHCP (and no 6to4,
Tunnel Broker or 6over4 stuff), how can the MN sends a Binding Update to its
Home Agent in IPv6? Can the MN uses some configuration information it has
when it was previously at home to access the 6Bone?

The best candidate I see it Shipworm. I'm wondering if anyone has come
across other proposals.

SG
Soo Guan, Eng
R&D Engineer (Software Lab)
Centre for Wireless Communications, NUS
http://www.cwc.nus.edu.sg
Tel (65) 8709330
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
----- Original Message -----
From: Hesham Soliman (EPA)
To: [email-masked]'
Sent: Wednesday, October 24, 2001 3:12 PM
Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

Hello Eng,

-----Original Message-----
From:   Eng Soo Guan [SMTP:[email-masked]]
Sent:   Wednesday, 24 October 2001 12:04
To:     [email-masked]
Subject:        [mobile-ip] IPv4 and MIPv6 Transition
Dear All,
I would like to know if any work has being done with regard to 'transiting'
to Mobile IPv6 with IPv4 Internet, especially with Mobile Node behing a NAT.
The closet drafts I find are "Mobile IPv4 Traversal Across NAT and VPN
Gateways" and "Mobility Support for IPv4 and IPv6 Interconnected Networks
based on Dual-Stack Model".
I read found the NGTRANS Shipworm draft attractive to be modified for MIPv6
in a IPv4 only network behind a NAT.
Warmest regards.
SG
Soo Guan, Eng
Centre for Wireless Communications, NUS
http://www.cwc.nus.edu.sg
~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: Pekka Savola <[email-masked]>
Date: Wed, 24 Oct 2001 12:08:13 +0300 (EEST)

Perhaps I shouldn't comment on this, but anyway...

> resubmit it after adding some of the comments received. 

SIIT is regarded by many to be an abomination (redefining internal 
structure like mapped-addresses) from security point-of-view among others.

It can probably solve some problems efficiently though, or else it 
wouldn't have been introduced. :-)

But it should be kept in mind that it, alone, cannot be relied on to be
sufficient for (M)IPv4 -> (M)IPv6 transition.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

---

From: Pekka Savola <[email-masked]>
Date: Wed, 24 Oct 2001 12:12:29 +0300 (EEST)

> The best candidate I see it Shipworm. I'm wondering if anyone has come

If you want a generic approach, Shipworm is the only way (assuming that
with "no 6to4" you meant that the NAT box doesn't run IPv6; I believe dual
stacked NAT boxes may be common in the coming years though).