Subject: RE: [mobile-ip] MIPv6 - Focus of the security discussion

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Wed, 10 Oct 2001 12:46:01 +1000

> > 
> >    You do _not_ need to change IPsec. All that is
> >    needed is a few relatively minor changes to
> >    MIP. This has been discussed ad infinitum on
> >    this list.
> 
> the minor changes involve throwing out piggybacking (which
> in my opinion is a nice feature). 
> 
	=> This was discussed in detail, it's nice but not practical. 
	BW-constrained links (like cellular links) allocate set
	channels based on the service, piggybacking the 
	BU _will_not_fit_ in the channel and the packet will
	dropped ! That's not nice is it. 
	Non-BW-constrained links could not care less if 
	we piggyback or not.

> and getting a new extension
> header. the BU as a destination option has been through a 
> lot of interoperability events (we have been at atleast 3- 
> 2000 Conectathon, 2000 ETSI IPv6 bakeoff amd 2001 
> Conectathon). lets not change it.
> 
	=> No one suggested changing the BU option, it was
	suggested that it should be carried in a different header. 
	That does not imply changing anything in the option.

	Hesham

---

From: Charlie Perkins <[email-masked]>
Date: Tue, 09 Oct 2001 22:39:12 -0700

Hello Hesham,

>      Non-BW-constrained links could not care less if

First, it was discussed in detail.  It's nice.  For some applications
on some links, it's not practical.  For other applications on other
links, it is practical.  It's been implemented, tested, and it works.

Regards,
Charlie P.

---

From: Michael Thomas <[email-masked]>
Date: Wed, 10 Oct 2001 09:05:30 -0700 (PDT)

> links, it is practical.  It's been implemented, tested, and it works.

   The problem is that on situations where you'd
   really like to use it (eg, cellular with voip)
   you can't. If somebody can show a real
   situation where it is a real win, that would
   be helpful. That has not been shown to my
   knowledge.

	       Mike

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 10 Oct 2001 10:23:37 -0700

>      That does not imply changing anything in the option.

read the sentence again. when i said lets not change it,
i meant lets not change BU as a destination option.

vijay