Subject: RE: [mobile-ip] LMM requirements: security issue

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Thu, 5 Sep 2002 00:04:17 +0200

So what happens if AH tunnel mode is used?

=> We can't decapsulate the packets in the MAP
(assuming they are coming from the HA). 
Of course this discussion assumes that no RO is used
because if it is, then the MAP processes the RH and 
tunnels to the MN, no decapsulation is needed.

> => I don't think there is an issue with a MN trusting 
> a MAP to route its packets. Or to phrase this better, I
> think that mobile nodes implicitly trust routers in the 
> visited network to forward their traffic, if they don't
> then they would have to choose another network.
> 

Are you proposing that the MAP participate in the routing security
association?

=> I wasn't proposing that although there is no reason for 
not doing it. What I was saying is that the MN
should implicitly trust the MAP _with_forwarding_packets, 
just like it trusts other routers without having 
any security relationship with them.

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Wed, 4 Sep 2002 18:20:25 -0700

> tunnels to the MN, no decapsulation is needed.

How can the MAP know that an AH tunnel is in use without snooping the packets?

> any security relationship with them.

Having it participate in the routing security association is fine, just we need
to make sure that this is a MUST in the spec.

            jak