Subject: RE: [mobile-ip] Mobile IPv6 - Issue 74 (Using the CoA as SRC Addr for short-term communications)

From: [email-masked]
Date: Thu, 19 Sep 2002 13:30:34 -0500

James,

The current IPv6 default address selection draft in section 5, rule 4
says:
"

   Implementations should provide a mechanism allowing an application 
   to reverse the sense of this preference and prefer care-of addresses 
   over home addresses (e.g., via appropriate API extensions). Use of 
   the mechanism should only affect the selection rules for the 
   invoking application. 
"

Now is this API extension a requirement on the socket API? If so, I
think that the requirement is already covered. If not, we may want to
make a formal request to the IPv6 WG that this requirement be considered
as part of the default address selection mechanism or the advanced socket
mechanisms draft.

-Basavaraj

> -----Original Message-----
> From: ext James Kempf [mailto:[email-masked]]
> Sent: 19 September, 2002 10:38 AM
> To: Patil Basavaraj (NET/Dallas); [email-masked]
> Subject: Re: [mobile-ip] Mobile IPv6 - Issue 74 (Using the CoA as SRC
> Addr for short-term communications)
> 
> 
> Raj,
> 
> I think some sort of communication, either formal or 
> informal, needs to be made
> to the IPv6 WG team doing the IPv6 socket API so that support 
> for this is
> inserted, if it isn't already there. It seems like this is 
> generating a
> requirement on the socket API that needs to be taken into account.
> 
>             jak
> 
> ----- Original Message -----
> From: <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, September 18, 2002 6:21 PM
> Subject: [mobile-ip] Mobile IPv6 - Issue 74 (Using the CoA as 
> SRC Addr for
> short-term communications)
> 
> 
> > Issue 74: Using the CoA as SRC Addr for short-term communications
> > ------------------------------------------------------------------
> >
> > http://www.piuha.net/~jarkko/publications/mipv6/issues/issue74.txt
> >
> > On pg. 94 in Section 11.2.1, the second bullet item allows the MN to
> > use the CoA for certain communications, but I have a difficult time
> > seeing how this could be done given the standard socket API. Perhaps
> > this is not an issue for this spec, but it does need some
> > consideration.
> >
> > On the next page, the direct delivery option should mention that the
> > described technique won't work without a Binding Cache entry or an
> > IPsec SA.
> >
> > Recommendation:
> > ---------------
> >
> > The MN while on a foreign link can choose to use the CoA for short
> > lived communications. IPv6 WG I-D
> > draft-ietf-ipv6-default-addr-select-09.txt is currently work in
> > progress and provides a solution w.r.t the address that is selected
> > for various sessions or applications. Hence policy would 
> specify what
> > address to use (HoA or CoA) as the source address. The Mobile Ipv6
> > specification hence does not have to deal with specifying how the MN
> > chooses the source address and let the IPv6 WG specify this
> > funcationality. Hence no change to the current 
> recommendation for the
> > short-term communications text in section 11.2.1
> >
> > The direct delivery sub section specification in section 
> 11.2.1 should
> > include the following additional text:
> >
> > "
> > The MN may send packets to the CN that includes the home address
> > destination option directly to the CN only if the MN is 
> aware that the
> > CN already has a binding cache entry for the MNs Home 
> address. Section
> > 9.2.2 specifies the rules for Home Address Destination Option
> > Processing at a CN. The MN needs to ensure that there 
> exists an active
> > binding cache for its home address in order to ensure that 
> the CN will
> > process the packet.
> > "
> >
> > If you have any concerns with the above recommendation, 
> please send a
> > note to the Mobile IP mailing list.
> >
> > -Basavaraj
> >
> >
> 
>

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Thu, 19 Sep 2002 14:33:47 -0700

I think an important question is, how does an application
know which IP address(es) is a home address (permanent)
and which ones are not.. (some of those non-home addresses
might be used as care-of addresses....)

We have a draft that can help. Address selection was not
one of the usage scenarios we considered, but still this api
can allow a mobile node to figure out its home address(es)
and the current care-of address(es).

http://www.ietf.org/internet-drafts/draft-yokote-mobileip-api-01.txt

alper

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, September 19, 2002 11:30 AM
Subject: RE: [mobile-ip] Mobile IPv6 - Issue 74 (Using the CoA as SRC Addr
for short-term communications)