Subject: RE: [mobile-ip] issues in mipv6-ipsec: DHAAD

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Fri, 27 Sep 2002 17:30:27 +0200

=> Sorry, I should have put an asterisk
or something. "a" was referring to that
option under which I had this statement

---

From: gabriel montenegro <[email-masked]>
Date: Fri, 27 Sep 2002 17:57:34 +0200

Hesham Soliman (EAB) wrote:
>   > 
>   > Hesham Soliman (EAB) wrote:
>   > > => This would work. a)
>   > 
>   > Hesham, what did you mean by "a)"?
> 

I guess you meant this:

- Prefix discovery MUST use (an existing) home address
   and DHAAD MUST use care-of address.

   The home agent MUST verify that it does not
   respond to a prefix discovery request to an address
   which is not a home address. This ensures that the
   SPD prevents prefix information from leaking (since
   it contains all home addresses and ICMP). Any problems
   in making the prefix discovery use home addresses?

   DHAAD goes to care-of address, and is not protected.

Agree, that makes sense.

-gabriel