Subject: RE: [mobile-ip] LMM requirements: security issue

From: "Alan O'Neill" <[email-masked]>
Date: Mon, 2 Sep 2002 04:56:26 -0400

A bit late I know due to a bout of flu..

Just wanted to mention that Nested MIP also supports these apparently
conflicting requirements because once again it is the MN that registers the
Regional address (RoA) into the global HA.

There is also the option for the MN to register via the Regional Mobility
Agent (RMA) which I guess has some similarities to your extended mode Hesham
in its security implications..

I for one though would suggest that the LMM requirements are somewhat harsh
in that a MN SHOULD be able to use end to end security and employ a direct
MIP BU, but MAY alternatively go via a trusted intermediate element, and use
a chain of trust that maybe in place between these elements either as a
supplement or a replacement to the e-e security approach.

Any push-back on that ?

-----Original Message-----
From: Hesham Soliman (EAB) [mailto:[email-masked]]
Sent: 26 August 2002 22:49
To: [email-masked]'; [email-masked]
Subject: RE: [mobile-ip] LMM requirements: security issue

Theo, 

  > In addition to what I have mentioned previously I would 
  > like to add that
  > I believe that two more requirements are conflicting about security:
  > 
  > In A: 
  >    it is required that the LMM agent does not interfere with the
  > security bindings between the MN and the peers
  > 
  > whereas on B:
  > 
  >  it is required that the MN preserves location privacy under LMM.
  > 
  > I cannot see how one can maintain location privacy (B) of 
  > the MN without
  > breaking the end-to-end principle (A) in terms of security 
  > bindings. 

=> These are requirements and are not meant to show how
it can be done. Of course we don't want to place impossible
requirements, but as Greg explained, this is already doable
to a large extent with the existing HMIPv6, so I don't think 
it's impossible. 

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Tue, 3 Sep 2002 09:46:17 -0700

I think we want to maintain end-to-end security for MIPv6. It is necessary for
the IPsec SA used to secure binding update traffic, for example.

The issue is the extra tunnel overhead, especially on the wireless link, though
also on any T1 links from the aggregation router to the access router. Header
compression can help, but there are issues on handoff.

            jak

----- Original Message -----
From: "Alan O'Neill" <[email-masked]>
To: "Hesham Soliman (EAB)" <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Monday, September 02, 2002 1:56 AM
Subject: RE: [mobile-ip] LMM requirements: security issue