Subject: RE: [mobile-ip] Fastv6: Issue 2: Deferring new CoA configuration

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Fri, 20 Sep 2002 18:36:38 +0200

One thing that has bothered me about the fast handover discussion for a
while is
a preponderance of speculative thinking about how link layers work.
Phil's
suggestion to do a spec on how fast handover might work on 802.11 is a
hopeful
antidote.

=> Agreed.

Talking about "setting up seperate channels for signaling" is an example
of
this. There are link layers out there, we need to accommodate them. We
may be
able to influence link layer designers to go in a particular direction
that is
more beneficial for IP, but we can only push them so far. 

=> I don't think any pushing is required. 
We are not talking about 802.11, we're talking about
cellular links that run IP right? 

UMTS people are defining different types of signalling
channels to accomodate SIP signalling for example. This
can be reused, why not? 

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Fri, 20 Sep 2002 11:08:57 -0700

> channels to accomodate SIP signalling for example. This

If the channels are available and 3GPP is can be convinced to get rid of GPRS
and use Mobile IP, why not? :-) Maybe we could also convince them to do true
make-before-break, like Flarion's flash-OFDM, so that a special fast handover
protocol wasn't necessary.

To me, what this argues for is standardizing drafts that specify how to do fast
handover on specific link layers. Maybe there is too much diversity in how
handover is done to write an optimization draft for a generic fast handover
protocol.

Alternatively, perhaps we could section the fast handover draft into techniques
(anticipated care of address change, tunnel-based routing fixup) that could be
applied to specific link layers with their own particular signaling. This is
somewhat how we did the FMIPv4 draft.

            jak

---

From: "s. goswami" <[email-masked]>
Date: Fri, 20 Sep 2002 14:24:22 -0400 (EDT)

Yes, link layers can be very different. What is needed is a way to
pass Mobile-IP Registration and CoA related packets within the link layer
hand off. In other words nesting Mobile IP handoff in link layer handoff.

The following  draft indicates how this can be done in 802.11 and Mobile
IP.

draft-goswami-mobileip-simultaneous-handoff-v4-01.txt

Subrata

Subrata

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 23 Sep 2002 11:53:57 -0500

Jim,
  The problem in public cellular network links vis-a-vis Mobile IP is 
that IP starts at GGSN/PDSN which is a core network node and everything 
below SGSN, PCF, UTRAN is the link layer. As such the cell size for MIP 
becomes large and thus the layer 3  handoffs are not so frequent. There 
are other things such as GTP, let's not talk about them.
  I agree that we should not develop drafts for each wireless link. What 
is really needed is the definition of an abstract wireless link layer 
interactions and making FMIPv6 protocol to work on it.
  I think that your idea of L2 triggers (was it initiated by you?) is a 
good starting point, however I find the term L2 trigger to be misnomer 
for this, maybe we should call it the wireless link layer indications. 
Maybe these indications must be revisited and redefined in order to use 
them effectively together with a handover protocol. The protocol could 
be defined such a way that the wireless link layer indications become 
the API for FMIPv6.
  The above could be a way out of FMIPv6 being defined for a single link.
My 2 euro cents.
Regards,

-- 
Behcet

---

From: "James Kempf" <[email-masked]>
Date: Mon, 23 Sep 2002 10:26:56 -0700

Behcet,

Unfortuantely, the L2 triggers work has not gotten a lot of traction in the
IETF. Outside of the mobile wireless arena, people are proposing using SNMP for
it, which completely misses the point. Others have complained that it is really
a specification for what goes on inside a box and has nothing to do with
observing protocol on the wire. There is also a question about what usefulness
it would have ultimately, since link layer designers generally do their own
thing. So unless there is some interest on the part of groups dealing with
mobile and wireless to take on the work, it seems likely that it will not be
continued.

                jak

----- Original Message -----
From: "Behcet Sarikaya" <[email-masked]>
To: "James Kempf" <[email-masked]>
Cc: "Hesham Soliman (EAB)" <[email-masked]>; "''Alper E. YEGIN'
'" <[email-masked]>; "'Singh Ajoy-ASINGH1 '" <[email-masked]>;
"''Rajeev Koodli' '" <[email-masked]>; <[email-masked]>
Sent: Monday, September 23, 2002 9:53 AM
Subject: Re: [mobile-ip] Fastv6: Issue 2: Deferring new CoA configuration

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 23 Sep 2002 13:48:40 -0500

My idea was an attempt to get out of the situation in which FMIPv6 is 
only applicable to one link and as such it could be part of FMIPv6 draft.

James Kempf wrote:

>>>To me, what this argues for is standardizing drafts that specify how to do
>>>      
>>>
>fast
>  
>
>>>Alternatively, perhaps we could section the fast handover draft into
>>>      
>>>
>techniques
>  
>
>>>(anticipated care of address change, tunnel-based routing fixup) that could
>>>      
>>>
>be
>  
>

---

From: "James Kempf" <[email-masked]>
Date: Mon, 23 Sep 2002 13:13:34 -0700

Well, we put the L2 triggers material into the FMIPv4 draft, but I don't think
there is any interest in doing that with FMIPv6. There is some interest in
keeping L2 issues separate. Perhaps that's not possible, though.

            jak

----- Original Message -----
From: "Behcet Sarikaya" <[email-masked]>
To: "James Kempf" <[email-masked]>
Cc: "Hesham Soliman (EAB)" <[email-masked]>; "''Alper E. YEGIN'
'" <[email-masked]>; "'Singh Ajoy-ASINGH1 '" <[email-masked]>;
"''Rajeev Koodli' '" <[email-masked]>; <[email-masked]>
Sent: Monday, September 23, 2002 11:48 AM
Subject: Re: [mobile-ip] Fastv6: Issue 2: Deferring new CoA configuration

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 23 Sep 2002 15:33:48 -0500

Jim, I think this was because people were not happy with the so-called 
L2 triggers. Maybe we should redefine them and make them into 
indications like signal strength, beacon, etc. that all wireless link 
layers provide.
Regards,

>>only applicable to one link and as such it could be part of FMIPv6 draft.

--behcet

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Tue, 24 Sep 2002 20:44:27 -0700

> observing protocol on the wire.

With some of the discussions going on, I can see some people might
think this is the only way triggers are generated and consumed. But
don't they consider the case where an access point (i.e., wired2wireless
bridge that can produce the trigger) is separated from the access
router (i.e., the consumer of the triggers)? How is this case neglected...?

> There is also a question about what usefulness

alper

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 25 Sep 2002 09:49:33 -0500

Alper,
  I think that we should separate the IETF work that was going on at 
pilc mailing list from the needs of FMIPv6. What has been on the table, 
i.e. L2 triggers in my opinion strictly belongs to FMIPv6 and that is 
the reason I said this work should probably be revisitied and renamed 
and possibly redefined and then integrated with FMIPv6 protocol.
  We had sometimes heated debates on pilc ML on, something like banana, 
it was a different thing for everyone involved in the discussion.
  I do not know if any new discussion is going on.
Regards,
Alper E. YEGIN wrote:

>>Behcet,
>>
>>Unfortuantely, the L2 triggers work has not gotten a lot of traction in
>>    
>>
>the
>  
>
>>IETF. Outside of the mobile wireless arena, people are proposing using
>>    
>>
>SNMP for
>  
>
>>it, which completely misses the point. Others have complained that it is
>>    
>>
>really
>  
>
>>it would have ultimately, since link layer designers generally do their
>>    
>>
>own
>  
>
>>mobile and wireless to take on the work, it seems likely that it will not
>>    
>>
>be
>  
>
>>continued.
>>
>>    
>>
>
>alper
>  
>

--behcet

---

From: "James Kempf" <[email-masked]>
Date: Wed, 25 Sep 2002 11:15:20 -0700

Alper,

I agree this case is important. It would help with 802.11 handover, for example,
to have such a protocol. Unfortunately, some people view this as an L2
functionality. So it seems we can't even get agreement about the need for a
protocol, much less a collection of abstractions to expose L2 functionality to
L3.

                jak

----- Original Message -----
From: "Alper E. YEGIN" <[email-masked]>
To: "James Kempf" <[email-masked]>; "Behcet Sarikaya"
<[email-masked]>
Cc: "Hesham Soliman (EAB)" <[email-masked]>; "'Singh
Ajoy-ASINGH1 '" <[email-masked]>; "''Rajeev Koodli' '"
<[email-masked]>; <[email-masked]>
Sent: Tuesday, September 24, 2002 8:44 PM
Subject: Re: [mobile-ip] Fastv6: Issue 2: Deferring new CoA configuration

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Thu, 26 Sep 2002 09:10:59 -0700

James,

Network initiated side of FMIP protocols depend on access routers receiving
such triggers. Unless all link-layers are already defining how these
triggers
are delivered from access points to access routers, I think we have a gap
in the protocol design.

alper

> > > Cc: "Hesham Soliman (EAB)" <[email-masked]>; "''Alper
E.
> > YEGIN'
> > > > >If the channels are available and 3GPP is can be convinced to get
rid
> > of GPRS
> > > > >and use Mobile IP, why not? :-) Maybe we could also convince them
to do
> > true
> > > > >make-before-break, like Flarion's flash-OFDM, so that a special
fast
> > handover
> > > > >To me, what this argues for is standardizing drafts that specify
how to
> > do
> > > fast
> > > > >handover on specific link layers. Maybe there is too much diversity
in
> > how
> > > > >(anticipated care of address change, tunnel-based routing fixup)
that
> > could
> > > be
> > > > >applied to specific link layers with their own particular
signaling.
> > This is

---

From: Michael Thomas <[email-masked]>
Date: Thu, 26 Sep 2002 09:59:41 -0700 (PDT)

Alper,

I've been struggling to keep up here, but isn't
that rather orthogonal to the job of FMIP? That is,
even if there were a hole here, wouldn't it be
better to consider that outside of the scope of
mobile IP?

	Mike

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Thu, 26 Sep 2002 11:06:42 -0700

Hi Mike,

> better to consider that outside of the scope of

From FMIP perspective, it is a requirement that
an access router can receive notifications for
certain link-layer events. The protocol doesn't work
in the absence of this capability. So, as we are developing
a protocol, we have to make sure its requirements can
be satisfied, and people can implement it and run it
today. If we realize that this requirement is already satisfied
by existing mechanisms, then we are fine. If not, we might have
to step in and fill this gap, imo. How can we be finished
designing a protocol if one of its dependencies is unfulfilled?

OK, this doesn't necessarily mean that the work has to
be done in Mobile IP WG. But at least we have to make sure
it's done somewhere. Otherwise we cannot complete this
Mobile IP task.

alper

---

From: "James Kempf" <[email-masked]>
Date: Thu, 26 Sep 2002 11:20:18 -0700

Alper,

I agree 100% and I would urge you, Behcet, and anybody else interested to pursue
this if you think it is important and have time. My comments were not meant to
discourage continued work on this approach, just to point out the obstacles that
have arisen. The only option I can see for this is that the work continue in
some wireless/mobility related WG, where the value of having an abstraction of
wireless link characteristics is appreciated.

            jak

----- Original Message -----
From: "Alper E. YEGIN" <[email-masked]>
To: "James Kempf" <[email-masked]>; "Behcet Sarikaya"
Sent: Thursday, September 26, 2002 9:10 AM

---

From: Michael Thomas <[email-masked]>
Date: Thu, 26 Sep 2002 11:57:43 -0700 (PDT)

> designing a protocol if one of its dependencies is unfulfilled?

   Well, it seems to me that there are serveral
   ways to work around this for the time being. For
   one, this only affects network triggered moves,
   and for two this isn't an issue if the AP and AR
   are colocated. Given this, it doesn't strike as
   a huge problem to move FMIP forward without
   addressing transport of L2 triggers across a
   wire. If that proves to be beneficial, we could
   always survey the landscape for suitable
   existing protocol or invent a new one at that time.

	       Mike

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 26 Sep 2002 13:59:07 -0500

Hi Jim,
  I have been arguing that Mobile IP WG is the place, since it seems 
that only FMIPv6 needs such a thing.

Regards,

James Kempf wrote:

>>>I agree this case is important. It would help with 802.11 handover, for
>>>      
>>>
>>example,
>>    
>>
>>>functionality. So it seems we can't even get agreement about the need for
>>>      
>>>
>>a
>>    
>>
>>>protocol, much less a collection of abstractions to expose L2
>>>      
>>>
>>functionality to
>>    
>>
>>>L3.
>>>
>>>                jak
>>>
>>>      
>>>
--behcet

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Thu, 26 Sep 2002 12:11:38 -0700

>    are colocated. 

Assuming AP and AR are co-located takes away good chunk
of deployment cases. And limiting the protocol to mobile
initiated voids a considerable portion of the protocol
work. Of course we can find a combination of protocol
and deployment scenario that doesn't require transport
of L2 triggers, but that would be too limiting.

>   Given this, it doesn't strike as

alper