Subject: RE: [mobile-ip] Fastv6: Issue 2: Deferring new CoA configuration

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Wed, 18 Sep 2002 14:59:32 -0500

Ajoy, under what conditions sending few extra packets
is an issue? If we have such delicate conditions, how do
they perform when a router sends an unsolicited router
advertisement, or some other node sends a neighbor solicitation,
or user of the mobile node wants to browse the Internet
simultaneously, etc.. (many reasons to send/receive
packets at the same time...)

Ajoy->

This question is difficult to answer unless I use 
a specific air interface technology. For example, in CDMA
2000 access network, each mobile is allocated a low 
bandwidth dedicated pipe and a high bandwidth shared
pipe. The high bandwidth pipe is shared among multiple 
users for obvious reason. The high bandwidth pipe is allocated 
when an MN has enough buffered data to send or receive. Moreover, 
the access time of this channel is very high, hence 
it is not suitable for carrying any real time 
voice or Fast Mobile/IP messages. Typically the shared channel won't 
get allocated for low bandwidth voice over IP or
say Mobile/IP signaling message. In this case, the Mobile/IP
messages will have to compete with VoIP traffic for low
bandwidth channel. On the other hand, the bulky traffic (e.g., FTP)
are buffered until the high bandwidth channel is available for 
communication. This is ok for non-real time traffic because
the users don't care about the buffering delay associated with 
these packets. BTW, the one solution of this problem is 
to allocate high bandwidth dedicated channel to each 
users which is very expensive and not done so far.

-----Original Message-----
From: Alper E. YEGIN [mailto:[email-masked]]
Sent: Wednesday, September 18, 2002 1:54 PM
To: Singh Ajoy-ASINGH1; 'Rajeev Koodli'; [email-masked]
Subject: Re: [mobile-ip] Fastv6: Issue 2: Deferring new CoA
configuration

> Hello Rajeev,
> I have not read all the emails exchanged about this
> issue. BTW, I would like to have the option to defer 
> new care of address configuration. 
> Following are a few advantages of this approach:
> 
> 1.Avoid the possibility of blocking real time traffic 
> by the signaling traffic.

Ajoy, under what conditions sending few extra packets
is an issue? If we have such delicate conditions, how do
they perform when a router sends an uncolicited router
advertisement, or some other node sends a neighbor solicitation,
or user of the mobile node wants to browse the Internet
simultaneously, etc.. (many reasons to send/receive
packets at the same time...)

alper

> 2.Provides mechanism to remove header compression 
> context transfer or re-negotiation out of critical path 
> of handover. Similarly, provides mechanism to remove PPP 
> context transfer or or re-negotiatio (if PPP is used)out 
> of critical path of handover. 
> 
> If we keep context transfer as well as the handover signaling 
> in the critical path of handover, I do see possibility of call drop
> which will beat the purpose of fast handoff. BTW, in order to support 
> above feature (2,3), we need a mechanism to tunnel 
> compressed IP packet or PPP frame.
> 
> Regards,
> Ajoy
> 
> -----Original Message-----
> From: Rajeev Koodli [mailto:[email-masked]]
> Sent: Monday, September 16, 2002 8:37 PM
> To: [email-masked]
> Subject: [mobile-ip] Fastv6: Issue 2: Deferring new CoA configuration
> 
> 
> 
> Issue: Should a Fastv6 MN be required to have the
> option of deferring its new CoA configuration until
> a "convenient" time ?
> 
> Background: In version 04, a MN can defer new CoA
> configuration until it finds, for instance, suitable
> radio resources (See Section 3.5.2). This would mean
> that the MN would be required to suppress RS and
> Router Advertisement every time it changes access routers
> until a convenient time. This also means the previous CoA
> would potentially have to be supported across a series of
> access routers for arbitrary periods of time.
> 
> The proposal is to remove this restriction on new CoA
> configuration.
> 
> Please respond
> - YES if you agree to remove the restriction
>     of deferring new CoA
> - NO otherwise. Indicate a brief reason
> 
> Thanks,
> 
> -Rajeev
> 
>

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Wed, 18 Sep 2002 18:43:17 -0700

I still don't understand how we can ensure smooth
operation using this dedicated channel which cannot
even accomodate few additional IP packets.

For example, what happens if some of those
real-time packets needed to be fragmanted? Maybe this
doesn;t apply to voice packets since they are small,
but any larger packet can be pushed over the edge due
to tunneling overhead of Mobile IP based protocols. Now
you have more packets....

If accumulative bandwidth is an issue, well then additional
extension headers (e.g., routing header) and one or more
encapsulation can consume more bandwidth than we
have provisioned for the dedicated channel.

Also, how does the network decide which packets can take
the dedicated channel? In the presence of IPsec encryption
and changing source and destionation addresses via Mobile IP,
filtering of those packets is not practical.

What I'm trying to say is, before 2 packets of mobility signaling,
I think this system has some other problems to deal with....

alper