Subject: RE: [mobile-ip] Summary of Issues: Forwarding without FBU

From: [email-masked]
Date: Wed, 25 Sep 2002 10:43:33 -0500

James,

> 
> Rajeev,
> 
> I disagree with this proposal. I sent out a proposal last 
> week to modify the
> signaling so that the FBU confirms completion of care of 
> address configuration
> on the new router. I believe the current FBU semantics in the 
> fast handover
> draft is confused, and contradicts how BU is defined in the 
> base MIPv6 draft.
> 
> I think a better match with the semantics of base MIPv6 is 
> for the HI/HACK to
> optimize DAD by confirming CoA on the new router, and for the 
> tunnel to be set
> up once the PrxyRtAdv is sent. The draft should make this 
> SHOULD. The old route
> MAY rather wait until it has link layer confirmation of the 
> handover via a link
> down (secured if possible). Then, when the MN has completed 
> BU to HA, RR, BUs to
> CN, etc. etc., it sends FBU to old AR to remove the tunnel.

The FBU is a signal which begins the forwarding of packets from
the oAR via the tunnel that has been setup. The Hi/HAck signaling
setups the tunnel even before the MN may have moved (just an example
here). Hence the use of Hi/HAck for initiating the packet forwarding
from oAR is not useful.

-BP 

> 
>             jak
> 
> ----- Original Message -----
> From: "Rajeev Koodli" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, September 24, 2002 1:58 PM
> Subject: [mobile-ip] Summary of Issues: Forwarding without FBU
> 
> 
> >
> > Hello folks,
> >
> > we have had some good discussion in the last
> > couple of weeks and I would like to progress the
> > draft forward. So, I will try to summarize the
> > discussion and propose moving forward.
> >
> > It appears that we should allow traffic re-direction
> > upon processing the FBU even though the tunnel
> > itself may be set up earlier. Even though "secure
> > link layer" was brought up during the discussion,
> > the nature, purported support we could expect of
> > such link layers and whether we should rely on
> > such a functionality are all unclear. In addition,
> > it is not clear whether specification assuming such
> > functionality is within the scope of this WG.
> > So, we should not attempt specify traffic redirection
> > when FBU is not processed.
> >
> > -Rajeev
> >
> >
> >
> >
> 
>

---

From: "James Kempf" <[email-masked]>
Date: Wed, 25 Sep 2002 19:15:47 -0700

Hi Raj,

> here). Hence the use of Hi/HAck for initiating the packet forwarding

Why is the FBU any better signal for beginning forwarding of packets? It can
also (and often is) sent prior to the MN moving.

            jak