Subject: RE: [mobile-ip] Fastv6: Issue 2: Deferring new CoA configuration

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Wed, 18 Sep 2002 12:10:41 -0500

Hello Rajeev,
I have not read all the emails exchanged about this
issue. BTW, I would like to have the option to defer 
new care of address configuration. 
Following are a few advantages of this approach:

1.Avoid the possibility of blocking real time traffic 
by the signaling traffic.
2.Provides mechanism to remove header compression 
context transfer or re-negotiation out of critical path 
of handover. Similarly, provides mechanism to remove PPP 
context transfer or or re-negotiatio (if PPP is used)out 
of critical path of handover. 

If we keep context transfer as well as the handover signaling 
in the critical path of handover, I do see possibility of call drop
which will beat the purpose of fast handoff. BTW, in order to support 
above feature (2,3), we need a mechanism to tunnel 
compressed IP packet or PPP frame.

Regards,
Ajoy

-----Original Message-----
From: Rajeev Koodli [mailto:[email-masked]]
Sent: Monday, September 16, 2002 8:37 PM
To: [email-masked]
Subject: [mobile-ip] Fastv6: Issue 2: Deferring new CoA configuration

Issue: Should a Fastv6 MN be required to have the
option of deferring its new CoA configuration until
a "convenient" time ?

Background: In version 04, a MN can defer new CoA
configuration until it finds, for instance, suitable
radio resources (See Section 3.5.2). This would mean
that the MN would be required to suppress RS and
Router Advertisement every time it changes access routers
until a convenient time. This also means the previous CoA
would potentially have to be supported across a series of
access routers for arbitrary periods of time.

The proposal is to remove this restriction on new CoA
configuration.

Please respond
- YES if you agree to remove the restriction
    of deferring new CoA
- NO otherwise. Indicate a brief reason

Thanks,

-Rajeev

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Wed, 18 Sep 2002 11:53:52 -0700

> by the signaling traffic.

Ajoy, under what conditions sending few extra packets
is an issue? If we have such delicate conditions, how do
they perform when a router sends an uncolicited router
advertisement, or some other node sends a neighbor solicitation,
or user of the mobile node wants to browse the Internet
simultaneously, etc.. (many reasons to send/receive
packets at the same time...)

alper