Subject: [mobile-ip] HMIPv6-next steps

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 17 Sep 2002 18:38:36 +0200

Hi all, 

After some discussion with the chairs we agreed
that we will send an update on HMIPv6 to the 
list FYI and comments. 

A couple of people have indicated that it might
be good to put extended mode in a separate draft,
partly because it is helpful for nemo and partly
because it will need some more work to accomodate
the latest changes in the MIPv6 base. 

Extended mode might be useful for nemo, but it's too
early to tell right now, for this reason it is hard
to keep it in a MIP WG document. On the other hand, 
it is also useful for removing the extra tunnel
when CNs do not use/implement RO. 

What we're trying to do is to finish the draft ASAP. 
For this reason, and given comments on the list, the
chairs suggested that we remove extended mode for 
now and proceed with Basic mode only. If we later
agree on a nice solution for using extended mode
with MNs implementing RR with CNs, then we can proceed
with a separate draft. 

We are now working on a new revision that will reflect
these changes, your feedback is welcome as usual.

Hesham

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 17 Sep 2002 12:07:34 -0500

Hesham,
  I agree with the decision to remove the extended mode.
As for the comments, I suggest that you look into the open issues I 
tried to point out in my draft on LMM architectures, the most important 
one being how to detect domain changes, etc. The pointer to version 1 is 
in one of my previous messages.

Regards,

-- 
Behcet

---

From: "James Kempf" <[email-masked]>
Date: Tue, 17 Sep 2002 10:26:13 -0700

Hi Hesham,

I wonder if we could get the chairs to ask the IESG for an early ruling on the
IPR statement for HMIP. It is rather unusual, and I would rather that we not end
up in a position like that which I believe occured in the iSCSI WG, in which the
chairs and WG proceeded forward on a draft for standards track only to be told
by the IESG at the end that the IPR was not acceptable.

This could considerably expedite bringing HMIP to standard.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Tue, 17 Sep 2002 10:56:49 -0700

This is an issue that has come up in our discussions as well.

We are particularly interested in some way of doing MAP discovery that does not
involve detecting modified RAs. This could involve a custom built
administratively scoped multicast discovery protocol, or possibly the use of SLP
or some other discovery protocol.

The reason for this is because we would like to maintain the option of deploying
MIPv6 with standard IPv6 routers, and then deploy MAPs for location privacy
without requiring any modifications on the routers or configuration of router
advertisements.

This option does not have to be in the base specification, unless there is wider
agreement that this would be a better design.
If it is not in the base specification, then RA-based MAP advertisement should
be properly qualified as the advertisement technique so that other techniques
are allowed. We are prepared to work together on designing a MAP discovery
technique if there is broader interest in this possibility, either in a separate
draft or as a contribution to the base draft.

            jak

---

From: Greg Daley <[email-masked]>
Date: Wed, 18 Sep 2002 10:22:48 +1000

Hi Hesham,

I think that getting (Basic) HMIPv6 out ready for use
is very important, but would be reluctant to see
extended mode disappear from the WG completely.

Obviously of the NEMO applications of extended mode
are possible, but the improvements over basic
mode make it useful in  a mobile-ip context as well.

I don't think that there will be too much work to
bring extended mode into conformance with MIPv6.
As I indicated in the thread of 5 september -
'supporting multiple nodes behind one CoA CoTI/CoT',
limited modification is required to perform RR on
Extended Mode devices.

Is it an option to put a (largely unmodified) version
of the extended mode spec up as a draft soon, so that it
doesn't disappear out of the LMM debate?

We could fix it up later as time allows.
Even an individual submission would be valuable.

Greg

---

From: "James Kempf" <[email-masked]>
Date: Tue, 17 Sep 2002 18:13:20 -0700

> Even an individual submission would be valuable.

I think having extended mode as an individual submission to keep it active would
be a fine idea.

There's an issue of whether it should be done in MIP or in NEMO. The discussions
in NEMO about how the mobile router would handle the care of address look alot
like extended mode, and it might make sense to combine them. On the other hand,
the major issue of extended mode for MIP is how to handle route optimization,
which won't be considered as a fixed design for a bit yet in NEMO. Perhaps we
could keep it in MIP and continue considering how to do RO, then if we figure
something out it might provide some input into NEMO.

            jak

---

From: Vrizlynn Thing <[email-masked]>
Date: Wed, 18 Sep 2002 11:19:19 +0800

Hi all,

I have an individual submission on a new LMM scheme design at
http://www.ietf.org/internet-drafts/draft-vriz-mobileip-hbhlmap-00.txt

Abstract

   This document introduces an extension to Mobile IPv6 to provide
   support for Localized Mobility Management. This proposed Hop-by-Hop
   Local Mobility Agents Probing scheme specifies the Local Mobility
   Agents Discovery, Selection and Failure Detection architecture and
   procedures for deploying the localized mobility management, whereby
   the Local Mobility Agents are distributed. It reduces the amount of
   signalling to the home agent and correspondent nodes when mobile
   node moves among the subnets of the visited domain.

This scheme supports Local Mobility Agents discovery, selection and failure
detection without modifications to routers not acting as LMAs.

Regards,
Vrizlynn Thing (Ms.)
Senior Engineer

Laboratories for Information Technology
21 Heng Mui Keng Terrace
Singapore 119613
Tel: +65 68746728
Fax: +65 67768109
Email: [email-masked]

----- Original Message -----
From: "James Kempf" <[email-masked]>
To: "Behcet Sarikaya" <[email-masked]>; "Hesham Soliman (EAB)"
<[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, September 18, 2002 1:56 AM
Subject: Re: [mobile-ip] HMIPv6-next steps