Subject: [mobile-ip] RE: Extended Mode, Basic Mode, and NestedMIPv6 (was: Re: [mobile- ip] LMM requirements: security issue)

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Thu, 5 Sep 2002 19:44:35 +0200

If we intend to include extended mode into the base spec, and if the
NestedMIPv6
work would fold into extended mode, then we should discuss it here.

I think there are a number of issues with extended mode that we need to
resolve,
and I assume that any fold-in of NestedMIPv6 would either resolve them
or not,
and may perhaps generate more. Would it make sense to maybe spend a
little time
seeing if we can resolve them, after Alan and Hesham have had time to
chat, then
perhaps make a decision, based on the discussion, whether to keep
extended mode
in the base spec or separate it into a different spec?

=> Yes, I think we need to discuss Extended mode's 
future. I was preparing something to send to the list
but didn't want to disrupt the MIPv6 discussions, 
so now I'm trying to catch up :) 
There are a couple of issues that need to be polished 
due to the MIPv6 changes. Let's see if we can address
them, and after that assess whether it makes sense to
keep extended mode at all in the draft.
I'll send a proposal very shortly to the list. 

This would be a way to accelerate progress on basic mode, assuming we
have
agreement that the issues with basic mode have been addressed. Also, if
people
think that the issues with basic mode haven't been addressed, then
perhaps we
could focus on them?

=> I don't want to jumpt the gun but basic mode 
works without any problems at all. All it needs is 
some text about SA establishment between the MN and the 
MAP. No fixes needed IMHO, unless we want to add new
features. 

Hesham

---

From: "Alan O'Neill" <[email-masked]>
Date: Thu, 5 Sep 2002 22:53:34 -0400

Hesham,

I think my interests are on the requirements and associated feature side to
see if HMIP + Nested can give us the super-set of must haves from my
perspective.

Concat MIP (option within Nested MIP) is maybe more in the space of extended
mode...

I have an open mind about how we wrap things together, once we have done the
analysis..

Alan.

-----Original Message-----
From: Hesham Soliman (EAB) [mailto:[email-masked]]
Sent: 06 September 2002 03:15
To: 'James Kempf '; [email-masked] '; 'Alan O'Neill '
Cc: [email-masked] '
Subject: RE: Extended Mode, Basic Mode, and NestedMIPv6 (was: Re:
[mobile- ip] LMM requirements: security issue)

Hesham