Subject: RE: [mobile-ip] closing issue #79 (too drastic collision acftion)

From: [email-masked]
Date: Wed, 25 Sep 2002 10:06:24 -0500

> > The mobile node SHOULD NOT wait for reconfiguration
> > or disable the interface. The mobile node MUST NOT discard the
> > home address based on a failure of a link-local address with the
> > same interface identifier.
> > 
> 
> What should happen to the link-local address that failed DAD?  Should
> it remain "tentative" untill the node moves again and then retry DAD?

Options:
1. Disable the link-local address until the MN moves to a different 
link (as you suggest above) at which time it can perform DAD again
2. Disable address for a specific period of time
3. Disable address till MN returns home 

I prefer option 1.

> 
> -vlad
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> Vladislav Yasevich		Tru64 UNIX - IPv6 Project Lead
> Hewlett Packard 		Tel: (603) 884-1079
> Nashua, NH 03062		ZKO3-3/T07
> 

-Basavaraj

---

From: Jari Arkko <[email-masked]>
Date: Thu, 26 Sep 2002 11:01:23 +0300

It is perhaps best to reference RFC 3041 to get the details
of generating random addresses. However, RFC 3041 does
not seem to talk about link-local addresses, only global
addresses. Also, we will likely want to have a different
action than RFC 3041 specified when the five attempts
run out. Here's a suggested new text proposal on describing
this:

7.6. Changes to Duplicate Address Detection

Upon failing Duplicate Address Detection, RFC 2462 requires
IPv6 nodes to stop using the address and wait for reconfiguration.
In addition, if the failed address was a link-local address
formed from an interface identifier, the interface should
be disabled.

Mobile IPv6 extends this behaviour as follows. Upon failing
Duplicate Address Detection while away from home, the
mobile node SHOULD stop using the address on this interface
until the mobile node moves to another link. The mobile
node SHOULD NOT wait for reconfiguration or disable the
interface.

The mobile node MUST NOT discard the home address based on a
failure of a link-local address with the same interface identifier.
Instead, the mobile node SHOULD generate a new random interface
identifier and use it for assigning itself a new link-local
address. In order to do this, the mobile node applies to the
link-local address the procedure described in RFC 3041 for
global addresses. At most 5 consecutive attempts SHOULD be
performed to generate such addresses and test them through
Duplicate Address Detection. If after these attempts no
non-unique address was found, the mobile node SHOULD log
a system error and give up attempting to find a link-local
address on that interface, until the node moves to a new link.

---

From: "James Kempf" <[email-masked]>
Date: Thu, 26 Sep 2002 08:43:08 -0700

Agree.

            jak