Subject: [mobile-ip] MobileIPv6 with IPSec, anyone?

From: Parijat Mishra <[email-masked]>
Date: Sat, 14 Sep 2002 01:34:43 +0800 (SGT)

Hello all,

Is there any discussion/documentation about how mobile-ipv6 and IPsec 
interact. Hesham Soliman's draft discusses security issues when IPSec is 
used to protect mobile-ipv6; but I am interested in understanding things 
like:

(a) for incoming/outgoing packets what would be the order of 
processing: IPSec, then Mobile-ipv6, or vice-versa, for e.g., (I suspect 
there is some interleaving);

(b) what happens when an IPSec tunneled 
packet comes to HA for a MN away from home? Does HA double-tunnel it to 
MN?

(c) How does a MN maintain its IPSec connection to a VPN GW while  
oving (i.e., what is the packet supposed to look like)?

I would be grateful to any pointers in this direction?

P.S.: has anyone got a system using IPSec+Mobile-ipv6 running?

-- 
Sincerely,
Parijat Mishra
R & D Engineer,
Institute for Communications Research
Tel: (65)68709353

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 13 Sep 2002 17:29:16 -0500

May I add to this question my question which is
the same as below, but also for MIPv4?

Regards,.

-- 
Behcet

---

From: Francis Dupont <[email-masked]>
Date: Sun, 15 Sep 2002 18:04:49 +0200

=> there is a private discussion (in order to produce a draft) about
the special case of MN-HA communications.

   
=> for incoming the answer is simple because it follows the order
of headers. For outgoing packets IPsec must be first and Mobile-IPv6
after according to the (updated ASAP) relevant section in the draft.

=> what is the end of the tunnel? If it is the MN this should give
a double-tunnel, if it is the HA the packet is decapsulated and
recapsulated.

   (c) How does a MN maintain its IPSec connection to a VPN GW while  
   moving (i.e., what is the packet supposed to look like)?
   
=> this is one point I am interested to (the case where the VPN GW and
the HA is the same box).

=> from the IPsec point of view you can read my draft
(draft-dupont-ipsec-mipv6-01.txt). From the MIPv6 you have to wait a bit...

=> I have one based on KAME/racoon...

Regards

[email-masked]

---

From: "Kevin Miles" <[email-masked]>
Date: Mon, 16 Sep 2002 16:52:57 +0100

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of 
> Parijat Mishra
> Sent: 13 September 2002 18:35
> To: [email-masked]
> Subject: [mobile-ip] MobileIPv6 with IPSec, anyone?
> 
> 
> Hello all,
>

---

From: "Kevin Miles" <[email-masked]>
Date: Mon, 16 Sep 2002 21:45:41 +0100

For those of you, like Jari, who were mystified by my previous content-free post, here's the URL I sent. 

 http://www.piuha.net./~jarkko/publications/mipv6/ipsec_usage.txt

Something along the way stripped it from the message. 

Kevin.