Subject: RE: [mobile-ip] Optimistic DAD for Fast Handovers

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Fri, 6 Sep 2002 14:56:45 +0200

This should work, and it will work even 
better when we get secure ND. Of course
it should be noted that this is a relaxation
of 2461 which says that the O flag MUST always
be set. But I think we should try to relax this 
requirement for this specific case.

Hesham

  > -----Original Message-----
  > From: Nick 'Sharkey' Moore [mailto:[email-masked]]
  > Sent: Friday, September 06, 2002 12:41 AM
  > To: [email-masked]
  > Subject: [mobile-ip] Optimistic DAD for Fast Handovers
  > 
  > 
  > G'day all,
  > 
  >         As part of an attempt to put together a minimal
  > specification / implementation of Fast Handovers for IPv6
  > over 802.11, I've been working on eliminating DAD delays
  > by using Optimistic DAD.
  > 
  >         There is some precedent for this based on 
  > draft-koodli-fastv6-00 and comments by Eric Nordmark in
  > the WG at IETF-54 in Yokohama, however this work is
  > really intended as a research rather than a standards-
  > setting effort :-)
  > 
  >         So far I've put together the beginnings of a 
  > spec and tweaked a Linux kernel to implement these
  > changes.  In initial tests, the modifications seem to 
  > be effective.  I've also made some modifications to 
  > _increase_ the likelihood of collision, in order to 
  > be able to test these cases.
  > 
  > 
  >         The modifications I'm experimenting with are:
  > 
  > * Always using randomized suffixes, as per RFC 3041.
  >     If there is a collision, pick a new random suffix and
  >     start again.
  > 
  > * Requiring the node to send unsolicited NAs:
  >         + When DAD commences, with Override = 0;
  >         + When DAD completes successfully, with Override = 1.
  >     This allows communication to start immediately if 
  >     there is no collision.
  > 
  > * Allowing the node to communicate while Tentative,
  >     which allows Binding Updates, etc to be sent.
  > 
  > * Allowing the node to respond to NSs while Tentative, but
  >     requiring that the reply NA Override flag is 0.
  > 
  > 
  >         Hopefully these changes allow a very fast handover 
  > while maintaining interoperation with normal nodes.
  > 
  >         I'm interested to hear your opinions!
  > 
  > -----N
  > -- 
  > Nick 'Sharkey' Moore                    <[email-masked]>
  > Research Fellow, CTIE                   Tel: +61 3 9905 3707
  > Monash University,  Australia           Fax: +61 3 9905 5358
  >

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 9 Sep 2002 15:15:28 +0200

=> I don't think that what Nick proposed will hurt any 
other nodes. This is clearly achieved by _clearing_ the 
O flag. BTW, the MIPv6 spec has an even cruder (is that
a word!?) approach, it simply says that MNs should just
use the address while performing DAD and says nothing 
about the O flag as far as I remember.

Hesham