Subject: RE: [mobile-ip] Mobile IPv6 - Issue 72 (Forwarding from previous CoA)

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Sun, 15 Sep 2002 00:31:25 +0200

Makes sense. The draft is currently quite 
confusing on this issue. The fast handovers draft 
is the right place for this. 

Hesham

  > -----Original Message-----
  > From: [email-masked] [mailto:[email-masked]]
  > Sent: Friday, September 13, 2002 11:34 PM
  > To: [email-masked]
  > Subject: [mobile-ip] Mobile IPv6 - Issue 72 (Forwarding 
  > from previous
  > CoA)
  > 
  > 
  > Issue 72: Forwarding from Previous Care of Address
  > --------------------------------------------------
  > 
  > http://www.piuha.net/~jarkko/publications/mipv6/issues/issue72.txt
  > 
  > Section 11.6.6 of the Mobile IPv6 specification describes 
  > the ability
  > to forward packets from a previous CoA to the new CoA as a result of
  > the MN connecting to a new link.
  > 
  > Since the BU sent to an HA on the previous link requires the same
  > security as the BUs sent to the MNs Home Agent (on home 
  > link), this is
  > quite a difficult proposition from an implementation and deployment
  > perspective. So,
  > 
  > Recommendation:
  > ---------------
  > 
  > The Mobile IP WG is currently working on fast handoffs for 
  > Mobile IPv6
  > which deals with the aspect of forwarding packets from the previous
  > CoA to the new CoA (draft-ietf-mobileip-fast-mipv6-04.txt).
  > 
  > Hence this entire feature can effectively be dropped out of the base
  > Mobile IPv6 specification and pursued independently as a separate
  > feature for IPv6 mobility. 
  > All text associated with the forwarding from previous CoA will be
  > deleted from the current specification.
  > 
  > If you have any concerns or views on why this feature 
  > should be a part
  > of the base specification, please post them to the list. 
  > 
  > -Basavaraj
  > 
  > 
  >

---

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 16 Sep 2002 10:40:19 -0700 (PDT)

> example, see Section 2:
> 
>     -  There is no longer any need to deploy special routers as
>        "foreign agents" as are used in Mobile IPv4.  In Mobile IPv6,
>        mobile nodes make use of IPv6 features, to operate in any
>        location without any special support required from the local
>        router.
> 
> This feature compromises this basic design goal, and I believe it should be
> moved to the fast handover spec, which explicitly requires changes in the 
access
> router. Another possibility is that this design goal could be removed from the
> MIPv6 spec, but I think that would be a mistake, since the rest of the spec
> conforms with the design goal. Or the MIP group could make a recommendation 
that
> all IPv6 routers be required to implement this functionality, and take the 
issue
> to the IPv6 Working Group. Of these three, I think the easiest is to move it
> into a spec that discusses MIPv6 handover directly and talks about specialized
> MIPv6 access router functionality.
> 

Jim has a good point. Personally, I think, it should be removed from the
main body of Base MIPv6 draft, however a reference to it can be made in the
appendix section to point to the MIPv6 fast handover document for further
discussion. 

-Samita

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 17 Sep 2002 00:34:11 +0200

=> OK.

  > 
  > However, and this is the reason of the discussion and 
  > concern I have. There are scenarios where forwarding from 
  > previous COA is useful. Namely when the Home Agents (the 
  > home, and all the visited link home agents) have a common 
  > group SA. We don't need to describe how this SA is set, 

=> I'm afraid we need to understand how they are
set. This is _the_ issue here.

but 
  > just note that this is a possibility as the spec has it 
  > already (in terms of MN home agent list functionality). 

=> Yes, but that's solving the easy part and 
leaving out the most important one.

Hesham

  > Regards Hannu
  > From: ext Hesham Soliman (EAB) 
  > [mailto:[email-masked]]
  > Sent: 16 September, 2002 11:16 AM
  > To: Flinck Hannu (NRC/MTView); [email-masked]; 
  > Patil Basavaraj
  > (NET/Dallas); [email-masked]
  > Subject: RE: [mobile-ip] Mobile IPv6 - Issue 72 (Forwarding from
  > previous CoA)
  > 
  > 
  > 
  >   > in section 8.3 of MIPv6 spec we have a list of shoulds 
  >   > against  "all IPv6 routers". Further we say in section 10.2
  >   > 
  >   >       " If the node is not a router that implements home agent
  >   >        functionality, then the node MUST reject the 
  > Binding Update
  >   >        and MUST return a Binding Acknowledgement to the 
  > mobile node,
  >   >        in which the Status field is set to 132 (home 
  >   > registration not
  >   >        supported). "
  >   > 
  >   > So there are already recommendations for all routers. 
  >   > 
  >   > There seems to be a number of ways to interpret the text. 
  >   > Mine is that that BUs are sent to CNs and Home Agents, not 
  >   > to (access)routers. I agree that this mentioned in the 
  >   > context of handovers but so are all the other BUs, even the 
  >   > BU to set up the primary care-of address registration to 
  >   > the Home Agent. At least I fail to see the difference.
  > 
  > 
  > => The main problem here is how to setup security
  > with random ARs. This is _not_ the same as a HA
  > where there is a strong assumption that most of 
  > the time manual config will be used. This is 
  > why the issue needs to be investigated in a lot
  > more detail than the MIPv6 spec can do now given 
  > the time limitations and difficulty of the problem.
  > Using manual config with random ARs is not
  > going to be useful in most deployment cases. 
  > 
  > Hesham
  > 
  >  
  >

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 17 Sep 2002 00:39:04 +0200

Hello Charlie,

  > It's not the job of the base Mobile IP specification to
  > describe how that security association would be established.

=> That's exactly what the spec does though. RR
is described for example. 

  > > the time manual config will be used.
  > 
  > That's not an assumption I have ever made.
  > I have typically assumed that there would be
  > other methods, compatible with the Mobile IP
  > requirements, but non-manual methods, for
  > creating the association.

=> Sure there would be other methods, but 
for now, there is only manual config or PKI
and the PKI option is far from described in the
spec. There would be additional requirements if 
certificates are used (like including HoA ..etc).
So I believe this needs to be described if dynamic keying
was to be used.

  > I think it's a mistake to require that every
  > possible security application related to Mobile
  > IP has to be put in the Mobile IP specification.

=> Yes but this is not _related_ this one is in the
_core_ of MIPv6: How to secure BUs to random ARs.

Hesham

---

From: [email-masked]
Date: Tue, 17 Sep 2002 10:20:41 -0500

At this time, I do not really find strong arguments for keeping
this feature in the base Mobile IPv6 specification. Consensus is
evenly split. The chairs believe that this feature can be included
in the fast handoff for MIPv6 work. 
I would suggest that we close this issue with the current 
recommendation and move forward.

-Basavaraj