Subject: [mobile-ip] Summary of Issues: Forwarding without FBU

From: Rajeev Koodli <[email-masked]>
Date: Tue, 24 Sep 2002 13:58:17 -0700

Hello folks,

we have had some good discussion in the last
couple of weeks and I would like to progress the
draft forward. So, I will try to summarize the
discussion and propose moving forward.

It appears that we should allow traffic re-direction
upon processing the FBU even though the tunnel
itself may be set up earlier. Even though "secure
link layer" was brought up during the discussion,
the nature, purported support we could expect of
such link layers and whether we should rely on
such a functionality are all unclear. In addition,
it is not clear whether specification assuming such
functionality is within the scope of this WG.
So, we should not attempt specify traffic redirection
when FBU is not processed.

-Rajeev

Subject: [mobile-ip] Fastv6:Issue 1: Forwarding without FBU
From: Rajeev Koodli <[email-masked]>
To: [email-masked]
Date: Mon, 16 Sep 2002 17:59:02 -0700

Issue: Should the Previous AR forward packets
on the tunnel without explicitly receiving an FBU
from the MN ?

Background: In base Mobile IP, there has been considerable
discussion on traffic redirection and associated security
issues. Should fastv6 spec allow the PAR to enable packet
forwarding without explicitly receiving a (Fast) Binding
Update from the MN ? In particular, should we assume that
link layer would provide necessary authorization to redirect
traffic ?

Provide your input as either

YES: also provide a "brief" reasoning
NO: may provide a "brief" reasoning

Thanks,

-Rajeev

---

From: "James Kempf" <[email-masked]>
Date: Tue, 24 Sep 2002 21:23:07 -0700

Rajeev,

I disagree with this proposal. I sent out a proposal last week to modify the
signaling so that the FBU confirms completion of care of address configuration
on the new router. I believe the current FBU semantics in the fast handover
draft is confused, and contradicts how BU is defined in the base MIPv6 draft.

I think a better match with the semantics of base MIPv6 is for the HI/HACK to
optimize DAD by confirming CoA on the new router, and for the tunnel to be set
up once the PrxyRtAdv is sent. The draft should make this SHOULD. The old route
MAY rather wait until it has link layer confirmation of the handover via a link
down (secured if possible). Then, when the MN has completed BU to HA, RR, BUs to
CN, etc. etc., it sends FBU to old AR to remove the tunnel.

            jak

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 25 Sep 2002 11:13:21 -0700

Hello Jim,

your proposal below constitutes a bigger change than
the issue is attempting to handle. Certainly folks
should engage in discussion. In the meanwhile,
I would like to progress the draft based on the
summary of discussion.

-Rajeev

---

From: "James Kempf" <[email-masked]>
Date: Wed, 25 Sep 2002 19:29:29 -0700

It sounds like I am outvoted (for now).

Perhaps we can schedule some discussion on this in Atlanta? I really do think it
would improve the design to make the BU semantics more symmetrical with the base
draft. I don't think it will help to talk about this on email now because the
bandwidth is not high enough to really explore the issues in detail.

            jak