Subject: RE: [mobile-ip] Optimistic DAD for Fast Handovers

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 11 Sep 2002 22:47:24 +0200

> In my proposal, the opportunistic node would not send NA
  > in response to NS from the router until its address is
  > confirmed (even though the proposal was not written with
  > the scenario that Mohan describes in mind).

=> I missed this part, but doesn't that mean that it won't
be able to receive traffic until DAD is finished? 

  > The NA can be unicast only to the AR (this is recommended
  > in the proposal).  Once the address is confirmed, a regular NA
  > is multicast.

=> Right, but how does it communicate with PeerNodes in the 
mean time? Does it have to go through the NAR?

Hesham

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 11 Sep 2002 17:01:38 -0700

> be able to receive traffic until DAD is finished?

Yes. And, I realize the correct thing to do is to send NA with
T bit set to the AR.

> mean time? Does it have to go through the NAR?

Basically, the AR replies to NA (with T bit set to 1) with a RA-NAACk
option(i.e., fmipv6 behavior). So, that's one round-trip during which it

cannot communicate directly with its PeerNodes. However, in order to
communicate with them, it needs to do ND first with those nodes right ?
The opportunistic node could use unspecified address while doing ND with

PeerNodes and use the confirmed address later for actual data
communication. This way, you could parallelize (address confirmation and

ND with PeerNode) operations.

Thanks,

-Rajeev