Subject: RE: [mobile-ip] RFC3012bis-04 Available

From: "Jayshree Bharatia" <[email-masked]>
Date: Fri, 20 Dec 2002 16:25:45 -0600

Hello Yoshi,

For a verification error, the AAA has to set the error code. This is what
currently is not in the scope of RFC3012bis. But once this verification
failure is notified to the FA, the error code BAD_AUTHENTICATION is sent to
the mobile node in the Registration Reply. This is discussed in section 3.2
of RFC3012bis draft. 

Regards,
Jayshree

-----Original Message-----
From: Yoshiyuki Tsuda [mailto:[email-masked]]
Sent: Friday, December 20, 2002 4:17 PM
To: Bharatia, Jayshree [RICH1:2H13:EXCH]
Cc: [email-masked]; [email-masked]'; Chowdhury, Kuntal
[RICH1:2H18:EXCH]
Subject: Re: [mobile-ip] RFC3012bis-04 Available

Hi Jayshree and all,

 Thank you for your qualification.
 Ah, it's outside the scope of rfs3012bis ?!!!
 I understand authentication issues by AAA should be treated
 by AAA(diameter).  But, personally I'd thought rfc3012 was
 the best place to define error codes related to MN-AAA
 authentication extension, because MN's developers won't
 read Diameter's I-Ds without a pointer, and because right
 now such an error code is missing in Diameter's I-Ds, I'm
 afraid.
 Have great holidays!

Thanks.
-Yoshi

at Fri, 20 Dec 2002 11:44:12 -0600, Jayshree Bharatia wrote:
>Hello Yoshi,
>
>The verification and related processing at AAA is outside the scope of
>RFC3012bis. The current version of RFC3012bis (04) has a description in
>section 3.2 regarding how verification errors received from the AAA are
>treated at the foreign agent.
>
>Regards,
>Jayshree
>
>
>-----Original Message-----
>From: Yoshiyuki Tsuda [mailto:[email-masked]]
>Sent: Friday, December 20, 2002 4:46 AM
>To: Bharatia, Jayshree [RICH1:2H13:EXCH]
>Cc: [email-masked]; [email-masked]'
>Subject: Re: [mobile-ip] RFC3012bis-04 Available
>
>
>Hi Jayshree,
>
> Just one question:
> If an AAA find an authentication error in MN-AAA
> authentication extension, what error code will the AAA
> return to an MN ?
>
> I've just found the above error code is missing; a
> guideline to allocate error codes from the AAA seems to
> be missing, I'm afraid.  Or, am I missing any other RFCs ?
>
> Someone suggested me to use 131 (mobile node failed
> authentication).  I think it's a good idea to use it
> instead now...
>
>Thanks in advance.
>-Yoshi
>
>
>at Tue, 17 Dec 2002 13:09:32 -0600, Jayshree Bharatia wrote:
>>Hello all,
>>
>>New version of RFC3012bis (version 04) is now available at
>>http://www.ietf.org/internet-drafts/draft-ietf-mobileip-rfc3012bis-04.txt.
>>
>>Thanks,
>>Jayshree

---

From: Yoshiyuki Tsuda <[email-masked]>
Date: Sat, 21 Dec 2002 19:10:23 +0900

Hi Jayshree,

 Thank you for your pointer.  I've found it in Appendix B.
 OK, AAA is expected to set BAD_AUTHENTICATION(67).  Then,
 there is a small issue; if an MN receives the error code
 of BAD_AUTHENTICATION(67), and if there are Mobile-Foreign
 authentication extension and MN-AAA authentication
 extension in a registration request or a registration reply,
 the MN cannot distinguish which extension has the error...

 Also, in case of a co-located Mobile Node, which error code
 does the MN expect to receive, 67 or 131 ?

 Although the above issues might be so small, it would have
 be much clearer to assign a new error code to the verification
 error of MN-AAA authentication extension, I'd like to think.
 Have great holidays!

Thanks.
-Yoshi