Subject: [mobile-ip] Destination Option and Routing Header type 2

From: "zhang haofeng" <[email-masked]>
Date: Sun, 1 Dec 2002 17:25:15 +0800

Hi, all:	
	I have two questions about draft 19:
	1. We use destination option to carry the home address for packets from MN to CN while using Routing Header type 2 to carry the home address for packets from CN to MN. Then why don't we use the same way to carry the home address, for example, both use Destination option or both use Routing Header?
	2. Why don't we use IPsec to protect the Update message to MN to CN but use RR procedure? I notice that We do use IPsec to protect the Update message to MN to HA!
	Are they both silly questions? :-)
	Regards
			    	zhang haofeng
					Beijing University of Post and Telecommunications
					[email-masked]
					2002-12-01

---

From: Jari Arkko <[email-masked]>
Date: Mon, 02 Dec 2002 18:33:01 +0200

> 	1. We use destination option to carry the home address for packets from MN to CN while using Routing Header type 2 to carry the home address for packets from CN to MN. Then why don't we use the sa…

This is just the way that it was done... you could say also that the
routing header already existed so its use for this purpose was easy,
while nothing existed for carrying the home address. Note that type 2 RH
is a subset of the general RH, mainly just to make sure that it is not
vulnerable to the same sort of problems general RH is.

> 	2. Why don't we use IPsec to protect the Update message to MN to CN but use RR procedure? I notice that We do use IPsec to protect the Update message to MN to HA!

This was in fact the earlier approach, but there are two problems with it:
- The fact that you can authenticate a random peer doesn't mean that
  you know what address he is supposed to "own"
- You can't authenticate random peers on any large scale, given the
  current state of the art. Lack of global PKI etc.

Jari