Subject: [mobile-ip] Re: Sorting DHAAD replies with same preference values

From: Krishna Kumar <[email-masked]>
Date: Tue, 10 Dec 2002 16:19:37 -0800

I am not very familiar with anycast myself. But from what I know of it, I
believe IP does cache the anycast result for some time which could lead to
one HA getting all DHAAD requests for the cached period of time. In which
case, my earlier suggestion wouldn't work.

thanks,

- KK

                      Jari Arkko                                                                                                          
                      <jari.arkko@kolum        To:       Krishna Kumar/Beaverton/IBM@IBMUS                                                
                      bus.fi>                  cc:       [email-masked]                                                    
                                               Subject:  Re: Sorting DHAAD replies with same preference values                            
                      12/10/2002 02:53                                                                                                    
                      PM                                                                                                                  

Krishna Kumar wrote:
>
> To support load balancing, isn't use of anycast enough ? The node with
the
> fastest response (and *theoretically* the lowest load) will process the
> DHAAD request. If every home agent has the same preference, the MN would
> use the replying HA as it's HA. So different MN's could get different HA,
> which is about the same randomness that one would get with the algo below
?
>
> I guess it is not a big issue, except that I was wondering if anyone
> supports the part where all HA's have equal preference. In Linux we
support
> ordering based on preference, but don't support random order for multiple
> HA's having the same preference.

Hmm... you may be right, but I know too little of anycast to say whether
practical implementations produce the above effect. Is there any danger
that
the IP layer 'favors' one HA in a non-random manner?

Jari

---

From: Vladislav Yasevich <[email-masked]>
Date: Wed, 11 Dec 2002 09:37:43 -0500

Krishna

Here is what I found out by implementing anycast.

Assuming that the routes for the anycast address get aggregated
(it is very likely since the prefix is the same), then you MAY
end up in a situation you describe.  The ND entry will be cached
for whichever HA responds first, and that will be used in
the future without trying a different HA.

However this really depends on the number of paths to a given
address.  If each HA is on separate path, then you may be able
to load ballance between them.

-vlad

-- 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Vladislav Yasevich		Tru64 UNIX - IPv6 Project Lead
Hewlett Packard 		Tel: (603) 884-1079
Nashua, NH 03062		ZKO3-3/T07