Subject: [mobile-ip] Re: Sorting DHAAD replies with same preference values (WAS: Re: Sorry about the wrong subject, I used an existing mail to reply :-))

From: Krishna Kumar <[email-masked]>
Date: Tue, 10 Dec 2002 13:53:11 -0800

To support load balancing, isn't use of anycast enough ? The node with the
fastest response (and *theoretically* the lowest load) will process the
DHAAD request. If every home agent has the same preference, the MN would
use the replying HA as it's HA. So different MN's could get different HA,
which is about the same randomness that one would get with the algo below ?

I guess it is not a big issue, except that I was wondering if anyone
supports the part where all HA's have equal preference. In Linux we support
ordering based on preference, but don't support random order for multiple
HA's having the same preference.

Thanks,

- KK

                      Jari Arkko                                                                                                          
                      <jari.arkko@kolum        To:       Krishna Kumar/Beaverton/IBM@IBMUS                                                
                      bus.fi>                  cc:       [email-masked]                                                    
                                               Subject:  Re: Sorry about the wrong subject, I used an existing mail to reply :-)          
                      12/10/2002 01:33                                                                                                    
                      PM                                                                                                                  

> I was wondering about the usefulness vs the complexity of implementing
the
> following ordering in DHAAD reply in section 10.5.1 :
>
> "Among home agents with equal preference, their IP addresses in the Home
> Agent Addresses field SHOULD be listed in an order randomized with
respect
> to other home agents with equal preference, each time a Home Agent
Address
> Discovery Reply message is returned by this home agent."
>
> Is there any implementations today that do this. If this were an issue,
it
> could be handled at the sysadm level by providing Home Agent Information
in
> the router advertisement rather than making the implementations more
> complex.

I think the idea is to provide load balancing by giving different
answers every time. I'm not sure there is any other way of doing
this, though it is of course debatable whether the HA or the MN
should do it.

Jari

---

From: Jari Arkko <[email-masked]>
Date: Wed, 11 Dec 2002 00:53:16 +0200

> HA's having the same preference.

Hmm... you may be right, but I know too little of anycast to say whether
practical implementations produce the above effect. Is there any danger that
the IP layer 'favors' one HA in a non-random manner?

Jari

---

From: Thomas Narten <[email-masked]>
Date: Tue, 17 Dec 2002 12:22:35 -0500

> which is about the same randomness that one would get with the algo below ?

I don't think anycast will achieve load balancing. The semantics of
anycast are that *only* one server using the anycast will
respond. I.e, if there are N HAs on the same link, the router's ND
cache will point to one of them, and all packets sent to the anycast
address will get routed to the same HA.

Thomas