Subject: RE: [mobile-ip] Issues with the S bit.

From: "Greg O'Shea" <[email-masked]>
Date: Wed, 4 Dec 2002 18:10:46 -0000

I agree. I do not think the IPv6 world should design to be constrained
to a single [provider|interface|(Home)address|HomeAgent].

I think multi-home agent is entirely legit per the existing draft, but
clearly an informational draft would be a good idea at this time. At the
moment the only obvious glitch I've noticed is the S-bit. Do you know of
any more?

Greg
>-----Original Message-----
>From: KASSI-LAHLOU Mohammed FTRD/DMI/CAE 
>[mailto:[email-masked]] 
>Sent: 04 December 2002 09:32
>To: Vijay Devarapalli; Greg O'Shea
>Cc: Mobile IPv6 mailling list
>Subject: RE: [mobile-ip] Issues with the S bit.
>
>
>Hi folks,
>
>A mobile node can have several providers and thus it can have 
>several Home Agents, one per provider. So the mobile node has 
>several home networks. In this case, when the mobile node is 
>in one of its home networks it is considered in its home 
>network for this network and in a visited network for the 
>other home networks. It must use its home address in this 
>network as a care-of address when it sends BU to its Home 
>Agents on the other home networks. We will propose a draft to 
>specify this case of use
>
>Kassi
>
>-----Message d'origine-----
>De : Vijay Devarapalli [mailto:[email-masked]]
>Envoye : mardi 3 decembre 2002 21:24
>A : Greg O'Shea
>Cc : Mobile IPv6 mailling list
>Objet : Re: [mobile-ip] Issues with the S bit.
>
>
>hi Greg,
>
>> Greg O'Shea wrote:
>> 
>> I have some questions concerning the S bit in Binding Updates of 
>> Section 6.1.7 and 10.3.1. I have no real experience of using this 
>> feature, which appeared sometime post draft 13,
>
>it was called the prefix length field before. it used to be a 
>fixed 8 bit length field in the BU. if the prefix length field 
>is non-zero 
>it is the same as setting the 'S' bit to 0. instead of using 8 bits, 
>it was replaced by the 'S' bit.
>
>> 1.  A mobile node has potentially several Home Agents each 
>potentially 
>> offering several routing prefixes for home agent service. We cannot 
>> assume that these sets of routing prefixes are distinct, or if they 
>> are, that they won't change such that they suddenly 
>intersect. Assume 
>> that the MN is using the same IFId for all its Home Agents. 
>Now, when 
>> the MN moves it sends BU+S+D to several HA
>
>??? several HAs? why is the MN using more than one HA at a 
>time?" maybe I am ignorant, but I cant figure out why the MN 
>would use multiple home agents. anyway, in the implementations 
>I have seen so far, the MN at any time uses only one home agent.
>
>Vijay
>

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 04 Dec 2002 10:16:10 -0800

> to a single [provider|interface|(Home)address|HomeAgent].

and I dont think MIPv6 places this restriction.

> moment the only obvious glitch I've noticed is the S-bit. Do you know of

no Greg, the glitch is not there. section 11.4.1 says the MN sticks
to one home agent.

Vijay

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 04 Dec 2002 13:36:14 -0600

I agree with Vijay. I do not understand Kassi's mail, see below.

>>Agents on the other home networks. We will propose a draft to 
It is not clear what what you mean by HAs? There is supposed to be a 
single HA.
There could be HAs, but one in each visited network, that is called MAP, 
see HMIPv6 draft.

-- 
Behcet