Subject: [mobile-ip] draft-moore-optimistic-dad-03.txt

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Mon, 8 Sep 2003 15:32:25 +1000

G'day all,

	well, I've finally gotten around to updating the
Optimistic DAD draft to -03.  It's really just a few tweaks to
the rules, but I've also added a mini problem statement just
to clarify what I think the problems of standard DAD are.

	It should, nits willing, appear on the archives soon,
but in the meantime you can grab it fresh from: 
<http://bluesky.zoic.org/sharkey/draft-moore-ipv6-optimistic-dad-03.txt>

	Let me know what you think -- it's only 13 honest pages,
so it shouldn't take too long!  I'd really like to get
an informed discussion going about this at IETF 58.

-----Nick

---

From: Soohong Daniel Park <[email-masked]>
Date: Mon, 08 Sep 2003 16:56:30 +0900

Hi Nick

oDAD-03 looks good and I have a question as follows.

>An optimized DAD method needs to:

   * remove the RETRANS_TIMER delay during address configuration.

In my opinion, above mention is not optimized DAD but omited DAD and
I don't make sense what optimized DAD means in this draft without
definitions. Also this work is not compatible with the concept of oDAD.

Could you let me know your view on this ?

Daniel 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> Nick 'Sharkey' Moore
> Sent: Monday, September 08, 2003 2:32 PM
> To: [email-masked]; [email-masked]
> Subject: [DNA-BOF] draft-moore-optimistic-dad-03.txt
> 
> 
> G'day all,
> 
> Optimistic DAD draft to -03.  It's really just a few tweaks 
> to the rules, but I've also added a mini problem statement 
> just to clarify what I think the problems of standard DAD are.
> 

-----Nick

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Mon, 8 Sep 2003 18:23:23 +1000

On 2003-09-08, Soohong Daniel Park wrote:
> [draft-moore-ipv6-optimistic-dad-03.txt]

What I mean by that is that the delay in address configuration 
caused by RETRANS_TIMER must be removed. 

Optimistically configured addresses still stay Tentative for at 
least RETRANS_TIMER, but their use is not _delayed_ by this.
They can be used while still Tentative.

I hope that clarifies things!

cheers,
-----Nick