Subject: Re: [Mobopts] New Draft on Proxy SEND

From: gabriel montenegro <[email-masked]>
Date: Wed, 25 May 2005 11:22:27 -0700 (PDT)

Yes, inefficiency over the air (implying fragmentation) is an issue.
Also, how does performance of signing and verification operations compare
with, say, vanilla RSA?

-gabriel

--- James Kempf <[email-masked]> wrote:
> Hi Brett,
> 
> > I have one question about the backward compatibility section (3.5).
> > If a multi-CGA capable node needs to be able to issue ND messages
> > with standard SEND RSA signatures, what procedure is used to decide
> > when to do this?  Does the node try a Ring Signature Option, and if
> > it gets no response, try again with a standard SEND signature?  If
> > so, would it keep an notation in its neighbour cache of the Ring
> > Signature capability of each node, for future reference?
> >
> 
> It could to that, or the other possibility is it could include both standard
> SEND and multi-key SEND signatures in the packet, at a considerable expense
> in terms of packet size. A multi-key node will ignore the standard signatue
> while a regular SEND node will ignore the ring signature.
> 
> At this point, I haven't completely thought through the backward
> compatibility issues, but they will need to be thought through clearly if
> this work ever goes to IETF.
> 
>             jak
> 
> 
> 
> _______________________________________________
> Mobopts mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mobopts
> 

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: "James Kempf" <[email-masked]>
Date: Wed, 25 May 2005 11:53:36 -0700

> Also, how does performance of signing and verification operations compare

I'm working on getting it implemented, so I can measure it.

BTW, there are a couple other ring signature algorithms, including one based
on pairings, but some of those are covered by patents. The
Rivest-Shamir-Tauman algorithm is public domain, so far as I can tell.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Fri, 27 May 2005 08:54:33 -0700

We did some work on generating standard single key CGAs and the amount of
time required to validate a signature compared to standard ND w.o SEND. It
was presented at the SF IETF (I think), in the SEND WG. I'll see if I can
dig it up.

            jak

----- Original Message ----- 
>From: "Jean-Michel COMBES" <[email-masked]>
To: "'James Kempf'" <[email-masked]>;
<[email-masked]>; "'Brett Pentland'"
<[email-masked]>
Cc: <[email-masked]>
Sent: Friday, May 27, 2005 5:30 AM
Subject: RE : [Mobopts] New Draft on Proxy SEND

> Hi,
>
> At first, sorry if my question is a little out of scope of the subject.
>
> Does someone has some figures regarding the time to generate CGA addresses
> and linked security material on devices (eg. on PDA, laptops, ...)? Or a
> link to a paper on this subject?
>
> BTW, I will be interested by your results James :)
>
> Best regards.
>
> JMC.
>
> France Telecom - R&D Division - MAPS/NSS
> Jean-Michel COMBES, Internet/Intranet Security
> E-Mail: [email-masked]
> Phone: +33 (0)1 45 29 45 94
> Fax: +33 (0)1 45 29 65 19
> Mobile: +33 (0)6 07 29 30 16
>
>
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]] On Behalf Of James Kempf
> > Sent: Wednesday, May 25, 2005 8:54 PM
> > To: [email-masked]; Brett Pentland
> > Cc: [email-masked]
> > Subject: Re: [Mobopts] New Draft on Proxy SEND
> >
> >

---

From: "Jean-Michel COMBES" <[email-masked]>
Date: Fri, 27 May 2005 14:30:21 +0200

Hi,

Best regards.

JMC.