Subject: [Mobopts] Compact Neighbor Discovery

From: Pars Mutaf <[email-masked]>
Date: Tue, 17 May 2005 10:37:44 +0200

Hello,

This is FYI. We have a paper  on
"Compact Neighbor Discovery" (appeared in Infocom'05).

This is a "stateless" bandwidth optimization for reducing
more than 40 times the bandwidth consumed by ND-DoS in IPv6
subnets with wireless access points.

If you are interested, the paper is available online:

http://www.inrialpes.fr/planete/people/mutaf/infocom05.pdf

BTW, I'm looking for a simpler hash function. MD5 was
probably an overkill.

Regards,
pars

James Kempf wrote:

>I've just posted a new draft on how to do secure address proxying. Until the
>draft appears in the Interent Drafts directory, you can find the draft here:
>
>http://www.geocities.com/kempf42/draft-kempf-mobopts-ringsig-ndproxy-00.txt
>
>The draft defines how to use Rivest-Shamir-Tauman ring signatures (Asiacrypt
>2001) and CGAs generated with multiple keys to allow a router, such as a
>Mobile IPv6 home agent, to securely proxy a CGA. Multi-key CGAs allow secure
>proxying without revealing from the cryptographic material whether the
>mobile node is on or off the link, unlike other secure proxying techniques.
>
>Note that DoCoMo has filed for IPR on this draft, we're working on the
>release currently. DoCoMo's policy is to release IPR royality-free if the
>draft is approved as an Internet Standard if the IPR involves
>interoperability, and I'm recommending that for this case.
>
>                jak
>
>
>
>_______________________________________________
>Mobopts mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/mobopts
>
>  
>

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: "James Kempf" <[email-masked]>
Date: Mon, 16 May 2005 10:48:36 -0700

jak

---

From: Brett Pentland <[email-masked]>
Date: Wed, 25 May 2005 17:32:58 +1000

Hi Jim,

I don't think I understand the signature stuff well enough for
much meaningful commentary, but the general concept sounds good.

I have one question about the backward compatibility section (3.5).
If a multi-CGA capable node needs to be able to issue ND messages
with standard SEND RSA signatures, what procedure is used to decide
when to do this?  Does the node try a Ring Signature Option, and if
it gets no response, try again with a standard SEND signature?  If
so, would it keep an notation in its neighbour cache of the Ring
Signature capability of each node, for future reference?

Cheers,
Brett.

---

From: "James Kempf" <[email-masked]>
Date: Wed, 25 May 2005 09:18:13 -0700

Hi Brett,

> Signature capability of each node, for future reference?

It could to that, or the other possibility is it could include both standard
SEND and multi-key SEND signatures in the packet, at a considerable expense
in terms of packet size. A multi-key node will ignore the standard signatue
while a regular SEND node will ignore the ring signature.

At this point, I haven't completely thought through the backward
compatibility issues, but they will need to be thought through clearly if
this work ever goes to IETF.

            jak