Subject: [Mobopts] Mobility related API

From: "Tschofenig, Hannes" <[email-masked]>
Date: Mon, 14 Nov 2005 04:08:38 +0100

hi all, 

problems with my laptop prevented me from showing the slides. 
please find them at: 

http://www.tschofenig.com/mobopts/IETF64/Mobility-related-API.ppt

please take a look at the slides (and at the draft). drop me/us a note
if you think that this is useful stuff. 

ciao
hannes

ps: the draft can be found at: 
http://www.ietf.org/internet-drafts/draft-schilcher-mobike-trigger-api-0
2.txt 

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: Greg Daley <[email-masked]>
Date: Tue, 15 Nov 2005 06:18:38 +1100

Hi Hannes,

Sorry I couldn't make it to the session.

I've had some chats with people recently, and it may
be good to look at the common elements required by
upper-layer services (like mobike/mobileip) caused
by address and routing changes (or expected changes).

Some of these events may be due to underlying changes
in wireless connectivity.

As you mentioned in the slides, this may be related to
802.21-like events.  I'd like to focus on Network-layer
visible events though (as opposed to even media independent
link-layer events).

I think that some of these could be provided by DNA,
or actively managed events from layer 2, which have
upper-layer relevance (for example, something useful for
FMIPv6).

Identifying which classes of events are required in
Mobike etc, may help clarify the overall architecture
(though it may be the reverse of how to design things
for IETF document development).

Do you think we could discuss this on the mobopts list to
see if there's interest and common ground?

If there is, it would be interesting to see if we could
do that without concentrating on a particular API,
but the types of communications and parameters required.

I guess the output could be something analogous to
draft-ietf-dna-link-information-03.txt

Comments and suggestions are welcome.

Greg

---

From: Nicolas Montavont <[email-masked]>
Date: Tue, 15 Nov 2005 03:02:22 +0100

Hi,

> for IETF document development).

I think this is a good idea, especially to identify which parameter/ 
event will be produced and which entity will use them. We should  
somehow avoid duplicate use of events. Defining an overall  
architecture would definitely help in understanding the relevance of  
parameter/events exchange.

> draft-ietf-dna-link-information-03.txt

I would support such a document.

Nicolas

>> hi all, problems with my laptop prevented me from showing the  
>> slides. please find them at: http://www.tschofenig.com/mobopts/ 
>> IETF64/Mobility-related-API.ppt
>> if you think that this is useful stuff. ciao
>> hannes
>> ps: the draft can be found at: http://www.ietf.org/internet-drafts/ 
>> draft-schilcher-mobike-trigger-api-0
>> 2.txt _______________________________________________
>> Mobopts mailing list
>> [email-masked]