Subject: [Mobopts] Re: L2 abstractions draft

From: "Soohong Daniel Park" <[email-masked]>
Date: Tue, 26 Sep 2006 20:45:47 +0900

Rajeev,

After glancing at this draft, I am not sure whether authors are
referring what's going on in IEEE 802.21 working group. 802.21 begun
their efforts on the L2 facility to support IP mobility from 2004 (in
face study group is more early than 2004). There are already lot of L2
primitives which are well defined and categorized in there. To me,
this draft seems really duplicated with 21 spec. Why we need several
documents for the same way ? I am willing to be a review on this
document in conjunction with IEEE 802.21 folks. But, before that, we
should clarify the relationship between this draft and IEEE 802.21
spec.

Am I missing anything ? if yes, please let me know...

-- 

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Tue, 26 Sep 2006 14:48:57 +0200

Hi Daniel, 

some time back I wrote a draft that uses the PF_KEY/PF_ROUTE socket interface as an instantiation for the IEEE 802.21 API. 

I proposed it for usage in MOBIKE but it obviously has broader applicability. 

Unfortunately, I wasn't able to find enough people to work on it. 

Is someone interested? 
 
Ciao
Hannes
 
> -----Ursprüngliche Nachricht-----
> Von: Soohong Daniel Park [mailto:[email-masked]] 
> Gesendet: Dienstag, 26. September 2006 13:46
> An: [email-masked]
> Betreff: [Mobopts] Re: L2 abstractions draft
> 
> Rajeev,
>

---

From: Koshiro MITSUYA <[email-masked]>
Date: Wed, 27 Sep 2006 13:40:01 +0900

Hello Daniel,

I am one of the authors.  Please let me explain.

Some histories:
We started this works since 2002.   The first version of the draft
  (draft-koki-mobopts-l2-abstractions) was submitted July 2004.
We had presentations several times in the Mobopts meetings.
We also had a presentation the IEEE 802.21 meeting March 2005.

I do not know the actual status of IEEE 802.21, but we developed
the implementation and confirmed our L2 primitives works fine.
We presented the demonstration in the Mobopts meetings.
 From this point, I believe our draft is stable as the L2 primitives  
spec.
So, it is worth to be publish as an "informational" draft.

To be honestly, one of the purpose is to get attentions from people
working on IEEE 802.21.  I am very glad to have your question like
this way :)

regards,
Koshiro

---

From: Soohong Daniel Park <[email-masked]>
Date: Wed, 27 Sep 2006 13:45:44 +0900

Hannes,

At the last 802.21 meeting, we had a similar discussion
in terms of socket API for the 802.21 called NET_SAP
(Network Service Access Point). Anyhow, I am interested
in this work definitely.

----- Original Message ----- 
From: "Tschofenig, Hannes" <[email-masked]>
To: "Soohong Daniel Park" <[email-masked]>; <[email-masked]>
Sent: Tuesday, September 26, 2006 9:48 PM
Subject: AW: [Mobopts] Re: L2 abstractions draft

Hi Daniel, 

Is someone interested? 
 
Ciao
Hannes

---

From: Soohong Daniel Park <[email-masked]>
Date: Wed, 27 Sep 2006 14:30:44 +0900

Koshiro, 

My comments are inline.

> We also had a presentation the IEEE 802.21 meeting March 2005.

I do not blame this work. Sure, this work is really helpful from
the higher layer mobility management. Good job.
 
> So, it is worth to be publish as an "informational" draft.

Even it is targeting for an Informational RFC, it can cause several
troubles to implement Link primitives aside from 802.21 draft.

802.21 defined Link Layer primitive and it's above twenty. So, 
I encourage you to harmonize your primitives with 802.21. Or
at least mentioning gab between them in this draft.

> working on IEEE 802.21.  I am very glad to have your question like

802.21 will have an adhoc meeting on October. If allowed, I
will raise the interest of this work in there. Obviously, we will
be able to expect further details and useful comments from there.

Hope this helps...

---

From: Koshiro MITSUYA <[email-masked]>
Date: Wed, 27 Sep 2006 22:37:00 +0900

Hi Daniel,

Please find my comments inline.

[snip]
> the higher layer mobility management. Good job.

Thanks!

[snip]
> at least mentioning gab between them in this draft.

I see.   I will work on the gab analysis first.

[snip]
> be able to expect further details and useful comments from there.

OK,  that is very good.

regards,
Koshiro

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 27 Sep 2006 03:45:01 -0700

Hi Daniel,

Good to see your input.

Koshiro has already provided the background and context for this work.

The purpose here is not to compete with 802.21 primitives work. I believe
this is in one of the early works on L2 primitives and their usage in L3
handovers which has been _demonstrated_ in a testbed. As Koshiro mentioned,
this work was also presented at 802.21 meeting very early on.

The purpose here is to bring out how one could use L2 primitives in L3
handovers as evident from an experimental testbed. I think it is very useful
for the RG community and for 802.21 community as well.

As you point out, perhaps the draft can mention that the L2 primitives
defined here are not exactly the same as what 802.21 has defined. Someone
else may consider harmonizing this with 802.21 if they are interested.
Nevertheless, the experiences here are useful enough for us to publish.

Regards,

-Rajeev

---

From: "Soohong Daniel Park" <[email-masked]>
Date: Thu, 28 Sep 2006 09:00:58 +0900

Rajeev,

> for the RG community and for 802.21 community as well.

Sure, in principle, I agreed.

> Nevertheless, the experiences here are useful enough for us to publish.

As I pointed out, addressing at least what difference from 802.21 L2
primitives would be included into this draft. If allowed, I can help
with this work.

--