Subject: [Mobopts] Re: mmcastv6-ps Draft

From: Thomas C Schmidt <[email-masked]>
Date: Mon, 17 Sep 2007 13:04:22 +0200

Hi Stig,

thanks - and sorry for answering late ...

Stig Venaas wrote:
> I've had a quick read through the document now, and it looks quite
> good. I can't really think of anything to add or change. But I have
> one comment below.
> 
[...]
> Worth mentioning scoped multicast? Using tunnel from HA you can when
> leaving your site continue receiving multicast from your site of
> site-local scope. If you join natively you will instead receive
> whatever that multicast group might be used for in the other site...

Yes, but there are issues to that: People tend to consider this a 
security fraud, if you participate in link-local group while being away 
(3775 says "should not be tunneled").

> Also, it might be important for a source sending scoped multicast to
> detect that it is no longer in the same scope zone. These are hard
> problems, and maybe not worth addressing...
> 
We can mentioned this - even though I don't know any elegant solution to 
it. Regional scoping requires non-local knowledge, which usually is not 
available at the mobile source, I suppose.

> After writing the above I saw that you did briefly mention scoping as
> well. Your current text might be sufficient.
> 
> The L2 discussion is quite useful. It could possibly have been a
> separate document, but I think it's fine here as well.
> 
Many thanks :-)

Hope everything is fine at yours!

Best wishes,

thomas
-- 

° Prof. Dr. Thomas C. Schmidt
° HAW Hamburg, Dept. Informatik
° University of Applied Sciences
° Berliner Tor 7, D 20099 Hamburg
° Germany, Fon: +49-40-42875-8157
° http://www.informatik.haw-hamburg.de/~schmidt

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: Thomas C Schmidt <[email-masked]>
Date: Mon, 17 Sep 2007 14:25:17 +0200

Stig Venaas wrote:
> Thomas C Schmidt wrote:

> Right, but how about site-local. Are you part of the site? I think in
> general when people today use VPNs from laptops to access things at
> home, they consider the laptop a part of the site. I would assume there
> would be some administrative setting whether the HA should tunnel site-
> scoped multicast.

Sorry, my mistake: The quote "should not ..." was about site-local mcast 
- for the link-local case RFC 3775 says "Multicast packets addressed to 
a multicast address with link-local scope [3], to which the mobile node 
is subscribed, MUST NOT be tunneled to the mobile node."

The picture of a VPN-scenario you are drawing appears natural to me, 
too. The difference of course is that today's VPN-configs express the 
explicit will of domain administrators, while 3775 describes a general 
mobility standard.

I guess it's reasonable to suggest that site-local mcast forwarding 
should be configurable at the HA. We can add that.

Best,

thomas
--