Subject: [Model-t] Small sub-team for drafting - volunteers?

From: <[email-masked]>
Date: Fri, 25 Sep 2020 08:54:21 -0500

All:

Back on August 20th Model-T had its last call. During that call we came to
some consensus that a small subteam should be convened to make progress on a
single, focused draft. I haven't seen anything on the mailing list but I
gather that people have been tightly and rightly focused on holidays and
sheltering in place.

I'd like to convene that small subteam so that some productive work gets
done before the next IETF interim. We talked about a handful of volunteers
getting together and I'd be happy to arrange a first, virtual call.

Assuming that we still find the consensus from the last call acceptable, are
there volunteers that would like to join a drafting team?

Thanks!

Mark

Mark McFadden
internet policy advisors ltd uk

---

From: Dominique Lazanski <[email-masked]>
Date: Mon, 28 Sep 2020 12:47:29 +0100

Hi Mark,

> On 25 Sep 2020, at 14:54, [email-masked] wrote:
> 
> All:
> 

I am in !

Dominique 

> -- 
> Model-t mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/model-t

---

From: Jari Arkko <[email-masked]>
Date: Tue, 29 Sep 2020 19:24:05 +0300

I am interested. 

Jari

> On 25 Sep 2020, at 16.54, [email-masked] wrote:
> 
> All:
>

---

From: Russ Housley <[email-masked]>
Date: Tue, 29 Sep 2020 12:26:30 -0400

I do not have a huge amount of time for this effort, but I am interested. Hopefully, there is a chunk of the work that fits my time availability.

Russ

---

From: Raymond Mamattah <[email-masked]>
Date: Tue, 29 Sep 2020 17:28:51 +0100

Hi all, I am new here, so if permitted, I would like to be an observer in
the WG to learn something new.

Regards,

Raymond Mamattah
<https://www.linkedin.com/in/raymond-selorm-mamattah-02637610> [image:
facebook] <https://www.facebook.com/selorm.mamattah> 
<https://join.skype.com/invite/bWJCTPbNPkIF> 
<https://twitter.com/RMamattah>
Accra, Ghana

On Tue, Sep 29, 2020 at 5:26 PM Russ Housley <[email-masked]> wrote:

> I do not have a huge amount of time for this effort, but I am interested.
> Hopefully, there is a chunk of the work that fits my time availability.
>
> Russ
>

---

From: Jari Arkko <[email-masked]>
Date: Wed, 30 Sep 2020 00:27:06 +0300

I’m sitting here and scratching my head about possible ways to go about this effort. Let me propose a straw man and see if people agree.

First, off, re-stating goal of the exercise: work through example(s) to show a chain from (1) specific security threats to (2) general guidance that can be derived from them to (3) how such guidance would potentially be useful for protocol designs. In a way that they could take it into account and design something better. Non goals include going through more than a single or a couple examples, or attempting to boil the entire space. Just an example so that we can show some of the work  can be useful.

Everyone with me so far? If not, I should say that it is late here and that you should let me know what  the exercise was :-)

(A quick observation before we go further about the “could take it into account and design something better” part. People may have different ambition levels. Someone might be expecting ground breaking revelations, but I personally think this is perhaps more in line what the IETF has in the past said in writing about various topics. Long before we wrote things into RFCs, we “knew” that weak crypto was bad, that end-to-end strong encryption was necessary as an at least partial defence against pervasive surveillance, that automatic key management is a good idea, etc. I think we are looking for something similar — something that may remind us about the importance of a thing, and give some backing for those of us who want to ensure that good design comes out in our protocol work. We might also be able to identify areas where we don’t necessarily know direct solutions, but know that an area is problematic, and deserves research and/or care if applied.)

But going on to examples. One might think for instance that you could derive example fairly simple examples of the chain. E.g.
- specific threat: messaging systems where the system sees private messaging between people, which may lead to e.g., a government attempts to get them to hand over the messaging, commercial surveillance, or accidental leaks
- general guidance: apply end-to-end security, avoid involving third parties except for their specific role (e.g., message forwarding)
- specific technologies that can be designed to improve past designs: MLS

Or:
- specific threat: mobile authentication systems being vulnerable to attacks against SIM card manufacturers or the transfer of SIM card keys to operators
- general guidance: limit the scope of compromise, and assume compromise may happen anywhere. See draft-arkko-farrell-model-t-3552-additions Section 5.1 (by Ekr and Chris). Or forcing active attack (S5.2)
- specific technologies: apply perfect forward secrecy in relevant protocols.

Or:
- specific threat: tracking of users in web browsing, for various purposes including advertising, and using various methods
- general guidance: <various>
- specific technologies: <various>

And so on.

Are these the kinds of things that people had in mind? Or something else?

Jari

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 30 Sep 2020 11:37:41 +0200

Hi Mark, hi all,

in general: most certainly! While I have been mostly lurking, I am very 
committed to the topic. The biggest issue I face, though, is available 
meeting time (CEST here). The last call I missed due to 23pm-1am.

Viele Grüße,

Henk