Subject: Re: [Modern] draft charter

From: Richard Shockey <[email-masked]>
Date: Wed, 11 Feb 2015 13:03:10 -0500

+1  its time.

In addition its time to take a look at the CNAM CNIT proposition as well.
My reluctance to draft a charter has been due to understanding what, if
anything 3GPP, is doing in this space.

Comments in line.

‹ 
Richard Shockey
Shockey Consulting LLC
Chairman of the Board SIP Forum
www.shockey.us
www.sipforum.org
richard<at>shockey.us
Skype-Linkedin-Facebook rshockey101
PSTN +1 703-593-2683

From:  "Peterson, Jon" <[email-masked]>
Date:  Wednesday, February 11, 2015 at 12:18 PM
To:  "[email-masked]" <[email-masked]>
Subject:  [Modern] draft charter

At the Dallas IETF meeting in March, we'd like to get together and talk
about what a working group for MODERN might look like. As an initial input
to the discussion, a few of us have put together a proposed charter. While
the TeRQ work was positively evaluated in the DISPATCH process, we feel this
is broader enough in scope to warrant its own BoF.

Comments are welcome, this is just a starting point.

------

Modern charter text:
 
The MODERN working group will define a set of Internet-based mechanisms for
the purposes of managing and resolving telephone numbers (TNs) in an IP
environment.  Existing mechanisms for these purposes face obsolescence as
the voice [specific] communications infrastructure evolves to IP technology
and new applications for TNs become possible.  [The limitations of the
existing ENUM RFC 6116 mechanisms are well understood]   The traditional
model of a TN having an association to a single service provider and a
single application is breaking down.  Its use as a network locator is going
away, but its use as an identifier for an individual or an organization will
remain for some time [probably after we are all dead] . Devices,
applications, and network tools increasingly need to manage TNs, including
requesting and acquiring TN delegations from authorities.
 
The working group will define a framework for the roles and functions
involved in managing and resolving TNs in an IP environment. This includes a
protocol mechanism for acquiring TNs, which will provide an enrollment
process for the individuals and entities that use and manage TNs. TNs may
either be managed in a hierarchical tree, or in a distributed peer-to-peer
architecture.  Privacy of the enrollment data and security of the resource
will be primary considerations.
 
Additionally, the working group will deliver a protocol mechanism for
resolving TNs which will allow entities such as service providers, devices,
and applications to access data related to TNs, possibly including caller
name data (CNAM).  Maintaining reliability, real time application
performance, security and privacy are primary considerations.  The working
group will take into consideration existing IETF work including ENUM,
SPEERMINT, STIR, and DRINKS.

The work of this group is limited to specifying a solution for TNs and
covers any service that can be addressed using a TN.  Expanding the work to
other identifiers is out of scope.

[what about the STIR certs?]

 Solutions and mechanisms created by the working group will be flexible
enough to accommodate different policies, e.g., by different regulatory
agencies. 
 
The work group will deliver the following:
 
-      An architecture overview document that includes high level
requirements and security/privacy considerations

-      A document describing the enrollment processes for existing and new
TNs including any modifications to metadata related to those TNs

-      A document describing protocol mechanisms for accessing contact
information associated with enrollments

-      A document describing mechanisms for resolving information related to
TNs
_______________________________________________ Modern mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/modern

---

From: Brian Rosen <[email-masked]>
Date: Wed, 11 Feb 2015 13:32:28 -0500

I’ll work with you on that if you want.  I am sure we can work through the 3GPP issues.

Brian

> On Feb 11, 2015, at 1:03 PM, Richard Shockey <[email-masked]> wrote:
> 
> 
> +1  its time.
> 
> In addition its time to take a look at the CNAM CNIT proposition as well.  My reluctance to draft a charter has been due to understanding what, if anything 3GPP, is doing in this space.
> 
> Comments in line.
> 
> — 
> Richard Shockey
> Shockey Consulting LLC
> www.shockey.us <http://www.shockey.us/>
> www.sipforum.org <http://www.sipforum.org/>
> richard<at>shockey.us <http://shockey.us/>
> From: "Peterson, Jon" <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> At the Dallas IETF meeting in March, we'd like to get together and talk about what a working group for MODERN might look like. As an initial input to the discussion, a few of us have put together a proposed charter. While the TeRQ work was positively evaluated in the DISPATCH process, we feel this is broader enough in scope to warrant its own BoF.
> 
> The MODERN working group will define a set of Internet-based mechanisms for the purposes of managing and resolving telephone numbers (TNs) in an IP environment.  Existing mechanisms for these purposes face obsolescence as the voice [specific] communications infrastructure evolves to IP technology and new applications for TNs become possible.  [The limitations of the existing ENUM RFC 6116 mechanisms are well understood]   The traditional model of a TN having an association to a single service provider and a single application is breaking down.  Its use as a network locator is going away, but its use as an identifier for an individual or an organization will remain for some time [probably after we are all dead] . Devices, applications, and network tools increasingly need to manage TNs, including requesting and acquiring TN delegations from authorities.
>  
> The working group will define a framework for the roles and functions involved in managing and resolving TNs in an IP environment. This includes a protocol mechanism for acquiring TNs, which will provide an enrollment process for the individuals and entities that use and manage TNs. TNs may either be managed in a hierarchical tree, or in a distributed peer-to-peer architecture.  Privacy of the enrollment data and security of the resource will be primary considerations.
>  
> Additionally, the working group will deliver a protocol mechanism for resolving TNs which will allow entities such as service providers, devices, and applications to access data related to TNs, possibly including caller name data (CNAM).  Maintaining reliability, real time application performance, security and privacy are primary considerations.  The working group will take into consideration existing IETF work including ENUM, SPEERMINT, STIR, and DRINKS.
> 
>  
> The work of this group is limited to specifying a solution for TNs and covers any service that can be addressed using a TN.  Expanding the work to other identifiers is out of scope. 
> 
> Solutions and mechanisms created by the working group will be flexible enough to accommodate different policies, e.g., by different regulatory agencies.
>  
> -       An architecture overview document that includes high level requirements and security/privacy considerations
> -       A document describing the enrollment processes for existing and new TNs including any modifications to metadata related to those TNs
> -       A document describing protocol mechanisms for accessing contact information associated with enrollments
> -       A document describing mechanisms for resolving information related to TNs
> _______________________________________________ Modern mailing list [email-masked] <mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/modern <https://www.ietf.org/mailman/listinfo/modern> _______________________________________________
> Modern mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/modern <https://www.ietf.org/mailman/listinfo/modern>

---

From: Richard Shockey <[email-masked]>
Date: Wed, 11 Feb 2015 13:42:07 -0500

OK

Its my understanding that it was SA-1 that was looking into this but the
document is essentially blank.

http://www.3gpp.org/DynaReport/TSG-WG--s1--wis.htm

‹ 
Richard Shockey
Shockey Consulting LLC

From:  Brian Rosen <[email-masked]>
Date:  Wednesday, February 11, 2015 at 1:32 PM
To:  Richard Shockey <[email-masked]>
Cc:  Jon Peterson <[email-masked]>, "[email-masked]"
<[email-masked]>, dispatch <[email-masked]>
Subject:  Re: [Modern] draft charter

I¹ll work with you on that if you want.  I am sure we can work through the
3GPP issues.

Brian

> In addition its time to take a look at the CNAM CNIT proposition as well.  My
> reluctance to draft a charter has been due to understanding what, if anything
> 3GPP, is doing in this space.
> 
> Comments in line.
> 
> ‹ 
> Richard Shockey
> Shockey Consulting LLC
> At the Dallas IETF meeting in March, we'd like to get together and talk about
> what a working group for MODERN might look like. As an initial input to the
> discussion, a few of us have put together a proposed charter. While the TeRQ
> work was positively evaluated in the DISPATCH process, we feel this is broader
> enough in scope to warrant its own BoF.
> 
> environment.  Existing mechanisms for these purposes face obsolescence as the
> voice [specific] communications infrastructure evolves to IP technology and
> new applications for TNs become possible.  [The limitations of the existing
> ENUM RFC 6116 mechanisms are well understood]   The traditional model of a TN
> having an association to a single service provider and a single application is
> breaking down.  Its use as a network locator is going away, but its use as an
> identifier for an individual or an organization will remain for some time
> [probably after we are all dead] . Devices, applications, and network tools
> increasingly need to manage TNs, including requesting and acquiring TN
> delegations from authorities.
>  
> The working group will define a framework for the roles and functions involved
> in managing and resolving TNs in an IP environment. This includes a protocol
> mechanism for acquiring TNs, which will provide an enrollment process for the
> individuals and entities that use and manage TNs. TNs may either be managed in
> a hierarchical tree, or in a distributed peer-to-peer architecture.  Privacy
> of the enrollment data and security of the resource will be primary
> considerations.
>  
> and applications to access data related to TNs, possibly including caller name
> data (CNAM).  Maintaining reliability, real time application performance,
> security and privacy are primary considerations.  The working group will take
> into consideration existing IETF work including ENUM, SPEERMINT, STIR, and
> DRINKS.
> 
>  
> The work of this group is limited to specifying a solution for TNs and covers
> any service that can be addressed using a TN.  Expanding the work to other
> identifiers is out of scope.
> 
> Solutions and mechanisms created by the working group will be flexible enough
> to accommodate different policies, e.g., by different regulatory agencies.
>  
> [email-masked]
> https://www.ietf.org/mailman/listinfo/modern

---

From: "Gorman, Pierce A [NTK]" <[email-masked]>
Date: Wed, 11 Feb 2015 19:11:56 +0000

I think you're right it is  SA-1 regardless.

Sent on a Sprint Samsung Galaxy S® III

-------- Original message --------
From: Richard Shockey
Date:02/11/2015 1:07 PM (GMT-06:00)
To: Brian Rosen
Cc: dispatch , [email-masked], Jon Peterson
Subject: Re: [Modern] draft charter

OK

Its my understanding that it was SA-1 that was looking into this but the document is essentially blank.

—
Richard Shockey
Shockey Consulting LLC

From: Brian Rosen <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, February 11, 2015 at 1:32 PM
To: Richard Shockey <[email-masked]<mailto:[email-masked]>>
Cc: Jon Peterson <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, dispatch <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Modern] draft charter

Brian

On Feb 11, 2015, at 1:03 PM, Richard Shockey <[email-masked]<mailto:[email-masked]>> wrote:

+1  its time.

Comments in line.

—
Richard Shockey
Shockey Consulting LLC
Chairman of the Board SIP Forum
www.shockey.us<http://www.shockey.us/>
www.sipforum.org<http://www.sipforum.org/>
richard<at>shockey.us<http://shockey.us/>
Skype-Linkedin-Facebook rshockey101
PSTN +1 703-593-2683

From: "Peterson, Jon" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, February 11, 2015 at 12:18 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Modern] draft charter

------

Modern charter text:

-       An architecture overview document that includes high level requirements and security/privacy considerations
-       A document describing the enrollment processes for existing and new TNs including any modifications to metadata related to those TNs
-       A document describing protocol mechanisms for accessing contact information associated with enrollments
-       A document describing mechanisms for resolving information related to TNs
_______________________________________________ Modern mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/modern _______________________________________________
Modern mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/modern

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.