Subject: [Modern] draft charter

From: "Peterson, Jon" <[email-masked]>
Date: Wed, 11 Feb 2015 17:18:37 +0000

At the Dallas IETF meeting in March, we'd like to get together and talk about what a working group for MODERN might look like. As an initial input to the discussion, a few of us have put together a proposed charter. While the TeRQ work was positively evaluated in the DISPATCH process, we feel this is broader enough in scope to warrant its own BoF.

Comments are welcome, this is just a starting point.

------

Modern charter text:

The MODERN working group will define a set of Internet-based mechanisms for the purposes of managing and resolving telephone numbers (TNs) in an IP environment.  Existing mechanisms for these purposes face obsolescence as the voice communications infrastructure evolves to IP technology and new applications for TNs become possible.  The traditional model of a TN having an association to a single service provider and a single application is breaking down.  Its use as a network locator is going away, but its use as an identifier for an individual or an organization will remain for some time. Devices, applications, and network tools increasingly need to manage TNs, including requesting and acquiring TN delegations from authorities.

The working group will define a framework for the roles and functions involved in managing and resolving TNs in an IP environment. This includes a protocol mechanism for acquiring TNs, which will provide an enrollment process for the individuals and entities that use and manage TNs. TNs may either be managed in a hierarchical tree, or in a distributed peer-to-peer architecture.  Privacy of the enrollment data and security of the resource will be primary considerations.

Additionally, the working group will deliver a protocol mechanism for resolving TNs which will allow entities such as service providers, devices, and applications to access data related to TNs, possibly including caller name data (CNAM).  Maintaining reliability, real time application performance, security and privacy are primary considerations.  The working group will take into consideration existing IETF work including ENUM, SPEERMINT, STIR, and DRINKS.

The work of this group is limited to specifying a solution for TNs and covers any service that can be addressed using a TN.  Expanding the work to other identifiers is out of scope.  Solutions and mechanisms created by the working group will be flexible enough to accommodate different policies, e.g., by different regulatory agencies.

The work group will deliver the following:

-       An architecture overview document that includes high level requirements and security/privacy considerations

-       A document describing the enrollment processes for existing and new TNs including any modifications to metadata related to those TNs

-       A document describing protocol mechanisms for accessing contact information associated with enrollments

-       A document describing mechanisms for resolving information related to TNs

---

From: "Holmes, David W [CTO]" <[email-masked]>
Date: Tue, 24 Feb 2015 22:06:01 +0000

Jon,

Thank you for the work in assembling this draft of the charter for MODERN.

We would like to suggest some minor clarifications to the bullets describing the deliverables, to align them with the statement regarding flexibility to support the needs of different regulatory regimes, & thus to ensure that if quoted alone they are not taken out of context; i.e. the group product will be the protocols to support the allocation etc. activities, & it would not attempt to define the allocation processes.  We also would like the charter to note the relevant work that has already been performed by both IETF & the ATIS/SIP Forum JTF, & incorporate that into the output from the MODERN WG as appropriate.  These changes/additions are have been added to your text inline below.

We are hoping that the MODERN session at IETF#92 will have remote access, to allow participation by those of us that cannot attend in person due to other commitments that week.

Regards,

David/Sprint
______________________________________________________________________________

From: Modern [mailto:[email-masked]] On Behalf Of Peterson, Jon
Sent: Wednesday, February 11, 2015 9:19 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Modern] draft charter

------

Modern charter text:

-          An architecture overview document that includes high level requirements and security/privacy considerations built on the work of IETF & the ATIS/SIP Forum JTF, that included:

o   Call routing architecture

o   Inter-carrier NNI

o   Cryptographically-enabled Anti-spoofing (STIR)

o   Enhanced Calling Name (CNIT/CNAM)

-          A document describing the protocols to support enrollment processes for existing and new TNs including any modifications to metadata related to those TNs

-          A document describing protocol mechanisms for resolving information related to TNs

-

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.