Subject: RE: [Monami6] Do we need to update the Monami6 charter ?

From: "BINET David RD-CORE-CAE" <[email-masked]>
Date: Tue, 2 Aug 2005 14:53:34 +0200

Hello, 

Comment inline
> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de marcelo 
> bagnulo braun
> Envoyé : jeudi 28 juillet 2005 21:58
> À : Monami6 BOF proposal
> Objet : Re: [Monami6] Do we need to update the Monami6 charter ?
> 
> 
> El 27/07/2005, a las 23:54, Nicolas Montavont escribió:
> 
> > marcelo bagnulo braun wrote:
> >
> >> As i said in another message, imho the monami work should 
> be aimed to 
> >> solve the mip host multihoming problem, as described in 
> the problem 
> >> statement draft, and should not limit itself to 
> registering multiple 
> >> CoAs
> 
> > This is definitly not what we want to do.
> >
> 
> well, if you read the proposed charter, it states that:
> 
> The expected output of the WG is:
> 
> A document explaining the needs for and the design goals of 
> multihoming [Informational] An analysis document of 
> multihoming under the operation of Mobile IPv6 
> [Informational] A solution to register multiple care-of 
> addresses for a given home address [Standard Track] A 
> solution to exchange policies between the parties involved in 
> the mobility management (presumably the mobile node/mobile 
> router, the home agent and possibly the correspondent nodes 
> in case of Routing
> Optimization) [Standard Track]

Do the policies exchanged between parties concern only Routing Optimization or can we imagine that such policies could be used for other means such as selection of CoA for example. We can imagine that in multihoming situation, it could be convenient to try to set up some means to prioritize use of a specific CoA according to some trafic engineering process or for some quality of service reason. In this case, some exchanges between MR or MN and HA could be useful. 
I am not sure such item has to be addressed by this next working group (I hope it will be !)

David 
> >
> > _______________________________________________
> > Monami6 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/monami6
> >
> 
> 
> _______________________________________________
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6
> 

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: "BINET David RD-CORE-CAE" <[email-masked]>
Date: Tue, 2 Aug 2005 17:53:19 +0200

Hello, 

> De : [email-masked] 
> [mailto:[email-masked]] De la part de Thierry Ernst
> Envoyé : mardi 2 août 2005 17:35
> À : Monami6 BOF proposal
> > > In order to clarify, shall we rephrase the text to:
> > >
> > >  "A solution to exchange policies influencing the choice of the 
> > > interface
> > 
> > I am not sure about this...
> > selecting interfaces may be quite different from selecting 
> addresses.
> > 
> > I mean, in a case where the multihomed node has a single interface, 
> > but multiple global HoAs/Coas, then this solution wouldn't apply?
> 
> I'm not sure I get you here: our purpose is to address the 
> case where we have a MN/MR has multiple interfaces and wants 
> to use them simultaneously.
I was in the configuration (but I think my mail was not clear enough) a MN/MR has multiple interfaces and/or multiple addresses for one interface and possibly several CoAs simultaeously. Do we want to address the selection of one or several CoAs from available CoAs thanks to QoS reasons or trafic engineering reasons ?
For example, if I have a bluetooth and several 802.11 connections (from hotspot 1, ISP1, ISP2), will I use all interfaces and all addresses simultaneously and is it possible to prioritize one provider and/or one interface. 
> Thierry. 
David

---

From: "BINET David RD-CORE-CAE" <[email-masked]>
Date: Wed, 3 Aug 2005 09:41:47 +0200

> Envoyé : mercredi 3 août 2005 09:37
> À : Monami6 BOF proposal
> > > I'm not sure I get you here: our purpose is to address the case 
> > > where we have a MN/MR has multiple interfaces and wants 
> to use them 
> > > simultaneously.
> > 
> > Clarification question:  what do you mean by simultaneously - 
> > something like bi-casting or loadsharing across multiple 
> interfaces or 
> > do you mean just having both interfaces active at the same 
> time, but 
> > not necessarily have packets flowing on them.
> 
> I give you a concrete example: one interface would be used to 
> send VoIP while another, at the same time, would be used to 
> send your GPS positions.
Could we imagine that both services use a single interface maybe with two different addresses ?
> Thierry

---

From: [email-masked]
Date: Wed, 3 Aug 2005 12:01:09 +0300

Hi Romain,

> [email-masked] wrote:
> > That would be fine, but what I was more asking is, can we support a mode
> > of operation where we have your above scenario, but also support this
> > kind of scenario:
> > 
> >  I have two interfaces active, but I only want packet flow on one at a time.
> >  Having two transmitting interfaces will drain batteries greatly, so I'd
> >  prefer only using one as a sort of backup.  
> 
> At the moment you can already have those features in some implementations:

That I know, but was hoping for more standard behavior on this.

> - either you use one interface at a time, and if another better one is 
> available, then it switches to this one (kind of interface preference 
> mechanism, where you put a priority on each interface). In that case the 
> MN-HA tunnel is moved from one interface to amother.

Exactly.

> - or you can use several interfaces at the same time, ie have several 
> MN-HA tunnels (for example thanks to multiple CoA registrations). In 
> that case you can either separate the flows to several  interfaces with 
> some policies, or send all your traffic to one interface, it's up to the 
> user's policies.

Agreed.

John

---

From: [email-masked]
Date: Wed, 3 Aug 2005 12:11:44 +0300

Hi Koojana,

> > I have two interfaces active, but I only want packet flow on 
> >one at a time.  Having two transmitting interfaces will drain 
> >batteries greatly, so I'd  prefer only using one as a sort 
> of backup.  
> >
> >This is overlapping greatly with multihoming work elsewhere, 
> >so I just wanted to check if people are also thinking of this 
> >type of work here.
> 
> I do not aggree here with you. If you think abt current/ future trend of
> mobile devices, you can't argue like this. We are used to have devices
> which could support energy efficient access technologies as well as more
> alternatives to extend the lifetme of batteries in a small devices.
> 
> One e.g., we are working for EU project that deals with waerable
> devices, --> i.e. a computer in a buckle of the belt, you can use
> Bluettoth, WLAN together and battery lifetime of 3-4 hrs. 

The general trend has been that computing power has been increasing exponentially
while battery capacities are increasing linearly.  One could argue that
better processing could help cut power consumption, but more DSP processing
also increases power consumption - so you win some & you loose some.  However,
this is quite off-topic for this work.

> You would see the importance of the use of multiple technologies
> simulataneously, considerig the scenarios that are highlighted in
> generic-PB drafts. On the other hand, you will not use them
> simulataneouly all the time. That's why we need some policy exchange to
> utilise them in a proper way. As you said, for some cases, you would use
> it as a back up solutions. 

Well, the use of single vs multiple l2 usage does seem like a policy issue
as well, so I agree having a standard way to express policies is a good 
thing, IMO.

John

---

From: [email-masked]
Date: Wed, 3 Aug 2005 18:44:30 +0300

Marcelo,

> how do you know that a better one is available?

Running the shim6 mechanisms :)  

No, seriously, there could be multiple mechanims.  Imagine your device
'knows' your home WLAN network, and after a long, hard day at work,
you come home and at first you were using GPRS, but once your home,
your device switches to WLAN.

However, I think what is 'best' is very subjective, so we should be
careful about this.

John

---

From: "BINET David RD-CORE-CAE" <[email-masked]>
Date: Wed, 3 Aug 2005 17:55:52 +0200

> No, seriously, there could be multiple mechanims.  Imagine 
> your device 'knows' your home WLAN network, and after a long, 
> hard day at work, you come home and at first you were using 
> GPRS, but once your home, your device switches to WLAN.
When you are mobile, you will "discover" networks and it is not always
possible to rely on a priori knowledge. In such mobility case, you need
some information to select "best" interface (thanks for example to DNA
mechanisms if we consider layer 2 attributes or upper layers information
if we consider policy decisions set up by providers for example). 

> 
> However, I think what is 'best' is very subjective, so we 
> should be careful about this.
Agree.

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Mon, 29 Aug 2005 09:41:09 +0200

the moment, our implementation provides priorities per interface, and
use that highest priority working one. There's a lot more that could
come up to WRT to policies... But it seems pretty moot if the
applications running in the MN/MNN are not aware of the network
capabilities. 

This pleads for some "mobility triggers" between mobile L3 and upper
layers. For instance in your case, some download could start
automatically because I'm home. The other way around, upper layers might
need some control on which networks are being used based on appl needs:
I have nothing important to do with the network, do not even start the
WIFI. 

Pascal

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
>Sent: Wednesday, August 03, 2005 5:45 PM
>To: [email-masked]
>Subject: RE: [Monami6] Do we need to update the Monami6 charter ?
>
>Marcelo,
>