Subject: [Monami6] RE: Monami6 Digest, Vol 12, Issue 4

From: xiazhongqi <[email-masked]>
Date: Wed, 22 Feb 2006 09:48:05 +0800

Vidya:
    Even though MN has many CoA to be registered wiht HA, I think it's
doubted 
that the best solution is to adpopt the primary CoA and primary interface.
Maybe 
MN wants HA to direct traffics through different CoA.. For example,  Flow 1
is destined 
to CoA1 of MN, and Flow2 is destined to CoA1 of MN. In addition, there
should be 
a default CoA of MN for use of HA. When HA doesn't know to select the CoA of
MN for 
some a flow, HA can use the default CoA. Here, default CoA maybe serves as
Primary CoA.
But the name "Primary CoA" easily makes people think the Primary CoA has
preference to 
the other CoAs. But, actually, all these CoAs are equal. 

    In addition, I have another question.
    When the MN is attacted to home network through the primary interface
and the other interfaces 
of MN are still attached to visited network, the BUs in HA are deleted, and
the BUs for not primary 
CoAs of MN can be reserved in CN. Why do we do like this? Because MN returns
to home, it is
 reasonable that home network communicates with MN through HoA of MN. Why is
it necessary for CN
to communicate with MN still in RO mode? RFC3484 specifies that a HoA will
always be prefered to a CoA.
If we do like this, it breaks the rule of RFC3484.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Wednesday, February 22, 2006 1:00 AM
> To: [email-masked]
> Subject: Monami6 Digest, Vol 12, Issue 4
> 
> 
> Send Monami6 mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www1.ietf.org/mailman/listinfo/monami6
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more 
> specific than "Re: Contents of Monami6 digest..."
> 
> 
> Today's Topics:
> 
>    1. question about draft-wakikawa-mobileip-multiplecoa-04.txt
>       (xiazhongqi)
>    2. RE: question about	
> draft-wakikawa-mobileip-multiplecoa-04.txt
>       (Narayanan, Vidya)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Tue, 21 Feb 2006 14:53:25 +0800
> From: xiazhongqi <[email-masked]>
> Subject: [Monami6] question about
> 	draft-wakikawa-mobileip-multiplecoa-04.txt
> To: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=us-ascii
> 
> X-MSMail-priority: Normal
> 
> 
>  Hi, all:
>     I am reading some drafts from monami6. And I have a 
> question about Multiple Care-of Addresses Registration.
> 
>     In this draft, primary care-of addres is 
> redefined(primarily associated with a home address) and 
> primary interface 
> is introduced.  The draft says that a mobile node MUST have a 
> primary care-of address all the time. But I don't know the 
> reasons. Maybe these care of addresses are equal in position 
> and there is no difference about primary and secondary 
> position. Mobile node or user can randomly select any address 
> to use.  Why we introduce the model like this?
> 
> 
> 
> 
> ------------------------------
> 
> Message: 2
> Date: Tue, 21 Feb 2006 08:05:09 -0800
> From: "Narayanan, Vidya" <[email-masked]>
> Subject: RE: [Monami6] question about
> 	draft-wakikawa-mobileip-multiplecoa-04.txt
> To: "Monami6 WG" <[email-masked]>
> Message-ID:
> 	<[email-masked]>
> Content-Type: text/plain;	charset="us-ascii"
> 
> Without a primary CoA, the HA will not know where to forward 
> the packets for the MN - you certainly don't want the HA to 
> forward all the packets to all the CoAs - that may be very 
> undesirable in a lot of situations. 
> 
> Vidya 
> 
> > -----Original Message-----
> > From: xiazhongqi [mailto:[email-masked]]
> > Sent: Monday, February 20, 2006 10:53 PM
> > To: [email-masked]
> > Subject: [Monami6] question about 
> > draft-wakikawa-mobileip-multiplecoa-04.txt
> > 
> > X-MSMail-priority: Normal
> > 
> > 
> >  Hi, all:
> >     I am reading some drafts from monami6. And I have a
> > question about Multiple Care-of Addresses Registration.
> > 
> >     In this draft, primary care-of addres is
> > redefined(primarily associated with a home address) and 
> > primary interface is introduced.  The draft says that a 
> > mobile node MUST have a primary care-of address all the time. 
> > But I don't know the reasons. Maybe these care of addresses 
> > are equal in position and there is no difference about 
> > primary and secondary position. Mobile node or user can 
> > randomly select any address to use.  Why we introduce the 
> > model like this?
> > 
> > 
> > _______________________________________________
> > Monami6 mailing list
> > [email-masked] https://www1.ietf.org/mailman/listinfo/monami6
> > 
> 
> 
> 
> ------------------------------
> 
> _______________________________________________
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6
> 
> 
> End of Monami6 Digest, Vol 12, Issue 4
> **************************************
> 

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: Thierry Ernst <[email-masked]>
Date: Wed, 22 Feb 2006 19:33:08 +0900

Hi,

On the 1st point, this is why we have WG item #4 (exchange policies
between the MN and the HA).

For your 2nd point, I don't think it's reasonable to say "it is
**necessary** for the CN to communicate with MN in RO mode". It's not a
requirement, but it should be a feature ! I think it's nice not to
require all traffic to transit via the HA when the MN is on the home
link.  In any case, this point is discussed in
draft-ietf-monami6-mip6-analysis-00.txt. (the draft has been submitted,
it should be announced before the end of the week).

Thierry.

PS: could all people on this list make sure to set a meaningful subject
line ? 

Thierry.

-- 
Thierry ERNST, PhD
WIDE, Jun Murai Lab., Keio University, Japan
Nautilus6 Chair: http://www.nautilus6.org
Web: http://www.sfc.wide.ad.jp/~ernst/
T:+81-44-580-1600 F:+81-44-580-1437
--

---

From: Ryuji Wakikawa <[email-masked]>
Date: Fri, 24 Feb 2006 03:39:54 +0900

Hi again

please find my comments inline

At Wed, 22 Feb 2006 09:48:05 +0800,
> the other CoAs. But, actually, all these CoAs are equal. 

Thierry already answered this.
thanks Thierry.

> If we do like this, it breaks the rule of RFC3484.

When a MN returns home, the MN is no longer multihomed. The MN can use
only the interface attached to the home link. However, for CNs, the MN
can still register its CoAs of interfaces attached to foregin links
and use all the interfaces. 

I'm not sure why we break RFC3484..
Even in RO mode, the source address is HoA. so why do you think so?

regards,
ryuji