Subject: RE: [Monami6] RE: Monami6 Digest, Vol 12, Issue 4

From: "Bound, Jim" <[email-masked]>
Date: Thu, 23 Feb 2006 13:00:11 -0500

OFFLINE: perfect response. 
/jim

> -----Original Message-----
> From: Thierry Ernst [mailto:[email-masked]] 
> Sent: Thursday, February 23, 2006 12:32 PM
> To: [email-masked]; Monami6 WG
> Subject: Re: [Monami6] RE: Monami6 Digest, Vol 12, Issue 4
> 
> 
> 
> We perfeclty know what our job is and a meeting will be held 
> if there is
> a need for a meeting. So, now I would like people who have never
> contributed to any technical discussion to stop discussing if 
> we should
> have a meeting or not and invite active people to comment on the
> technical issues, which will give a hint if a meeting is needed or not
> ...
> 
> Thierry.
> 
> 
> On Thu, 23 Feb 2006 10:16:47 -0600
> Behcet Sarikaya <[email-masked]> wrote:
> 
> > Dear all,
> >   With this don't we have quite good concensus in favor of 
> a F2F meeting 
> > in Dallas?
> > Shouldn't the co-chairs work on dressing up an agenda and 
> cooperate with 
> > the AD to get an appropriate person to chair the meeting?
> > 
> > My 3 cents.
> > 
> > --behcet
> 
> _______________________________________________
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6
> 

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: Ryuji Wakikawa <[email-masked]>
Date: Fri, 24 Feb 2006 18:04:00 +0900

Hi Xiazhongqi

On 2006/02/24, at 17:35, xiazhongqi wrote:

> Hi, Wakikawa
>       Thank you for your answer. Please find my comments in the  
> following.
>
>> From: Ryuji Wakikawa [mailto:[email-masked]]
>> Sent: Friday, February 24, 2006 2:40 AM
>> To: xiazhongqi
>> Cc: [email-masked]
>> Hi again
>> please find my comments inline
>>
>>
>> At Wed, 22 Feb 2006 09:48:05 +0800,
>> xiazhongqi wrote:
>>>
>>> Vidya:
>>>     Even though MN has many CoA to be registered wiht HA, I
>> think it's
>>> doubted that the best solution is to adpopt the primary CoA and
>>> primary interface. Maybe
>>> MN wants HA to direct traffics through different CoA.. For
>> example,  Flow 1
>>> is destined
>>> to CoA1 of MN, and Flow2 is destined to CoA1 of MN. In
>> addition, there
>>> should be
>>> a default CoA of MN for use of HA. When HA doesn't know to
>> select the CoA of
>>> MN for
>>> some a flow, HA can use the default CoA. Here, default CoA
>> maybe serves as
>>> Primary CoA.
>>> But the name "Primary CoA" easily makes people think the
>> Primary CoA has
>>> preference to
>>> the other CoAs. But, actually, all these CoAs are equal.
>>
>> Thierry already answered this.
>> thanks Thierry.
>>
>>>     In addition, I have another question.
>>>     When the MN is attacted to home network through the primary
>>> interface and the other interfaces of MN are still attached
>> to visited
>>> network, the BUs in HA are deleted, and the BUs for not primary
>>> CoAs of MN can be reserved in CN. Why do we do like this?
>> Because MN returns
>>> to home, it is
>>>  reasonable that home network communicates with MN through
>> HoA of MN. Why is
>>> it necessary for CN
>>> to communicate with MN still in RO mode? RFC3484 specifies
>> that a HoA will
>>> always be prefered to a CoA.
>>> If we do like this, it breaks the rule of RFC3484.
>>
>> When a MN returns home, the MN is no longer multihomed. The
>> MN can use only the interface attached to the home link.
>> However, for CNs, the MN can still register its CoAs of
>> interfaces attached to foregin links and use all the interfaces.
>>
>
> When a MN returns home on condition that one interface of MN is  
> attached to
> home link and
> the others are attached to foreign network, can we define this  
> situation as
> NOT multihomed?

Well, it is multihomed, but a MN can not use both interface  
simultaneously.
The HA no longer intercept packets due to de-registration of MN.
Thus no packets can be arrived to interfaces attached to foreign links.

>
>> I'm not sure why we break RFC3484..
>> Even in RO mode, the source address is HoA. so why do you think so?
>>
>
> In RO mode, HoA is used as Home Address Option. Can we think of it  
> as source
> address?

The IPv6 source address selection pick the HoA as "souce" and
MIP6 stack find BC or BULIST for the pair of the HoA and the  
destination (CN).
It, then, adds HoA option in the packet and store HoA in the option.
So, yes.

regards,
ryuji

>> regards,
>> ryuji
>>>> From: [email-masked] [mailto:[email-masked]]
>>>> Sent: Wednesday, February 22, 2006 1:00 AM
>>>> To: [email-masked]
>>>> Subject: Monami6 Digest, Vol 12, Issue 4
>>>>
>>>>
>>>> Send Monami6 mailing list submissions to
>>>> 	[email-masked]
>>>>
>>>> To subscribe or unsubscribe via the World Wide Web, visit
>>>> or, via email, send a message with subject or body 'help' to
>>>> 	[email-masked]
>>>>
>>>> You can reach the person managing the list at
>>>> 	[email-masked]
>>>>
>>>> When replying, please edit your Subject line so it is more
>>>> specific than "Re: Contents of Monami6 digest..."
>>>>
>>>>
>>>> Today's Topics:
>>>>
>>>>    1. question about draft-wakikawa-mobileip-multiplecoa-04.txt
>>>>       (xiazhongqi)
>>>>    2. RE: question about	
>>>> draft-wakikawa-mobileip-multiplecoa-04.txt
>>>>       (Narayanan, Vidya)
>>>>
>>>>
>>>>
>> --------------------------------------------------------------------
>>>> --
>>>>
>>>> Message: 1
>>>> Date: Tue, 21 Feb 2006 14:53:25 +0800
>>>> From: xiazhongqi <[email-masked]>
>>>> Subject: [Monami6] question about
>>>> 	draft-wakikawa-mobileip-multiplecoa-04.txt
>>>> To: [email-masked]
>>>> Message-ID: <[email-masked]>
>>>> Content-Type: text/plain; charset=us-ascii
>>>>
>>>> X-MSMail-priority: Normal
>>>>
>>>>
>>>>  Hi, all:
>>>>     I am reading some drafts from monami6. And I have a
>>>> question about Multiple Care-of Addresses Registration.
>>>>
>>>>     In this draft, primary care-of addres is
>>>> redefined(primarily associated with a home address) and
>>>> primary interface
>>>> is introduced.  The draft says that a mobile node MUST have a
>>>> primary care-of address all the time. But I don't know the
>>>> reasons. Maybe these care of addresses are equal in position
>>>> and there is no difference about primary and secondary
>>>> position. Mobile node or user can randomly select any address
>>>> to use.  Why we introduce the model like this?
>>>>
>>>>
>>>>
>>>>
>>>> ------------------------------
>>>>
>>>> Message: 2
>>>> Date: Tue, 21 Feb 2006 08:05:09 -0800
>>>> From: "Narayanan, Vidya" <[email-masked]>
>>>> Subject: RE: [Monami6] question about
>>>> 	draft-wakikawa-mobileip-multiplecoa-04.txt
>>>> To: "Monami6 WG" <[email-masked]>
>>>> Message-ID:
>>>> 	<[email-masked]>
>>>> Content-Type: text/plain;	charset="us-ascii"
>>>>
>>>> Without a primary CoA, the HA will not know where to forward
>>>> the packets for the MN - you certainly don't want the HA to
>>>> forward all the packets to all the CoAs - that may be very
>>>> undesirable in a lot of situations.
>>>>
>>>> Vidya
>>>>
>>>>> From: xiazhongqi [mailto:[email-masked]]
>>>>> Sent: Monday, February 20, 2006 10:53 PM
>>>>> To: [email-masked]
>>>>> Subject: [Monami6] question about
>>>>> draft-wakikawa-mobileip-multiplecoa-04.txt
>>>>>
>>>>> X-MSMail-priority: Normal
>>>>>
>>>>>
>>>>>  Hi, all:
>>>>>     I am reading some drafts from monami6. And I have a
>> question
>>>>> about Multiple Care-of Addresses Registration.
>>>>>
>>>>>     In this draft, primary care-of addres is
>> redefined(primarily
>>>>> associated with a home address) and primary interface is
>>>>> introduced.  The draft says that a mobile node MUST
>> have a primary
>>>>> care-of address all the time. But I don't know the
>> reasons. Maybe
>>>>> these care of addresses are equal in position and there is no
>>>>> difference about primary and secondary position. Mobile node or
>>>>> user can randomly select any address to use.  Why we
>> introduce the
>>>>> model like this?
>>>>>
>>>>>
>>>>> [email-masked] https://www1.ietf.org/mailman/listinfo/monami6
>>>>>
>>>>
>>>>
>>>>
>>>> ------------------------------
>>>>
>>>> End of Monami6 Digest, Vol 12, Issue 4
>>>> **************************************
>>>>
>>>
>>>

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Mon, 27 Feb 2006 10:06:52 -0800

Hi Thierry,
I found this email rather disturbing. There are many people on many of
the IETF mailing lists who follow the work very closely, but don't
necessarily participate in active discussions on the list. This email of
yours implies that such people should have no say in the functioning of
the WG. I, for one, am on a few mailing lists on which I don't actively
participate, but monitor those closely enough to have an opinion on
subjects like this. 

Plus, needless to explicitly say, the Monami6 mailing list can hardly be
categorized as very active - there are bound to be people on this list
who are silent observers. 

While I agree that there isn't a reason to hold a meeting just for the
sake of holding one (unless there are concrete technical things to
discuss and move forward), I have to raise an objection against
dismissing people's opinions just because they have not previously
participated in technical discussions. 

Regards,
Vidya

> Sent: Thursday, February 23, 2006 9:32 AM
> if there is a need for a meeting. So, now I would like people 
> who have never contributed to any technical discussion to 
> stop discussing if we should have a meeting or not and invite 
> active people to comment on the technical issues, which will 
> give a hint if a meeting is needed or not ...
> 
> Thierry.
> 
> 
> >   With this don't we have quite good concensus in favor of a F2F 
> > meeting in Dallas?
> > Shouldn't the co-chairs work on dressing up an agenda and cooperate 
> > with the AD to get an appropriate person to chair the meeting?
> > 
> > My 3 cents.
> > 
> > --behcet
>

---

From: "Bound, Jim" <[email-masked]>
Date: Mon, 27 Feb 2006 13:15:25 -0500

Folks, what we have here is one of those cases where mis communications
is running abundant. I think in hind sight all Thierry was trying to do
is to get input as to if we have technical details to discuss in depth
face to face, and sent to those actively speaking and working "vocally"
here.  This is good IETF working group lets not distract our ownselves
and years ago I would have reacted the same so thats cool.  If there is
work then lets meet if not lets not just to do it.  I for one would like
to hear the technical work that would support a meeting at this point
and I think I can ask this of a few IETF working groups I have to
attend.

Best,
/jim 

> From: Narayanan, Vidya [mailto:[email-masked]] 
> Sent: Monday, February 27, 2006 1:07 PM
> To: Monami6 WG; [email-masked]
> Subject: RE: [Monami6] RE: Monami6 Digest, Vol 12, Issue 4
> 
> Hi Thierry,
> cooperate