Subject: [Monami6] question about draft-wakikawa-mobileip-multiplecoa-04.txt

From: xiazhongqi <[email-masked]>
Date: Tue, 21 Feb 2006 14:53:25 +0800

X-MSMail-priority: Normal

 Hi, all:
    I am reading some drafts from monami6. And I have a question about
Multiple Care-of Addresses Registration.

    In this draft, primary care-of addres is redefined(primarily associated
with a home address) and primary interface 
is introduced.  The draft says that a mobile node MUST have a primary
care-of address all the time. But I don't know the 
reasons. Maybe these care of addresses are equal in position and there is no
difference about primary and secondary 
position. Mobile node or user can randomly select any address to use.  Why
we introduce the model like this?

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: Ryuji Wakikawa <[email-masked]>
Date: Fri, 24 Feb 2006 03:33:45 +0900

Hi xiazhongqi

The primary IF/CoA was basically introduced for a MN's returning home.
When one of IF attaches to the home link, the MN has two choices to do.
1. just returning home and disabling other available IFs attached to foreign networks.
2. invalidating the IF attached to the home link and keep using the IF connected to foreign networks.

For such decision, we introduce the primary concept.
However, after the last meeting, we received comments from WG about this definition.
We drop the primary IF/CoA from the udpated draft. The draft will be submitted soon.

thanks 
ryuji

At Tue, 21 Feb 2006 14:53:25 +0800,

---

From: Keigo Aso <[email-masked]>
Date: Tue, 28 Feb 2006 15:40:49 +0900

Hi Ryuji,

Please see my comments inline.

On Fri, 24 Feb 2006 03:33:45 +0900

> 2. invalidating the IF attached to the home link and keep using the IF connected to foreign networks.
I think priority value is useful in place of the primary IF/CoA.
However, I don't think it is effective that there is the constraints
that MN has to choice either 1 or 2 when returning home.
Because, for example, this choice causes the drawback that flow
control by HA is limited by the situation of MN's connection. 
Flow policies at HA is a WG item.
The detail about this is described in the following I-D:
http://www.ietf.org/internet-drafts/draft-aso-monami6-multiple-forwarding-00.txt
I would like you and many WG members to see this draft for further
discussion.

Regards,
Keigo