Subject: Re: [Monami6] (Issue-2 MCoA) Should MN returns Home with bothinterfaces attached to home and foreign?

From: RYUJI WAKIKAWA <[email-masked]>
Date: Mon, 4 Dec 2006 23:21:30 +0900

Hi Keiichi

On 2006/11/21, at 12:13, Keiichi SHIMA wrote:

> Hello George,
>
> On 2006/11/21, at 6:34, Tsirtsis, George wrote:
>
>> I think the problem is that the mobile can be in a situation where  
>> one
>> of its interfaces is at home and one or more of its other interfaces
>> maybe connected to foreign links. In this case the mobile is  
>> supposed to
>> deregister, since it has returned home, which would mean that the
>> interfaces connected to foreign links can not be utilized.
>
> Ah, OK, we are trying to utilize the other link (that is not  
> attached to the home link of a mobile node) using the home address  
> of the mobile node, while it is at home.
>
> Well, since the traffic sent via the foreign link will go to the  
> home agent eventually, I am not sure such use is really useful or  
> not.  Maybe it is useful in the RO case, but currently we are not  
> talking about the RO case.

I like your statement. This is a bit odd operation to use the  
interfaces attached to a foreign link when MN is home.
The packets are arrived to the HA, the cheapest operation is using  
the interface attached to the home link.
No tunnel, 1 Hop,,,

> If I have to choose one from the two proposals, then I choose the  
> proposal-1.

agree

ryuji

> ---
> Keiichi SHIMA
> IIJ Research Laboratory <[email-masked]>
> WIDE Project <[email-masked]>
>
>
>
>
> _______________________________________________
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: Romain KUNTZ <[email-masked]>
Date: Mon, 04 Dec 2006 23:28:39 +0900

Hi,

RYUJI WAKIKAWA wrote:
> I like your statement. This is a bit odd operation to use the interfaces 
> attached to a foreign link when MN is home.
> The packets are arrived to the HA, the cheapest operation is using the 
> interface attached to the home link.
> No tunnel, 1 Hop,,,

For fault-tolerance purposes, it could still be useful to maintain 
several MR-HA tunnels at the same time.

regards,

-- 
Romain KUNTZ
[email-masked]

---

From: RYUJI WAKIKAWA <[email-masked]>
Date: Mon, 4 Dec 2006 23:39:43 +0900

Hi Romain

> several MR-HA tunnels at the same time.

There are no multiple tunnels when MN returns home and uses the home- 
interface.
However, the foreign interface is still active though it's CoA is not  
registered.

If the interface attached to home link is somehow failed, MN may  
start using the foreign-interface.
This may be totally operational issue.
We may not discuss the protocol/operation to provide fault tolerance  
in MCoA spec.

ryuji