Subject: MEXT charter [was Re: [Monami6] consensus call on draft-soliman-monami6-flow-binding-04.txt]

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 27 Sep 2007 08:28:47 -0700 (PDT)

Hi all,
  Have the people in this ML paid attention to a recent discussion in netlmm on the problems related to multihomed MNs and point to point links? My feeling is that in monami6 the fundamental assumption is shared link. However this may not be true even if MN attaches to the links that are traditionally shared because HA has to assign per MN prefix to MN and also all cellular links are point to point.
  Any thoughts?

Behcet

----- Original Message ----
From: RYUJI WAKIKAWA <[email-masked]>
To: Monami6 WG <[email-masked]>
Sent: Monday, September 24, 2007 1:48:12 PM
Subject: Re: MEXT charter [was Re: [Monami6] consensus call on draft-soliman-monami6-flow-binding-04.txt]

Hi Nicolas,

On 2007/09/25, at 0:06, Nicolas Montavont wrote:

> Hi Ryuji,
>
> [snip]
>
> On Sep 15, 2007, at 7:23 AM, Hesham Soliman wrote:
>
>>>
>>> A general question (not specific to this document)
>>> Monami6 WG needs to coordinate activity. I think we
>>> reach the consensus what we need in the WG such as..
>>> - registering multiple CoAs (mcoa WG document)
>>> - MN initiated filters registration (draft-hesham)
>>> - HA initiated filters registration (supporting MH signaling
>>> in draft-
>>> hesham?)
>
> In the MEXT charter, it is written :
>
> A "Flow/binding policies exchange" solution for an exchange of
> policies from the mobile host/router to the Home Agent and from the
> Home Agent to the mobile host/router influencing the choice of the
> Care-of Address and Home Agent address. The solution involves two
> specifications, one for the policy format and another for its
> transport [both Standard Track].

If this is the fixed charter, the Hesham's draft does not satisfy the  
charter, doest it?
It fails to support the function from the Home Agent to the mobile  
host/router...

> And I proposed at the last IETF to change it because it is not  
> clear to me.
> Here is the text I wrote on this issue:
>
> I think this goal is not very clear and would need to be clarified.  
> I can read here three different goals, which are:
>    (1) Exchange policies to influence the choice of the CoA
>    (2) Exchange policies to influence the choice of the HA address
>    (3) Specify a generic format to describe the policies
>
> I think that (1) should be re-written to "Policies enforcement from  
> the mobile host/router to the HA to influence the choice of the  
> CoA." I suggest that because the mobile host/router is the only one  
> to know the addresses that are mapped to its interfaces. What we  
> need, is a protocol to indicate to the HA which CoA to use at the  
> HA for a specific flow. The policies set up (e.g., I want VoIP over  
> your Wifi interface) was always out of scope of the work in monami6.

Agree with you that Policies setup is out of scope in monami6.
However, I cannot agree that the client is the only one to know the  
mapping of CoA and its interface.
If operators has wifi and wimax networks, they can surely know which  
address is mapped to which interface.
This is just an example, but we should not exclude this case. (At  
least, Tasaka and koshiro expressed their support on this approach.)

> (2) We never discuss this point in the WG. Shall we?

no..

regards
ryuji

>
> (3) Can't we add an additional item to make clear that we will have  
> 2 documents?
>
> Regards,
>
> Nicolas
>
>
>>
>> => I don't recall discussing this third point in the meeting or  
>> getting any
>> concensus on it. Not sure which discussion you're referring to. I  
>> don't
>> think draft-soliman is the right place for it, as indicated  
>> earlier on the
>> list.
>>
>> Hesham
>>
>>
>>
>>
>> _______________________________________________
>> Monami6 mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/monami6
>
>
> _______________________________________________
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: RYUJI WAKIKAWA <[email-masked]>
Date: Fri, 28 Sep 2007 19:24:42 +0900

Hi Behcet,

On 2007/09/28, at 0:28, Behcet Sarikaya wrote:

> Hi all,
>   Have the people in this ML paid attention to a recent discussion  
> in netlmm on the problems related to multihomed MNs and point to  
> point links?

The discussion of multihomed MN in NETLMM is slightly different from  
the problem discussed in Monami6.
The netlmm issue is more general issue:
-whether an IPv6 host can have the same IP address on multiple  
interfaces.
-how MAG/LMA can prevent assigning the same prefix to multiple  
interfaces.

> My feeling is that in monami6 the fundamental assumption is shared  
> link. However this may not be true even if MN attaches to the links  
> that are traditionally shared because HA has to assign per MN  
> prefix to MN

Why HA has to assign per MN prefix??

> and also all cellular links are point to point.

Do you mean all cellular links are managed with PMIP?

regards,
ryuji

> Subject: Re: MEXT charter [was Re: [Monami6] consensus call on  
> draft-soliman-monami6-flow-binding-04.txt]
>
> Hi Nicolas,
>