Subject: RE: [MEXT] AD review of draft-korhonen-mip6-service-03.txt

From: <[email-masked]>
Date: Thu, 1 Nov 2007 10:15:43 +0100

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]] 
> Sent: Tuesday, October 30, 2007 4:28 PM
> 
> I'm wary of specifying something might be found in DNS or might not.
> 
> Also, do we have any evidence that we actually need the 
> identifiers to be resolved by DNS? In any case, no one would 

Hard to tell.. There are deployment scenarios where DNS definitely
will be involved. However, at the same time I cannot say that it
would apply to all deployment scenarios. Looks like it is better
to leave out the explicit note on DNS.

> turn on service for a particular domain without an agreement 
> in place with that domain. So the box initiating a VPN tunnel 
> simply has to have configuration for that domain, its not 
> enough for the DNS query to succeed.

If DNS were involved it could be used with the HA discovery.
I.e. to point the MN to a group of HAs that host/allow access
to the desired service.

Cheers,
	Jouni

> 
> Jari
> 
> [email-masked] kirjoitti:
> > There was comment I received offline pointing out that 
> description of 
> > the service selection option identifier in -04 does not mention DNS 
> > anymore. In -03 it read
> >   "The Identifier MAY be resolveable by DNS."
> > I think it could be put back. The new text could be:
> >
> > "  o  Type: 8-bit identifier set to TBD (to be defined by 
> IANA) of the
> >       type of the skipable mobility option. Depending on the system
> >       deployment the Identifier MAY be resolveable by DNS."
> >
> > Any thoughts? 
> >
> >
> >
> > Cheers,
> > 	Jouni
> >
> >   
> >> -----Original Message-----
> >> From: Jari Arkko [mailto:[email-masked]]
> >> Sent: Monday, October 22, 2007 8:55 AM
> >> To: Korhonen, Jouni /TeliaSonera Finland Oyj
> >> Cc: [email-masked]; [email-masked]
> >> Subject: Re: [MEXT] AD review of draft-korhonen-mip6-service-03.txt
> >>
> >>
> >> The new version addresses the concerns I had. Thanks. The document 
> >> will now be moved forward.
> >>
> >> Jari
> >>
> >>
> >>
> >>     
> >
> >
> >   
> 
> 

_______________________________________________
MEXT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mext

---

From: Jari Arkko <[email-masked]>
Date: Thu, 01 Nov 2007 12:42:21 +0200

> I.e. to point the MN to a group of HAs that host/allow access
When the service id sent in a Mobile IPv6 message, we are
past the discovery phase, no?

In any case, my point was that no one would/should configure
their HAs to allow them to be used for tunnel gateways
for arbitrary domains. You must have configuration that
tells you a business relationship exists. DNS doesn't give
you that, even if it could supply additional pieces of information.

Jari

---

From: <[email-masked]>
Date: Thu, 1 Nov 2007 12:19:08 +0100

> > I.e. to point the MN to a group of HAs that host/allow 
> access to the 
> > desired service.
> >   

Yes.. I was just thinking that the id used for discovery could
then also be included in the servise selection option.

> their HAs to allow them to be used for tunnel gateways for 
> arbitrary domains. You must have configuration that tells you 
> a business relationship exists. DNS doesn't give you that, 
> even if it could supply additional pieces of information.

Agree.

/Jouni